09:05:48 <nishanth> #startmeeting check-in_20170203
09:05:48 <zodbot> Meeting started Fri Feb 3 09:05:48 2017 UTC. The chair is nishanth. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:05:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
09:05:48 <zodbot> The meeting name has been set to 'check-in_20170203'
09:06:00 <nishanth> #topic team updates
09:06:23 <nishanth> anmol, can you update on the monitoring please?
09:06:31 <anmol> 1. Synced up with tim over performance-monitoring rpm spec.
09:06:31 <anmol> 2. Completed incoporating namespace changes into alerting https://github.com/Tendrl/alerting/pull/35
09:06:31 <anmol> 3. @nishath, as you told I setup nodes for demo setup and installed bits on it.
09:06:31 <anmol> Its installed with gluster bits and gluster cluster is created on it.
09:06:34 <anmol> Monitoring bits also setup. Faced some issues during setup.
09:06:36 <anmol> Note:
09:06:38 <anmol> a. Performance monitoring requires python-etcd 0.4.4
09:06:40 <anmol> b. Sent some fixes @ https://github.com/Tendrl/performance-monitoring/pull/39 it got merged.
09:06:42 <anmol> c. Graphite-web uses port 80 by default but looks like that's already being used by ui.
09:06:44 <anmol> So, for now in the setup described above, we are using 10080 for graphite-web. But we probably need to discuss and close out on this.
09:06:47 <anmol> 4. Need to Start on:
09:06:49 <anmol> * Logging framework related changes to alerting including the alert proporgation related stuff impacting on this.
09:06:52 <anmol> Waiting for:
09:06:54 <anmol> a. I would like to request @anivargi and @brainfunked to review https://github.com/Tendrl/specifications/pull/124 which is spec to detail alerting apis
09:06:57 <anmol> requirement. This is required for tendrl/api to expose apis for alerting related configuration and others.
09:07:00 <anmol> b. Also updated https://github.com/Tendrl/specifications/pull/81 with changes as per [1] above.
09:07:04 <anmol> Implementation is already merged but this spec is approved before changes above but not merged. Please review and merge it.
09:08:17 <nishanth> k4n0, what is your take on using python-etcd 0.4.4 ?
09:08:33 <k4n0> nishanth, ?
09:08:36 <anmol> one small correction :) updated https://github.com/Tendrl/specifications/pull/81 as per comments from anup implemented as part of merged PR https://github.com/Tendrl/performance-monitoring/pull/36
09:09:26 <k4n0> nishanth, anmol https://github.com/Tendrl/commons/blob/master/dependencies/python-etcd/Makefile#L2
09:09:33 <k4n0> we are already using 0.4.4
09:09:34 <nishanth> k4n0, as anmol updated, there are some issues(etcd connections) with older version of etcd. When he upgraded to 0.4.4, things are fine
09:09:58 <nishanth> anmol, then what is the issue?
09:10:25 <anmol> nishanth, k4n0, when I installed tendrl-commons what came with it from epel was 0.3...
09:10:35 <anmol> nishanth, k4n0, not 0.4.4
09:10:39 <k4n0> anmol, talk to t1m1 and get this sorted
09:10:41 <k4n0> nishanth, ^
09:10:43 <anmol> t1m1, ^^
09:10:59 <anmol> k4n0, I have conveyed this to t1m1 already
09:11:06 <anmol> k4n0, I think he is on it
09:11:08 <k4n0> we should always be using the latest python-etcd or any other package that we are packaging , nishanth
09:11:10 <k4n0> ok
09:11:50 <nishanth> anmol, have you installed the repo file tendrl/tendrl(copr)
09:11:56 <anmol> nishanth, yes
09:12:20 <nishanth> t1m1, you need to sort this out
09:12:29 <t1m1> nishanth, sure
09:13:58 <nishanth> #action @anivargi and @brainfunked to review https://github.com/Tendrl/specifications/pull/124
09:14:32 <nishanth> anmol, any of your patches pending review?
09:14:59 <nishanth> t1m1, what is status of monitoring rpms?
09:15:14 <anmol> nishanth, I have a WIP alerting patch so its not ready for review yet other that that only the 2 specs in my update I require review
09:15:47 <t1m1> nishanth, perfor-monitoring specs are in and the package build added to jenkins ci , copr
09:16:10 <nishanth> #action anmol to start work on Logging framework related changes to alerting including the alert propagation
09:16:10 <t1m1> nishanth, node-monitoring build patch is under review
09:17:01 <t1m1> alerting: patch need to be updated after anmol fixes few things
09:17:15 <anmol> t1m1, what fixes?
09:17:26 <anmol> t1m1, did you mean requirements file issue?
09:17:31 <t1m1> anmol, yes
09:17:56 <anmol> t1m1, this is same as in other modules probably its an issue in environment right?
09:18:54 <t1m1> anmol, ya
09:18:57 <nishanth> t1m1, what is the ETA on node-monitoring?
09:19:14 <nishanth> anmol, have you tested the perf monitoring rpms?
09:19:46 <anmol> nishanth, I was doing it on demo setup but landed into issues so need to recheck again
09:19:55 <anmol> nishanth, I'll do it now
09:20:19 <nishanth> #action anmol to verify the performance monitoring rpms
09:20:31 <t1m1> ktdreyer, is reviewing the patch for node-monitoring, he asked few thing to clarify, anmol has replied to those things, hope it will be done by today
09:20:59 <anmol> t1m1, I am yet to push my comments
09:21:06 <anmol> t1m1, will be done shortly
09:21:17 <nishanth> t1m1, anmol, please close this today
09:21:27 <anmol> nishanth, ok
09:21:51 <nishanth> #action anmol, t1m1 to close out on the node monitoring rpms today
09:22:03 <nishanth> thanks for the updates
09:22:35 <nishanth> gowtham, anmol_s , update on the logging ?
09:23:22 <anmol_s> nishanth, gowtham has made rocommended changes
09:23:42 <anmol_s> nishanth, I will chage my spec and pr accordingly
09:26:15 <nishanth> anmol_s, do you have PR(code changes)?
09:27:21 <anmol_s> nishanth, I am working on the changes now ... Will push the pr as soon as I finish
09:28:01 <nishanth> anmol_s, Don't wait for the changes to complete. Push a WIP PR
09:28:39 <nishanth> #action anmol_s to push the pr for logging changes
09:28:46 <nishanth> thanks
09:29:08 <anmol_s> nishanth, okay I will push it
09:29:19 <anmol_s> nishanth, thanks
09:29:56 <nishanth> ndarshan, nishanth provisioning wrapper updates
09:30:23 <ndarshan> * worked on: https://github.com/Tendrl/node-agent/issues/198 (node_agent cpu consumption issue)
09:30:23 <ndarshan> Sent: https://github.com/Tendrl/node-agent/pull/199 and https://github.com/Tendrl/commons/pull/151 as Fix for above
09:30:24 <ndarshan> * Continue working on https://github.com/Tendrl/specifications/issues/49 (wrapper for gdeploy)
09:30:24 <ndarshan> Will post a WIP PR with wrapper and atoms for basic volume creation and configuration by EOD
09:32:48 <ndarshan> Re-sending my updates:
09:32:50 <ndarshan> * worked on: https://github.com/Tendrl/node-agent/issues/198 (node_agent cpu consumption issue)
09:32:50 <ndarshan> Sent: https://github.com/Tendrl/node-agent/pull/199 and https://github.com/Tendrl/commons/pull/151 as Fix for above
09:32:50 <ndarshan> * Continue working on https://github.com/Tendrl/specifications/issues/49 (wrapper for gdeploy)
09:32:51 <ndarshan> Will post a WIP PR with wrapper and atoms for basic volume creation and configuration by EOD
09:34:37 <nishanth> #accept ndarshan fixed https://github.com/Tendrl/node-agent/issues/198
09:35:34 <nishanth> #info wrapper work for gdeploy in progress( https://github.com/Tendrl/specifications/issues/49)
09:35:47 <nishanth> ndarshan, do you have a PR for code changes?
09:36:01 <ndarshan> No, will post one by EOD
09:36:37 <nishanth> #action nishanth to send PR for specification(Issue- https://github.com/Tendrl/specifications/issues/48)
09:36:44 <nishanth> thanks for the updates
09:37:10 <Shu6h3ndu> nishanth, ndarshan has to send PR for this
09:37:10 <nishanth> shu6h3ndu, CRUD updates
09:37:42 <Shu6h3ndu> nishanth, Gregory has not replied on the spec issue. I have gone ahead and made pool create/delet working for ceph pools
09:38:06 <Shu6h3ndu> nishanth, also I have added update pool and ec-pool creation/deletion/updation working with existing rados way
09:38:07 <nishanth> shu6h3ndu, rados?
09:38:32 <Shu6h3ndu> nishanth, yes. https://github.com/Tendrl/ceph-integration/pull/104
09:38:55 <Shu6h3ndu> nishanth, yesterday sent some PRs for SDS detection fixes and delete volume atom and merged
09:39:06 <nishanth> shu6h3ndu, there is meeting scheduled by Jeff next I guess, let us what happens
09:39:18 <Shu6h3ndu> nishanth, ok
09:39:20 <nishanth> shu6h3ndu, for now its good to go with rados
09:39:24 <Shu6h3ndu> nishanth, ok
09:39:44 <Shu6h3ndu> nishanth, I am continuing and trying to make rbds work with rbd commands
09:40:11 <nishanth> #accept shu6h3ndu send a PR for pool CRUD(https://github.com/Tendrl/ceph-integration/pull/104)
09:40:42 <Shu6h3ndu> nishanth, please review the spec PR https://github.com/Tendrl/specifications/pull/130. Its already approved by Rohan
09:40:56 <nishanth> #action shu6h3ndu working on CRUD for rbd ops
09:41:21 <nishanth> #action, nishanth, brainfunked to review https://github.com/Tendrl/specifications/pull/130
09:41:31 <nishanth> thanks
09:41:53 <nishanth> ankush, updates(dashboard)?
09:43:43 <nishanth> neha, kaverma, updates(CRUD ops)?
09:44:16 <kaverma> we have decided to complete pending items (CRUDs) first before starting on "create cluster workflow" (Created one github issue :- https://github.com/Tendrl/dashboard/issues/123 - We need endpoints where we need to send the post request and also how this form will get generated through an API response or to use hard-coded values?)
09:44:16 <kaverma> so right now i am working on https://github.com/Tendrl/dashboard/issues/121 - converting all directives to components
09:44:17 <kaverma> and ankush working on responsive design for listing .
09:45:11 <kaverma> nishanth, i sent one mail to mrugesh for pending items on CRUDs so we are looking into same
09:45:17 <kaverma> as well
09:46:07 <ankush> nishanth, I have created a issue regarding "Data points required for Dashboard UI" and tagged anmol on the same.
09:46:12 <kaverma> and ankush is working on this - https://github.com/Tendrl/dashboard/issues/122 --
09:46:16 <ankush> https://github.com/Tendrl/dashboard/issues/120
09:46:20 <nishanth> kaverma, what you require here --? https://github.com/Tendrl/dashboard/issues/123
09:46:49 <kaverma> nishanth, basically We need endpoints where we need to send the post request and also how this form will get generated through an API response or to use hard-coded values?
09:47:50 <nishanth> kaverma, the git issues doesnot have the details. Also I havn't seen anup is tagged here as well
09:48:23 <nishanth> kaverma, did you speak to anup on this?
09:48:25 <kaverma> nishanth, i am going to tag now all respective person. and update details more in ti
09:48:32 <kaverma> *it
09:48:46 <kaverma> nishnath, not now
09:49:08 <kaverma> will talk to him
09:49:47 <nishanth> #action kaverma to input the details into https://github.com/Tendrl/dashboard/issues/123 and tag the module owner
09:50:15 <kaverma> nishanth , and right now i am working on https://github.com/Tendrl/dashboard/issues/121 - converting all directives to components
09:50:34 <kaverma> nishanth, about to be done . very soon sent patch for it
09:51:09 <nishanth> #action kaverma to send a PR for the issue --> https://github.com/Tendrl/dashboard/issues/121
09:52:19 <nishanth> anmol, did you have a look at https://github.com/Tendrl/dashboard/issues/120 created by ankush ?
09:53:00 <anmol> nishanth, I have seen it but didn't have a chance to follow up on details of each of the data points mentioned in there
09:53:40 <anmol> nishanth, I'll probably be able to do it after verifying performance-monitoring and node-monitoring rpms and completing alerting changes
09:53:48 <nishanth> #action, anmol, ankush work together and sort out the items listed in https://github.com/Tendrl/dashboard/issues/120
09:53:51 <nishanth> anmol, ok
09:54:36 <nishanth> neha, any updates from your side?
09:55:52 <nishanth> k4n0, updates?
09:56:04 <kaverma> nishanth, she is not here .. i think she is participated on some annual event. she is busy on that
09:56:06 <k4n0> nishanth, havent finished the import flow, was busy with reviews yest
09:56:31 <k4n0> nishanth, thats all
09:56:33 <nishanth> k4n0, sure
09:57:01 <nishanth> #action k4n0 is working on the import flows
09:57:48 <nishanth> #topic QE Team updates
09:58:13 <nishanth> dahorak, updates?
09:58:58 <nishanth> fbalak, updates
10:00:02 <nishanth> ltrilety, updates?
10:00:47 <nishanth> mkudlej, updates?
10:01:46 <ltrilety> #info ltrilety is working on https://github.com/Tendrl/usmqe-tests/issues/12
10:03:30 <dahorak> no Tendrl related update from me
10:03:36 <mkudlej> nishanth: I'm working on Tendrl unrelated tasks
10:03:51 <nishanth> ok
10:04:16 <fbalak> #action fbalak Testing new packages.
10:04:18 <fbalak> #action fbalak Working on https://github.com/Tendrl/usmqe-tests/issues/20
10:04:20 <fbalak> #action fbalak Blocked by Issue related to problems with creation of gluster volume via api: https://github.com/Tendrl/api/issues/68
10:05:37 <nishanth> fbalak, thanks I will follow up on https://github.com/Tendrl/api/issues/68
10:06:06 <nishanth> thanks
10:06:37 <nishanth> #endmeeting