19:01:54 <gholms> #startmeeting Cloud SIG (28 Oct 2011)
19:01:54 <zodbot> Meeting started Fri Oct 28 19:01:54 2011 UTC.  The chair is gholms. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:58 <rbergeron> oh sure
19:01:59 <gholms> #meetingname cloud
19:01:59 <zodbot> The meeting name has been set to 'cloud'
19:02:02 <gholms> #topic init process
19:02:04 * rbergeron sits back
19:02:07 * kkeithley is here
19:02:08 <gholms> rbergeron: You were too slow
19:02:17 <rbergeron> gholms: maybe i should always be this slow ;)
19:02:18 <gholms> #chair rbergeron jforbes
19:02:18 <zodbot> Current chairs: gholms jforbes rbergeron
19:02:21 <rbergeron> AH SHOOT
19:02:28 <gholms> rbergeron: <3
19:02:39 * jforbes is here
19:02:42 * douglax lurks
19:02:53 * rbergeron is here
19:02:55 * tflink is lurking
19:03:16 * gholms waits
19:03:32 <rbergeron> s/lurking/bugs
19:03:33 <gholms> rbergeron: You're the one with the agenda.  Go for it.
19:03:35 * rbergeron hugs tflink
19:03:38 <rbergeron> okay
19:03:50 <rbergeron> #topic EC2
19:03:59 <rbergeron> jdarcy mentioned something this morning about... about...
19:04:00 * rbergeron looks
19:04:25 <rbergeron> /dev/stderr stuff.
19:04:26 <jdarcy> About permissions errors on /dev/stderr during AMI startup.
19:04:30 <rbergeron> There you go.
19:04:48 <rbergeron> #info jdarcy was looking for info this morning on permissions errors on /dev/stderr during AMI startup.
19:04:54 <jdarcy> There's like three or four of them right at the end of startup.
19:05:03 <rbergeron> gholms: did you say they're benign? or ...
19:05:09 <gholms> Anyone know what those are about?  They don't seem to be the things that broke startup.
19:05:17 <gholms> They happen when I start instances that work.
19:05:34 <jdarcy> I was able to log in despite that, so I think they are benign.  I'd still like to understand where they're coming from, though.
19:05:46 <gholms> .bug 747692
19:05:49 <zodbot> gholms: Bug 747692 Networking startup failure on EC2, ami-7f5a063a (Cloud test day) - https://bugzilla.redhat.com/show_bug.cgi?id=747692
19:05:52 <gholms> ^ They appear here
19:06:53 <jdarcy> I might investigate a little further tonight.
19:07:10 <tflink> is that the only outstanding EC2 bug right now?
19:07:28 <rbergeron> yeah, but it's not breaking anything.
19:07:35 <rbergeron> oh wait
19:07:53 <gholms> Well, it *did* break things.  But I can't reproduce it.  Can any of you?
19:07:57 <rbergeron> gholms: that sounds like a failure, not benign
19:07:58 <rbergeron> ah
19:08:13 <gholms> The *error messages* appear to be benign.
19:08:46 <jforbes> I have never reproduced it here either
19:08:48 <tflink> so, not a failure?
19:08:48 <jdarcy> I was seeing it repeatedly last night, both on instances that succeeded and on instances that failed (due to my own security-group error).
19:08:55 <tflink> it'll be a final blocker if it is causing problems
19:09:13 <rbergeron> jdarcy: but did it cause networking problems for you?
19:09:21 <gholms> Can any of you reproduce the networking bug, though?
19:09:32 <gholms> The error messages look like they're just cosmetic.
19:09:38 <gholms> (effect-wise, at least)
19:09:44 <rbergeron> because there's a difference between benign /dev/stderr and that bug, which was networking doesn't start
19:09:57 <rbergeron> because nobody else saw that happen
19:10:12 <jforbes> Are there any new TC images yet?
19:10:12 <tflink> I see those errors all the time on serial console
19:10:22 <jdarcy> The only networking problem I saw was self-inflicted, not a bug.
19:10:24 <tflink> not EC2, but they aren't rare
19:10:25 <rbergeron> well, well, well
19:10:31 <gholms> tflink: Do you suppose it's a serial console-related issue?
19:10:32 <gregdek> ;)
19:10:52 <tflink> not sure, networking comes up so I've never really dug into it much
19:11:16 <rbergeron> jforbes: not ec2 ones, afaik
19:11:26 <rbergeron> dgilmore: you about?
19:11:31 <gholms> Unless someone can reproduce the networking issue I don't see that bug as a blocker.
19:11:39 <gholms> No word yet from the reporter.
19:11:50 <rbergeron> yeah. i mean, we had numerous people looking at it/testing and nobody else hit that
19:11:56 * tflink notes that we still don'
19:12:07 <tflink> t have EC2 stuff in the test matricies
19:12:32 <jforbes> It could have been something with the security group he used, networking came up, but wasn't allowed to do anything useful
19:12:52 <rbergeron> jforbes: he was one of the test day testers on the account i made
19:13:11 <rbergeron> tflink: maybe we can add that to the qa retrospective as a note?
19:13:23 <jforbes> rbergeron: makes no difference.  If you don't edit the default security group, you can't do anything
19:13:28 <tflink> yeah, as long as we actually test the EC2 images for final
19:13:37 <jdarcy> jforbes: That's exactly what I did.  Wouldn't be surprising if someone else did too.  IMO it's a bug that EC2 even allows an "allow nothing" instance.
19:13:41 <jforbes> tflink: oh, as soon as images are posted, they will be tested
19:13:51 <jdarcy> jforbes: But that's an Amazon bug, not a Fedora bug.
19:14:11 <gholms> jdarcy: It isn't an "allow nothing" instance; just one that falls into the default security group which can be opened up just like all the rest.
19:14:21 <jforbes> jdarcy: depends on how you look at it, I can certainly see cases where you don't want SSH listening on a group of hosts
19:15:00 * jdarcy shrugs.  Either way, not our problem.
19:15:05 * gholms nods
19:15:22 <tflink> do we need to create a releng ticket for the TC/RC EC2 AMIs?
19:15:38 <gholms> We should probably get a SOP for that as well.
19:15:40 <dgilmore> rbergeron: just got back from a bbq lunch
19:16:09 <dgilmore> tflink: no need to create a ticket for amis, i need to be able to compose them again
19:16:22 <rbergeron> dgilmore: that sounds yummay
19:16:33 <tflink> dgilmore: is something blocking you from composing them?
19:16:40 <dgilmore> tflink: yes me
19:16:47 <jforbes> dgilmore: any possibility of getting a TC?  Doesnt have to be made public, just something we can test a bit internally is okay
19:17:00 <tflink> ok, just making sure that we weren't missing any critical issues
19:17:04 <dgilmore> jforbes: as soon as i can compose them again
19:17:13 <jforbes> dgilmore: I appreciate it
19:17:38 <dgilmore> jforbes: my afternoon plan is to fix it
19:19:43 <gholms> On an unrelated note, I plan to update cloud-init in rawhide.
19:19:46 <rbergeron> okay, that sucked
19:19:46 * rbergeron gets back to having internet
19:19:48 <dgilmore> for the record the last attempt is http://koji.fedoraproject.org/koji/taskinfo?taskID=3461621
19:20:03 <rbergeron> dgilmore: yes, no, maybe? :) i know it's pretty busy atm
19:20:13 <dgilmore> just need to deal with grub once and for all
19:20:33 <dgilmore> the changes in grub in f16 finally killed appliance-creator
19:20:38 <dgilmore> so it needs a correct fix
19:20:53 <dgilmore> rbergeron: so the plan is to fix appliance-tools
19:20:57 <dgilmore> then we can compose again
19:21:00 <gholms> #info F16's grub changes broke appliance-creator
19:21:04 <dgilmore> then ill make a tc/rc
19:21:12 <dgilmore> depending on where exactly we are at
19:21:28 <gholms> #action dgilmore to fix appliance-tools and then create a TC/RC image in EC2
19:21:34 <jforbes> Well, I suppose appliance-tools in F16 not working with F16 needs tobe fixed EC2 or not
19:21:35 <rbergeron> okay... silence
19:21:38 <rbergeron> i'll move onwards
19:21:42 <rbergeron> to the next topic
19:21:44 <dgilmore> im hoping to have appliance-creator at least baindaded today
19:21:54 <dgilmore> so i could likely get some amis up
19:21:59 <rbergeron> and perhaps come back
19:22:09 <dgilmore> rbergeron: what silence? are you lagging?
19:22:13 <gholms> rbergeron: Silence? Are you not able to see what dgilmore is typing?
19:22:16 <rbergeron> #topic Since we're pretty much wrapped up feature wise....
19:22:33 <rbergeron> OH MY GOD
19:22:36 <rbergeron> I can now
19:22:37 <rbergeron> holy lag
19:22:39 <gholms> Haha
19:23:03 <gholms> Shall we go back?
19:23:08 <rbergeron> Um
19:23:14 <rbergeron> Did you guys make decisions
19:23:15 <rbergeron> ?
19:23:36 <gholms> rbergeron: dgilmore is going to fix appliance-tools so he can build a F16 image
19:23:37 <dgilmore> rbergeron: the only thing i think needing decided is where should we post the tc/rc
19:23:54 <dgilmore> rbergeron: should we just push to one or 2 zones
19:23:57 <dgilmore> or to all
19:24:08 <dgilmore> final should go to all for sure
19:24:23 <jforbes> dgilmore: no reason to push it anywhere but us-east-1 for TC/RC I would think
19:24:31 <rbergeron> yeah
19:24:33 <kkeithley> question about sysv/init vs systemd?
19:24:47 <gholms> #undo
19:24:47 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0xb23ebd0>
19:24:51 <dgilmore> jforbes: ok, i kinda prefer us-west-1 since its closer to where we make them
19:24:57 <dgilmore> but east is just as good
19:25:52 <jforbes> dgilmore: east is the "default" of sorts, and machine time is cheaper there
19:26:09 <gholms> All in favor, +1 plz :)
19:26:59 <gholms> Well, that didn't work.
19:27:11 <rbergeron> +1
19:27:31 <rbergeron> kkeithley: go for it, in a second, i'll switch topics after we... come to a conclusion
19:27:34 <dgilmore> jforbes: ok
19:27:36 <kkeithley> we shipped init.d scripts for glusterfs and hekafs. I opened BZs to convert to systemd. Does anyone object to an update soonish that switches to systemd or should they just stay as init.d scripts for the life of F16?
19:28:06 <dgilmore> kkeithley: your not allowed to switch mid release
19:28:15 <dgilmore> kkeithley: it wont be a cblocker for f16
19:28:27 <dgilmore> kkeithley: so it wonmt get in or hold up the release
19:28:40 <dgilmore> kkeithley: so that means your too late and must use sysv for f16
19:28:48 <dgilmore> you can switch to systemd in f17
19:28:53 <kkeithley> okay, good to know
19:29:34 <dgilmore> kkeithley: the rules are such that switching from one to the other can break things and have unintended consequences
19:29:48 <kkeithley> yup, that's why I asked
19:29:56 <gholms> dgilmore, jforbes: +1s for putting TC images in us-east-1?
19:30:08 <jforbes> gholms: yes
19:30:09 <dgilmore> gholms: :) ok thats what ill do
19:30:35 <gholms> #agreed Any TC/RC EC2 images will be registered in the us-east-1 region
19:31:10 <kkeithley> rbergeron: sorry, I read that as "go for it------ In a second I'll switch topics" not "go for it, in a second------"
19:31:19 <rbergeron> kkeithley: no worries :)
19:31:23 <gholms> rbergeron: What's next?
19:31:37 <rbergeron> #topic Anything else?
19:31:43 <rbergeron> I mean, things are kind of quiet right now.
19:31:57 * rbergeron looks at the people from eucalyptus thinking about F17, and the people from cloudstack thinking about F17
19:32:09 <rbergeron> But.
19:32:16 <rbergeron> I really don't have a whole heck of a lot.
19:32:27 <rbergeron> Does anyone have anything they'd like to talk about? :)
19:32:41 <dgilmore> rbergeron: well f17 work should have started at alpha branching and should be on its way to landing now :)
19:32:47 * jdarcy shrugs.
19:33:46 * rbergeron will hold for a momento and then tell everyone to go party
19:34:18 <kkeithley> half a sec
19:34:19 <gholms> rbergeron: Well, more dependencies are going into Fedora.  Does that count?
19:34:20 * jsmith could use a party
19:34:26 <tflink> ot tell them to help test F16 :)
19:34:32 * gholms could also use a party :)
19:34:35 <tflink> s/ot/or
19:34:40 * douglax has two scheduled :)
19:34:49 <tflink> tell/ask, anyways
19:35:05 <russellb> what, party?
19:35:10 <rbergeron> gholms: :)
19:35:13 <kkeithley> I just pulled my fedora-scm/glusterfs. No f17 branch. So if I put the systemd files on master then when it's branched (imminently) it'll be in rawhide and f17, right?
19:35:23 <gholms> kkeithley: Yes
19:35:45 <kkeithley> that's what I thought. Thanks
19:36:08 <rbergeron> kkeithley: udaman
19:36:20 <kkeithley> yeah, friday-list ftw
19:36:36 <kkeithley> or not
19:36:46 <kkeithley> :-)
19:36:54 <rbergeron> HAH
19:36:55 <rbergeron> ohgod
19:37:01 <rbergeron> okay. well,
19:37:19 <rbergeron> I LEAVE YOU ALL TO GO HAVE FUN (or test the living daylights out of tc3, pretty please)
19:37:34 <gholms> rbergeron: The two aren't exclusive.
19:37:42 <rbergeron> ;)
19:37:54 <rbergeron> Bye guys.
19:38:00 <rbergeron> #endmeeting