14:00:54 <mattdm> #startmeeting Cloud WG (2014-05-15)
14:00:54 <zodbot> Meeting started Thu May 15 14:00:54 2014 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:55 <mattdm> #meetingname cloud
14:00:55 <zodbot> The meeting name has been set to 'cloud'
14:00:57 <mattdm> #chair jzb mattdm geppetto red_trela samkottler mrunge rbergeron number80 frankieonuonga
14:00:57 <zodbot> Current chairs: frankieonuonga geppetto jzb mattdm mrunge number80 rbergeron red_trela samkottler
14:01:03 <mattdm> #topic Hello Everyone
14:01:09 <janeznemanic> hi
14:01:16 <mattdm> Hello everyone!
14:01:18 <mattdm> Who is here?
14:01:26 <mattdm> I suggest you "#info" yourself :)
14:01:35 <mattdm> #info mattdm
14:01:40 <jzb> #info jzb
14:01:46 <mattdm> that way, we'll have attendence in the minutes
14:01:47 <janeznemanic> #info janeznemanic
14:02:08 <roshi> #info roshi
14:02:12 <imcleod> #info imcleod
14:02:24 * imcleod trying to pay attention to this and the Nova Summit design session as well
14:02:36 <walters> #info walters
14:02:54 <scollier> #info scollier
14:03:00 <mattdm> i know red_trella and number80 are around somewhere because they were just lurking in #fedora-cloud
14:03:31 <number80> :)
14:03:33 <red_trela> #info red_trela
14:03:44 <number80> #info number80
14:03:55 <number80> .hellmynameis hguemar
14:04:02 <number80> .hellomynameis hguemar
14:04:03 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
14:04:15 <jsmith> .hellomynameis jsmith
14:04:16 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
14:04:26 <red_trela> sleepy and therefore not very attentive, but here ;)
14:05:09 <mattdm> okay, so, we technically need one more voting member for quorum if it comes to that, but we've got a lot of people in general so let's get started and we'll deal with any controversial votes if they come up. (doesn't seem likely)
14:05:15 <mattdm> #topic Current Tickets
14:05:19 <mattdm> https://fedorahosted.org/cloud/report/9
14:05:42 <mattdm> there are a handful of open tickets, some of which I think just need the meeitng keyword removed :)
14:06:01 <mattdm> I suggest we go through them really quickly and make sure they're disposed of appropriately
14:06:43 <mattdm> starting with....
14:06:45 <mattdm> #topic Deliverables and release engineering changes for Fedora.Next
14:06:46 <mattdm> https://fedorahosted.org/cloud/ticket/50
14:07:01 * jreznik_ is watching
14:07:03 <mattdm> This is pointing to releng ticket https://fedorahosted.org/rel-eng/ticket/5891
14:07:16 <mattdm> and I commented in _that_ ticket.
14:07:30 <mattdm> Anyone got anything more to do there?
14:08:34 <jreznik> thanks for the comment in the ticket mattdm
14:08:36 <jzb> mattdm: not at the moment
14:08:51 <number80> who will join the rel-eng group on our behalf ?
14:09:01 <jzb> mattdm: I believe I need to file tickets for the spints, but I haven't done that yet.
14:09:21 <imcleod> mattdm: It's possible that the Docker portion of that will block on getting a Factory update into koji.  I am unsure.  Will check with jgreguske and dgilmore.
14:09:45 <mattdm> imcleod okay thanks
14:09:59 <mattdm> jzb do you want this ticket to stay open to track that?
14:10:31 <mattdm> number80 excellent question. I know frankieonuonga had expressed some interest in the past...
14:10:45 <dgilmore> imcleod: we need to work out how to deliver the docker bits
14:10:57 <jzb> mattdm: yeah, thanks
14:11:25 <mattdm> also, on the releng front: oddshocks is joining as an intern this summer (as soon as school is out, in a week)
14:11:48 <number80> \o/
14:11:49 <mattdm> and his main task is going to be to work with releng to get automatic cloud image uploading working
14:12:00 <number80> glad he's back onboard
14:12:01 <mattdm> so I hope that will cover at least some portion of this.
14:12:53 <imcleod> dgilmore: Roger. Presumably the main goal would be to have the docker base images delivered directly to the official docker.io registry.
14:13:15 <mattdm> okay. so, I'll leave this on the agenda and we'll check back next week on the spins
14:13:35 <dgilmore> mattdm: i know the ostree patches landed in anaconda yesterday
14:13:48 <mattdm> #action jzb to file spins tickets
14:13:50 <dgilmore> mattdm: but we have no way today to deliver trees
14:14:08 <dgilmore> imcleod: okay.
14:14:22 <mattdm> #action mattdm to work with walters and dgilmore and whoever else to figure out the process of delivering ostree trees in a sane way
14:14:37 <walters> imcleod, i'm not sure; we probably want an intermediate stage where QA/users can verify before they're uploaded for real
14:14:41 <dgilmore> mattdm: so we need to make sure legal signs off on creating any accounts needed to upload images to third parties
14:14:54 <walters> imcleod, could be an internal registry, or could just be a .tar.gz one can docker import
14:15:04 <number80> we need taskotron here
14:15:06 <mattdm> dgilmore good point
14:15:33 <mattdm> scollier, can you get legal signoff on the docker account?
14:15:36 <scollier> mattdm, does that put a stop on the trusted builds?
14:15:40 <number80> I don't think we could rely only on QA puny human resources to test ostree updates
14:15:42 <walters> dgilmore, where can we discuss this?
14:15:47 <imcleod> walters: Makes sense.  I do, however, think there is benefit in having blessed and visible official images wherever possible, subject to the legal concerns dgilmore mentioned.
14:15:47 <scollier> mattdm, sure, with a pointer to get started.
14:15:50 <mattdm> scollier not really a stop, just a step to do
14:15:59 <walters> imcleod, yep definitely
14:16:17 <mattdm> scollier e-mail to legal@fedoraproject -- ping me after if you need more
14:16:31 <scollier> mattdm, thanks
14:16:51 <mattdm> #action scollier to get legal signoff for docker image upload account
14:17:20 <mattdm> and, is it too early to put someone down for action on the releng process for docker images?
14:17:50 <imcleod> scollier: If I can glom onto that discussion, I'm likely to want to establish something similar for the HP and Rackspace public clouds. (Assuming there is interest within this group in establishing an image upload process there as well.)
14:17:52 <scollier> mattdm, base images, layered images?
14:18:12 <mattdm> scollier there, I meant base images
14:18:29 <scollier> imcleod, sounds good.  i'll copy you
14:18:45 <mattdm> as I understand our plan, we'll push a base image from releng, and then use docker's trusted builds for our layered images
14:19:41 <mattdm> Yeah, I had a note to have gce, hp, rackspace as a meeting topic, but I guess this is actually the place for it already :)
14:20:08 <mattdm> I sent out a message about GCE. It really falls under the same umbrella
14:20:46 <imcleod> mattdm: I had a quick look at the upload process for GCE a few days back.  It doesn't look terrifying, but it does require using some of their client code.  I assume it is open source but need to double-check.
14:21:36 <mattdm> imcleod awesome. can I put you down for an action item to look into that? :)
14:21:58 <imcleod> mattdm: Sure.
14:22:10 <imcleod> #action imcleod to verify licensing status of GCE upload code
14:22:18 <dgilmore> walters: #fedora-releng or the releng list
14:22:18 <imcleod> mattdm: ^^^ - is that the right way to do it?
14:22:26 <mattdm> imcleod yes :)
14:22:28 <number80> gcutil ?
14:23:00 <imcleod> number80: I think so, yeah.
14:23:25 <number80> its code is apache
14:23:34 <mattdm> well that sounds good :)
14:23:42 <number80> we only had concern about potential bundled lib
14:23:54 <number80> (but none so far if i remember well)
14:24:07 <imcleod> Cool.
14:24:18 <mattdm> number80 is there a review request for that?
14:24:44 <number80> mattdm: nope, sam & some other guy were working on packaging it
14:25:50 <mattdm> since sam's not here, can you check into that? I know the _google_ folks want to get this moving and I hate it when _we_ are the bottleneck :)
14:26:11 <mattdm> imcleod -- you're in the process of talking to hp, right?
14:26:16 <scollier> mattdm, just getting back to your comment above, about base / layered images.  We are actually using the docker index for both base and layered.
14:26:18 <imcleod> Rackspace
14:26:26 <number80> i'd rather leave someone else until i get my left arm back ;)
14:26:34 <mattdm> imcleod er, yeah, right. :)
14:26:37 <number80> *taking care of it
14:26:39 <imcleod> mattdm: HP has an entirely public upload interface that uses the glance client, which is already packaged.
14:26:47 <mattdm> number80 I'll do it then :)
14:27:04 <mattdm> imcleod okay, so there, it's down to the legal signoff
14:27:17 <mattdm> #action mattdm to check with samkottler re state of gcutils
14:27:18 <imcleod> mattdm: My hope is that Rackspace is similar but I don't know yet.
14:27:48 <mattdm> #action mattdm to continue working on legal signoff for hp account
14:28:05 <mattdm> #action imcleod talking to rackspace about image upload api
14:28:23 <mattdm> and I think that's enough on this topic for now unless anyone has more?
14:29:57 <mattdm> #topic Project Atomic and Fedora Docker Host Image
14:29:58 <mattdm> https://fedorahosted.org/cloud/ticket/46
14:30:07 <mattdm> okay, last comment here is from red_trela
14:30:43 <mattdm> I think we are kind of covering the various other points in separate conversations ....
14:30:47 <mattdm> do we still want this ticket?
14:31:06 <red_trela> up to you :)
14:31:51 <mattdm> It is? :)
14:32:24 <mattdm> in that case, I *think* that there are more specific tickets that feel more... addressable, so I'm going to  close it
14:33:05 <red_trela> As far as I'm concerned, yes. Your ticket, your questions/concerns. If you feel they are looked after elsewhere, good.
14:33:11 <mattdm> #topic File F22 change: Re-factor cloud-init
14:33:13 <mattdm> https://fedorahosted.org/cloud/ticket/23
14:33:16 <number80> hi
14:33:31 <mattdm> number80 yes :)
14:33:43 * mattdm waits patiently for the one-handed typing
14:33:45 <number80> walters has added the user data script support so it should be usable, needs some testing
14:34:02 <number80> F22 is realistic
14:34:13 <mattdm> awesome
14:34:31 <red_trela> if it's usable, why not target F21? :)
14:34:49 <mattdm> six months is a long time away :)
14:34:50 <number80> we still need python on F21 image
14:35:05 <number80> and cloud-init is actually being refactored
14:35:09 <mattdm> number80 what about _just_ in the Fedora Atomic image?
14:35:14 <number80> +1
14:35:37 <mattdm> for f21?
14:35:41 <number80> yes
14:36:07 <mattdm> ok. so, I suggest leaving this open and removing the meeting keyword until there's something to decide
14:36:13 <number80> in tok
14:36:16 <number80> ok
14:36:22 <red_trela> +1
14:37:10 <mattdm> done
14:37:18 <mattdm> #topic start communication/collaboration on cloud image updates
14:37:20 <mattdm> https://fedorahosted.org/cloud/ticket/51
14:37:35 <mattdm> roshi, you around?
14:37:46 <roshi> I am :)
14:37:56 <mattdm> what's the status of this?
14:38:15 <roshi> not a lot has changed from last week
14:38:27 <roshi> development on taskotron is moving forward
14:38:46 <mattdm> heh, fair enough. is the ticket still useful for future meetings?
14:38:55 <roshi> I'm working on some documentation pieces for it, but am not to the point yet for doing cloudy things with it
14:39:05 <mattdm> do you need more help on anything specific?
14:39:09 <mattdm> or not specific? :)
14:39:19 <roshi> not unless you just wanted a "status update"
14:39:34 <roshi> not that I know of - but asking tflink would be better since he's point on this
14:39:55 <mattdm> okay -- let's leave it for a status update next week too. it's important.
14:40:04 <mattdm> but sounds like we can move on now.
14:40:04 <roshi> sounds good to me
14:40:11 <mattdm> #topic rename cloud spin kickstart to distinguish the cloud base image
14:40:13 <mattdm> https://fedorahosted.org/cloud/ticket/16
14:40:39 <mattdm> I think maybe this one can be moved from the meeting keyword...
14:41:13 <mattdm> red_trela: I have no idea the answer to your question but also can't imagine any resolution that I would think is a problem. whatever works :)
14:43:08 <red_trela> mattdm: so one seems less confusing, but yea, whatever works :)
14:43:35 <mattdm> red_trela cool. since we made the basic decision, can you handle the technical whatever-needs-to-get-done to make it happen?
14:45:20 <red_trela> mattdm: sure
14:45:24 <mattdm> #action red_trela to deal with cloud image kickstart file renaming
14:45:36 <mattdm> okay, so, then we have...
14:45:43 <mattdm> #topic Other Followups
14:45:43 <red_trela> mattdm: but first, we need to go through the spins process, I guess
14:45:55 <jzb> Have to run, sorry.
14:46:08 <mattdm> red_trela yeah
14:46:19 <mattdm> so the other followups are:
14:46:21 <red_trela> which we really need to get going...sigh, time is flying by recently :/
14:46:25 <mattdm> * mattdm create All the Things ticket (components needed for image)
14:46:27 <mattdm> * mattdm to make high-level ticket covering issues with shipping ostree
14:46:29 <mattdm> trees... this will fork into qa and releng and mirror conversations
14:46:31 <mattdm> * jzb Solicit folks who want to volunteer for the WG
14:46:51 <mattdm> red_trela jzb was going to file the spins tickets. but he just ran off :)
14:46:58 <mattdm> on the things I just highlighed:
14:47:04 <mattdm> #info All the things: https://fedorahosted.org/cloud/ticket/55
14:47:10 <mattdm> #info ostree conversations: https://fedorahosted.org/cloud/ticket/56
14:47:41 <mattdm> and I guess we will defer the last one because of the aforementioned jzb-just-ran-off :)
14:47:42 <red_trela> mattdm: I know :)
14:47:51 <mattdm> so that leaves:
14:47:54 <mattdm> #topic Open Floor
14:48:14 <mattdm> anything else?
14:49:05 <mattdm> going to close the meeting in one minute unless anyone speaks up
14:49:24 <red_trela> Speaking of spins process, I expect I'll push the atomic image through it and whoever own the big data image does likewise. Who's in charge of the base image in this regard?
14:50:00 <walters> base cloud or base docker?
14:50:05 <mattdm> red_trela Good question. I guess it's me, unless someone else wants to grab it
14:50:09 <mattdm> walters: base cloud
14:50:14 <mattdm> eg the traditional one
14:50:17 <walters> k
14:50:55 <red_trela> mattdm: I figure I can try to do base and atomic side by side, if you want
14:51:15 <mattdm> red_trela I am _totally_ willing to hand off anything I can :)
14:51:35 <mattdm> #info red_trela to handle cloud base and atomic spins process
14:51:41 <roshi> that seems to be a theme around here...
14:51:48 <mattdm> roshi \o/
14:52:08 <red_trela> good with me, I just end up putting it on roshi's plate in the end anyway, like always :)
14:52:29 <roshi> most places I've worked, people hold onto their tasks like Smeagol...
14:52:31 <roshi> lol
14:52:50 <number80> :)
14:53:17 <red_trela> roshi: see, we are all about sharing our tasks with you, aren't we nice guys? :)
14:53:25 <roshi> anybody look at those QA docs?
14:53:29 * mattdm is the Tom Bombadil of holding on to work
14:53:38 <roshi> yeah - it's an odd feeling
14:53:54 <mattdm> roshi what's th elink again?
14:53:57 <roshi> feels good to be around such nice guys - but also feels like more work
14:53:59 <roshi> jas
14:54:01 <number80> roshi: a project succeed when its creators can leave at any time without worries !
14:54:22 <roshi> https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs
14:54:30 <number80> feels good to be wtogami
14:54:31 <number80> :)
14:54:34 <roshi> for sure number80 :)
14:54:43 <mattdm> #halp need people to look at draft cloud QA docs https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs
14:55:11 <mattdm> I'm going to go ahead and assume that people would have said that they did it if they did, and instead put out the cry for help :)
14:55:15 <roshi> they're not complete - but need to know if I was even going in the right direction
14:55:36 <mattdm> I will look right after this meeting. because that's the only way to not put it off further.
14:55:37 <roshi> wfm
14:55:42 <mattdm> I've got it up in my browser now :)
14:55:43 <roshi> haha
14:55:51 <mattdm> anyone got anything else?
14:55:57 <roshi> no worries - just didn't want it to get forgotten :)
14:56:25 <mattdm> roshi absolutely!
14:56:48 <mattdm> okay, here we go again -- meeting closing in one minute unless anyone speaks up
14:57:41 <mattdm> #endmeeting