17:06:11 <mattdm> #startmeeting cloud (2014-09-12)
17:06:11 <zodbot> Meeting started Fri Sep 12 17:06:11 2014 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:06:18 <mattdm> #meetingname cloud
17:06:19 <zodbot> The meeting name has been set to 'cloud'
17:06:40 <mattdm> #chair agrimm roshi dustymabe oddshocks
17:06:40 <zodbot> Current chairs: agrimm dustymabe mattdm oddshocks roshi
17:06:57 <mattdm> #topic roll call!
17:07:06 <roshi> .hellomynameis roshi
17:07:08 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:07:11 <agrimm> .hellomynameis arg
17:07:12 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
17:07:15 <mattdm> I am here. As noted, wifi is laggy -- it's like I'm on a 12000 baud modem.
17:07:21 <dustymabe> .hellomynameis dustymabe
17:07:22 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@gmail.com>
17:07:32 <mattdm> .hellomynameis mattdm
17:07:33 <number80> .hellomynameis hguemar
17:07:34 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:07:35 * kushal is here to read the text :)
17:07:37 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:07:48 <mattdm> #chair number80
17:07:48 <zodbot> Current chairs: agrimm dustymabe mattdm number80 oddshocks roshi
17:08:00 <mattdm> #chair kushal
17:08:00 <zodbot> Current chairs: agrimm dustymabe kushal mattdm number80 oddshocks roshi
17:08:15 <mattdm> number80 I'm handing running the meeting over to you :)
17:08:20 <number80> thanks
17:08:21 <kushal> .hellomynameis kushal
17:08:22 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:08:46 <agrimm> hi, kushal!  glad to have HP represented here today.  ;-)
17:09:03 <number80> #topic Project Atomic
17:09:05 <kushal> agrimm, Eeeks.
17:09:22 <number80> https://fedorahosted.org/cloud/ticket/64
17:09:27 <kushal> agrimm, I still work for Eucalyptus :)
17:09:57 <agrimm> kushal, po-tay-to, po-tah-to
17:10:10 <number80> (please wait after the meeting ;) )
17:10:28 * oddshocks here
17:10:39 * oddshocks was cleaning microwave after a small disaster last night
17:10:46 <number80> jzb is excused today but he sent a report on the list
17:11:06 <oddshocks> .hellomynameis oddshocks
17:11:07 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
17:11:27 <mattdm> also jzb said that we should #action him for all of the things.
17:13:18 <ochento> sorry got disconnected
17:13:46 <oddshocks> sounds like a plan
17:13:56 <roshi> works for me :)
17:14:09 <roshi> does that mean we can action the rest of us to take naps?
17:14:41 <number80> wait for it
17:15:04 <mattdm> for the record that's not quoite what he said :)
17:15:10 <number80> #info Atomic website updated and removal of 32 bits downloads (ticket #36)
17:15:29 <1JTAAFO1I> ?
17:15:58 <number80> what the hell ?
17:16:08 <number80> (about the nick change)
17:16:16 <roshi> having some identity issues number80?
17:17:11 <mattdm> hmmm..
17:17:11 <1JTAAFO1I> mattdm: could you take the lead, between the VPN issue and freenode changing my nick, we won't move forward :(
17:17:32 <mattdm> or how about someone with fast interent? volunteers, anyone?
17:17:49 <mattdm> internet <- typo illustrates problem
17:17:49 * roshi wouldn't know how to run our cloud meetings
17:18:18 <Southern_Gentlem> roshi,  just like anyother meeting with meetbot
17:18:39 <roshi> I mean where our tickets are and whatnot, I can take a crack at it though
17:18:47 <1JTAAFO1I> https://fedorahosted.org/cloud/report/9
17:18:54 <mattdm> roshi https://fedorahosted.org/fesco/report/9
17:19:00 <roshi> anything else for the atomic issue?
17:19:28 <mattdm> it looks like jzb's patch should be good for now
17:19:44 <roshi> I get no matches found for ticket 9
17:19:49 <roshi> er, report 9
17:19:54 <kushal> roshi, I can view it.
17:20:09 <kushal> Next is
17:20:12 <dustymabe> roshi: I see it too
17:20:22 <kushal> Article for Fedora Magazine on "state of cloud SIG/product" for alpha release
17:20:24 <mattdm> uh use the cloud link not the fesco one i posted
17:20:32 * mattdm is causing more trouble than help
17:20:43 <kushal> https://fedorahosted.org/cloud/ticket/75 that is
17:20:43 <roshi> ah
17:20:45 <roshi> that's it
17:20:47 <roshi> haha
17:20:56 <roshi> I just clicked the last link thinking it was a dup
17:21:25 <dustymabe> so should I change the topic to be that?
17:21:43 <kushal> dustymabe, I guess go ahead.
17:21:45 <dustymabe> #topic Article for Fedora Magazine on "state of cloud SIG/product" for alpha release
17:21:53 <kushal> everyone is on slow network
17:21:59 <dustymabe> #link Article for Fedora Magazine on "state of cloud SIG/product" for alpha release
17:22:07 <roshi> my network is fine, now that I know where the tickets are :)
17:22:10 <dustymabe> #link https://fedorahosted.org/cloud/ticket/75
17:22:23 * walters is here now
17:22:25 <dustymabe> roshi: good. I don't know what I am doing :)
17:22:46 <mattdm> dustymabe clearly none of us do :)
17:22:50 * amita reading, good luck roshi :)
17:23:11 <dustymabe> ok.. anyone have anything for current topic?
17:23:15 <kushal> So any comments on that?
17:23:22 <kushal> dustymabe, ah you are fast.
17:23:29 * roshi has none
17:23:39 <mattdm> any volunteers to write?
17:23:45 <roshi> dustymabe: you going to run this then?
17:23:59 <dustymabe> roshi: sure.. i'll try
17:24:06 <roshi> kk :)
17:24:08 <dustymabe> roshi: that means no one can make fun of me :)
17:24:28 <dustymabe> mattdm: who is best qualified?
17:24:41 <dustymabe> mattdm: in other words.. who has the knowledge
17:24:42 <roshi> jzb owns the ticket
17:25:01 <mattdm> I hope we have enough people who are qualified overall that that's not the deciding factor :)
17:25:28 <roshi> should probably come from some WG member
17:25:30 <mattdm> I _can_ but I'd love for someone else to do it
17:25:34 <roshi> (someone listed in the wiki)
17:25:40 <dustymabe> mattdm: does "state" mean the state as far as being ready for F21?
17:26:01 <mattdm> dustymabe: I think the idea is to present initial marketing buildup for potential F21 users
17:26:14 <mattdm> so state reflecting what people will be able to see and do in F21
17:26:21 <dustymabe> Got it. so differences from last release ? new features.. etc?
17:26:33 <roshi> for F21 or for F21 *alpha?*
17:26:39 <kushal> dustymabe, also how to get it.
17:26:56 <number80> we could also start to write something on the wiki collaboratively
17:27:06 <dustymabe> number80: that might be a good idea
17:27:15 <kushal> #idea number80: we could also start to write something on the wiki collaboratively
17:27:16 <dustymabe> number80: at least to get all "bullet points" together
17:27:23 <mattdm> sounds good to me.
17:27:26 <number80> *nods*
17:27:31 <dustymabe> then someone could pull it all together
17:27:33 <kushal> I hope that was a right command.
17:27:36 <mattdm> I think not just new features but also introduction for people who haven't used it before.
17:27:45 <mattdm> possibly even separate articles for atomic and base
17:27:54 <dustymabe> mattdm: indeed
17:28:09 <kushal> mattdm, may be few lines on how they can use it?
17:28:16 <mattdm> yes
17:28:34 <dustymabe> k.. anyone want to take an action item to start a wiki page?
17:28:37 <roshi> kushal: #info is what you're looking for I think
17:28:44 <mattdm> I think in general, as many bite-sized articles as possible.
17:28:45 <roshi> #idea isn't a meetbot command I don't thikn
17:29:07 <kushal> roshi, it is based on our wiki page, just now confirmed it.
17:29:09 <kushal> #commands
17:29:09 <zodbot> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #rejected #restrictlogs #save #startmeeting #topic #unchair #undo #unlurk
17:29:13 <number80> https://fedoraproject.org/wiki/User:Hguemar/marketing/cloud_image_f21_status
17:29:25 <kushal> #link https://fedoraproject.org/wiki/User:Hguemar/marketing/cloud_image_f21_status
17:29:26 <roshi> oh, I stand corrected
17:29:32 <dustymabe> number80: is that the page we should add info to?
17:29:42 <roshi> :)
17:29:50 <number80> dustymabe: it's a sandbox before submitting to fedora magazine
17:30:00 <number80> I'll start filling it but you're welcome to join me
17:30:05 <dustymabe> number80: got it
17:30:06 <dustymabe> thanks
17:30:29 <kushal> Moving to next topic?
17:30:34 <dustymabe> #info wiki page created for ideas for fedora magazine article for f21 cloud image
17:30:35 <number80> (and a line starts by an url, it's implicitly calling #link command)
17:30:56 <mattdm> -> nexttopic :)
17:30:57 <kushal> number80, Okay, never knew that one.
17:30:58 <imcleod> .hellomynameis imcleod
17:30:59 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
17:31:00 <dustymabe> can someone add this information to the ticket?
17:31:02 <imcleod> Sorry I'm late folks.
17:31:07 <kushal> #topic Plan test days for Atomic image
17:31:16 <kushal> #link https://fedorahosted.org/cloud/ticket/74
17:32:02 <kushal> Owner is also jzb
17:32:05 <roshi> I can help plan the test day and facilitate throughout the day
17:32:16 <roshi> testdays are one of the things I do kinda by default for QA
17:32:22 <dustymabe> walters: do you have an opinion on when atomic will be ready for testing?
17:33:52 <dustymabe> roshi: can you reach out to jzbto coordinate?
17:34:32 <roshi> sure
17:34:35 <kushal> #action roshi will reach out to jzb for corodination of Atomic image testdays.
17:34:46 <dustymabe> thanks
17:34:48 <dustymabe> next topic
17:34:49 <roshi> np
17:34:55 <kushal> #topic Coordinate F21 / fedora next website
17:35:03 <kushal> #link https://fedorahosted.org/cloud/ticket/36
17:35:51 <mattdm> this one we already covered
17:36:16 <kushal> mattdm, then can we move to next topic?
17:36:55 <number80> *nods*
17:36:57 <walters> dustymabe, hard to say for sure
17:37:03 <kushal> #topic start communication/collaboration on cloud image updates
17:37:07 <walters> but we had a working base for a while, modulo bugs
17:37:17 <kushal> #link https://fedorahosted.org/cloud/ticket/51
17:37:43 <dustymabe> walters: do you think it will be this month? for the sake of fedora test days?
17:37:59 <roshi> not a whole lot has changed for 51 since agrimm and I talked last week, afaik
17:39:18 <kushal> roshi, so should we move to the next topic?
17:39:28 <roshi> as far as I know we can
17:39:30 <kushal> if no extra updates on this.
17:39:37 <kushal> #topic meeting agenda item: next steps on test plan
17:39:43 <kushal> #info https://fedorahosted.org/cloud/ticket/61
17:41:13 <walters> dustymabe, i'd certainly hope so
17:41:51 <roshi> I think we have everything we need for testing our base image
17:41:52 <kushal> https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/ticket61 also pointed out in the ticket.
17:42:13 <roshi> I have an appt right after this meeting, but then I'll create a validation page on the wiki like Server has
17:42:13 <mattdm> so right now the next step is "do the test plan!" :)
17:42:25 <mattdm> thanks roshi!
17:42:43 <roshi> np - I'm sure it'll evolve as we move forward, but it should be a good starting point
17:43:00 <roshi> and oddshocks and I have been talking about the smoke testing part of the test plan
17:43:27 <mattdm> any quick updates on that?
17:45:17 <roshi> not really - we were discussing splitting out the testing from fedimg and keeping the testing seperate
17:45:28 <oddshocks> after talking with roshi and tflink it seems like test control could be done through taskotron
17:45:32 <roshi> to make it more easily pluggable into taskotron
17:45:39 <oddshocks> it would be really easy to split the testing out of fedimg. it's very modular
17:45:49 <mattdm> okay cool.
17:45:53 <mattdm> that makes sense to me.
17:46:08 <mattdm> the thing I want is to know very quickly whether a koji-produced image is good
17:46:19 <mattdm> so no one wastes time trying to test ones which aren't
17:46:28 <roshi> makes sense
17:46:33 <number80> *nods*
17:46:41 <roshi> this is a different ticket though :)
17:46:43 <roshi> #38
17:46:48 <mattdm> heh yes
17:47:02 <kushal> roshi, is there any automated checks we run?
17:47:19 <roshi> not at the moment, outside of oddshocks fedimg tests
17:47:26 <roshi> does /bin/true work, iirc
17:47:34 <kushal> roshi, Okay.
17:48:34 <kushal> mattdm, I guess I can move to next ticket then?
17:49:14 * mattdm nods
17:49:17 <kushal> #topic meeting agenda item/tracker for Project Atomic
17:49:22 <kushal> #info https://fedorahosted.org/cloud/ticket/64
17:50:44 <kushal> Any update on this?
17:51:28 <kushal> No I suppose.
17:51:29 <roshi> I thought we already did this one
17:51:36 <roshi> it was first, wasn't it?
17:51:52 <kushal> roshi, that was #74
17:52:14 <roshi> oh, nvm then
17:52:22 <kushal> but I think we talked about it anyway.
17:53:53 <roshi> we did, it was #topic Project Atomic
17:54:10 <kushal> Yes
17:54:11 <kushal> then
17:54:14 <roshi> 15:10 in the logs
17:54:19 <kushal> #topic Open Floor
17:54:38 <kushal> roshi, I just do not know yet why two different tickets :)
17:54:46 <mattdm> Open floor item!
17:54:51 <kushal> roshi, I thought it had something different.
17:54:51 <number80> are we holding a classic image test day ?
17:55:02 <roshi> no worries kushal :)
17:55:22 <mattdm> We've gotten to a state where the people coming to these meetings and doing the active work do not have a lot of overlap with official wg membership
17:55:44 <roshi> I don;t think we have a base image test day
17:55:58 <mattdm> It's not been six months since last time, but I'm going to post another message to the SIG list saying that we should rearrange.
17:56:04 <roshi> would have to find a means of getting people test instances with the images though
17:56:17 <number80> +1 mattdm
17:56:18 <roshi> or to test locally
17:56:41 <roshi> makes sense to me
17:57:00 <mattdm> I'm in favor of a test day
17:57:34 <number80> if you want to join in the RDO test day, it will be around september, 25
17:57:34 <mattdm> we have the "community cloud" amazon account we can get people access to
17:57:35 <kushal> Just as a note: There is a new CentOS cloud SIG coming, I hope we will be able to share ideas  :)
17:58:00 <dustymabe> number80: sept 25th and 26th right?
17:58:10 <number80> i have been testing the nightlies against openstack and as for F21 it's ok (not so much for rawhide)
17:58:13 <number80> dustymabe: yup
17:58:33 <number80> mattdm: I could monkey test on AWS
17:58:37 <mattdm> number80: yeah i noticed -- we'll have to fix rawhide once f21 is basically going forward
17:58:52 <number80> *nods*
17:58:55 <kushal> oddshocks, do you run your tests in an automated fashion?
17:59:16 <number80> that's why I didn't worry, F21 is in a good shape, I want to make sure it's ok
17:59:22 <number80> s/ok/even better/
17:59:26 <kushal> like one will keep running the tests in the new cloud images build and share the result?
18:00:10 <number80> roshi: will you pair up with me for a test day ?
18:00:19 <roshi> sure
18:00:26 <roshi> for base image?
18:00:30 <number80> yup
18:01:00 <roshi> yep - sgtm
18:01:04 <number80> #action hguemar & roshi organize a test day for base image (discussion on the list)
18:01:05 <roshi> I have to depart for an appt
18:01:13 <number80> see ya
18:01:15 <kushal> mattdm, do you think it will be a good idea to have a system which will run some basic tests in an automated way to any latest cloud image builds?
18:01:18 <mattdm> #action mattdm to discuss wg composition on list
18:01:18 <roshi> thanks guys!
18:01:32 <kushal> roshi, bye.
18:01:35 <mattdm> kushal: yes. roshi and oddshocks were talking about using taskotron to do this
18:01:48 <kushal> mattdm, Ah, okay.
18:01:49 <jsmith> mattdm: I'd be happy to test our AWS cloud documentation again, if you'd like
18:02:32 <oddshocks> kushal: yes, sorry for the delayed response
18:02:42 <kushal> oddshocks, Okay, no issues.
18:02:56 <oddshocks> kushal: after the AMI is programmatically created, tests run automatically as well, after a test instance is spun up based on the AMI that was created :)
18:03:09 <kushal> oddshocks, cool,
18:03:59 <mattdm> jsmith: that'd be great
18:04:09 <number80> oddshocks: it would be nice to also test on various type of instance, there are some tricky bugs due to Xen and the underlying hardware btw
18:04:27 <jsmith> mattdm: Let's connect up offline to get the credentials passed along, etc.
18:04:57 <mattdm> jsmith: yeah sounds good.
18:05:10 * mattdm is going to walk to somewhere with fast internet now :)
18:06:22 <oddshocks> number80: always down for more coverage. unfamiliar with Xen though
18:07:01 <kushal> number80, we need those hardware too
18:07:11 <number80> oddshocks: just firing up the VM on different generation of hardware on AWS
18:07:18 * dustymabe has to run
18:07:18 <kushal> number80, Okay.
18:07:27 <kushal> dustymabe, Good bye :)
18:07:33 <number80> let's close the meeting !
18:07:39 <kushal> #endmeeting