21:03:09 <rbergeron> #startmeeting Cloud SIG
21:03:09 <zodbot> Meeting started Thu Dec 16 21:03:09 2010 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:03:10 <dgilmore> rbergeron: sorry
21:03:17 <rbergeron> #meetingname Cloud SIG
21:03:17 <zodbot> The meeting name has been set to 'cloud_sig'
21:03:24 <rbergeron> #topic Roll call!
21:03:27 <rbergeron> dgilmore: no worries :)
21:03:28 <gholms> dgilmore: Three minutes is nothing.  ;)
21:03:39 * jforbes is here and caffeinated :)
21:03:45 * mmorsi is here
21:03:49 <gholms> Hai!
21:03:54 <rbergeron> jforbes: woot for caffeine
21:04:03 <rbergeron> hey mmorsi
21:04:05 <mmorsi> hey
21:04:21 * gholms has also had way too much caffeine  @_@
21:04:25 <rbergeron> clalance :)
21:04:26 * mmorsi drank a full cup of coffee and is still tired 0_o
21:04:28 * rbergeron needs moar caffeine
21:04:29 <clalance> rbergeron: Sorry I'm late.
21:04:39 <rbergeron> clalance: we are just getting started.
21:04:42 <clalance> mmorsi: Thanks for the heads up :).
21:04:47 <mmorsi> np
21:04:59 <rbergeron> alrighty.
21:05:08 <mgoldmann> here here
21:05:09 <gholms> Meeting schedule first?
21:05:11 <rbergeron> #topic It's the most wonderful time of the year
21:05:21 <mgoldmann> cannot agree :)
21:05:27 <rbergeron> mgoldmann: me either.
21:05:43 <rbergeron> #chair gholms
21:05:43 <zodbot> Current chairs: gholms rbergeron
21:05:46 <rbergeron> #chair jforbes
21:05:46 <zodbot> Current chairs: gholms jforbes rbergeron
21:06:03 <gholms> #info It might actually *not* be the most wonderful time of the year.  :-\
21:06:03 <rbergeron> So: I know a number of folks will be out on vacation during the next few weeks.
21:06:34 <rbergeron> I wanted to see if we can continue to have cloud meetings, or if we will be too thin to do so.
21:06:41 <rbergeron> I think we should be able to forge ahead.
21:06:43 <jforbes> http://www.youtube.com/watch?v=mvZ0KmPNAk8
21:06:46 <mmorsi> its the cloudiest time of the year, how about that ;-)
21:06:49 <rbergeron> gholms: did you ahve anything you wanted to add to that?
21:06:54 <rbergeron> mmorsi: brilliant.
21:07:03 <jforbes> I will certainly be here next week, but not the week after
21:07:03 <gholms> mmorsi: +1
21:07:11 <clalance> rbergeron: I will miss the meeting on the 30th.  Otherwise I can make it.
21:07:25 * rbergeron will be here next week, and may or may not be able to make it on the 30th, depending on what's going on.
21:07:35 <gholms> How about this?  Who can make it on Thursday the 23rd?
21:07:44 * rbergeron can make it on thursday the 23rd.
21:07:45 * clalance can
21:07:48 <jforbes> I will be here on the 23rd
21:07:56 * mmorsi can
21:08:02 * mgoldmann too
21:08:06 <mmorsi> not the week after that tho
21:08:09 <gholms> Sounds like a meeting is in order for the 23rd, then.  How about the 30th?
21:08:15 * clalance cannot
21:08:19 * mmorsi can't
21:08:19 <rbergeron> #agreed meeting will work on the 23rd
21:08:23 * jforbes will not be here on the 30th
21:08:28 * mgoldmann says maybe
21:08:34 * rbergeron says maybe as well
21:08:49 <gholms> I'm moving, so I can't commit to either.  :(
21:08:59 <rbergeron> Okay.
21:09:23 <rbergeron> Why do'nt we just cancel the meeting on the 30th, since it looks like we are pretty slow.
21:09:31 <rbergeron> With the caveat that if anyone needs something, the mailing list is always open.
21:09:39 <sdake> ya im moving onthe 30th too
21:09:40 <sdake> ;)
21:09:41 <rbergeron> And please raise your hand if you're having a fire, etc. :)
21:09:44 <mgoldmann> rbergeron: +1
21:09:46 <mmorsi> works 4 me
21:10:31 <rbergeron> #agreed cancelling the meeting on the 30th; please mail the list if you have anything needing addressing.
21:10:32 <jforbes> or call 911
21:10:35 <clalance> Haha.
21:10:49 <jforbes> irc response times can be slow
21:11:06 <rbergeron> thankfully 911 doesn't respond over irc.
21:11:11 <rbergeron> :)
21:11:17 <rbergeron> okay, moving forward!
21:11:22 <rbergeron> #topic EC2
21:11:28 * gholms looks for brianlamere
21:11:30 <rbergeron> jforbes: whatcha got
21:12:00 <rbergeron> yeah, i don't see brianlamere about
21:12:09 <rbergeron> :(
21:12:34 <jforbes> Nothing to report at the moment, I tried to get with dgilmore earlier today for the koji permissions and incantation to build images to test, but he asked that I contact him tomorrow.  Infrastructure is busy today
21:12:46 <rbergeron> yeah, they are.
21:12:58 <gholms> They're going to be dealing with an overloaded netapp for a while, from the sound of things.
21:13:34 <rbergeron> jforbes: coolio.
21:13:48 * rbergeron passes jforbes the "fastest ec2 wrapup ever in a meeting" award :)
21:13:52 <gholms> Heh
21:13:53 <jeremy> netapp, schmetapp ;)
21:13:58 <rbergeron> #topic Boxgrinder
21:13:59 <gholms> I've got a small thing.
21:14:02 <gholms> (for BG)
21:14:02 <rbergeron> ohhhh
21:14:04 <rbergeron> oh.
21:14:08 <gholms> ;)
21:14:12 <rbergeron> mgoldmann: how goes it?
21:14:18 <mgoldmann> very good! :)
21:14:23 <rbergeron> gholms: ask away :)
21:14:35 <mgoldmann> thanks to gholms we have now working euca2ools
21:14:42 <rbergeron> sweet.
21:14:43 <gholms> We reportedly have images that work with EC2 now.
21:14:48 <mgoldmann> it needs karma :)
21:15:02 <gholms> It's on its way to updates-testing, though when the next push will be is anybody's guess.
21:15:07 <mgoldmann> so, I'm going to push a full set of BG ASAP
21:15:14 <clalance> gholms: 1.3.1-4.fc13, correct?
21:15:20 <gholms> clalance: Yep
21:15:23 <mgoldmann> I need testers for packages that are already in updates-testing
21:15:32 <gholms> So please get your packages from here for now... http://repos.fedorapeople.org/repos/gholms/cloud/
21:15:33 <rbergeron> brianlamere: welcome
21:15:38 <brianlamere> greetings!
21:15:39 <clalance> gholms: OK, cool.  We are trying to update the deltacloud aggregator to the new BG.
21:15:46 <clalance> So that should test it indirectly.
21:15:53 <mgoldmann> very good!
21:15:56 <gholms> Then add karma at https://admin.fedoraproject.org/updates/euca2ools-1.3.1-4.fc14 and https://admin.fedoraproject.org/updates/euca2ools-1.3.1-4.fc13 , please.
21:15:56 <clalance> (we'll add karma when/if we get it working)
21:16:04 <clalance> That really should be when :).
21:16:08 <brianlamere> holiday party happening around me, apologies for lateness
21:16:09 <mgoldmann> of course, perfect
21:16:31 <mgoldmann> rbergeron: so, moving forward, quite fast with BG
21:16:37 <clalance> mgoldmann: Which version of the boxgrinder ec2 plugin uses euca2ools?
21:17:00 <gholms> You need a nightly of the S3 plugin, IIRC.
21:17:09 <clalance> OK, gotcha.  Will pull that down.
21:17:10 <mgoldmann> it was not yet released, because I needed a working one
21:17:17 <clalance> Ah, OK.
21:17:23 <mgoldmann> nightly will be build this night :)
21:17:47 <brianlamere> where'd the kickstart file usage issue end up?
21:17:50 * gholms recommends depending on "euca2ools >= 1.3.1-4"
21:18:07 <mgoldmann> gholms: good point, adding
21:18:09 <gholms> brianlamere: Here:  https://issues.jboss.org/browse/BGBUILD-73
21:18:45 <skvidal> essentially mgoldmann has forked the kickstart file format by adding functional comments
21:18:58 <gholms> >:(
21:19:19 <mgoldmann> exactly two: operating system name and version which kickstart file does not provide
21:19:58 <mgoldmann> many other plugns depend on those values (for example S3 - selecting proper AKI pair)
21:20:16 <mgoldmann> if you have better idea - I'm listening, really
21:20:22 <gholms> Use pvgrub?
21:20:38 <skvidal> I'm thinking the ami-creator katzj posted seems like a good avenue for dev
21:20:38 <mgoldmann> we use pvgrub
21:20:49 <gholms> Then you don't need to pick a AKI.
21:21:07 <skvidal> it's a vastly simpler base and therefore doesn't bring into it nearly as much feature requirements beyond the scope we actually require in fedora
21:21:27 <mgoldmann> well, partially correct, I have also support for fedora 11, but I think I get rid of that soon
21:22:29 <skvidal> f11 is EOL'd there's no need for supporting it from fedora's standpoint
21:22:43 <gholms> #info ami-creator:  http://lists.fedoraproject.org/pipermail/cloud/2010-December/000453.html
21:23:11 <gholms> brianlamere: Any thoughts?
21:23:19 <mgoldmann> sure, if katzj's creator works better for Fedora rel-eng, I'm cool with that, BG is not meant for sysadmins really - it's a tool that helps other people: app developers, home users etc making live easier
21:23:43 <mgoldmann> skvidal: yes, I agree with the F11 bit
21:24:01 <brianlamere> gholms: just was skimming over the issue - bookmarked it, I have a quiet weekend.  everyone is leaving tomorrow, I'm not.  I'll drop a line there
21:24:45 <mgoldmann> https://issues.jboss.org/browse/BGBUILD-117
21:25:12 <gholms> mgoldmann: F12 is EOL as well.
21:25:30 * rbergeron looks around for anything else on BG
21:25:34 <mgoldmann> yup. but we don't support F11 on EC2
21:25:41 <mgoldmann> F12*
21:26:12 <mgoldmann> but yes, extending the issue
21:26:23 <gholms> So do we know enough to decide whether or not we can use BG going forward?
21:26:46 <gholms> One benefit we get is that it's more or less extensible to different guest formats so we can expand to other cloud providers.
21:26:58 <rbergeron> we as in Cloud SIG/release engineering?
21:27:01 <gholms> Yeah
21:27:10 <skvidal> gholms: I doubt releng is going to set it up
21:27:22 <jforbes> I think the answer we got from releng is BG will not be used at this time.  That said it is a good tool for the community to build their own images
21:27:23 <skvidal> s/it/BG/
21:28:05 <rbergeron> jforbes: +1
21:28:23 <gholms> So what is the plan as far as releng is concerned?
21:28:35 <gholms> Can plain ol' appliance-tools build what we need?
21:29:03 <jforbes> In other words, it is important for Fedora rather releng uses it or not... Many people wanting to build their own images wont have koji access (not even sure how public that capability will be), and wont want to set up all of the koji -> publish scripting even if they do have koji access
21:29:25 <mgoldmann> gholms: it can provide the base image, not the EC2-ready one
21:29:28 <brianlamere> ^
21:29:48 <jforbes> gholms: plan for releng is using koji, which at the moment uses appliance-tools, but jeremy's project looks interesting there too
21:30:39 <gholms> Then are they supposed to get a script that converts and uploads it somehow?
21:30:49 <jforbes> gholms: yes
21:31:20 <jforbes> well, ami-creator might take care of that part when it gets further along
21:31:46 <skvidal> out of curiosity - can someone dump out the requirement tree for boxgrinder?
21:32:08 <skvidal> repoquery --tree-requires <name_of_boxgrider_pkg>
21:33:05 <gholms> skvidal: You realize that's going to be huge, right?
21:33:13 <clalance> Yeah, it's ridiculous.
21:33:15 <skvidal> gholms: which is why I was curious
21:33:23 <clalance> (it goes all the way down to glibc dependencies)
21:33:37 <skvidal> clalance: then just get the first layer deep
21:33:44 <mgoldmann> we use libguestfs, this is the cause
21:34:08 <gholms> skvidal: How does one limit depth?
21:36:03 * rbergeron wonders if we could take that to the mailing list?
21:36:09 <gholms> Probably
21:36:17 <skvidal> sorry got pulled away for a omment
21:36:18 <gholms> Anything else BG-related?
21:36:36 <skvidal> repoquery --tree-requires pkgname | grep '^ \\_'
21:36:41 <skvidal> that'll get top level only
21:37:00 <mgoldmann> if you have comments on kickstart file support, please add them here: BGBUILD-73
21:37:07 <mgoldmann> https://issues.jboss.org/browse/BGBUILD-73
21:37:23 <rbergeron> #info if you have comments on kickstart file support, please add them to https://issues.jboss.org/browse/BGBUILD-73
21:37:51 <clalance> Top-level isn't bad at all: http://fpaste.org/wPun/
21:37:53 <brianlamere> mgoldmann:  bookmarked
21:38:08 <gholms> skvidal: http://fpaste.org/eRGZ/
21:38:13 <clalance> Hm, although that is just for the s3-delivery-plugin.
21:38:17 <clalance> I probably need to add more to that.
21:38:30 <rbergeron> gholms: can you take that info to the mailing list? :)
21:38:40 <gholms> rbergeron: I doubt it's necessary there.
21:38:48 <mgoldmann> clalance: try also ec2-plugin
21:38:49 <rbergeron> I just meant so I could move forward :)
21:39:03 <gholms> Sounds like there's no new BG stuff left.
21:39:08 <rbergeron> yeah.
21:39:26 <rbergeron> #topic CloudFS
21:39:30 <rbergeron> jdarcy: any updates?
21:39:37 <jdarcy> A couple.
21:39:44 <jdarcy> There's actually some content in the git repo now.
21:40:02 <rbergeron> #info CloudFS git repo has some content now
21:40:10 <gholms> That's a plus.
21:40:19 <jdarcy> That includes the "first drafts" of the recovery-logging, encryption, and multi-tenancy translators, with developer-level docs.
21:40:51 <rbergeron> #link http://git.fedorahosted.org/git/?p=CloudFS.git
21:41:02 <jdarcy> There's still plenty of work to be done on all three of those, plus real docs, plus setting up cloudfs.org with real content (other than the code).
21:41:11 <brianlamere> it gets deep fast because it reqs the i686 and the x86_64 version of a couple things.
21:41:46 <jdarcy> Still working with the Gluster folks on build processes so I can package this properly.
21:41:50 <brianlamere> (sorry, that was delayed - typed it - pressed enter a few minutes later)
21:42:05 <jdarcy> I think that's about it.
21:42:21 <rbergeron> #info jdarcy is still working with Gluster folks.
21:42:24 <rbergeron> excellent. thanks!
21:42:36 <rbergeron> #topic Deltacloud & friends
21:42:43 <brianlamere> jdarcy: lovin where it's goin, though - just fyi
21:42:51 <jdarcy> brianlamere, thanks!
21:42:51 <rbergeron> mmorsi, clalance: thanks for all the information you've been sending to the list.
21:42:56 <mmorsi> np
21:43:00 <clalance> You are welcome.
21:43:27 <rbergeron> So I'm curious about what stuff, if any, will be coming to Fedora in the near term (meaning F15). :)
21:43:32 <mmorsi> so yes, asked and the concensus is that we would like to add deltacloud as a feature for f15
21:43:46 <rbergeron> I know there are some pieces - clalance, I know you had mentioned cloud engine as well - that aren't just deltacloud.
21:44:00 <mmorsi> ah yes, things have undergone a bit of nemaing
21:44:01 <rbergeron> mmorsi: do you know where all hte bits / information are to do that?
21:44:01 <gholms> If you're going to add it as a feature for F15 would you please make it work with selinux?
21:44:03 <mmorsi> renaming*
21:44:15 <clalance> gholms: Yeah, that is on the list.
21:44:21 <clalance> It should be a fairly simple matter, really.
21:44:23 <mmorsi> will it works w/ it, but only if you have it permissive ;-)
21:44:33 <clalance> (just haven't gotten to it yet)
21:44:35 <mmorsi> but yes thats something to fix on the list
21:44:38 <gholms> mmorsi: That isn't "working with it."  :-\
21:44:46 <mmorsi> i was joking
21:44:52 <gholms> Yeah, I know.  :P
21:44:53 <mmorsi> (hence the ;-) )
21:44:55 <clalance> rbergeron: With the fixed boxgrinder+euca2ools, one of the hurdles is out of the way.
21:45:08 <clalance> Most of the dependencies are in fedora now (with the exception of a few).
21:45:31 <rbergeron> clalance: is the deltacloud packaging page fairly up to date?
21:45:32 <mmorsi> yes and we're making sure that any new ones that are added to the project are being added to fedora as we go
21:45:33 <clalance> So it's a matter of packaging it up for F-15, and giving it a whirl to see what breaks.
21:45:38 <clalance> rbergeron: Yeah, mostly.
21:45:41 <clalance> Oh, hm.
21:45:45 <rbergeron> http://deltacloud.org/page/Packaging_list
21:45:47 <clalance> There is one other blocker for us, actually.
21:45:51 <clalance> We require some custom condor code.
21:45:59 <clalance> Which we have submitted upstream, but is definitely not in the Fedora package.
21:46:00 <gholms> Ugh, condor?
21:46:02 <bbrowning> Is getting deltacloud-client and deltacloud-core (Apache Deltacloud) into f15 a separate effort from the other deltacloud things?
21:46:08 <clalance> gholms: Yeah, that's the scheduler we use.
21:46:13 <mmorsi> gholms: ya we use it for our instance scheduling
21:46:18 <mmorsi> instances are modeled as jobs in condor
21:46:19 <clalance> bbrowning: Yeah, definitely separate.
21:46:19 <gholms> I see.
21:46:24 <rbergeron> gholms: you *love* condor, odn't you ;)
21:46:29 <clalance> bbrowning: That's definitely something we can do right now.
21:46:40 <gholms> rbergeron: Let's just say I have a hate-hate relationship with condor.
21:46:41 <bbrowning> k - I was under the impression that getting deltacloud in f15 was just the apache bits, not the rest - good to know :)
21:46:53 <clalance> bbrowning: Well, it is confusing with the name.
21:47:01 <clalance> deltacloud API is the simple matter of doing a couple of packages.
21:47:06 <clalance> The aggregator/engine is more complex.
21:47:27 <gholms> So is the holdup there some patches to condor you have to get merged?
21:47:31 <clalance> Yeah.
21:47:50 <sdake> the packaging process could be started
21:47:50 <clalance> Has to get merged upstream, and also then put into the fedora package.
21:47:54 <sdake> the software wouldn't work
21:47:58 <clalance> Unfortunately we require condor 7.5.5.
21:48:01 <sdake> but would be ready to go
21:48:03 <clalance> And I think fedora is still on 7.4.
21:48:08 <clalance> (condor versions, that is)
21:48:33 <gholms> Yep.  Fedora only uses stable versions.
21:48:34 <clalance> sdake: True.  We do have packages already available, they just haven't gone through fedora review process.
21:49:25 <sdake> clalance takes time to get those reviews going, best to queue them up so we know what we are faced with :)
21:49:42 <clalance> sdake: Yes, true.  How long do we have again until feature deadline?
21:49:57 <sdake> jan 26
21:50:01 <clalance> sdake: OK, thanks.
21:50:10 <clalance> I'll try to enlist some help from the team for it.
21:50:20 <clalance> At the very least, we can do more of the dependencies.
21:50:59 <mgoldmann> ha :)
21:50:59 <sgordon> ahem
21:50:59 <clalance> Wow.
21:50:59 <sdake> that explains where rbergeron went :)
21:51:00 <gholms> Hopefully you can get your patches merged by the time 7.6 is released so you can meet all your deps.
21:51:06 <jdarcy> Ouch.
21:51:10 <gholms> Holy netsplit, Batman!
21:51:16 <clalance> gholms: Yeah, we are shooting for that.
21:51:24 <gholms> But we still have zodbot!
21:51:31 <sgordon> we won the kids
21:51:32 <sgordon> ;p
21:52:02 <sdake> should prob put meeting on hold for few minutes while irc works itself out
21:52:06 * brianlamere hi-fives all the cool kids?
21:52:09 <clalance> Si.
21:53:37 <sdake> Schedule is here: http://fedoraproject.org/wiki/Schedule
21:53:40 <gholms> So is condor likely to be your most problematic dependency?
21:54:11 <sgordon> what about boxgrinder?
21:54:20 <gholms> What about it?
21:54:20 <clalance> sgordon: Well, the new BG should fix that.
21:54:29 <clalance> We are also going to move away from boxgrinder in the near future.
21:54:29 <sgordon> well it's the image builder...
21:54:34 <sgordon> and last i checked it isnt in
21:54:42 <gholms> BG just doesn't quite suit your needs?
21:54:57 <clalance> gholms: Not really, no.  In particular, it can't do non-linux OSs.
21:55:01 <clalance> Which is something we want to support.
21:55:02 <gholms> Oof
21:55:30 * robynishere shakes the fist of doom at freenode
21:55:57 <clalance> gholms: The other possibly problematic package is qpid/qmf.
21:56:04 <clalance> We need at least a certain version of that.
21:56:09 <mgoldmann> the idea for BG was to write plugins for OS to support other OSes
21:56:09 <clalance> No idea what version is currently in fedora.
21:56:24 * mgoldmann hides
21:56:30 <clalance> mgoldmann: Yeah, understood.  And we can write a boxgrinder plugin for oz that does that.
21:56:37 <clalance> (I just haven't gotten around to it yet)
21:56:52 <mgoldmann> yup
21:57:00 <brianlamere> wouldn't that be better than doing the work to shift to something else?
21:57:11 <clalance> brianlamere: It's more or less the same thing.
21:57:25 <sdake> clalance let me know which version of qpid/qmf you need, i'll ask aconway to address it in fedora
21:57:39 <sdake> overall we need to decide if we are going to target dc for f15 or f16
21:57:47 <sdake> there is a ton of work to do and f15 is fast approaching
21:57:51 <clalance> sdake: OK.  Right now it looks like we need: qpid-cpp-0.7.946106-3
21:57:53 <sdake> with alot of dependencies in fedora out of date
21:57:55 <clalance> Or better.
21:58:05 <clalance> Right.
21:58:15 <gholms> [Everyone falls silent and stares]
21:58:15 <clalance> Ah, netreconnect :).
21:58:24 <mgoldmann> uhm
21:58:26 <brianlamere> ok, what did you all miss?
21:58:33 <rbergeron> HEY THERE PEOPLE
21:58:42 <rbergeron> brianlamere: like, the last 15 minutes.
21:58:57 <sdake> so summary is we are sorting out dependencies that deltacloud needs to be included in f15
21:58:59 <clalance> rbergeron: We've been discussing cloud engine dependencies.
21:59:03 <gholms> Thankfully we had zodbot here to help us out.
21:59:03 <clalance> And where they are in fedora.
21:59:05 <brianlamere> (I know, was the start of a joke that I...lost the punchline for.   ha)
21:59:07 <clalance> Ah yes.
21:59:23 <rbergeron> brianlamere: woot
21:59:45 <rbergeron> gholms, sdake, clalance: did we make notes on dependencies that need to get taken care of?
21:59:56 <rbergeron> and by we i mean, did you make zodbot do that? :)
21:59:56 <gholms> clalance: You might be better off holding off the feature until F16 for safety's sake.  You can still add packages to F15 even without the feature.
22:00:04 <clalance> gholms: Yeah, that's what I'm thinking.
22:00:10 <clalance> gholms: We'll work towards getting more of our dependencies in.
22:00:17 <clalance> And then we'll see where we are on the 26th.
22:00:23 <clalance> (but as you can tell, we probably won't make it)
22:00:40 * rbergeron nods
22:00:41 <gholms> Was there a page with DC deps on it?
22:00:49 <clalance> gholms: Yeah, it's on deltacloud.org.
22:00:57 <clalance> (it may be slightly out of date, but should be mostly right)
22:01:04 * clalance finds it
22:01:09 <gholms> http://deltacloud.org/page/Packaging_list
22:01:13 <clalance> There you go :).
22:01:37 <clalance> Yeah, I need to add the qpid and the condor dependencies there.
22:02:13 <gholms> #info Deltacloud needs a patched version of condor 7.5.5 to work properly; upstreaming is in progress
22:02:20 <mmorsi> ah so the feature will be pushed back to f16 then
22:02:21 <mmorsi> ?
22:02:24 <sdake> that packaging list doesn't have the qpid/qmf dependency
22:02:28 <clalance> Yeah.
22:02:29 <mmorsi> prolly a good idea
22:02:31 <clalance> I'll need to add it.
22:02:38 <clalance> mmorsi: Yeah, we'll work towards what we can for F-15.
22:02:45 <gholms> You can still add the stuff to F15 if you want.  ;)
22:02:47 <mmorsi> ah sure
22:02:49 <clalance> Yeah.
22:03:10 <mmorsi> somewhat unrelated but should look on adding a f15 feature for rails 3 and ruby 1.9 if we're gonna get both in
22:03:19 <mmorsi> will definetly get the former in
22:03:21 <mmorsi> not sure about the latter
22:03:23 <clalance> mmorsi: I thought we were holding off on 1.9 until later?
22:03:23 <mmorsi> but neways
22:03:25 <mmorsi> i digress
22:03:33 <clalance> OK, yeah, we don't have to do that here.
22:03:35 <mmorsi> clalance: well if it gets in, it will be parallel installable
22:03:36 <clalance> We'll talk elsewhere.
22:03:45 <mmorsi> like python 2 / 3
22:03:46 <mmorsi> sure
22:03:57 <rbergeron> clalance: you'll add the qmf/qpid info to hte dc.o ackaging_list page?
22:04:01 <sdake> gholms put action on me to ping Alan about an upstream update of qpid to atleast version qpid-cpp-0.7.94106-3
22:04:02 <rbergeron> with the versioning needed
22:04:36 <clalance> sdake: I updated the wiki page now.
22:04:43 <rbergeron> clalance: thanks
22:04:52 <gholms> #action sdake will ping qpid-cpp's maintainer about an update
22:04:55 <sdake> are there any other deps missing we need?
22:05:04 <clalance> sdake: There are, but they are mostly rubygems.
22:05:09 <clalance> Those just need to go through the process.
22:05:23 <gholms> sdake: 0.7.946106-4 has been built.  Is it not pushed or something?
22:05:29 <clalance> (at least, nothing sticks out to me as problematic)
22:06:05 <gholms> qpid-cpp-0.7.946106-3.fc14 is in F14 stable.  What is it you're missing?
22:06:05 <sdake> when it doubt dont say anything
22:06:17 <sdake> i have older version sorry gholms
22:06:21 <gholms> #undo
22:06:21 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1b0aa6d0>
22:06:21 <clalance> gholms: Ah, yeah, that looks fine.
22:06:23 <sdake> i run f13 :)
22:06:29 <gholms> Ah
22:07:13 <gholms> #info Sufficiently new version of qpid-cpp is incompatible with F13 due to soname bump
22:07:39 <clalance> Ah, right.  That's why we needed that (currently we are on F-13, we are moving to 14 soon).
22:09:05 <gholms> [Somewhere in the distance, a dog barks.]
22:09:20 <clalance> rbergeron: I think we are done with deltacloud for now.
22:09:36 <mmorsi> yeh nothing to add here
22:09:46 <gholms> Open floor / Open stack?
22:10:41 * gholms pokes rbergeron
22:10:42 <clalance> I guess we lost rbergeron again.
22:10:49 <gholms> #topic OpenStack
22:10:50 <clalance> rbergeronn: ?
22:11:02 <brianlamere> timing out?
22:11:03 <gholms> I think they aren't the same people...
22:11:07 <mmorsi> she fell through the open floor ;-)
22:11:08 <clalance> Ah, oops :).
22:11:11 <clalance> Yeah, maybe timeout.
22:11:13 <gholms> Anything new on the openstack front?
22:12:11 <gholms> Hm, I guess not.
22:12:23 <jdarcy> What are we doing with OpenStack?
22:12:48 <gholms> AFAIK there was a packaging effort.  I'm not sure how well that has been going.
22:12:59 <rbergeron> sigh.
22:13:09 * rbergeron lost her interwebz access
22:13:18 * gholms duct tapes rbergeron to the Internet
22:13:32 <gholms> #topic Open floor
22:13:38 <rbergeron> no kiddig
22:13:51 <gholms> brianlamere: Any luck figuring out how to push stuff up to a S3 bucket?  s3cmd?
22:14:10 * rbergeron will ping on the list about openstack - maybe silassewell can update us on that.
22:14:44 * rbergeron is typing from her droid, btw, so pardon any errors :)
22:15:09 <brianlamere> I will absolutely have something posted on the list this weekend.  my first open weekend in eons :P  things have just been busy pre-holidays
22:15:34 <brianlamere> funny that I can't just find 30 minutes to sit and focus on something...
22:15:59 <gholms> I know what you mean.  :-\
22:16:29 <gholms> #action brianlamere will mail the list his progress on the S3 mirroring front
22:17:15 <clalance> Maybe I'm showing my complete ignorance, but...what's the status of eucalyptus in Fedora?
22:17:17 <brianlamere> well I decided to take Xmas off - meaning, I am not running all over the country this year.  just not gonna, darn it.  quiet house, quiet office, if I can't find a 30min block somewhere then I'm simply broken
22:17:53 <gholms> clalance: Eucalyptus bundles a ton of libraries, so it's blocked on separating those.
22:17:59 <clalance> Ah, OK.
22:18:03 <gholms> clalance: They're hiring me to, in part, fix just that.
22:18:08 <brianlamere> euca2ools was the first/biggest thing, and that's in (right?) but....yeah, what gholms said
22:18:09 <clalance> Cool :).
22:18:19 * rbergeron cheers for gholms
22:18:38 <gholms> Oh right, since repetition is good:
22:19:02 <gholms> Please test the euca2ools update to ensure that the images it builds work with EC2, then provide karma.
22:19:10 <clalance> gholms: I'm doing that at the moment.
22:19:13 <gholms> Thanks
22:19:15 <clalance> I confirmed that -3 failed.
22:19:18 <clalance> I'm trying -4 right now.
22:19:36 * gholms needs testers on both F13 and F14
22:19:42 <clalance> Yeah, this is on F-13.
22:19:44 <mgoldmann> ha, I thought you tried to add -3 karma :)
22:19:50 <clalance> Haha.
22:19:53 <gholms> D:
22:19:56 <clalance> I meant the package versions ;).
22:20:21 <gholms> Anyone have anything else?
22:20:40 * gholms kicks Xorg
22:20:44 <sgordon> i have an f13 vm i try run deltacloud in
22:20:46 <sgordon> i will give it a go
22:21:15 <brianlamere> I think my main problem is I use my own stuff :P
22:21:33 <brianlamere> err...main problem with testing euca2ools, that is...
22:21:53 <gholms> Ah, but then you can rewrite your stuff so that it employs it.  ;)
22:22:54 <clalance> gholms: Nice it works.
22:23:00 * clalance adds karma
22:23:02 <gholms> :D
22:23:20 <gholms> rbergeron: Shall we send everyone home?
22:23:46 <rbergeron> sure thing.
22:23:53 <rbergeron> thanks for coming!
22:23:59 <rbergeron> #endmeeting