19:00:27 <rbergeron> #startmeeting Cloud SIG
19:00:27 <zodbot> Meeting started Fri May 27 19:00:27 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:34 <rbergeron> #meetingname Cloud SIG
19:00:34 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:43 <rbergeron> #topic Who's here?
19:00:46 * clalance here
19:00:47 * rbergeron looks around
19:00:47 * rrix 
19:00:50 <rbergeron> hey clalance :)
19:00:54 * jforbes is here
19:01:28 <rbergeron> word.
19:01:38 <rbergeron> gholms is tied up in work stuff.
19:01:39 * quaid is here
19:01:41 <rbergeron> hey quaid.
19:01:46 <quaid> howdy!
19:01:50 <rbergeron> I'll moooooooove on forward.
19:02:13 <rbergeron> #topic F15 over, F16 incoming
19:02:20 * rbergeron claps
19:02:24 <rbergeron> hooray! F15 out the door.
19:02:35 <rbergeron> And, well, yeah. F16 time.
19:02:51 <rbergeron> #link http://fedoraproject.org/wiki/Schedule
19:02:53 <rbergeron> Schedule is up.
19:03:02 <rbergeron> (Though probably nitpicky fixes incoming.)
19:03:20 <rbergeron> And that's a bout all i have to say about that. For the moment. :)
19:03:25 <rbergeron> #topic EC2
19:03:30 <rbergeron> #chair jforbes gholms
19:03:30 <zodbot> Current chairs: gholms jforbes rbergeron
19:03:36 <clalance> Ah yes.
19:03:39 <rbergeron> jforbes: what's shakin?
19:03:39 <clalance> I have a topic for this :).
19:03:48 <clalance> But I'll let jforbes give status first.
19:03:48 <rbergeron> #chair clalance
19:03:48 <zodbot> Current chairs: clalance gholms jforbes rbergeron
19:03:50 <jforbes> Things are moving along, there will be some new images up by the end of the day
19:04:46 <clalance> jforbes: Hopefully you saw BZ 708406?
19:04:50 <rbergeron> Exciting. And i assume they'll get updated on the wiki page and so forth?
19:05:07 <jforbes> So, the koji images take forever to build (about 9 hours for a full build/test) so as a stopgap, I am doing bg created images which we will publish as "unofficial"
19:05:17 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=708406
19:05:50 <jforbes> clalance: we do it differently
19:05:56 <clalance> jforbes: Oh?
19:06:14 <jforbes> echo "hwcap 1 nosegneg" > /etc/ld.so.conf.d/libc6-xen.conf
19:06:22 <jforbes> in post for 32bit images
19:06:26 <clalance> jforbes: Right, but that is in your AMI build scripts, right?
19:06:33 <jforbes> clalance: correct
19:06:45 <clalance> jforbes: The problem is that that is not enabling it for 32-bit Xen on non-AMI.
19:06:52 <clalance> If you just do it in the kernel package, it will be right everywhere.
19:07:11 <clalance> My suggestion is to remove that hack from the AMI build scripts and add it to the kernel spec file instead.
19:07:28 <jforbes> clalance: sure, but how many people are running 32bit xen guests anymore outside of EC2?
19:07:36 <clalance> jforbes: I have no idea.
19:07:41 <clalance> But we may as well do it right :).
19:07:46 <clalance> It's not that much work, I don't think.
19:07:50 <clalance> A few lines in the kernel spec.
19:08:04 <jforbes> Sure, we can do that
19:08:42 <jforbes> I will poke kyle about it and see what he thinks
19:08:42 <rbergeron> does someone need to take ownership on the bz?
19:08:44 <rbergeron> ah
19:08:51 <clalance> jforbes: Perfect,t hanks.
19:08:54 <clalance> Thanks, even :).
19:09:07 <rbergeron> #action jforbes to poke kyle re BZ 708406
19:09:28 <jforbes> So, the bg created images will be public and publicised to an extent, just not as much as the final koji images will be.
19:09:36 <rbergeron> jforbes: do the koji images always take this long?
19:09:39 * rbergeron has no clue
19:09:41 <jforbes> rbergeron: yes
19:10:02 <rbergeron> so ideally we'd want to just kick them off at the same time as everything else as we're moving into release day
19:10:06 <jforbes> rbergeron: it takes koji a couple of hours to spin each image, then download 10G, bundle/upload/register/test
19:10:06 <rbergeron> and not afterwards
19:10:08 * rbergeron nods
19:10:10 <jforbes> rbergeron: correct
19:10:14 <rbergeron> okay.
19:10:42 <rbergeron> well, dgilmore is out, but let's see if we can get that fixed after he gets back.
19:10:49 <rbergeron> since this probably sucks for you. :)
19:11:07 <jforbes> The truth is, the bg created images will serve well enough as official images, but I want rel-eng to do koji images and push them for F15 so that we know we are on track for them doing that for F16 alpha/beta/release
19:11:21 <rbergeron> #action rbergeron to get dgilmore in here next week to figure out more official rel-eng process
19:11:25 * rbergeron nods
19:11:36 <jforbes> rbergeron: yes, it sucks considerably, but it has to be done
19:11:42 * rbergeron nods
19:12:07 <rbergeron> alrighty. We'll hang on to it for next week, and in the meantime, thank you, jforbes, as always :D
19:12:16 <jforbes> NP
19:12:40 <rbergeron> anyone else have ec2 comments/questions?
19:13:09 <rbergeron> #topic Packaging needs
19:13:10 <jforbes> (and since gholms isnt heare, yes, the bg spins include EBS images)
19:13:13 <rbergeron> lol
19:13:19 <rbergeron> #undo
19:13:19 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1bfd6d4c>
19:13:32 <rbergeron> #info the BG spins include EBS images (this note is for you, gholms)
19:13:40 <rbergeron> #topic Packaging Needs
19:14:03 <rbergeron> So: I don't know who saw my mail to the list about cleaning up the wiki page.
19:14:12 <rbergeron> But it's cleaned, or at least, cleanER.
19:14:31 <rbergeron> #info CLoud SIG page cleaned up, feel free to add more if you see fit.
19:14:33 * quaid heaps praise on rbergeron
19:14:35 <rbergeron> #link https://fedoraproject.org/wiki/Cloud_SIG
19:15:04 <rbergeron> And we have a few folks working on packaging things, and thus it's probably convenient to have some of the information in one place.
19:15:21 <rbergeron> As you'll probably find that helping out with reviewing others' packages results sometimes in getting your own packages reviewed. ;)
19:15:27 <rbergeron> #link https://fedoraproject.org/wiki/Cloud_SIG_packaging
19:15:40 <clalance> rbergeron: Ah, sweet.
19:15:46 <rbergeron> So, if you're working on packaging something, feel free to link it there.
19:15:48 <clalance> You just answered my question about how to track it :).
19:15:55 <rbergeron> clalance: i added in the link to aeolus.
19:15:59 <clalance> Yes, thanks.
19:16:04 <rbergeron> But if you want to just skip that and link straight to bz's on that page, or whatever, feel free.
19:16:14 <clalance> No, I actually prefer it this way.
19:16:15 <rbergeron> I expect you guys to figure out whatever works for you, I don't know what's best.
19:16:21 <clalance> That way I only have to update one place when status changes.
19:16:26 <rbergeron> Yup.
19:16:35 <rbergeron> But this is a nice place to go and look for review swaps, etc, also.
19:16:41 <clalance> Right!
19:16:47 <rbergeron> #info Packaging list - nice place to go look for review swaps, etc.
19:17:13 <rbergeron> Anyway: If you're not on that list, and you know of packages needing love, feel free to add them.
19:17:23 <rbergeron> They don't even have to be your own, just cloud-related. :)
19:17:42 <rbergeron> Any questions? :)
19:17:54 <rbergeron> Okee dokee.
19:17:58 <rbergeron> #topic CloudFS
19:18:05 <rbergeron> Mr. Darcy: You're just in time.
19:18:33 <jdarcy> :)
19:18:46 <jdarcy> Well, let's see.  I think I mentioned the SSL transport last time.
19:18:59 <rbergeron> Yup.
19:19:01 <jdarcy> It's still chugging through review, Gluster has said they're willing to support it.
19:19:10 <rbergeron> cool. :)
19:19:31 <jdarcy> I've prototyped some performance enhancements (multi-threading the transport module) and they seem to improve things ~2x
19:19:49 <jdarcy> Kaleb is chugging away on the UID-mapping stuff.
19:20:05 <jdarcy> That's really kind of it.  Trying to measure encryption overhead right now.
19:20:22 <jdarcy> And yes, I know I need to do the feature stuff.  ;)
19:20:30 <rbergeron> jdarcy: so you are planning on it then :)
19:20:39 <quaid> I've got a cloudfs prod ...
19:20:43 <jdarcy> Yes.  I think this time we'll be ready well ahead of any deadline.
19:20:44 <quaid> #link https://fedoraproject.org/wiki/CloudFS
19:20:55 <quaid> that page has some new how-to-contribute content
19:21:04 <jdarcy> Cool.
19:21:04 <quaid> and I wanted to prod you about adding the content or a link from cloudfs.org
19:21:12 <jdarcy> Will do.
19:21:12 <rbergeron> quaid: cool, thanks ;)
19:21:13 <quaid> since currently it's a bit unclear how to participate
19:21:16 <quaid> word!
19:21:36 <rbergeron> quaid: do you want to maybe add the link to the cloudFS wiki page (which is different from the feature page) to the list on the Cloud SIG wiki page? :)
19:21:50 * rbergeron didn't know that openshift uses cloudFS
19:22:12 <rbergeron> I learn something new every day.
19:22:15 <quaid> rbergeron: will do, thx for the idea
19:22:17 <rbergeron> Exciting.
19:22:34 <rbergeron> #action quaid to link CloudFS wiki and .org pgs to the Cloud SIG wiki page
19:22:35 <quaid> rbergeron: I went almost 2 months not getting that iwhd == Image Warehouse
19:23:04 <rbergeron> jdarcy: thanks. I'll see your feature when it moves into FeatureReadyForWrangler and I'll send it fesco's way. ;)
19:23:34 <rbergeron> #topic Aeolus
19:23:41 <rbergeron> clalance, mmorsi: HI
19:24:00 <clalance> Hello :)
19:24:03 <rbergeron> #link http://aeolusproject.org/page/Packages_Missing_From_Fedora
19:25:00 <rbergeron> So I see you guys already have a feature page ready, that I will be sending to fesco this weekend for their meeting next week.
19:25:03 <rbergeron> Thank you!
19:25:07 <clalance> rbergeron: You are welcome :).
19:25:16 <rbergeron> #link https://fedoraproject.org/wiki/Features/Aeolus_Conductor
19:25:33 <rbergeron> #info Aeolus for F16 feature page is posted.
19:26:20 <clalance> rbergeron: Other than that....
19:26:21 <rbergeron> so... how many other people who aren't in this meeting / don't come to this meeting are working on packaging this stuff?
19:26:41 <clalance> rbergeron: A few of the other developers on aeolus do packaging.
19:26:48 <clalance> (mostly because I prodded them to :)
19:26:58 <rbergeron> I guess maybe a better question is, Who is maintaining the Package List on the aeolus site vs. the packaging list on on the feature page?
19:27:06 <clalance> And a number of the packages we depend on are useful in the ruby ecosystem.
19:27:11 * rbergeron nods
19:27:13 <clalance> (so we've gotten contributions from there)
19:27:22 <clalance> rbergeron: Well, that would be me for both ;).
19:27:35 <clalance> rbergeron: Actually, maybe I'll replace the list of packages on the feature page with a link to the aeolus wiki.
19:27:38 <clalance> rbergeron: Is that acceptable?
19:27:53 <rbergeron> Sure.
19:27:59 <clalance> OK, I'll do that.
19:28:03 <rbergeron> So long as you're keeping your overall % up to date on the feature page, that's fine with me.
19:28:03 <clalance> Then it will really only be one place.
19:28:07 <clalance> Right.
19:28:17 <rbergeron> Yeah. It just becomes terribly redundant/tedious for you.
19:28:21 <clalance> Yep.
19:28:45 <quaid> a question about Aeolus from a higher level - since you have a dedicated community-focused person now, do you have plans or ideas to use F16 as a vehicle for usage, participation, and contribution growth? If so, should we start coordinating that *now*?
19:29:01 <quaid> i.e., via this SIG :)
19:29:03 <clalance> quaid: I'm honestly not sure what the plan is.
19:29:10 <clalance> quaid: I mean, obviously, yes, we would like to do that.
19:29:14 <clalance> But I am a lowly engineer :).
19:29:17 <rbergeron> quaid: I think clalance is hoping ot just get it all in at this point
19:29:31 <clalance> Yeah, if we get that I'll be pretty happy.
19:29:48 <clalance> quaid: You might want to contact jclift@redhat.com and CC the list
19:29:52 <clalance> To get his take on it.
19:30:04 * rbergeron nods
19:30:08 <quaid> roger
19:30:42 <quaid> thx
19:30:53 <rbergeron> Cool.
19:31:40 <rbergeron> Alrighty.
19:31:53 <clalance> Other than that, we are going to be finishing another iteration in a couple of weeks.
19:31:56 <clalance> And then we'll put out 0.3.0.
19:32:03 <clalance> That will probably be what I'll try to get into F-16.
19:32:04 <rbergeron> sweet.
19:32:06 * rbergeron nods
19:32:09 <clalance> Though I might try to sneak 0.4.0 in as well.
19:32:15 <rbergeron> so right now it's more dependencies as well that you're getting in?
19:32:19 <rbergeron> things you know aren't really going to change?
19:32:28 <clalance> Yeah, that's what I'd like to do in the very short term.
19:32:55 <rbergeron> good to know. Thanks :)
19:33:37 * rbergeron wishes you guys luck, and remember to YELL FOR HELP if you need it. (that goes for you too, jdarcy)
19:34:00 <clalance> rbergeron: Thanks.
19:34:06 <rbergeron> :)
19:34:09 <rbergeron> #topic Sheepdog
19:34:18 * rbergeron looks around for a ke4qqq or an sdake
19:34:33 <rbergeron> okay. well, the long and short of it is:
19:34:48 <rbergeron> #link http://fedoraproject.org/wiki/Features/Sheepdog
19:34:53 <rbergeron> #info Sheepdog feature page is in progress
19:35:09 <rbergeron> I think the package has already made its way through review and so forth.
19:35:29 <rbergeron> ke4qqq made a few bz's for sdake to get some stuff in upstream with the sheepdog folks, AIUI.
19:35:39 <rbergeron> And I think that's about it there.
19:35:49 <rbergeron> thanks to both of them.
19:35:54 * rbergeron throws a rock at sdake from across the house
19:36:19 <rbergeron> And I suppose if anyone has any questions, feel free to mail them to the list, since neither of them are present at the moment. :)
19:36:38 <rbergeron> Or you can yell them now, and they can see them in the logs.
19:36:41 * rbergeron holds for a momento
19:37:38 <rbergeron> Okay. MOVING ON
19:37:41 <rbergeron> #topic OpenStack
19:38:21 <rbergeron> #link http://fedoraproject.org/wiki/Cloud_SIG/OpenStack
19:38:33 <rbergeron> So - there are a couple of random open BZ's relating to OpenStack.
19:38:39 <rbergeron> FWIU, it's fairly close to being packaged.
19:39:00 <rbergeron> There was a package posted to the cloud sig mailing list last week which is an easy-thing-to-do, if anyone's interested.
19:39:05 <rbergeron> Perhaps rrix. :)
19:39:09 <rrix> Yup
19:39:13 <rrix> I'll take care of it :)
19:39:15 <quaid> btw, wiki note - the Page/Nesting is not the best way to organize on the wiki
19:39:17 <rbergeron> Otherwise, I think we need to sort out openstack stuff a bit, so we can get it in.
19:39:22 <rbergeron> Because it's SUPER CLOSE
19:39:38 <quaid> so Cloud_SIG/OpenStack should be [[OpenStack]] and put itinthe [[Category:Cloud sIG]]
19:39:46 <rbergeron> Um, sure.
19:39:52 <rbergeron> I know you're better at the wikigardening than i am. ;)
19:40:00 <rbergeron> Feel free to use your redirecting magic.
19:40:07 * rbergeron salutes quaid's magic skillz
19:40:35 <rbergeron> And that's all I have there.
19:40:45 <rbergeron> If someone wants to take that on and turn it into a feature, we can do that.
19:40:55 <rbergeron> ke4qqq is getting it updated, i think, to at least more recent versions.
19:40:59 <rbergeron> because what we have is a few iterations old.
19:41:44 <rbergeron> anyway.
19:41:47 <rbergeron> #topic Open Floor
19:41:55 <rbergeron> Speak up, quiet people. :)
19:43:04 <rbergeron> ohh.
19:43:13 * rrix speaks up
19:43:14 * clalance hears the crickets
19:43:39 <rbergeron> clalance: so sdake told me that he's planning on packaging pacemaker-cloud-HA or whatever it is, and putting it in as a feature.
19:43:45 <jforbes> People fall through open floors
19:43:50 <clalance> rbergeron: Ah, cool.
19:43:53 <rbergeron> And I guess it may possibly have some dependency on oz?
19:43:54 <rbergeron> Not sure.
19:43:58 <quaid> Tip to all: put [[Category:Cloud SIG]] on ALL cloud wiki pages
19:43:58 <clalance> rbergeron: Not sure about that.
19:44:04 <rbergeron> I should use my flogger to make him come to these meetings.
19:44:05 <clalance> I didn't think so, but I haven't been following it closely.
19:44:10 <rbergeron> Yeah, i don't know.
19:44:19 <rbergeron> I think matahari may be coming as well, but we'll see.
19:44:23 <clalance> rbergeron: Speaking of oz, I am going to put out version 0.4.0 next.
19:44:27 <clalance> next week, even.
19:44:46 <rbergeron> I'm hoping that all the free press that marek got gives people a bit of motivation. :)
19:44:55 <clalance> There are a few new features, support for more OSs, etc.
19:45:02 <clalance> Oh, and support for F-15 :).
19:45:18 * rbergeron grins
19:46:07 <rbergeron> Alrighty.
19:46:10 <rbergeron> Anyone have anything else?
19:46:34 <rbergeron> Well then.
19:46:50 <rbergeron> Enjoy the long weekend if you're in the US. Eat a beefy miracle if you have the opportunity :)
19:46:56 * rbergeron is so frankful that you all came today.
19:47:01 <clalance> rbergeron: Thanks.
19:47:04 <rbergeron> <pause for groans>
19:47:10 <clalance> I'm going to leave before I throw up.
19:47:10 <clalance> ;)
19:47:13 <rbergeron> lol
19:47:18 <rbergeron> thanks, guys!
19:47:21 <rbergeron> #endmeeting