18:59:59 <rbergeron> #startmeeting Cloud SIG
18:59:59 <zodbot> Meeting started Fri Nov  4 18:59:59 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:00 <tflink> fun time?
19:00:03 <rbergeron> #meetingname Cloud SIG
19:00:03 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:10 <rbergeron> #topic Who's here on FUN FRIDAY
19:00:48 * tflink is present
19:00:57 * ke4qqq is quasi-here
19:01:11 * kkeithley is here
19:01:41 <mdomsch> whee
19:01:43 <rbergeron> quasi?
19:01:44 <rbergeron> lol
19:01:44 * jsmith is barely here
19:02:19 <rbergeron> okay, um, let's start.
19:02:24 <rbergeron> actually, i'm going to ping people.
19:02:24 * jforbes is here
19:03:04 <rbergeron> okay, duly pinged
19:03:09 <johnmark> w00t
19:03:15 <rbergeron> #topic EC2
19:03:22 <gholms> Hai
19:03:23 <rbergeron> #chair gholms
19:03:23 <zodbot> Current chairs: gholms rbergeron
19:03:26 <jsmith> gholms!
19:03:28 <rbergeron> howdy
19:03:30 <rbergeron> mull!
19:03:39 <rbergeron> greetings
19:03:39 <mull> hi, rbergeron
19:03:53 <rbergeron> Okay, so, I know tflink is going to ask: Did anyone actually test rc4 on ec2, so I'll beat him to it.
19:03:56 <rbergeron> :)
19:04:14 <jforbes> I ran the last images that were posted
19:04:20 * tflink needs to be faster
19:05:04 * spevack is here
19:05:18 <jforbes> spevack: you ran them as well correct?
19:05:40 <rbergeron> holy crap, spevack
19:05:43 <spevack> jforbes: the images looked good to me
19:06:01 <spevack> also i wanted to make sure folks in cloud sig knew what I'd done from the web/release announcement POV
19:06:05 <spevack> but I can mention that when the time is right
19:06:07 <rbergeron> #chair spevack
19:06:07 <zodbot> Current chairs: gholms rbergeron spevack
19:06:12 <rbergeron> spevack: take it away
19:06:18 <rbergeron> or talk and i can info it if you'd prefer
19:06:35 <spevack> I wanted to make sure that the fact that EC2 images for F16 are ready on launch day is publicized.
19:06:44 <spevack> So I added a line or two in the draft of the release announcement
19:06:57 <spevack> and I added a line to the website under the "other ways to consume fedora" section.
19:07:03 <spevack> That discussion happened on the websites list
19:07:04 <jsmith> Thanks for doing that, spevack
19:07:17 <spevack> additionally, i phrased it in all places in a vendor-neutral way
19:07:24 <spevack> effectively "Fedora is available for cloud providers"
19:07:29 <gholms> "Consume Fedora"?  I am glad to not be in marketing.
19:07:30 <spevack> and EC2 is certainly one of them
19:07:43 <spevack> but it makes it easy for us to talk about Fedora in other cloud environments
19:07:45 <johnmark> spevack: awesome
19:07:47 <spevack> without having to change wording around
19:07:50 <gholms> Good idea
19:08:00 <spevack> gholms: i see myself as a Fedora contributor in this
19:08:05 <spevack> and I wanted to come up with a general solution
19:08:32 <spevack> the fact that EC2 images are available is secondary to finding a way to talk about it from the FEDORA PERSPECTIVE that is just "Fedora is becoming available on more and more clouds"
19:08:35 <rbergeron> #info EC2 images on F16 for launch day will be publicized.
19:09:06 <gholms> I just find that particular wording funny; nothing more.
19:09:06 <gholms> I agree with you. ;)
19:09:10 <spevack> so that's about it
19:09:12 <rbergeron> #info Info has been added to release announcement, website in "other ways to consume fedora" section, in a vendor-neutral way
19:09:18 <spevack> eventually a "Cloud" section will be added to http://fedoraproject.org/en/get-fedora-options#spins
19:09:25 <jforbes> We need to remember to fill out the page on the amazon site to get them listed
19:09:32 <rbergeron> #info FEDORA IS CONSUMABLE BECAUSE IT IS A DELICIOUS BEEFY MIRACLE
19:09:43 <gholms> rbergeron: That's Fedora *17*.
19:09:43 <jforbes> dgilmore: are you going to do that, or should I?
19:09:49 * rbergeron notes that SOMEONE AROUND HERE has strong urges to make a cloud.fp.o page.
19:09:55 * rbergeron kicks johnmark in the pants
19:09:57 * gregdek lurks.
19:10:00 <rbergeron> oh god.
19:10:05 <rbergeron> gregdek and spevack in one meeting?
19:10:05 <mull> heh
19:10:08 * rbergeron looks around for hte poker chips
19:10:09 <spevack> EOF from me.  Just wanted to make sure folks knew what I had done, and that I had purposefully attempted to do it in a vendor neutral way
19:10:18 <gholms> spevack: Thanks!
19:10:22 <jforbes> spevack: appreciate it!
19:10:28 <spevack> gregdek: i thought you'd appreciate the vendor-neutral intentions since in this meeting, we're all Fedorans :)
19:10:32 <spevack> EOF
19:10:38 <rbergeron> spevack: yes, thank you. it's amazing what we are blind to doing when it should have been obvious :)
19:10:59 <gregdek> spevack: we're working on a little beefy miracle of our own, btw.  Ask mull for details.  ;)
19:11:20 <rbergeron> jforbes: what are you asking dgilmore about?
19:11:25 <ke4qqq> mull: what are the details? :)
19:11:26 <rbergeron> ohhh, making them official?
19:11:35 <rbergeron> gregdek: you should call it "little smokie"
19:11:39 <jforbes> rbergeron: filling out the little page on Amazon's site to get them listed
19:11:54 <mull> ke4qqq, F16 livecd for eucalyptus ...
19:11:59 <rbergeron> #info need to know if dgilmore or jforbes is filling out the little page on amazon's site to get the ami's listed
19:12:18 <johnmark> Ouch!
19:12:27 <mull> but since we're not in Fedora yet, that means no Fedora artwork, hence BEEFY MIRACLE artwork instead (assuming that's still the default replacement)
19:12:46 <ke4qqq> indeed it still appears to be. thats awesome.
19:12:55 <rbergeron> mull: so are you guys thinking fedora Spin, or Remix?
19:13:17 <gregdek> rbergeron: we're thinking "hey, let's get a eucalyptus demo!"
19:13:32 <rbergeron> gregdek: so either, really
19:13:33 <ke4qqq> they can't do spin, euca isn't in fedora yet.... /me knows their pain
19:13:40 <mull> rbergeron, whatever the proper terminology is for one including non-Fedora packages... spot told me back in June, but I forget
19:13:41 <gregdek> :)
19:13:54 <gregdek> I'm deliberately avoiding your process until we've got something to show.
19:14:14 <johnmark> gregdek: probably for the best
19:14:57 <gregdek> Ecclesiastes 3:1.
19:14:58 <spevack> mull: it's Fedora packages + other packages not in Fedora all merged together into an image.  That's a "Fedora Remix"
19:15:06 <rbergeron> I mean, I don't want to steal thunder, but: obviously it would be cool for you guys to have Euca-on-a-Delivery-Mechanism, but it would be cool for *us* to have something like, insert stick, select $cloud_solution from list, magically deploy to 3 or 4 boxes.
19:15:17 <rbergeron> Of course that would require us having eucalyptus packages and cloudstack packages.
19:15:19 <johnmark> rbergeron: werd
19:15:34 <mull> rbergeron, we'll discuss that in Blacksburg.  :)
19:15:36 <johnmark> gregdek: I'm not going to look that up :)
19:15:37 <gregdek> rbergeron: you can have these things if you pull in multiple yum repos.
19:15:40 <spevack> mull: https://fedoraproject.org/wiki/Remix
19:15:46 <mull> spevack, thanks
19:15:54 <gregdek> But it's not official Fedora then.
19:16:13 * rbergeron tries to not roll her eyes which are carefully made up in fedora-blue eyeshadow
19:16:17 <johnmark> LOL
19:16:21 <rbergeron> oh, god, was that out loud? sorry
19:16:24 <johnmark> gregdek: we should chat :)
19:16:27 * rbergeron coughs and composes herself
19:16:33 <gregdek> johnmark: I'm sure we will. :)
19:16:36 <johnmark> lol
19:17:27 <rbergeron> okay, so i'm counting on at least 2 groups here having their shiz in F17. If you need help, well, TBD, I'm hoping for a rope here in this category, but you guys know the ropes pretty well as well.
19:18:12 <rbergeron> #info rbergeron respectfully requests eucalyptus and cloudstack in F17 from our excellent community memborz, please
19:18:19 <rbergeron> Hrmm. Okay, i'm going to move on
19:18:23 <rbergeron> #topic Docs
19:18:30 <rbergeron> jsmith has requested me to pass on the following message:
19:18:31 <gholms> If I have time I want to make more of cloud-init work.
19:18:37 <gholms> Doh!
19:18:47 <rbergeron> 12:02 <jsmith> Can you please mention in the cloud meeting that I put gholms' EC2 stuff into the cloud guide -- I'd love feedback on it
19:18:55 <rbergeron> He has sent mail to the mailing list, iirc.
19:18:59 <rbergeron> And gholms:
19:19:00 <rbergeron> Again:
19:19:04 <rbergeron> #info gholms is da man
19:19:16 <gholms> heh
19:19:24 <rbergeron> #info feedback on EC2 information in the F16 cloud guide is requested
19:19:34 <rbergeron> #topic cloud-init stuff
19:19:37 <rbergeron> gholms: speaketh
19:20:12 <gholms> So cloud-init only partially works in F16.
19:20:39 <gholms> This is partly why it was not a feature.
19:21:05 * rbergeron nods
19:21:35 <gholms> It might be nice to make the rest of it work, but right now I can't commit much time to it.
19:21:56 <rbergeron> what else is needed?
19:22:16 <rbergeron> COULD THIS BE DETAILED IN AN EMAIL? :D
19:22:23 <gholms> But what would be useful in tbe mean time is testing cloud-init's cloud-config functionality and filing bugs.
19:23:10 * gholms would dig out a link if he was not typing from a phone
19:23:33 <gholms> That's all I have for now.  Stay tuned.
19:23:45 * jforbes seconds the email idea, people might pitch in with the missing pieces
19:24:07 <rbergeron> #info cloud-init is partially working at this point. could be a feature in f17. need testing and bug filing and FIXES. STAY TUNED FOR MORE!
19:24:20 <gholms> Sounds like a good idea
19:24:27 <rbergeron> #action gholms to shoot out an email in his copious spare time, time permitting, of course, re: cloud-init
19:24:35 * johnmark wonders if oVirt in F17 is a possibility - and what the process is
19:25:13 <rbergeron> johnmark: hey, i feel like i had htat conversation all week long
19:25:17 <johnmark> :)
19:25:20 <johnmark> indeed
19:25:57 <rbergeron> johnmark: They'd need to... well, I think there are a crapton of dependencies.
19:26:02 <johnmark> right
19:26:10 <rbergeron> And it may depend on mgoldmann's progress on AS7, I'm not sure how that plays into things.
19:26:27 <johnmark> and my experience trying to build wasn't exactly for the feint of heart
19:26:35 <sgordon> a bit of all of the above
19:26:39 <rbergeron> And then I don't know about the whole, you know, "Those glass panes you look through out of your house" thing, and if that's necessary, and what trauma comes with.
19:27:05 <johnmark> :)
19:27:14 <rbergeron> I assume that stuff can be stripped out, or that it's not, like, you know, "oh and you have to have random proprietary bit," but I'm really not sure.
19:27:21 <gregdek> You have the mojo now. Use it. :)
19:27:35 <rbergeron> johnmark: I think you have just thrown yourself under the bus to be the guy who goes and finds out, eh?
19:27:40 <johnmark> shit
19:27:46 * johnmark kicks himself
19:27:48 * rbergeron hands you a trenchcoat and magnifying glass
19:27:48 * ke4qqq thought he just volunteered to package it all
19:27:56 <johnmark> rbergeron: *grin*
19:28:13 <johnmark> ke4qqq: I think I volunteered to look into what is required for packaging
19:28:21 <rbergeron> ke4qqq: he told me he knows how to package, but I'm going to keep that a secret so he can impress everyone when it happens.
19:28:25 <rbergeron> OH
19:28:27 <rbergeron> ohhhhhhh
19:28:27 <johnmark> and then someone who's actually competent can do the packaging :)
19:28:36 <johnmark> LOL
19:28:46 <johnmark> rbergeron: I knowenough to be dangerous
19:28:52 <johnmark> ...to myself and others
19:29:01 <sgordon> i was only following on lists/irc but AS7 and the windows guest tools
19:29:05 <sgordon> seem like the main issues
19:29:14 <mull> johnmark, don't worry, that's why we have package reviews.  :)
19:29:27 <johnmark> mull: nice :)  I'm sure I'll figure out something
19:29:44 <rbergeron> #action johnmark to investigate requirements for packaging oVirt, rbergeron to hook him up with a name of a person for where to start
19:30:04 <rbergeron> I may just send you to carl, becuase, you know.
19:30:09 <johnmark> haha!
19:30:17 * gregdek advises shoving dirty packages into a koper and forgetting about it.
19:30:25 <johnmark> gregdek: koper?
19:30:39 <rbergeron> LMGTFY?
19:30:40 <gholms> gregdek: kopers... hah!
19:30:46 * ke4qqq wonders what ever happened to kopers
19:30:48 <gregdek> LOL
19:30:59 <ke4qqq> that seemed to have momentum for a while.
19:31:07 <gregdek> Ah well.  Good times.
19:31:12 <johnmark> rbergeron: yes, please ;)
19:31:42 <gregdek> johnmark: stood for "Koji Personal Repos".  Could have been a great scratch space for this kind of thing, but never quite got off the ground.
19:31:51 <ke4qqq> johnmark: fedora variant of ppas
19:31:52 <rbergeron> johnmark: http://skvidal.wordpress.com/2010/03/24/koperspersonal-repos/ <-- follow the yellow brick road.
19:32:34 <johnmark> OOOOHHHHH
19:33:01 <rbergeron> okay.
19:33:02 <gregdek> Yes, but... no.
19:33:21 <gregdek> (Well, I still think they're a good idea, but anyway.)
19:33:29 <rbergeron> ummmmmmmmmm, i'm going to squeeze some mustard here, progress, moving on
19:33:32 <rbergeron> wow, that sounded wrong
19:33:33 <rbergeron> um
19:33:36 <ke4qqq> yes kopers scope was larger, but it's the closest analogue
19:33:49 <rbergeron> #topic What else?
19:33:57 * ke4qqq wants to talk about swift
19:34:02 <rbergeron> #chair ke4qqq
19:34:02 <zodbot> Current chairs: gholms ke4qqq rbergeron spevack
19:34:06 <rbergeron> take it away.
19:34:48 * rbergeron looks to see if russellb is about since he's mr. openstack these days and may be the only one about besides us
19:34:51 <ke4qqq> So currently 1.4.0 is in Fedora - 1.0.x is in EPEL - and I'd like to see everything that 1.4.3 - but I have incredibly low amounts of time (excluding thanksgiving I am basically on the road from this weekend til christmas)
19:35:06 <ke4qqq> s/that/at/
19:35:58 <rbergeron> #info Swift 1.4.0 is in Fedora - 1.0.x is in EPEL - would like to get to 1.4.3.
19:36:01 <johnmark> ke4qqq: is that part of diablo? or a later release?
19:36:11 <ke4qqq> johnmark: 1.4.3 is diablo
19:36:19 <johnmark> ok
19:36:40 * ke4qqq wonders why drumkilla isn't in this channel.
19:36:49 <rbergeron> dunno.
19:36:52 <ke4qqq> that is all from me.
19:36:59 <rbergeron> HE SHOULD ALWAYS be drumkilla.
19:38:05 <rbergeron> ke4qqq: basically you're humbly requesting? :)
19:38:12 <ke4qqq> indeed
19:38:13 <mull> what are the policies about upgrades that like in EPEL?  is it just up to the package maintainer's discretion?
19:38:45 <ke4qqq> mull - not really - but hanging on to ancient version isn't great either - slowness, lots of warning, etc .
19:38:45 <gholms> Stick witb a version as long as you can.
19:39:10 <johnmark> ke4qqq: who's the maintainer?
19:39:11 <gholms> But rebases do happen.
19:39:18 <ke4qqq> johnmark: I am one of them
19:39:24 <ke4qqq> silas sewell is the other
19:40:11 <ke4qqq> but anyone who is a provenpackager, feel free to play with it. /me wonders if i have approveacls on swift.
19:41:19 <johnmark> ke4qqq: cool, ok
19:41:44 <ke4qqq> i don't have approveacls so can't give away commit access - though silas is pretty reasonable.
19:42:37 <rbergeron> ooh, i see russellb's name in there too.
19:42:41 <rbergeron> but he doesn't have commit access even.
19:43:46 <rbergeron> okay.
19:44:18 <rbergeron> ke4qqq: you should just talk to russell. or throw a rock in the general direction of chaaaaaaalston.
19:44:49 <rbergeron> see if he'll do it. :)
19:45:14 <ke4qqq> good coastal accent there
19:45:21 <ke4qqq> i'll harass him offline
19:45:23 <rbergeron> I try.
19:45:43 * rbergeron puts on her best jersey shore outfit
19:45:48 <rbergeron> okay, NEXT
19:45:50 * rbergeron looks around
19:46:03 <Southern_Gentlem> best or worst
19:46:12 <rbergeron> johnmark, aspiring cloud.fp.o guy: any comments to that thought?
19:46:15 <gholms> Southern_Gentlem: Depends who you ask
19:46:18 * rbergeron forces participation
19:46:55 <rbergeron> orrrrrr
19:46:58 * rbergeron thinks of other topics
19:47:04 <gholms> Well, that backfired. :(
19:47:50 <rbergeron> well, that happens
19:47:57 <rbergeron> a lot for me :)
19:47:58 <mull> I have one:  gholms needs to put his name on the fudcon list
19:48:01 <rbergeron> you should have seen me this week
19:48:02 <johnmark> rbergeron: wait, wha?
19:48:17 <rbergeron> johnmark: I am a relentless bus-thrower-underer
19:48:24 <johnmark> rbergeron: I noticed! :)
19:48:39 <rbergeron> #topic cloud.fp.o
19:48:42 <johnmark> about packaging swift? just use glusterfs ;)
19:49:07 <ke4qqq> johnmark: if you had 3.3 beta in fedora and epel that might be an acceptable response....
19:49:08 <gregdek> Oh shoot -- /me makes a note to add that to the euca event calendar.
19:49:17 <johnmark> ke4qqq: I wasn't actually serious
19:49:18 <johnmark> BUT
19:49:19 <rbergeron> gregdek: yesplz
19:49:34 <johnmark> you should understand that 3.2.x can also use the object storage bits
19:49:43 <johnmark> not that we publicize that very much
19:49:55 <rbergeron> (in a public channel in a logged meeting)
19:50:04 <johnmark> :)
19:50:12 <johnmark> rbergeron: so cloud.fp.o - what a stupendous idea
19:50:36 <rbergeron> yeah, i had it last year, but i'm not much for actually getting all my ideas done, what with there not being 45 hours in a day
19:50:38 <gholms> What is it for?
19:50:47 <rbergeron> gholms: Being Awesome?
19:50:52 <johnmark> heh
19:50:59 <rbergeron> #idea A place to get all information cloudy about Fedora.
19:51:00 <gholms> That's what regular fp.o is for. :)
19:51:08 <johnmark> gholms: ha!
19:51:17 <johnmark> so... in talking with rbergeron and others about this
19:51:36 <rbergeron> gholms: think of it as, say, spins.fedoraproject.org
19:51:43 <johnmark> it seems that there needs to be a place to discuss a. what actuallly would need to be included in a cloudy version/remix/whatever of fedora
19:51:51 <johnmark> and b. how to make that happen
19:52:00 <rbergeron> you know, SHINIER, easier links to amis (ping spevack on thoughts, yo, come back)
19:52:07 <ke4qqq> the cloud list?
19:52:10 <johnmark> right
19:52:12 <rbergeron> oh, wait, see, now i see two roads in a forest, diverging
19:52:18 <johnmark> cloud list?
19:52:23 <rbergeron> we have a mailing list.
19:52:25 <rbergeron> You are on it.
19:52:28 <gholms> johnmark: The mailing list
19:52:29 <johnmark> yes
19:52:39 <johnmark> oh that. yes.
19:52:42 <rbergeron> That's a good place to *discuss* things.
19:52:47 <johnmark> oh right. heh.
19:52:52 <rbergeron> Though
19:52:53 <rbergeron> I THINK
19:53:23 <rbergeron> That having a shiny version of cloud.fp.o would possibly lure people into thinking that we Have Our Shit Together, are serious, and might actually want to package their shit in here too.
19:53:38 <johnmark> rbergeron: agreed
19:53:40 <rbergeron> And have a nice place to highlight:
19:54:22 * gholms highlights rbergeron
19:54:43 <rbergeron> #info A spot to highlight: AMIs, Tools (Cloudstack/Euca/Aeolus/Openstack), Storage (HekaGlusterCloudFS), BigDataFun (someday), Deltacloud, other places with Fedora consumable in a cloudy way (rackspace)
19:54:49 <rbergeron> You know.
19:55:04 <rbergeron> #info Making us look like we mean Serious Business.
19:55:22 <rbergeron> So I seek other thoughts from the skeptics who are shaking their heads.
19:55:26 * rbergeron looks at gholms and ke4qqq
19:55:32 <gholms> Za?
19:55:33 <johnmark> rbergeron: and most importantly, making it easy to deploy
19:56:09 <rbergeron> #info Oh, and loftygoal, Make This Easy To Deploy, though that has a lot of associated stuff beyond "make a website"
19:56:24 <johnmark> rbergeron: true, but ultimately, that is the holy grail we seek
19:56:34 <rbergeron> which amazingly ties in with things Euca is rumored to be considering.
19:56:49 <gholms> What makes this different from other projects in Fedora?
19:57:08 <rbergeron> gholms: not a thing.
19:57:11 <johnmark> gholms: other than that is doesn't exist yet?
19:57:14 <rbergeron> gholms: except cloud is awesome.
19:57:19 <johnmark> er s/is/it/
19:57:42 <gregdek> Well.
19:57:59 <gregdek> Code is a good starting point, and fingers crossed that we'll have some cool stuff soon.
19:58:09 <gregdek> And then we can drag you into our #eucalyptus meetings.  ;)
19:58:10 <rbergeron> gholms: I can bring ke4qqq over here and have him explain that you don't need permission to Just Do Shit, if you have people who want to do it, then Let It Be So.
19:58:25 <rbergeron> (except I think he's wandered off)
19:58:30 <johnmark> gregdek: yes. no offense, but this has to be more than just euca ;)
19:58:36 <gholms> rbergeron: You do if you want a domain under fp.o.
19:58:42 <gholms> rbergeron: But beyond that, sure.
19:59:16 * ke4qqq is all for telling an awesome story - but do we have one yet? - /me hates vaporware announcements, and right now we are a one cloud distro..... admittedly that's our own fault...but still...
19:59:16 <johnmark> gregdek: not that Euca isn't 10 kilos of awesomem
19:59:17 <rbergeron> gholms: We're not entirely a Spin. And we're not entirely just "Distro."
19:59:41 <johnmark> ke4qqq: it's not vapor if there are actually packages involved
19:59:51 <rbergeron> ke4qqq: aren't we a 2-cloud distro?
20:00:00 <johnmark> we *do* have a story here
20:00:04 <gholms> I'm all for seeing something standing up to see what we can do with it.
20:00:05 <rbergeron> or is it like ... 2 halves... oh
20:00:07 <ke4qqq> rbergeron: aeolus keeps saying they are a metacloud now....so I dunno
20:00:11 * johnmark wonders if it's ok to utter the U-word here
20:00:20 <rbergeron> Unicorn!
20:00:23 <johnmark> LOL
20:00:26 <gregdek> U-boat?
20:00:26 * rbergeron looks in the mirror
20:00:28 <ke4qqq> johnmark: utter away
20:00:43 <johnmark> how did Ubuntu become the platform of choice inthe cloud?
20:00:48 <johnmark> other than because swardley is awesome
20:01:01 <ke4qqq> because they actively went out and targeted cloud ISVs
20:01:11 <ke4qqq> and they are still doing that
20:01:36 <jdarcy> They're also big in NoSQL, BigData, etc.  Those all play off one another.
20:01:39 <johnmark> true. they had to start somewhere
20:01:45 <rbergeron> oh, look, it's mr. darcy.
20:01:46 <johnmark> jdarcy: also true
20:01:46 <rbergeron> ;)
20:01:54 <ke4qqq> and that's gotten them critical mass
20:02:08 <johnmark> point is, there was the aha moment of "hey, let's go after this"
20:02:14 <johnmark> there was a vision, and there was a plan to execute
20:02:28 <gregdek> RH has visions.
20:02:30 <ke4qqq> when euca was the only game in town, they recruited it , when openstack came along, they were early to jump on board...etc...
20:02:36 <johnmark> right
20:02:44 <johnmark> gregdek: :)
20:02:47 <johnmark> of... ?
20:02:56 <johnmark> sugarplums?
20:03:00 <gregdek> Lots of visions.
20:03:04 <johnmark> LOL
20:03:05 <gregdek> Have for years.
20:03:26 <gholms> Visions alone mean little, for those of you who are playing at home.
20:03:26 <gregdek> Now, that whole "plan to execute" thing... well, that's a bit harder, to be fair.
20:03:43 <ke4qqq> indeed
20:03:47 <rbergeron> Yes. I had a vision of winning the 200 million dollar powerball, and yet, I am here today.
20:03:47 <gregdek> Ubuntu had the advantage of desperation.
20:03:47 <gregdek> And to be fair, so does Eucalyptus, LOL.
20:03:52 <johnmark> anyway, the thinking is, we have enough now to start putting together a story, and a place thathighlights the useful things already here
20:03:56 <johnmark> and what's coming up
20:03:58 <gregdek> Startup hunger and focus is a great advantage.
20:04:11 <johnmark> gregdek: boooooo
20:04:37 <johnmark> gregdek: yes, granted. (not actually booing)
20:04:39 <rbergeron> Can i ask what RHT's visions have to do with what we're doing?
20:04:41 <ke4qqq> johnmark: so past a story - what are you going to do? (because I've seen what Ubuntu does - and I've seenpast Fedora and Red Hat attempts) and a story isn't enough IMO.
20:04:55 <johnmark> ke4qqq: no. we're talking about how to start
20:04:59 <rbergeron> Whatever it is that we do?
20:05:02 <johnmark> you have to plant the seeds somewhere
20:05:12 <gregdek> johnmark: I think RH has planted too many seeds.
20:05:18 <johnmark> gregdek: :P
20:05:28 * ke4qqq fears I am not grokking the intent then.
20:05:31 <gregdek> Seriously -- there's a lot of seeds there.  :)
20:05:32 <johnmark> ke4qqq: ???
20:05:40 <sgordon> we have all the seeds johnmark
20:05:54 <johnmark> sgordon: so seeds are there. got it. ok
20:06:15 <rbergeron> so maybe the question is:
20:06:19 <rbergeron> What is the goal?
20:06:20 <johnmark> ke4qqq: so the point is to explain what's available now, what's coming, how to use it... etc.
20:06:23 <rbergeron> To be a sandbox?
20:06:24 <sgordon> with the ubuntu thing
20:06:30 <rbergeron> To be widely deployed in clouds?
20:06:34 <jdarcy> ke4qqq: I'll bite.  We'll start delivering functionality that Ubuntu et al haven't even started talking about yet.  I'm surely biased, but I think a lot of that has to do with storage.
20:06:34 <johnmark> rbergeron: right
20:06:44 <johnmark> jdarcy: that's one
20:06:44 <sgordon> another noticeable thing was they were the 'free' distro available on most cloud compute platforms first
20:06:52 <rbergeron> To be the place to have your shit and know (given that the market is still very early stage) that Your Stuff works with Other Stuff?
20:06:57 <ke4qqq> johnmark: so is the goal for Fedora - and by extension RHT to have cloud mindshare?
20:07:01 <johnmark> ke4qqq: and the reason we're having this discussion is we're looking for input on how to do thhis
20:07:24 <jdarcy> "Yay, I have my compute in the cloud.  Now, where the hell is my data?"
20:07:27 <rbergeron> or if we want to, or if there's consensus?
20:07:34 <johnmark> ke4qqq: the goal is to build the badest fucking cloud distro - around fedora. ultimately.
20:07:45 <ke4qqq> jdarcy: thats a start - but being better isn't always give you mindshare, or market - see betamax tapes.
20:08:00 <ke4qqq> wow I can't conjugate verbs
20:08:07 <johnmark> ke4qqq: yes, but you keep throwing out "what won't work" without suggestions on what would
20:08:13 <jdarcy> ke4qqq: True.  I think you need evangelism *and* reality.  Either one alone won't cut it.
20:08:19 <johnmark> jdarcy: yes
20:08:30 <ke4qqq> jdarcy: exactly
20:08:45 <johnmark> there has to be a "there" there
20:08:45 <rbergeron> #agreed We need evangelism *and* reality
20:08:51 <rbergeron> WHEW
20:08:57 <johnmark> well at least we can agree on something ;)
20:09:37 <rbergeron> So maybe I should ask this:
20:09:45 <jdarcy> Of course, first, we need to write code that doesn't have compile errors.  :(
20:09:49 <johnmark> LOL
20:09:53 <johnmark> details...
20:09:55 <ke4qqq> and we do it wrong IMO (we being fedora.) - we had some people pointing out that cloud was important years ago - and we didn't care....now we are trying to play catchup - and still IMO doing a feeble job. (and I am one of the guilty parties here)
20:09:55 <rbergeron> Does anyone here care about mindshare OR being better?
20:10:07 <rbergeron> :)
20:10:16 <johnmark> ke4qqq: absolutely true. playing catchup sucks :(
20:10:26 * johnmark raises hand
20:10:26 <gregdek> I believe that the undercurrent at RHT has always been "privilege RH projects in the cloud space".  The potential advantage of Fedora is its inherent ability to act as a platform for other advances in the cloud space.
20:10:40 <rbergeron> gregdek: dingdingding
20:10:41 <kkeithley> if you want to win you need more than just better
20:10:50 <kkeithley> you need better and mindshare
20:10:55 <rbergeron> kkeithley: :)
20:10:56 <gregdek> So for me, the open question is, "to what degree is that attitude at RH still/actually true?"
20:11:19 <johnmark> gregdek: honestly? no idea.
20:11:22 <ke4qqq> gregdek: by all outward appearances, I'd say it's still very true.
20:11:39 <gregdek> And I don't know.  What I do know is that Fedora/CentOS/RHEL have great tools, and we're going to use them.  If Fedora benefits, fine, but the primary benefit is for us.
20:11:48 <gregdek> And if others benefit as well, I'm delighted with that.
20:11:52 <johnmark> gregdek: word.
20:11:58 <johnmark> in full agreement here
20:12:13 <gregdek> So that, I suppose, is the Euca "distro strategy" 0.1, such as it actually exists.
20:12:17 <rbergeron> gregdek: Do you believe the undercurrent at RHT is also one that extends to what happens here in Fedora-land?
20:12:20 <gregdek> Which it doesn't yet, really.  :)
20:12:26 <johnmark> haha
20:12:53 <gregdek> rbergeron: I've always seen Fedora as the counterbalance, to some degree, where the field is more level.  But not entirely level, no.
20:13:06 <johnmark> gregdek: fair enough.
20:13:17 <gregdek> (And, of course, I fought hard my whole time at RH to *make* it level.)
20:13:21 <johnmark> I would actually like to see more agressive pursuit of non-RHT packaging in fedora
20:13:26 <ke4qqq> for instance - I send emails to people in RHT about cloud collaboration stuff - 1/2 of it goes unanswered - and it's not like I don't know folks at rht, or have some rep in fedora, but if I don't even merit a 'not interested' reply, then there's clear indifference.
20:13:37 <rbergeron> so is the question, then, "Why, as an ISV, should I give a rat's ass about Fedora" ?
20:13:37 <jdarcy> How about if we have stuff those others don't because *the development is being done on Fedora*?  Not because of some mandate, but because that's where the developers already are?
20:13:46 <johnmark> rbergeron: ding
20:14:02 <gregdek> jdarcy: what you have is customers in your ecosystem.  :)
20:14:04 <johnmark> jdarcy: but we're not there yet - although that's where we want to be
20:14:14 <johnmark> gregdek: oh right. that.
20:14:17 <gregdek> And Ubuntu, for all their progress, doesn't really have that.  Yet.
20:14:31 <gregdek> And to folks who are trying to build a business on open source, that matters.  A lot.  Maybe more than anything else.
20:14:39 <johnmark> gregdek: right. but I don't want to bet on that continuing.
20:14:56 <gregdek> Sure you do.  You want to make it continue.
20:15:01 <johnmark> ke4qqq: that is sad
20:15:09 <gregdek> And the way to make it continue is to play ball with an ecosystem that privileges your product.
20:15:12 * johnmark always responds to ke4qqq's emails :)
20:15:31 <johnmark> gregdek: no, wrong piece
20:15:42 <johnmark> gregdek: I meant, I don't want to bet on ubuntu continuing to not have customers
20:15:47 <gregdek> LOL
20:16:01 <gregdek> All I know is what I see.
20:16:04 <johnmark> ie. we can't rely on continued incompetence from the space friends :)
20:16:11 <gregdek> And what I keep seeing from every new vantage point I take.
20:16:13 <jdarcy> gregdek: Not sure what you're getting at.  How do we "play ball with an ecosystem..."?
20:16:30 <jforbes> jdarcy: with a really big bat!
20:16:37 <ke4qqq> so the 'why' an ISV should care about Fedora is easy. 1) greater adoption, 2) ready for next version of RHEL.
20:16:51 <johnmark> ke4qqq: nicely put
20:16:59 <gregdek> What ke4qqq said.
20:17:06 <ke4qqq> we've done anecdotal stats before on packages
20:17:10 <johnmark> except fedora doesn't yet have greater adoption - correct me if I'm wrong
20:17:25 <ke4qqq> johnmark: let me choose better words
20:17:25 <gregdek> johnmark: I treat Centos as an extension of Fedora.
20:17:30 * rbergeron goes to get a soda, since y'all are doing just fine without me ;)
20:17:34 <johnmark> gregdek: ah! ok
20:17:36 <ke4qqq> greater adoption than they could achieve on their own.
20:17:47 <johnmark> rbergeron: what? you're not frantically taking notes???
20:18:01 <jdarcy> ke4qqq: Does Fedora lose when ISVs make *RHEL* the target?
20:18:01 * ke4qqq introduces johnmark to zodbot
20:18:02 <johnmark> ke4qqq: ok. good point.
20:18:28 <johnmark> ke4qqq: I'm afeared of bots
20:18:29 <ke4qqq> jdarcy: I don't think so - do you? *with my ISV that targets RHEL hat on*
20:18:46 <gregdek> jdarcy: I make RPM+associated tools my target.
20:19:08 <jdarcy> ke4qqq: Just wondering whether ISVs decide they can skip Fedora and go straight to RHEL.  I honestly don't know, that's why I asked.
20:19:12 <gregdek> Which is Fedora + CentOS + RHEL, depending on which is right for my particular use case.
20:19:36 <ke4qqq> jdarcy: the fedora becomes RHEL model is well known and used at least here.
20:19:53 <jdarcy> ke4qqq: Here being your employer?
20:20:17 <ke4qqq> jdarcy: yes
20:20:40 <jdarcy> ke4qqq: OK, good to know.  I do wonder if others are as savvy, though.
20:20:53 <gregdek> RH has this weird insistence that Fedora+CentOS+RHEL are different.  They're not.  They're part of a continuum.  The pressure comes from the fact that RH only makes money from one of them -- but out here, outside of RH, we move freely between them according to our needs.  :)
20:21:12 <ke4qqq> jdarcy: so when we had the ISV sig - it was easy to explain - don't know how common - but the idea existed before I arrived, and I was the first fedora contrib here.
20:21:34 <ke4qqq> gregdek: +1
20:21:49 <gholms> gregdek: +1
20:22:39 <rbergeron> ke4qqq: telling the isv sig tale? :)
20:22:55 <ke4qqq> nah - most here know it already.
20:23:13 <jdarcy> So, how does that bring us to the folks in the Cloud SIG wondering why Fedora isn't already the distro of choice for cloud stuff?
20:23:48 <gregdek> oh, people are using it.  Trust me.  But not everyone is super inclined to bring any of it back.
20:24:17 <rbergeron> I don't want us to be all defeatist. Nor do I want us to just be complacent or think we're just fine doing what we do.
20:24:20 <rbergeron> Unless we are.
20:24:42 <rbergeron> But I think we can do better, if we focus around something.
20:24:50 <gregdek> I think RH gets lots of advantage just by being awesome.
20:24:53 <ke4qqq> gregdek: yep, we have fostered a cloud culture of use but not contribution.
20:25:18 <ke4qqq> and a lot of that is because RHT, RHEL, CentOS, etc are awesome.
20:25:56 <gregdek> Look, Fedora 16 and CentOS 6 kick ass.  And the tools are great, so we'll use them, and that will trickle down to customers, and RH will make money whether the customers are running Euca or OpenStack or RHEV-M or whatever.
20:26:15 <johnmark> gregdek: right
20:26:18 <gregdek> And this is a great forum to figure out how to work together with the cloudy tools we all have in common.
20:26:23 <johnmark> ke4qqq: curious about the ISV SIG
20:26:38 <ke4qqq> johnmark: I'll give you the story after the meeting if you wish
20:26:47 <johnmark> ke4qqq: sure.
20:26:51 <johnmark> of even better, over beers
20:27:04 <ke4qqq> we can do that too
20:27:08 <johnmark> Ok. SO.
20:27:17 <jdarcy> How do we drive *contribution*?  Give the people developing Cool New Stuff some reason to work within the community instead of just throwing stuff over the wall at us after it was natively developed in Ubuntu?
20:27:40 <johnmark> 1. we have cool stuff. 2. I don't think there's as much awareness of it as some of us think and 3. we have some catchup to do
20:27:41 <gregdek> johnmark: https://www.redhat.com/archives/fedora-isv-sig-list/2008-June/thread.html
20:27:46 <johnmark> gregdek: thanks
20:28:04 <johnmark> so now what? this is where the cloud.fp.o idea came from
20:28:27 <gregdek> (And now my day job calls again.)
20:28:30 <johnmark> I think there are a lot of individual components out there
20:29:24 <ke4qqq> jdarcy: part of it is just showing you care - certain distros are very hungry - and they actively go out and get commitments and also offer to help (for certain defs of help) the ISV/project. RHT, and largely fedora seem apathetic.
20:30:36 <rbergeron> Well, I can only help so much. :)
20:30:40 <rbergeron> As in: Robyn can't package.
20:30:46 <rbergeron> (Even though she took a class once. :D)
20:31:03 <jdarcy> ke4qqq: So, offer to help more on existing projects, instead of inviting people to drop what they're doing and come work on RH-controlled ones?  Something like that?
20:31:05 <ke4qqq> a good measure of this is how many folks here were fedora contribs before they went to a cloudy company. spevack, mull, gholms, gregdek, me......see any new blood?
20:31:41 <johnmark> ke4qqq: the awful truth unfolds
20:32:13 <ke4qqq> jdarcy: yes, or even just say, thats not the direction RHT or whoever is going, but we'd still love for you to contribute and be a part of the story even if it isn't a product we sell.
20:32:15 <johnmark> ke4qqq: but yes, excellent point about helping ISV's, or in our case, not helping
20:32:37 <johnmark> ke4qqq: correct. that's how you build a greater ecosystem
20:32:37 <jforbes> rbergeron: "can't" or won't?
20:32:40 <jforbes> :)
20:32:41 <johnmark> and bring in fresh meat
20:32:42 <johnmark> LOL
20:32:50 <johnmark> rbergeron: who's under the bus now?
20:32:52 * gholms throws a hotdog at johnmark
20:32:58 <jdarcy> ke4qqq: OK, I think I'm beginning to understand.
20:33:00 <gregdek> ke4qqq: not a bad thing that we're all at cloud companies.  Gives Fedora an opportunity.
20:33:14 <johnmark> gholms: LOL
20:33:23 <johnmark> gregdek: also true
20:33:25 <gholms> gregdek: An opportunity for everybody to pull in their own directions?  Yeah, that works well.
20:33:32 <ke4qqq> gregdek: not saying it is - I am saying we are the only ones here participating by and large - see anyone knocking on our door to get into fedora that wasn't a preexsting contrib.
20:33:41 <rbergeron> gholms: i don't see it as pulling in different directions.
20:33:44 <johnmark> brb
20:33:54 <rbergeron> I see it as: No Cloud is going to Stand Alone.
20:34:01 <rbergeron> There will always be multiple pieces.
20:34:03 <ke4qqq> jdarcy: /me is happy to talk offline more openly.
20:34:28 <jdarcy> ke4qqq: Careful, I might take you up on that.  I can be blunt too.  ;)
20:34:42 <ke4qqq> jdarcy: bluntness is good - feelings won't get hurt here :)
20:34:47 <rbergeron> And we already, as a small crowd, despite having paychecks from obviously some competitive places, seem to do a reasonable job of getting some things done that are of benefit to all.
20:34:57 <gregdek> gholms: an opportunity to legitimately identify opportunities to abstract out commoditized non-value.
20:35:25 <rbergeron> And gregdek wins the dollar for most epic line of the day.
20:35:27 * gholms takes a moment to process that sentence
20:35:45 <gregdek> LOL
20:35:51 <rbergeron> gholms: we all have commons problems, we all have common components
20:35:54 <rbergeron> common
20:35:56 <kkeithley> if you can't dazzle them with brilliance, baffle them with bullsh*t
20:35:57 <jdarcy> I've read it six times and my brain's still rejecting it.
20:36:00 <gregdek> As Tiemann says: "what can be the same so everything else can be different?"
20:36:15 <rbergeron> I would dazzle you with brilliance, if I only had the knack
20:36:26 <rbergeron> oh, I'm singing.
20:36:43 * ke4qqq notes this is the best cloud-sig meeting he thinks he has attended.
20:36:44 <kkeithley> Is the bar set too high to contribute to Fedora? I think it might be.
20:36:52 <gregdek> No question it is.
20:36:56 <ke4qqq> kkeithley: it's very high
20:37:02 <ke4qqq> but so is every place else
20:37:05 <kkeithley> well, not for a good reason
20:37:22 <kkeithley> I mean, it's high for a good reason
20:37:24 <sgordon> i think it actually for a good reason
20:37:26 <sgordon> yeah
20:37:55 <kkeithley> but if you want to attract cloudy stuff, how about a fast track option just for cloudy stuff
20:38:05 <sgordon> users have expectations with regards to what they get when they install a package that has made it through the review process etc and is in the repos
20:38:16 <jforbes> kkeithley: why just cloudy stuff, in general we need to make it easier for people to contribute to Fedora
20:38:19 <ke4qqq> fesco would never approve, and i still don't think it would matter
20:38:30 <ke4qqq> there are ways of making it faster - we've done some of that here....
20:38:35 <rbergeron> gholms: everyone needs a storage solution. Everyone needs a chef or puppet. Everyone needs virt-y stuff. People are going to have hybrid solutions. And there are going to be vendors who want to sit on top or on the bottom or in the middle of all of this.
20:38:42 <sgordon> yeah ec2 images outside of the rel-eng process for example
20:38:47 <gregdek> If we have a set of repos that have mutual depclosure, it doesn't matter what Fedora's policies are.
20:38:52 <ke4qqq> for isntance, I've offered to sponsor anyone who wants to be a packager - I've offered to trade reviews with gdk and gholms...
20:39:24 <ke4qqq> we've dedicated interns to doing cloudy reviews
20:39:25 <ke4qqq> etc.
20:39:32 <mull> ke4qqq, we should definitely trade some reviews... I have some queued
20:39:41 * jforbes too
20:39:42 <ke4qqq> mull: so do I
20:40:02 <rbergeron> kkeithley: I think the problem with the fast track thing gets uglier once you start getting into "i need 14 different versions of ruby" and that kind of thing also
20:40:18 <gholms> True
20:40:37 <ke4qqq> and we now have at least two packaging sponsors in ths sig, so packaging and even sponsoring shouldn't be adversely painful.
20:40:47 <rbergeron> ke4qqq: who's the other sponsor?
20:40:51 <ke4qqq> gregdek:
20:40:53 * rbergeron looks at jforbes
20:40:55 <ke4qqq> rbergeron: gregdek
20:40:57 <rbergeron> oh
20:41:09 <johnmark> heh
20:41:16 <gregdek> Although I haven't used that power in a very long time.
20:41:34 <jforbes> In all honesty I think it is a better effort to see how we can make it easier for people to contribute to Fedora in any category then spend energy coming up with rules and petitioning to allow for cloud specific bits to be "fast tracked"
20:41:36 <rbergeron> johnmark: here's your big opportunity to learn packaging and get sponsored :)
20:41:42 <johnmark> rbergeron: hooray!
20:41:46 <johnmark> definitely want to learn packaging
20:41:50 <ke4qqq> jforbes: +1
20:42:06 <johnmark> jforbes: sounds reasonable
20:42:14 <johnmark> fast-tracking can be a slippery slope
20:42:23 <kkeithley> rbergeron: I'm not suggesting lowering the standards. fast track could be having a small pool of pkg reviewers who will make reviews of cloudy stuff a priority
20:42:25 <rbergeron> jforbes: you running for the board, too? :)
20:42:26 <jforbes> ke4qqq: and no, I didn't forget about your RHEL patch, it has been passed on, but RHEL moves at a much slower pace for obvious reasons
20:42:28 <johnmark> because by definition it means other things have been slow-tracked
20:42:29 <rbergeron> kkeithley: I know :)
20:42:34 <ke4qqq> jforbes: but honestly - at that level, it's not going to get significantly better - the barriers to package inclusion are relatively low (unless you look at bundled libraries)
20:42:46 <ke4qqq> jforbes: you were the responsive 1/2 :)
20:43:34 <johnmark> ok, I must actually get on with $_dayjob
20:43:51 <jforbes> ke4qqq: The barriers are higher than you think there is a lot of process to get through, which doesnt necessarily reflect on the quality of the package, but it takes effort which scares people away I think
20:44:10 <ke4qqq> jforbes: what would you eliminate?
20:44:46 <jforbes> ke4qqq: I am not sure that eliminate is the best term, but perhaps streamline, and make it less daunting
20:44:46 <mull> ke4qqq, a significant amount of required reading.  it's daunting for a new contributor
20:44:52 <rbergeron> jforbes: you should be running for the board, you know :)
20:44:53 <mull> documentation is good
20:45:12 <mull> but tens of pages of policy is maybe too much
20:45:31 <ke4qqq> mull: it's only tens now???
20:45:39 * ke4qqq thought we easily were at 100
20:45:45 <sgordon> well, i find a lot of it you can skip through and rpmlint will tell you where you screwed up
20:45:45 <mull> ke4qqq, well, for the packaging guidelines
20:45:57 <sgordon> obvs there is still some of it that is required reading tho
20:46:04 <jforbes> rbergeron: heh, thanks
20:46:06 <ke4qqq> mull: thats what I was thinking too
20:46:15 <ke4qqq> at least 100 pages for pg
20:46:20 <mull> sgordon, exactly, so rpmlint's existence should mean less documentation is necessary
20:46:36 <ke4qqq> sgordon: well yes and no - theres lots that can't be tested for in rpmlint.
20:46:42 <sgordon> disclaimer applies, im not actually sponsored
20:47:09 <sgordon> yeah i know ke4qqq, but there is also a lot in the guide which it can and does test for
20:47:32 <ke4qqq> sgordon: true
20:47:40 <ke4qqq> sgordon: we can fix that for you :)
20:47:53 <sgordon> yeah i know, i need to do some other reviews
20:48:07 <sgordon> i put an aqemu package up a while ago which after good feedback is now in reasonable shape
20:48:35 <ke4qqq> sgordon: if you don't have a sponsor, let me know.
20:48:48 <sgordon> i would like to put an owncloud one together as well but i suspect that is going to be a lot more involved...
20:50:11 * ke4qqq thought rrix was packaging owncloud, but maybe I am wrong
20:50:34 * johnmark goes to look up owncloud
20:50:46 * abadger1999 notes that he would love for someone who understands documentation to help out with organizing the packaging guidelines
20:51:34 <rbergeron> not sure.
20:54:25 <sgordon> ke4qqq, i think that was suggested when i brought it up on the list
20:54:25 <sgordon> but i haven't seen anything further
20:54:25 <sgordon> at the time i let it slide as the stable upstream was still pretty shaky
20:54:25 <sgordon> but owncloud2 looks to be pretty good
20:54:25 <rbergeron> johnmark: it's a kde thang
20:54:25 <rbergeron> as a tip
20:54:25 <rbergeron> abadger1999: that would be a great thing to do, actually
20:54:25 <rbergeron> god, EVERY GROUP SHOULD BE HAVING THIS MEETING RIGHT NOW
20:54:25 <sgordon> i deployed it on openshift yesterday: http://rainhilltrials.blogspot.com/2011/11/installing-owncloud-on-openshift.html
20:54:26 * ke4qqq wonders if we're done with this meeting?
20:54:26 <rbergeron> yeah, I feel like we are.
20:54:26 <sgordon> i thought you guys were done an hour ago
20:54:26 <rbergeron> I feel like we're undone on what spurred hte last hour, but I suppose we can come back to it.
20:54:26 <sgordon> i went and a coffee in the meantime :p
20:54:26 <rbergeron> It's good to get Thoughts Out There.
20:54:26 <rbergeron> #info HIGHLY PRODUCTIVE AND THOUGHTFUL MEETING. Logs are absolutely fascinating.
20:54:26 * aeperezt Wao I read this meting and I like it, congratulation to all Cloud SIG, salutes to all
20:54:27 <rbergeron> #info What is the Future of Fedora in the Cloud??? Or With a Cloud? Or As a Cloud?
20:54:28 <rbergeron> #info How do we enable the Cloud SIG, Cloudy Efforts, and... Fedora in General?
20:54:36 <rbergeron> #info Find out at the next meeting!
20:54:40 <rbergeron> Thanks for playing, kids.
20:54:46 <rbergeron> jdarcy, ke4qqq: you two should talk.
20:54:56 <jdarcy> Absofinglutely.
20:54:57 <rbergeron> johnmark, gregdek: you two should talk.
20:55:15 <rbergeron> gholms: you should sign up for fudcon
20:55:24 <gholms> Indeed.
20:55:41 <rbergeron> And that's it.
20:55:45 <ke4qqq> abadger1999: we've tried that before - I think it scared of laubersm :)
20:56:02 <gholms> I would like to congratulate you all on holding the longest meeting in recent cloud-sig history and remaining on topic the entire time.
20:56:08 <gholms> s/on/for/
20:56:09 <rbergeron> #info abadger1999 thinks it would be great if we could have someone familiar with documentation work with the packaging guidelines to make them more consumable.
20:56:19 <gholms> Aaand s/recent //
20:56:32 <abadger1999> ke4qqq: yeah, I do too :-)
20:56:35 <rbergeron> :)
20:56:42 * rbergeron holds for 87 seconds
20:56:53 <johnmark> that long?
20:56:53 <jforbes> wait for it...
20:56:54 <johnmark> geez
20:56:59 * gholms plays catchy hold muzak
20:57:34 <kkeithley> say good night gracie
20:57:37 * jforbes misses our old hold muzak, luckily someone recorded it for when meetings get too efficient
20:57:46 <gholms> Heh
20:59:14 <gregdek> Good night, Gracie.
20:59:14 <ke4qqq> #endmeeting