19:00:10 <rbergeron> #startmeeting Cloud SIG Meeting
19:00:10 <zodbot> Meeting started Fri Jul  8 19:00:10 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:15 <rbergeron> #meetingname CLoud SIG meeting
19:00:15 <zodbot> The meeting name has been set to 'cloud_sig_meeting'
19:00:53 <rbergeron> #topic Roll Call
19:01:01 * kkeithley1 nods
19:01:01 <rbergeron> YO
19:01:05 <rrix> boing!
19:01:20 * tflink remembered this meeting for once
19:01:20 <jforbes> Heya
19:01:21 <athmane> hay
19:01:55 <gholms> blargh
19:02:09 <rbergeron> well. i can tell we're all very excited, so i'll get going
19:02:15 <rbergeron> #topic EC2 images
19:02:22 <rbergeron> jforbes: where are we? ;)
19:02:50 <jforbes> rbergeron: still moving slowly, about to commit my most recent kickstart changes
19:03:02 <rbergeron> jforbes: where are those going?
19:03:23 <jforbes> the cloud-kickstarts git repo on fedorahosted
19:03:25 <rbergeron> okay
19:03:36 <tflink> jforbes: does that have other docs in it, too?
19:03:48 <tflink> I've been trying to figure out how the official AMIs are being built
19:03:58 <jforbes> no, there is no other doc in it
19:03:58 <rbergeron> jforbes: tflink, and athmane, and others are going to be helping us out with the whole "testing" thing
19:04:17 * athmane wondering if thincrust is used to compose ami (kickstart)
19:04:18 <jforbes> the images that are up right now are built from boxgrinder (I can add those configs too)
19:04:38 <jforbes> but the end goal is for koji to build them.
19:04:40 * clalance is here
19:04:41 <rbergeron> tflink: but i think th egoal is to have them coming from koji, not bg
19:04:42 <clalance> (late)
19:05:03 <jforbes> Unfortunately boxgrinder is really fast, easy, working and well tested...  koji is none of these for EC2
19:05:09 <gholms> IIRC, koji uses appliance-tools.
19:05:18 <jforbes> yes, it does
19:05:35 <jforbes> so does boxgrinder if I recall
19:05:48 <tflink> this might be a conversation for another place/time but which appliance-tools repo? I think I found 2
19:05:48 <jforbes> But there are things done to the images after creation which really matter
19:06:09 <tflink> one on redhat-et and one on fedorahosted
19:06:10 <jforbes> tflink: I don't know honestly
19:06:11 <gholms> Are you able to ask those who created the RHEL EC2 images? Those used koji.
19:06:37 <jforbes> gholms: I am, and I have access to the repos used to create those, F15 is a bit different though
19:06:52 <gholms> Oh, the problems are distro-specific. :(
19:07:02 <jforbes> gholms: And of course the kickstart is a very small part of what creates the images, it is a ton of post mangling
19:07:23 <gholms> Yeah, it's the post-mangling that I'm curious about, personally.
19:07:31 <gholms> I suppose that *would* differ, though.
19:07:46 <jforbes> gholms: some are, some of it is trying to move cruft out of the python scripts which mangle an image, and putting them into kickstart %post
19:07:57 <rbergeron> jforbes, et al: i think people had some questions about what we needed different kernels for, and why we'd have two different things to test ,and if someone could elaborate on that stuff it would be awesome (since I can't)
19:08:04 <jforbes> Either way, I suppose koji has *very* little to do with what the final image looks like
19:08:29 <jforbes> rbergeron: we don't need different kernels, we are using the same kernels as everyone else in Fedora
19:08:35 <gholms> Koji itself? Nope. The important part there was just taking cues from the RHEL people.
19:08:49 <rbergeron> so we don't need different versions?
19:08:54 <jforbes> gholms: Oh, I have
19:08:58 <tflink> rbergeron: that's what I'm interested in. how are the AMIs different from normal fedora and what needs to be focused on for testing
19:08:59 <jforbes> rbergeron: nope, not since F12
19:09:00 <gholms> No, Fedora's kernel works fine on EC2.
19:09:08 <rbergeron> okay
19:09:22 * rbergeron thought we had had a discussoin a few meetings back about needing to have 2 different versions tested
19:09:30 <tflink> gholms: this might be a dumb question but are the AKIs updated with new kernel versions?
19:09:40 <tflink> or can they be updated with yum
19:09:40 <gholms> tflink: No, they boot their own kernels.
19:10:01 <jforbes> tflink: the only real differences are EC2 specific bits, like pulling the ssh key so you can actually log in, how you set the fstab for S3 and EBS, etc
19:10:14 <gholms> rbergeron: 32-bit and 64-bit, ephemeral instance storage and persistent EBS storage
19:10:25 <tflink> gholms: so an F15 AMI would always use the same kernel that it was created with?
19:10:32 <gholms> tflink: Yep
19:10:40 <jforbes> rbergeron: Oh, I think you might have cought on that I need to link to a diffrent AKI when I migrate... That is technically a "kernel image" to amazon, but it is really just the pvgrub image, it actually boots our kernel
19:10:53 <rbergeron> jforbes: ah
19:10:57 <gholms> tflink: Unless its kernel is updated and the instance rebooted.  Then it will use the newest one on the image.
19:11:10 <jforbes> rbergeron: from a testing standpoint on migrate, we only have to verify that the images boot, because the actual image is the same, we just have to ensure it is linked to the correct AKI for that region
19:11:14 <tflink> gholms: is that how people do security updates for the kernel, then?
19:11:22 <rbergeron> gholms: so ..... how much do we need to test here? now i'm feeling like i'm seeing four things
19:11:25 <jforbes> tflink: managed with yum
19:11:25 <gholms> tflink: Yes
19:11:47 <gholms> rbergeron: Well, we've been bitten with 32-bit-specific issues in the past, so at the very least we need to test that.
19:11:58 * rbergeron nods
19:12:10 * rbergeron wonders if everyone has seen the test-day documentation that athmane has been putting together?
19:12:23 <gholms> rbergeron: F14 didn't have any images that live on EBS, so we should probably test that as well.
19:12:26 <tflink> jforbes, gholms: I think I'm missing something here. can you use yum to update the kernel that an EC2 instance is using through yum?
19:12:30 <jforbes> I have not yet, been playing catch up this week
19:12:47 <gholms> tflink: ``yum upgrade kernel; reboot'' works like normal.
19:12:49 <jforbes> tflink: yes, all updates are done with yum
19:13:01 <tflink> ok, thanks. I misunderstood something earlier then
19:13:43 <rbergeron> so i guess the question is this:
19:13:49 <rbergeron> do we want to just test the images we have now?
19:13:54 <rbergeron> or do we want to wait for the ones made with koji
19:14:43 <jforbes> That goes back to my point that bg is well tested, and we are confident with what it puts out... koji is not in this regard
19:14:51 <rbergeron> right.
19:15:09 <rbergeron> at the same time, to get something called "official" we're supposed to get release-engineering to sign off on it
19:15:18 <rbergeron> and i suspect rel-eng isn't going to sign off on anything using bg
19:15:29 <rbergeron> because it's not part of their process at this point
19:15:43 <rbergeron> now we could probably go to the board and say process doesn't work, etc
19:15:50 <rbergeron> and we need a different process
19:15:56 <rbergeron> but i can't do that on my own ;)
19:16:05 <jforbes> rbergeron: neither is the massive amount of post that has to be done to a koji image once koji is done with it
19:16:32 <rbergeron> jforbes: none of that can be done automagically?
19:16:43 <jforbes> rbergeron: it can, but not using tools they have
19:16:57 <jsmith> jforbes: Is any of that -post work documented anywhere?
19:17:07 <jforbes> rbergeron: at the very least we are introducing a couple of python scripts and euca-tools
19:17:26 * rbergeron nods
19:17:37 <jforbes> jsmith: it was loosley documented at some point, though that probably needs some updating
19:18:04 <jforbes> jsmith: and I don't know that current rel-eng has ever seen it, jkeating did when we last went through all of that
19:18:26 <jforbes> jsmith: rhel does something similar, but not using tools that fedora rel-eng will allow
19:18:49 <rbergeron> jforbes: but i'm assuming that automating all of that magic will take some time and so forth to actually make automated
19:19:20 <jforbes> rbergeron: probably so, yes.  The point was more that it is defining a new process for rel-eng either way
19:19:53 <rbergeron> and bg is easier for us, and koji script hell will be easier for them
19:19:54 <jforbes> koji is us writing from scratch, bg has an active and responsive upstream, and is well tested
19:20:14 <rbergeron> and bg is fairly well tied in with our community as well
19:20:31 <jforbes> rbergeron: dont know that koji will be any easier for them, but it is the beast they know, at least for that part of it
19:20:59 * jforbes cannot stress enough how insanely easy bg is to go from scratch to published images
19:21:01 <tflink> have any alternatives been proposed?
19:21:04 * rbergeron feels like she is stuck between a rock and a hard place
19:21:10 <rbergeron> tflink: the alternative to koji is boxgrinder
19:21:44 <jforbes> tflink: they were proposed many moons ago, rel-eng chose koji
19:22:04 <tflink> ok, I kind of figured that I missed that discussion
19:22:23 <gholms> jforbes: Even in light of all the manual labor after image creation?
19:22:30 <rbergeron> dgilmore: are you here
19:22:31 <jforbes> of course at that point bg was "coming to fedora" and not actually in it, so maybe that might change
19:23:01 <jforbes> gholms: guess so, this is nothing new
19:23:09 <gholms> :-\
19:23:27 <jsmith> The whole idea is to automate it (whether it's koji or bg)
19:23:34 <jforbes> though, like I said, jkeating was the rel-eng representative for those discussions
19:23:42 <jforbes> jsmith: with bg, it is already automated
19:23:47 <rbergeron> it's automated with bg
19:25:00 <gholms> [Nothing happens]
19:25:05 <rbergeron> gholms: no shit :)
19:25:22 * rbergeron snickers. anyway
19:25:42 <jforbes> (though there is still the issue of credit card for the official account, since amazon decided to bill me anyway, even though I removed my card from the account)
19:25:43 <gholms> Any thoughts, people?
19:25:43 <rbergeron> so where are we, folks... do we want to propose using bg to rel-eng?
19:25:55 <jforbes> I would love to
19:25:57 <rbergeron> jforbes: ummmm
19:26:08 <rbergeron> jforbes: can i just dial you post meeting?
19:26:13 <tflink> +1 to using boxgrinder
19:26:18 <jforbes> rbergeron: sure
19:26:25 <tflink> proposing, rather
19:26:31 <rbergeron> maybe we can sort that out, because i'm lost
19:26:41 * ke4qqq shows up late
19:26:50 <clalance> Use koji to call boxgrinder ?
19:27:04 <jforbes> rbergeron: though it isn't a huge deal, we are using the other account for machine time, this account only pays for transfers, so it was less than $4, but I dont like other people having credentials to an account that can bill me directly if they do decide to use machine time
19:27:28 <rbergeron> jforbes: if i give you the credentials for the community account, can you just make it there??
19:27:46 <rbergeron> that gets billed to commarch
19:27:53 <rbergeron> though now i'm wondering wtf commarch is getting charged for
19:28:01 <jforbes> rbergeron: no, Amazon has tied free S3 storage to this account for the use of our public images
19:28:17 <rbergeron> okay, i'm just going to call you when we're done here and sort it out
19:28:23 <jforbes> rbergeron: okay
19:28:25 * ke4qqq thought I saw some pretty heady resistance to bg from releng. but I may be imagining things.
19:28:33 <rbergeron> in the meantime: we need some documetnation on wtf would need to happen on the rel-eng side for them to use bg.
19:28:38 <jforbes> ke4qqq: you did
19:28:48 <gholms> At that point BG was still a new a lightly-tested thing.
19:28:56 <gholms> *new and
19:29:04 <rbergeron> or alternatley, we need to have some sort of automated process that essentially doesn't involve rel-eng, if they're not interested, which i believe is the case.
19:29:06 <jforbes> And not actually in Fedora yet, and a bunch of other things
19:29:19 <ke4qqq> gholms: I didn't think a week or two ago was that long ago.
19:29:21 <ke4qqq> :)
19:29:47 <jforbes> rbergeron: we have that, I can spin up images in BG in less than 1 hour
19:30:03 <rbergeron> jforbes: can you do some of that documentation, fairly soon-ish? i know you're swamped. or at least give someone some permission to look at whatever you have going on (scripts or commands or something) so someone can write it.
19:30:03 <jforbes> ke4qqq: Oh, no those discussions were more than 6 months ago
19:30:11 <rbergeron> because we need to not have it all stuck in your brain, basically. ;)
19:30:23 <jforbes> rbergeron: yeah, I can write up BG docs this week
19:30:57 <rbergeron> jforbes: can you additionally perhaps do some write-up as to wtf koji would need to do, or what needs to happen in post, for that way to work?
19:31:16 <jforbes> rbergeron: I can
19:31:18 * rbergeron offers cookies
19:31:26 <rbergeron> :D
19:31:52 <gholms> [You hear a sound reminiscent of an elephant stepping on a peanut.]
19:32:01 <rbergeron> okay. because while i think we're moving towrads having testing plans made, we need to sort out the whole image creation process before rel-eng will sign off on anything, before we can call things "official" or whatever
19:32:05 * rbergeron sighs
19:32:14 <rbergeron> okay.
19:32:23 <rbergeron> #action jforbes to document bg and koji details for image creation
19:32:26 <rbergeron> (thank you, sir)
19:32:32 <jforbes> NP
19:32:50 <gholms> What about figuring out the whole credit card mess?
19:33:17 <rbergeron> so - i'll talk to justin after this to try and sort out at least who's getting billed for things.
19:33:36 <gholms> Remember that if you're concerned about the ways in which people will use that account, that is exactly what IAM is for.
19:33:52 <rbergeron> the other part is the "community testing", and the dude at amazon that i've been talking to sort of offered to get us some AWS credits to give people.
19:34:04 <rbergeron> gholms: yeah, but that doesn't put any restrictions on what they can use it for
19:34:12 <rbergeron> they can more or less do other things, can they not?
19:34:23 <rbergeron> ie: decide to make a 400-machine cluster at 2 bucks an hour? ;)
19:34:23 <gholms> rbergeron: Yes it does.  It's an op-for-op ACL.
19:34:35 <gholms> i.e. "these credentials can only use UploadImage"
19:34:42 <jforbes> gholms: the problem is, you have to actually launch machines to do the EBS creation, but either way, I would rather not even pay for transfer time
19:34:43 <gholms> (or whatever)
19:34:54 <gholms> Oh, crap. EBS images.
19:35:09 <tflink> just to make sure I'm clear on this - there is still no decision on whether we want to go forward with testing the current F15 AMIs?
19:35:14 <gholms> Amazon stopped charging for data transfer into EC2.
19:35:21 <rbergeron> tflink: we want to test them, yes.
19:35:24 <jforbes> gholms: yeah, basically IAM is useless in this regard
19:35:44 <tflink> rbergeron: but which ones? the BG created ones that are currently up or wait for koji-ish ones?
19:35:59 <rbergeron> i don't know. concensus, folks?
19:36:05 <rbergeron> jforbes: how far are you from having koji-ish ones?
19:36:34 <tflink> it doesn't sound like we'll have koji-ish ones any time soon, so I'd say the BG ones before the F16 test days get started
19:36:45 <gholms> #action rbergeron and jforbes to figure out who will get billed for things
19:36:52 <rbergeron> #chair gholms
19:36:52 <zodbot> Current chairs: gholms rbergeron
19:37:05 <jforbes> rbergeron: from having working images generated (mostly) by koji, or from having full automation for rel-eng using koji? Two very different things
19:37:23 <rbergeron> i mean from the former (you having working images generated mostly by koji)
19:37:48 <jforbes> rbergeron: hopefully by next week.
19:37:54 <rbergeron> though knowing the man-hours behind the latter might be interesting to know as well
19:38:19 <rbergeron> jforbes: by this meeting next week, or monday, or?
19:38:19 <jforbes> rbergeron: depends on how many of the insanely slow build/test cycles I have to go through with koji
19:38:22 <rbergeron> right
19:38:29 <rbergeron> okay
19:38:32 <jforbes> rbergeron: hopefully by this meeting next week
19:38:33 * rbergeron doesn't have a preference.
19:39:09 <rbergeron> at this point, either way,we're not going to be going to release engineering with a full-blown plan for the future, so i don't see why we wouldn't want to use bg-generated images.
19:39:29 <gholms> rbergeron: +1
19:39:57 <rbergeron> okay.
19:40:21 <rbergeron> well, i'll run that by dgilmore today or monday and see what his feeling sare.
19:40:32 <jforbes> Yeah, it is an easy argument from a technical standpoint.  Here is a fully automated solution, with an active upstream, supported in fedora by the developers, and well tested
19:40:42 <rbergeron> if he's kosher with that, we'll make a plan for a test day, and we'll figure out how we're going to pay for it.
19:40:51 <rbergeron> in the short-term.
19:40:59 <jforbes> Or here is a plan to write something specifially for us that no one else can ever even us
19:41:18 <rbergeron> which is probably either (a) we trust people with account access or (b) I pay a bunch of people $5 for their amazon usage via paypal
19:41:21 * jforbes notes normal users and developers do not have permissions to even try to spin a koji image
19:41:32 <gholms> Another thing to consider is that regular people can use BG, whereas they can't use koji.
19:42:44 <dgilmore> wfrom a releng perspective boxgrinder is not acceptable
19:43:17 <ke4qqq> dgilmore: is there a way bg could be made acceptable, or is that a lost cause?
19:43:19 <athmane> ruby ?
19:43:34 <dgilmore> its not taking in a kickstart being the biggest hurdle
19:44:08 <dgilmore> ke4qqq: well it needs to take a kickstart, then we could look at koji integration
19:44:12 <jforbes> dgilmore: it can take a kickstart I believe, he added that functionality a few releases ago
19:44:25 <dgilmore> but last i looked there was more promising tools coming along
19:44:50 <dgilmore> jforbes: thats good then, communication has been no existant so i cant change my thoughts
19:44:51 <gholms> BoxGrinder can read kickstart files if they have bg_os_name and bg_os_version as comments in the kickstart file.
19:44:52 <ke4qqq> dgilmore: ok, i mean if releng is completely opposed to bg there's no point in working on it, but if there are things that can be fixed then perhaps it is. I just don't want anyone wasting cycles.
19:45:22 <dgilmore> ke4qqq: right now its not our favoured tool
19:45:31 <dgilmore> ke4qqq: and not likely to become so
19:45:49 <jforbes> ke4qqq: not really wasting cycles, bg works, works well.  it is used until we can get something that releng likes either way.
19:45:53 <dgilmore> from the fudcon in tempe it looked like more promising things were coming along
19:46:04 <dgilmore> but im certainly happy to visit the situation
19:46:14 <ke4qqq> dgilmore: so if we wanted amazon images generated by releng so they can be blessed and annointed, how should that be pursued?
19:46:34 <dgilmore> ke4qqq: by working with releng for a start
19:46:35 <clalance> There is the oz/imagefactory combination from aeolus, which can do some of the same things.
19:46:37 <rbergeron> or if we wanted existining amazon images blessed and anointed
19:46:59 <dgilmore> ke4qqq: we want to make the images in koji
19:47:01 <clalance> But it is not as mature at the moment.
19:47:20 <rbergeron> clalance: you guys don't have GA until november, correct?
19:47:22 <jforbes> clalance: Yes, that was the more promising bits from Tempe :)  but that has no koji integration at the moment either
19:47:33 <clalance> jforbes: Yeah, that is going to be problematic as well.
19:47:44 <rbergeron> so either way, we don't have anything now or up and coming that will work with koji.
19:47:44 <dgilmore> jforbes: right which is why we are using immage-creator for now
19:47:54 <clalance> Right, correct.
19:48:18 <dgilmore> rbergeron: oz/imagefactory was what releng was considering
19:48:34 <dgilmore> and looking to integrate with koji once it all stabalised
19:48:37 <jforbes> dgilmore: sure, (and so does bg underneath), but what image-creator spits out is only a piece of the puzzle for EC2 either way
19:49:03 <dgilmore> anaconda itself is adding functionality that will be useful for appliance creation as well
19:49:23 <rbergeron> well thank god there are 15 red hat projects all working on the same problem.
19:49:26 <rbergeron> lol
19:49:49 <dgilmore> jforbes: right, releng has scripts to do that magic, i need to just grab them from inside rh, sanitize them and put them into the releng git repo
19:50:07 <dgilmore> jforbes: ive been waiting on a kickstart file and communications from you to do that
19:50:14 <jforbes> dgilmore: not quite (I have been working with those scripts)
19:51:01 <jforbes> dgilmore: well, as far as that goes, a kickstart file that creates an image is sitting in cloud-kickstarts respository
19:51:50 <jforbes> dgilmore: unfortunately that image will not work with EC2 without modification.  The scripts from the repo inside rh need serious work to meet these needs
19:52:25 <jforbes> dgilmore: but if releng is going to take on the part of making those scripts work, I am more than happy to hand it over
19:52:52 <dgilmore> jforbes: im happy to work on them. ive been waiting on you since f15 went ga
19:53:26 <dgilmore> jforbes: i cant do anything on the releng side without communications
19:53:31 <jforbes> dgilmore: kickstarts which created an image have been there since well before ga, every modification since then has been trying to do script stuff in %post and make the scripts work
19:54:07 <dgilmore> jforbes: i never knew the kickstart was in clouds-kickstarts repository? i assume thats on fedora-hosted?
19:54:28 <jforbes> dgilmore: kickstarts for the piece before that were given to you in Tempe.  I thought I was supposed to be making the post scripts work and it has consumed more hours than I care to count
19:54:32 <jforbes> dgilmore: yes
19:55:03 <dgilmore> jforbes: i think we are suffering from a major lack of communication
19:55:14 <dgilmore> jforbes: lets fix that and work together
19:55:20 <jforbes> please :)
19:55:42 <rbergeron> okay.
19:56:03 <rbergeron> jforbes: can you plz open a ticket with rel-eng and put the appropriate info in there about the ks file
19:56:15 <rbergeron> and um... SET UP A TIME TO TALK TO EACH OTHER ON THE TELEFONO or something :)
19:56:18 <rbergeron> so we can sort this crap out
19:56:18 <jforbes> rbergeron: sure can
19:56:22 <rbergeron> thakn you both :)
19:56:24 * rbergeron hugs everyone
19:56:32 * rbergeron looks at giant pack of cigarettes
19:56:35 <rbergeron> okay
19:56:40 <rbergeron> dgilmore: thanks
19:57:09 <dgilmore> rbergeron: :X your welcome
19:57:10 <rbergeron> #topic Features
19:57:19 <rbergeron> So feature submission deadline is next tuesday
19:57:28 <rbergeron> Feature Freeze is 2 weeks after that.
19:57:42 <rbergeron> that's an FYI, before I check in with everyone, assuming they haven't left yet. ;)
19:57:53 <rbergeron> #topic PrinceFS (aka CloudFS)
19:58:01 <jdarcy> Heh.
19:58:08 <rbergeron> kkeithley, jdarcy: what's the scoopola
19:58:12 <gholms> Wait, what?
19:58:36 <jdarcy> Short report here.  No movement on trademark.  Spent most of my time (30+ hours Wed+Thu) working on the at-rest crypto stuff.
19:58:40 * rbergeron nods
19:58:51 <rbergeron> gholms: it's the name i've given it in the interim
19:58:57 <gholms> Oh
19:59:03 <gholms> I'll ask you to explain it later.
19:59:09 <jdarcy> http://cloudfs.org/dist/design.md if anyone cares.
19:59:09 <kkeithley> I got mock (not hard), reviewed a few aeolus packages, got my packager bit.
19:59:35 <clalance> Yeah, kkeithley (along with rrix) has been a rock star reviewing aeolus packages.
19:59:38 <clalance> It is much appreciated.
19:59:56 <rbergeron> (gholms: "the feature formerly known as cloudFS" "the artist formerly known as prince")
20:00:03 <gholms> Got it.
20:00:05 <rbergeron> :D
20:00:11 <kkeithley> need to connect the dots to on being a packager. thanks ke4qqq for the sponsorship. working on issues from cloudfs pkg review. biggest one, not that big is a license mismatch
20:00:22 <kkeithley> see https://bugzilla.redhat.com/show_bug.cgi?id=675050#c16
20:00:56 <ke4qqq> kkeithley: if you need help, (well it will be next week at this point) I am happy to help connect the dot
20:00:59 <ke4qqq> dots
20:01:31 <kkeithley> ke4qqq: thanks
20:01:54 <jdarcy> I think we have a looming issue about having to carry the SSL transport as part of CloudFS instead of GlusterFS, because at this point I doubt Gluster will review it and get it into a package on time.
20:01:55 <ke4qqq> unless you want to talk after the meeting
20:02:22 <jdarcy> That will just be temporary, of course.  When it gets into GlusterFS we can drop it from CloudFS.
20:03:00 <kkeithley> ke4qqq: ? Next week will be fine. I just need to go through the steps at https://fedoraproject.org/wiki/PackageMaintainers/Join#Add_Package_to_Source_Code_Management_.28SCM.29_system_and_Set_Owner
20:03:09 <kkeithley> haven't even looked at it yet
20:03:30 <ke4qqq> ok, happy to help if i can, i think the instructions can be convoluted at times.
20:03:49 <kkeithley> I'll holler if I need to ;-)
20:04:24 * rbergeron shall move on? yes? :)
20:04:38 * jdarcy nods.
20:04:41 <rbergeron> thanks for helping out, ke4qqq, and jdarcy and kkeithley, thanks for your efforts on this feature. :)
20:04:51 <rbergeron> #topic Aeolus
20:05:01 <rbergeron> clalance: Hello there.
20:05:04 <clalance> rbergeron: In brief: lots of time spent packaging.
20:05:14 <clalance> We have maybe 75% of our packages in.
20:05:14 <rbergeron> clalance: no kidding. you guys have been rockin.
20:05:24 <clalance> kkeithley and rrix, thanks so much for the help so far.
20:05:27 <clalance> It has been really helpful.
20:05:37 <clalance> rbergeron: That being said, I would say that the feature is still at a bit of risk for F-16.
20:05:51 <clalance> There are still maybe 10 new packages we need, and the same amount we need updated.
20:05:59 <clalance> And the app itself (the conductor) is not yet ported to rails 3.
20:06:08 <clalance> There is ongoing work to get that done, but the earliest that will land is next week.
20:06:11 <rbergeron> Yikes.
20:06:12 <rbergeron> Okay.
20:06:39 <clalance> That's the short of it.
20:06:46 <kkeithley> clalance: yw
20:06:49 <clalance> kkeithley: :)
20:06:52 <rbergeron> Well, you've got until July 26. And there's not a ton of stuff really dependent on you, so i'd guess it's possible fesco could grant you a bit of a reprieve, maybe, though I'm not entirely sure how that would work. ;)
20:07:07 <clalance> rbergeron: OK, yeah.
20:07:13 <clalance> rbergeron: I'm on vacation next Friday.
20:07:15 <clalance> So I'll miss this meeting.
20:07:22 <clalance> But I'll make sure mmorsi is here to give status.
20:07:25 <rbergeron> clalance: Smart Man. ;)
20:07:27 <clalance> And see what progress we've made.
20:07:33 <rbergeron> okay.
20:07:51 <rbergeron> If you have any high-priority package reviews, etc. just ping me or rrix, and we'll see what we can do.
20:07:58 <clalance> rbergeron: Will do, thanks.
20:08:03 <rbergeron> (I'll see what I can get him to do, since I'm not exactly wearing my package review crown yet)
20:08:05 <ke4qqq> or send them to the list so that even more people can see
20:08:17 <rbergeron> or there's that, in the interest of transparency ;)
20:08:18 <clalance> ke4qqq: Right, also a good idea.
20:08:20 <rbergeron> thank you, ke4qqq.
20:08:21 <clalance> :)
20:08:41 <rbergeron> #topic Sheepdog
20:08:44 <rbergeron> #undo
20:08:44 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1a13ba2c>
20:08:50 <rbergeron> #topic Sheepdog and Cloudstack
20:08:58 <gholms> "And"?
20:08:59 <rbergeron> ke4qqq: you have two, so you can talk about them at once.
20:09:15 <ke4qqq> it's in, it's cool, and effectively done.
20:09:19 * rbergeron is just looking at the clock and thinking about how she needs food.
20:09:24 <ke4qqq> as far as whats in my control
20:09:33 <ke4qqq> ohhh the above is for sheepdog
20:09:44 <rbergeron> #info sheepdog is in, cool, and effectively done
20:09:45 <rbergeron> :)
20:09:53 <gholms> :D
20:10:04 <ke4qqq> cloudstack - one killer dep (ehcache) which I am having problems with, and also another java package
20:10:04 <jdarcy> (I should take it for a spin)
20:10:21 * ke4qqq wishes my java-packaging-fu was greater
20:10:27 <rbergeron> ke4qqq: have you gone to see the folks in java-sig for help?
20:10:39 <ke4qqq> rbergeron: I have, and theyve been helpful
20:10:54 <ke4qqq> just still not there yet
20:11:11 <rbergeron> okay
20:11:24 <gholms> ke4qqq: Then you can help me when $dayjob lets me start packaging more stuff! :)
20:11:31 <rbergeron> lol
20:11:38 <ke4qqq> lets you??? :)
20:11:42 * gholms has little java packaging experience
20:11:47 <ke4qqq> dayjob is MAKING ME.
20:11:51 <ke4qqq> lol
20:12:07 <gholms> Heh
20:12:20 <jdarcy> You guys should trade.
20:12:28 <rbergeron> lol
20:12:34 <rbergeron> pesky dayjobs.
20:12:39 <ke4qqq> jdarcy: already offered that to him a few months back
20:12:41 <rbergeron> Giving you money and stuff.
20:12:57 <ke4qqq> but seriously, if I cant get that done the feature is at risk
20:12:59 <rbergeron> ke4qqq: are you at risk for not making it? Do we need to make more noise?
20:13:00 <gholms> Well, the goal for me is to stop bundling deps in a tarball. :)
20:13:03 <rbergeron> okay.
20:13:16 <rbergeron> what's the other java package?
20:13:20 <rbergeron> also hellish, or some other issue?
20:13:45 <ke4qqq> log4j-extras - no it isn't hellish, it's 90% of the way done, just had some internal excitement of late that's kept me from focusing on it
20:13:59 <rbergeron> lol
20:15:06 <ke4qqq> eof from me
20:15:12 <rbergeron> okay.
20:15:19 <rbergeron> well, maybe we can revisit making noise about it on monday.
20:15:31 <rbergeron> #topic Any other Business
20:15:35 <rbergeron> did i forget anyone?
20:15:37 <rbergeron> i didn't mean to if i did
20:16:25 <gholms> [You suddenly realize it is unnaturally quiet]
20:16:33 <jgreguske> jforbes: do Fedora's EC2 images use the public pvgrubs?
20:16:39 <jforbes> jgreguske: they do
20:16:43 <jgreguske> k, thanks
20:18:33 <rbergeron> Okay.
20:18:37 <rbergeron> Well, THAT WAS EXCITING
20:18:44 <gholms> for shur
20:18:46 <rbergeron> yeah.
20:19:05 <clalance> rbergeron: Thanks for doing the herding, as usual.
20:19:07 <rbergeron> Yeah.
20:19:14 <rbergeron> tahnks. :)
20:19:32 <rbergeron> Um - I feel a bit like we don't know when we're going to do testing things, in light of the whole bg/koji convo we had.
20:19:34 * ke4qqq really wants to get ceph updated, but i have a hard time justifying it from a 'what I am supposed to be doing' standpoint. I keep thinking about requesting comaintainership -
20:19:42 <ke4qqq> bah - sorry, got discoed
20:19:45 <ke4qqq> didn't mean to interrupt
20:19:49 <rbergeron> no, go ahead.
20:19:56 <rbergeron> i'm just thinking/reading backlog
20:20:13 <ke4qqq> but anyway -if someone is interested in ceph - it would be a cool package to get updated for f16
20:20:19 <tflink> rbergeron: I'm not 100% sure either but I think that most of what athmane proposed will work for F15
20:20:23 <tflink> on the testing part
20:20:44 <gholms> #help co-maintainers wanted for ceph
20:20:58 <athmane> I can update it if it necessary
20:21:06 <tflink> I'm still trying to learn enough about EC2 and specifically S3 to figure out if we should be doing different storage tests
20:21:31 <rbergeron> tflink: there are some smart peeps hanging out in #fedora-cloud usually that know lots about that stuff.
20:21:34 <tflink> heck, I'm wondering if we should be testing EBS, too even though that is supposedly a block storage device
20:21:35 <rbergeron> and on the mailing list. ;)
20:22:22 <tflink> yeah, I've been waiting to see if we had a chance of getting an official F15 AMI before spending too much effort on it
20:22:28 <rbergeron> so maybe we should finish sorting out the test plans and make sure everyone is on the same page over the next week, while we see where dgilmore / jforbes get with koji stuff.
20:22:36 <tflink> or what the chances were, anyways
20:22:55 <rbergeron> tflink: well, we can't get the official ami without QA, but I assume you mean the rel-eng part of it. ;)
20:23:31 <tflink> yeah, I wasn't as worried about getting the QA part done if we had a rel-eng stamped AMI
20:23:45 <rbergeron> Anyway: I'll see what we can do about just using the one we have for now to call it official, and talk to dennis to see if that's going to be kosher, or not.
20:24:03 <rbergeron> And, um, that's all i have.
20:24:06 * rbergeron is beat.
20:24:18 <rbergeron> Well folks.
20:24:24 <rbergeron> It's Friday. YOu know what that means.
20:24:42 <jdarcy> Beer.
20:24:47 <rbergeron> Right.
20:24:48 <gholms> Beer?
20:24:52 <gholms> Dang, I'm too slow.
20:24:54 <rbergeron> Something like that.
20:24:59 * rbergeron waves
20:25:03 <rbergeron> See you next week, folks.
20:25:05 <rbergeron> #endmeeting