15:04:38 <andreasn__> #startmeeting Cockpit public meeting 2014-09-29
15:04:39 <zodbot> Meeting started Mon Sep 29 15:04:38 2014 UTC.  The chair is andreasn__. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:46 <andreasn__> apparently :)
15:04:53 <mvollmer> ok!
15:05:06 <andreasn__> #meetingname Cockpit
15:05:06 <zodbot> The meeting name has been set to 'cockpit'
15:05:13 <mvollmer> agenda:
15:05:16 <andreasn__> #chair puiterwijk andreasn mvollmer stefw sgallagh
15:05:16 <zodbot> Current chairs: andreasn andreasn__ mvollmer puiterwijk sgallagh stefw
15:05:22 <andreasn__> #topic Welcome
15:05:29 <mvollmer> * Fedora 21, "wheel"
15:05:34 <andreasn__> .hellomynameis andreasn__
15:05:35 <zodbot> andreasn__: Sorry, but you don't exist
15:05:39 <sgallagh> Ah, right. IRC meeting. I can do that :)
15:05:45 <sgallagh> .hellomynameis sgallagh
15:05:46 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:05:53 <sgallagh> andreasn__: Has to be your FAS name
15:05:55 <mvollmer> .hellomynameis mvo
15:05:58 <zodbot> mvollmer: mvo 'Marius Vollmer' <marius.vollmer@gmail.com>
15:06:03 <andreasn__> .hellomynameis andreasn
15:06:04 <zodbot> andreasn__: andreasn 'Andreas Nilsson' <anilsson@redhat.com>
15:06:45 <andreasn__> hum, how does this work
15:06:59 <andreasn__> so, yes, agenda
15:06:59 <sgallagh> andreasn__: What are you trying to do?
15:07:17 <andreasn__> #topic Agenda
15:07:31 <mvollmer> ohh, very meta. :-)
15:07:48 <mvollmer> stefw, are you here?
15:07:50 <andreasn__> so yes. Fedora21, Wheel, Navigation, Storage?
15:08:01 <mvollmer> sounds good
15:08:06 <andreasn__> cool
15:08:33 <andreasn__> #info agenda is Fedora21, Wheel, Navigation, Storage
15:08:47 <andreasn__> #topic Fedora 21
15:08:56 <mvollmer> right
15:08:58 <andreasn__> so, how are we doing?
15:09:09 <mvollmer> we have two weeks, I'd say.
15:09:10 <andreasn__> running Fedora 21 on the laptop too now
15:09:18 <mvollmer> after that, only blocker bugs.
15:09:33 <andreasn__> two weeks of wild development?
15:09:43 <mvollmer> almost done: making cockpit work nicely as wheel.
15:09:49 <andreasn__> NICE
15:09:59 <mvollmer> andreasn__, yeah, if you want to put it like that. :-)
15:10:04 <andreasn__> hehe
15:10:20 <andreasn__> so what do we want to land in those two weeks?
15:10:21 <mvollmer> wont be done: making cockpit work nicely as non-admin.
15:10:33 <mvollmer> that is the topic of this meeting. :-)
15:11:14 <andreasn__> right. Lets take that in time then :)
15:11:20 <mvollmer> so, we should wrap up the "wheel" pull requests.
15:11:27 <andreasn__> #topic Wheel
15:11:41 <andreasn__> how many are those? how much work is left?
15:12:25 <mvollmer> final review and merge by stefw, four pull requests.
15:12:26 <andreasn__> nice
15:12:43 <mvollmer> andreasn__, something for you, too:
15:12:57 <mvollmer> what should happen when a non-admin tries to log in?
15:13:10 <mvollmer> https://github.com/cockpit-project/cockpit/pull/1256
15:13:40 <andreasn__> it should fail, right?
15:13:51 <mvollmer> yes, but how?
15:14:03 <andreasn__> I agree with stefw's suggestion
15:14:06 <mvollmer> in a nasty way? or with an apology?
15:14:11 <mvollmer> ok, cool.
15:14:32 <andreasn__> hm, good question
15:14:33 <mvollmer> right, let's continue with the two-week roadmap.
15:14:40 <andreasn__> I'll comment on the bug
15:14:45 <mvollmer> yep.
15:14:57 <mvollmer> #action andreasn__ comment on #1256
15:14:57 <andreasn__> it's just a matter of polishing the sentence a bit
15:15:22 <mvollmer> so, after "wheel", I am fixing bugs.
15:15:33 <mvollmer> mostly storage right now
15:15:46 <andreasn__> lets jump to that
15:16:00 <mvollmer> like the mount point things, #1269, #1270
15:16:08 <andreasn__> #topic storage
15:16:20 <andreasn__> #info issues #1269, #1270
15:16:42 <mvollmer> those are pull requests already.
15:17:07 <mvollmer> anyway, biggest storage feature is the re-layout of the storage page to include mount points.
15:17:43 <mvollmer> the prototype is super nice already
15:17:51 <andreasn__> thanks!
15:18:04 <mvollmer> and I think it is not much work to connect all the wires in the background.
15:18:14 <andreasn__> great to hear!
15:18:15 <mvollmer> two days, maybe less.
15:18:25 <mvollmer> so let's go for it.
15:18:47 <andreasn__> #info storage relayout that includes mount points needs to be wired up correctly
15:19:01 <mvollmer> also, icons for volume group and raid
15:19:39 <andreasn__> do you think so? maybe
15:19:47 <mvollmer> well, drives have them.
15:19:57 <andreasn__> I wanted to use the disk as a way to highlight when you have a new disk
15:20:04 <andreasn__> (in the future)
15:20:21 <mvollmer> ok.
15:20:27 <mvollmer> details. :-)
15:20:31 <andreasn__> yeah :)
15:20:51 <andreasn__> I also have no idea how to draw a volume group :)
15:20:56 <mvollmer> anyway, we try to get it done for F21
15:21:01 <andreasn__> sounds good
15:21:30 <andreasn__> #info try to get the storage mounts ready for F21. Should be possible to finish fairly quickly
15:21:36 <andreasn__> next topic?
15:21:41 <mvollmer> sure
15:21:53 <andreasn__> #topic navigation
15:22:03 <mvollmer> after F21. :-)
15:22:09 <andreasn__> yes, I agree
15:22:21 <mvollmer> although, again, it looks like a lot less work than I initially thought.
15:22:36 <andreasn__> just pushed https://github.com/andreasn/cockpit/tree/navigation-v2
15:22:43 <mvollmer> but letÄs not commit to it now.
15:22:46 <andreasn__> the first branch just broke apart too much
15:23:11 <andreasn__> skipped the sidebar with the machines for now in that branch
15:23:20 <mvollmer> ok.
15:23:28 <andreasn__> #info branch for navigation relayout at https://github.com/andreasn/cockpit/tree/navigation-v2
15:23:40 <andreasn__> #info best to wait until after Fedora 21
15:24:00 <mvollmer> i have the feeling that we are abandoning tablet layouts, right?
15:24:22 <mvollmer> it's probabyl the right thing.
15:24:40 <andreasn__> not specifically, I'll try to make it work as good as possible on a tablet as well
15:24:48 <andreasn__> but the main target is a regular laptop screen
15:24:49 <mvollmer> ok.
15:26:01 <mvollmer> ok, shall I try to summarize what stefw has been doing?
15:26:44 <andreasn__> so topic SSO?
15:26:51 <mvollmer> yeah, and modules.
15:26:54 <andreasn__> #topic SSO
15:27:02 <andreasn__> #info Single Sign On
15:27:32 <mvollmer> so, SSO works: you can get a key with kinit and it will log you into cockpit.
15:27:52 <mvollmer> setup is a bit hairy, and stef is filing tickets and working out the kinks
15:28:41 <mvollmer> some kinks seem to be biggish, like that there is no way for a user account that is defined by a domain to be in the "wheel" group.
15:29:11 <andreasn__> oh
15:29:13 <mvollmer> also, IPA doesn't export policy kit rules.
15:29:28 <mvollmer> so, a lot to improve, as far as I understand.
15:29:35 <sgallagh> I'm working on that with the glibc folks right now
15:29:50 <sgallagh> We're proposing the ability to allow different nss modules to merge their groups together
15:29:52 <mvollmer> but, this isn't cockpit specific, the state of the art is just not nice enough for cockpit-
15:29:58 <sgallagh> So that SSSD can supplement a local group with remote users
15:30:10 <mvollmer> cool.
15:30:16 <mvollmer> (I was guessing. :-)
15:30:38 <mvollmer> or, remote groups could be flagged as wheel equivalent.
15:30:59 <mvollmer> anyway...
15:31:05 <sgallagh> Well, there's still discussion to be had over how we set up SSSD to select a remote group to supplement the local one.
15:31:16 <mvollmer> right
15:31:29 <sgallagh> The easy answer is "name them the same", which will probably be v1.0, but in the long-term, we want that to be configurable by machine/group of machines.
15:32:22 <sgallagh> The other idea I'm bouncing around in my head is to add a PAM backend to policykit that can use SSSD's HBAC rules to make decisions.
15:32:35 <mvollmer> i see.
15:32:41 <andreasn__> #info SSO is in the works. Still a lot of plumbing to do
15:33:14 <mvollmer> one piece that is missing from cockpit is delegation
15:33:42 <mvollmer> that will come with #1226.
15:33:58 <mvollmer> without it, you can SSO into the first machine, but not hop from there to the next.
15:34:03 <andreasn__> #info missing delegation, will be fixed in #1226
15:34:36 <mvollmer> i think stef wants to have that in F21.
15:34:52 <mvollmer> the other thing is modules.
15:35:15 <mvollmer> everyone ready for that?
15:35:16 <andreasn__> #info SSO will ideally go into F21
15:35:19 <andreasn__> sure
15:35:23 <andreasn__> #topic Modules
15:35:41 <mvollmer> so, right now we have one module, the "shell", which is everything.
15:36:17 <mvollmer> stef is working on putting modules into iframes, so that we can load different pieces from different sources and mash them up on the page.
15:36:50 <mvollmer> we have the rescue terminal and system-information as experimental modules.
15:37:10 <mvollmer> there will be client-side, inter-iframe communication.
15:37:11 <andreasn__> how tied is that to the navigation relayout?
15:37:24 <mvollmer> pretty closely.
15:37:33 <andreasn__> so F22 material as well?
15:37:41 <andreasn__> or, rather, post F21
15:37:47 <mvollmer> yes
15:38:22 <andreasn__> #info expand to other modules apart from 'shell'.
15:38:33 <mvollmer> i think there are no strong dependencies, actually, but it seems natural to take them both into account when looking at each topic.
15:38:35 <andreasn__> #info feature fairly tied to the navigation relayout
15:38:44 <andreasn__> #info post Fedora 21
15:39:22 <mvollmer> i mean, if we want to, we can do them in any order, I think, but it seems best to let them inform each other.
15:39:37 <andreasn__> yeah
15:40:12 <andreasn__> will be great to have
15:40:20 <andreasn__> so, anything else?
15:40:23 <andreasn__> open floor I guess?
15:40:28 <andreasn__> #topic Open Floor
15:41:41 <mvollmer> people are missing a visible roadmap...
15:41:55 <andreasn__> yes, I would like to have that too
15:42:46 <mvollmer> should we make it part of the weekly meeting to update the roadmap live?
15:43:02 <andreasn__> we could. Shall we make it just a wiki page?
15:43:14 <mvollmer> yes, I'd say so.
15:43:17 <andreasn__> or well, not part of the meeting, but maybe as followup actions
15:43:44 <mvollmer> we could use github milestones, maybe, but a simple document in one place seems much easier to consume.
15:44:17 <andreasn__> I created this page https://github.com/cockpit-project/cockpit/wiki/Roadmap
15:44:38 <andreasn__> #info created page Roadmap in the wiki https://github.com/cockpit-project/cockpit/wiki/Roadmap
15:44:55 <andreasn__> there is also the Trello
15:45:01 <mvollmer> i would like to have look like something that trails off into the distance.
15:45:06 <mvollmer> if you know what I mean.
15:45:35 <mvollmer> some 'stones' are very close and detailed, some are further away and we don't say much about them, and you can only see the big ones, etc.
15:46:23 <andreasn__> so maybe divide it up into immediate, long-term, blue sky?
15:46:28 <mvollmer> so maybe we can have fixed sections, "Next four week", "next four months", "next two years".
15:46:47 <andreasn__> much better names :)
15:47:16 <mvollmer> just to make it clear how far away some things are.
15:47:52 <mvollmer> #action mvollmer fill out the current roadmap
15:47:58 <andreasn__> sounds good
15:48:29 <andreasn__> cool. Anything else?
15:51:39 <andreasn__> doesn't sound like it
15:51:46 <mvollmer> nope. :-)
15:51:47 <andreasn__> ok, I'll end the meeting then
15:51:49 <andreasn__> #endmeeting