#cockpit: Cockpit public meeting 2014-10-27

Meeting started by stefw at 16:00:22 UTC (full logs).

Meeting summary

  1. Welcome ... any agenda points? (stefw, 16:01:30)
  2. Current Modularization Status (stefw, 16:04:31)
    1. dbus-json3 is ready for porting network page (andreasn, 16:07:12)
    2. ACTION: stefw will port Network page to new dbus code (stefw, 16:07:39)
    3. mvollner will make a pull request with navigation to /playground (andreasn, 16:08:35)
    4. ACTION: mvollmer will test out sub task navigation in /playground (stefw, 16:08:36)
    5. Websocket forwarding code is done (andreasn, 16:09:04)
    6. asyncronous module definition code landed (stefw, 16:12:57)
    7. backwards compatibility to the f21 version is not a goal right now (stefw, 16:15:07)
    8. ACTION: mvo fuzz testing of URL input (mvollmer, 16:15:38)

  3. Navigation / Host Switcher (stefw, 16:16:05)
    1. most of the new navigation is in place, but needs polishing and addressing of the multiple hosts selection (andreasn, 16:19:10)
    2. andreasn have mockups on paper, will publish tomorrow (andreasn, 16:19:24)

  4. Update on testing Cockpit (stefw, 16:19:36)
    1. https://github.com/cockpit-project/cockpit/commit/4d97c1320e6c4c16e0aef84edbba734d3dbb9946 (mvollmer, 16:23:34)
    2. ACTION: jscotka will test on wed, to see if encoding issues are fixed in latest cockpit git master (stefw, 16:25:55)
    3. jscotka working on generalizing integration test code (stefw, 16:28:01)

  5. URL scheme update (stefw, 16:31:36)
    1. legacy pages will retain old style urls, until they are ported to components (stefw, 16:34:59)

  6. Cross Frame Navigation (stefw, 16:42:14)
  7. Next release, and COPR repository (stefw, 16:42:54)
    1. ACTION: stefw will ping sgallagh again about the COPR and see how we can make that work. (stefw, 16:47:15)
    2. ACTION: stefw will do a new release (stefw, 16:47:22)

  8. Roadmap (stefw, 16:47:52)
    1. ACTION: sgallagh will create the COPR repo and grant access so that builds can be pushed to it (stefw, 16:55:00)
    2. https://github.com/cockpit-project/cockpit/wiki/Maintenance (stefw, 16:57:43)

  9. Open Floor (stefw, 17:02:22)


Meeting ended at 17:03:43 UTC (full logs).

Action items

  1. stefw will port Network page to new dbus code
  2. mvollmer will test out sub task navigation in /playground
  3. mvo fuzz testing of URL input
  4. jscotka will test on wed, to see if encoding issues are fixed in latest cockpit git master
  5. stefw will ping sgallagh again about the COPR and see how we can make that work.
  6. stefw will do a new release
  7. sgallagh will create the COPR repo and grant access so that builds can be pushed to it


Action items, by person

  1. jscotka
    1. jscotka will test on wed, to see if encoding issues are fixed in latest cockpit git master
  2. mvollmer
    1. mvollmer will test out sub task navigation in /playground
  3. sgallagh
    1. stefw will ping sgallagh again about the COPR and see how we can make that work.
    2. sgallagh will create the COPR repo and grant access so that builds can be pushed to it
  4. stefw
    1. stefw will port Network page to new dbus code
    2. stefw will ping sgallagh again about the COPR and see how we can make that work.
    3. stefw will do a new release


People present (lines said)

  1. stefw (140)
  2. mvollmer (71)
  3. andreasn (21)
  4. jscotka (19)
  5. sgallagh (14)
  6. zodbot (7)
  7. github (1)
  8. puiterwijk (0)


Generated by MeetBot 0.1.4.