14:08:19 <mvollmer> #startmeeting
14:08:19 <zodbot> Meeting started Mon Feb  2 14:08:19 2015 UTC.  The chair is mvollmer. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:08:29 <mvollmer> #meetingname Cockpit
14:08:29 <zodbot> The meeting name has been set to 'cockpit'
14:08:40 <mvollmer> #topic Agenda
14:09:06 <mvollmer> * Short hubbot update
14:09:12 <mvollmer> * Metrics archives
14:09:34 <mvollmer> jscotka, anything to report?
14:10:28 <jscotka> mvollmer, nothing new, more info will be when devconf to have some suprise aviable :-)
14:10:37 <mvollmer> ok! :-)
14:10:44 <mvollmer> pvolpe, are you here?
14:10:52 <pvolpe> yes
14:11:05 <mvollmer> ok!
14:11:20 <mvollmer> Andreas and Stef are travelling, I guess, or otherwise off-line
14:11:35 <mvollmer> * Docker storage
14:11:54 <pvolpe> * Permission UI
14:12:01 <mvollmer> yep
14:12:08 <mvollmer> sub-mod, awake?
14:12:28 <sub-mod> yep
14:12:44 <mvollmer> ok, you want to add something to the agenda?
14:12:59 <sub-mod> no nothing new from me
14:13:05 <mvollmer> ok
14:13:13 <mvollmer> let's start then
14:13:26 <mvollmer> #topic hubbot update
14:13:32 <mvollmer> that's me.
14:13:50 <mvollmer> so, I can't stop playing with hubbot, and now it should be in good enough shape to rely on it.
14:14:21 <mvollmer> of course, the tests themselves are still unreliable, but the bot should at least run them properly
14:15:01 <mvollmer> it can also make images now, which is mostly nice for me
14:15:25 <mvollmer> I have documented it a bit in thr Workflow wiki page.
14:15:39 <mvollmer> https://github.com/cockpit-project/cockpit/wiki/Workflow
14:16:09 <mvollmer> Check the section about "trigger-hubbot"
14:16:23 <mvollmer> Anybody should be able to trigger a retry for a failed pull request.
14:16:43 <mvollmer> docs are here: https://github.com/mvollmer/hubbot/blob/master/README
14:16:53 <mvollmer> ok!
14:16:56 <mvollmer> next topic?
14:17:08 <pvolpe> yep
14:17:33 <mvollmer> #topic Metrics archives
14:17:41 <mvollmer> has been merged
14:17:59 <pvolpe> nice
14:18:04 <mvollmer> works ok, but pmlogger is weird.
14:18:14 <mvollmer> we have a tracker bug for this
14:18:33 <mvollmer> https://bugzilla.redhat.com/show_bug.cgi?id=1185740
14:19:00 <mvollmer> biggest regression re pre-pcp is that the graphs reset themselves to be empty very often
14:19:14 <mvollmer> if you don't have any archives, that is.
14:19:25 <mvollmer> I'll try to fix that before stefs demo.
14:19:32 <mvollmer> looks good so far
14:19:49 <mvollmer> but there are artifacts still
14:20:03 <mvollmer> sometimes there is overlap etc
14:20:12 <mvollmer> I'll make a pull request soonish
14:20:20 <mvollmer> (eot)
14:21:08 <mvollmer> next?
14:21:21 <pvolpe> docker storage
14:21:23 <mvollmer> #topic Docker storage
14:21:37 <pvolpe> i opened i PR with them
14:21:42 <pvolpe> https://github.com/docker/docker/pull/10474
14:22:09 <pvolpe> for now we just have the warning
14:22:38 <pvolpe> andreas isn't here  but i was wondering if we should expose the metadata space as well
14:22:48 <pvolpe> but the design might need to change if we do that
14:23:20 <pvolpe> also that's only really applicable for the devicemapper backend
14:23:30 <mvollmer> metadata is a bit like "number of inodes" with traditional storage, right?
14:23:44 <mvollmer> you might run out of it, but it is not normally displayed.
14:23:58 <mvollmer> what about only showing it when it is close to running out?
14:24:16 <pvolpe> i'd be ok with that
14:24:50 <mvollmer> so would you say the storage display is useful as it is?
14:25:06 <mvollmer> or is it rather meaningless?
14:25:21 <pvolpe> if you underlying storage has more than 100gbs
14:25:33 <pvolpe> or if you did something special with your docker setup
14:25:35 <pvolpe> then yes
14:25:41 <mvollmer> right
14:25:45 <pvolpe> if everything is default
14:25:53 <pvolpe> and you have less, no
14:26:02 <mvollmer> hmm
14:26:10 <mvollmer> any followup plans?
14:26:10 <pvolpe> but that's why the warning
14:26:27 <mvollmer> can we figure out whether the warning applies?
14:26:28 <pvolpe> get a response from the docker guys on my PR
14:26:53 <pvolpe> we can, but i'd need to modify the bridge to allow me to run file stats and statfs
14:27:22 <pvolpe> at that point we might as well show the correct value
14:27:26 <mvollmer> there might be something in pcp, actually.
14:27:31 <mvollmer> we also have the fsys monitor.
14:27:35 <pvolpe> stef said he'd prefer not doing that for now
14:27:43 <mvollmer> ok
14:28:26 <pvolpe> i didn't know pcp could help though
14:28:34 <pvolpe> i can look into that a little
14:28:34 <mvollmer> yeah, maybe the warning will tickle people into improving the info reported by docker
14:28:51 <mvollmer> pvolpe, try "pminfo -L"
14:30:10 <mvollmer> pminfo -L | grep filesys
14:30:48 <mvollmer> ok, good stuff.
14:31:00 <mvollmer> next?
14:31:26 <pvolpe> sure
14:32:15 <mvollmer> #topic Permissions UI
14:32:30 <pvolpe> just wanted to get a review on that one
14:32:55 <mvollmer> code or UI?
14:33:06 <pvolpe> both
14:33:28 <mvollmer> it's marked as "WIP", is it ready?
14:33:40 * mvollmer should read...
14:33:44 <mvollmer> ok, I see
14:34:09 <mvollmer> #action mvollmer review #1744
14:36:24 <mvollmer> ok, done! :-)
14:36:36 <pvolpe> that was fast
14:36:39 <mvollmer> #topic Open Floor
14:36:53 <mvollmer> Fedora 22...
14:37:46 <mvollmer> I'll make a milestone and issues etc
14:38:21 <mvollmer> and then we can make some decisions about what to include
14:38:31 <mvollmer> e.g., events on the dashboard?
14:38:52 <mvollmer> k8?
14:38:58 <mvollmer> stuff like that.
14:39:10 <mvollmer> also, some serious manual testing needs to be done
14:39:13 <pvolpe> what's the deadline on that?
14:39:35 <mvollmer> yeah, I can never remember
14:39:40 <mvollmer> something march
14:39:43 <pvolpe> ok
14:39:59 <mvollmer> https://fedoraproject.org/wiki/Releases/22/Schedule
14:40:48 <mvollmer> we'll discuss F22 in Brno and at the hackfest, I guess.
14:41:25 <mvollmer> i think we have managed to keep Cockpit reasonably working during all this rearchitecting.
14:41:48 <mvollmer> so I am quite optimistic that we can make a nice release with what we have on master
14:42:18 <mvollmer> ok, are we done?
14:43:10 <pvolpe> think so
14:43:25 <pvolpe> my last thing is if there is anything you want me to pick up
14:43:47 <mvollmer> nothing comes to mind immediately...
14:43:57 <pvolpe> if not i'll keep grabbing stuff from trello/issues
14:44:01 <mvollmer> yep
14:44:06 <pvolpe> ok
14:44:08 * mvollmer should check trello
14:44:18 <mvollmer> ok
14:44:24 <mvollmer> #endmeeting