17:29:36 <jflory7> #startmeeting Fedora CommOps (2017-01-24)
17:29:36 <zodbot> Meeting started Tue Jan 24 17:29:36 2017 UTC.  The chair is jflory7. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:29:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:29:36 <zodbot> The meeting name has been set to 'fedora_commops_(2017-01-24)'
17:29:38 * cprofitt waves
17:29:42 <jflory7> #meetingname commops
17:29:42 <zodbot> The meeting name has been set to 'commops'
17:29:47 <jflory7> #nick commops
17:29:52 <jflory7> #topic Agenda
17:29:57 <jflory7> #link https://fedoraproject.org/wiki/Meeting:CommOps_2017-01-24
17:30:01 <jflory7> #info (1) Roll Call / Q&A
17:30:06 <jflory7> #info (2) Announcements
17:30:29 <jflory7> #info (3) Action items from last meeting
17:30:32 <jflory7> #info (4) Tickets
17:30:36 <jflory7> #info (5) Community Blog - skipping today, but will be back next week!
17:30:42 <jflory7> #info (6) Open Floor
17:30:47 <jflory7> #topic Roll Call / Q&A
17:30:53 <jflory7> #info Name; Timezone; Sub-projects/Interest Areas
17:30:58 <jflory7> #action commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
17:31:02 <jflory7> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
17:31:04 * mailga is lurking
17:31:06 <bt0> .hello bt0dotninja
17:31:07 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
17:31:07 * jflory7 waves back to cprofitt
17:31:08 <Rhea> .hello rhea
17:31:09 <jflory7> #chair cprofitt
17:31:09 <zodbot> Current chairs: cprofitt jflory7
17:31:10 <zodbot> Rhea: rhea 'Radka Janek' <radka.janek@redhat.com>
17:31:11 <Rhea> #info Radka Janek; UTC+1; CommOps, Diversity, DotNet,...
17:31:20 <cprofitt> .hello cprofitt
17:31:21 <zodbot> cprofitt: cprofitt 'Charles Profitt' <fedora@cprofitt.com>
17:31:34 <jflory7> #info Justin W. Flory; UTC+1; CommOps, Magazine, Marketing, Ambassadors, Diversity, Join SIG, sysadmin-badges, and more
17:31:44 <jflory7> #chair mailga bt0 Rhea
17:31:44 <zodbot> Current chairs: Rhea bt0 cprofitt jflory7 mailga
17:31:45 <bt0> #info Alberto Rodriguez; UTC-6; CommOps, metrics and more
17:31:46 * Rhea waves right in front of jflory7's face an screams at him
17:31:47 <Rhea> HI!!!
17:31:59 <jflory7> Rhea: Same timezone now!
17:31:59 <Rhea> :D
17:32:03 <bt0> hello everyone o/
17:32:08 <jflory7> Same city in a couple of days too.
17:32:10 <Rhea> welcome to europe
17:32:43 <jflory7> Hope everyone's evening is going well! I'm going to grab my tea really quick while we wait a couple more minutes for folks to roll in.
17:35:06 <jflory7> So, if you didn't catch it on the list, today's ticket queue is intentionally left empty for us to go ahead and re-situate and see what we should prioritize and focus on. I think triaging tickets will be helpful to have us set some firm goals for the coming month or two since we lost some momentum from the holidays.
17:35:49 <Rhea> o.o
17:35:53 <jflory7> My schedule should be a little more consistent in coming weeks too, which should help a fair bit. I'm wondering if a new meeting time might be helpful for some folks, but we can revisit that perhaps towards the end.
17:36:13 * jflory7 wonders if dhanesh95 is at the keyboard too
17:36:28 <Rhea> I think that we should focus now a little towards #join stuff
17:37:01 <dhanesh95> #info Dhanesh B. Sabane, UTC +5:30, CommOps, Marketing, ML, Python, Packaging and more to come
17:37:12 <Rhea> After the commblog / magazine post is out - ticket #98
17:37:15 <dhanesh95> Aloha CommOps!
17:37:25 <dhanesh95> Thanks jflory7 for the ping :P
17:37:32 <dhanesh95> I was busy designing a web page
17:37:34 <bt0> Aloha
17:37:39 <bt0> :D
17:37:53 <jflory7> Rhea: I'm thinking that could be something new for us to look at too. I definitely want to cycle back on some of our older tickets and either (1) consolidate, (2) close, or (3) reevaluate what needs to be done to close the ticket.
17:38:04 <jflory7> But some new things to work on will be refreshing as well.
17:38:07 <jflory7> #chair dhanesh95
17:38:07 <zodbot> Current chairs: Rhea bt0 cprofitt dhanesh95 jflory7 mailga
17:38:15 <jflory7> Okay, let's go ahead and move into announcements.
17:38:20 <jflory7> #topic Announcements
17:38:25 <jflory7> #info === "Elections Retrospective, January 2017" ===
17:38:29 <cprofitt> new and exicting things are always good.
17:38:29 <jflory7> #link https://communityblog.fedoraproject.org/elections-retrospective-january-2017/
17:38:35 <jflory7> #info jkurik combined a brief retrospective of the past election cycle. This was one of the top participated elections of Fedora history! Awesome job for everyone involved with the election process. The feedback in this post will be helpful for a later analysis of the election cycle and seeing what we can do better for next time.
17:38:39 <jflory7> cprofitt: Agreed.
17:38:45 <jflory7> #info === Upcoming travel arrangements ===
17:38:50 <jflory7> #info DevConf (27-29 Jan.) and FOSDEM (3-5 Feb.) are coming up soon. As a result, many people may be away or busy for the next couple of weeks, so be aware activity may slow down a little in some parts of the project until after the two conferences.
17:39:19 <jflory7> #help Are you going to be traveling at all for the next couple of weeks? Make sure you add your travel schedule to the Fedora vacation calendar so people know whether or not you will be around.
17:39:27 <jflory7> #link https://apps.fedoraproject.org/calendar/vacation/
17:39:34 <jflory7> <eof> from me.
17:39:39 <jflory7> Anyone else have anything they would like to add?
17:39:45 <Rhea> Nope
17:39:49 <bt0> no
17:39:53 <Rhea> If you want to look at something to close then the dotnet ticket - we've got a little bit of a problem, or maybe a question to be answered, that i could use help with...
17:40:03 * jflory7 makes a note
17:40:15 <jflory7> Announcements, going once...
17:40:23 <cprofitt> thanks for linking to the vacation calendar... did not know about that.
17:40:25 <jflory7> Going twice...
17:40:29 <dhanesh95> Nothing here
17:40:41 <jflory7> cprofitt: Yep, of course! It's super helpful to add to but also to check out every once in a while too.
17:40:45 <jflory7> #topic Action items from last meeting
17:40:50 <jflory7> #link https://meetbot.fedoraproject.org/teams/commops/commops.2017-01-17-17.28.html
17:40:55 <jflory7> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action it if needed. If no status, we'll try to get a quick update and move forward.
17:41:02 <jflory7> #info === Rhea Post on Reddit with the Election results ===
17:41:10 <jflory7> And I'm adding a sub-action to this:
17:41:33 <Rhea> You were faster with the link to commblog post
17:41:44 <jflory7> #action jflory7 Work with Rhea on adding her as a subreddit mod (due:2017-01-25)
17:41:47 <Rhea> So I didn't really post anything else then..
17:42:00 <jflory7> Rhea: Gotcha. Yeah, I think that post from jkurik did make it into the subreddit too.
17:42:06 <Rhea> yup
17:42:15 <Rhea> thats what im thinking of, probably
17:42:21 <jflory7> #info [COMPLETE] CommBlog post summarized the elections and was posted into the subreddit
17:42:29 <jflory7> #info === bt0 to try to get a list of Fedora contributors & talks out of FOSDEM calendar ===
17:42:42 <jflory7> In my attempts at getting caught up today, I did see what looks like a lot of activity there!
17:43:04 <Rhea> This is related to #98 https://pagure.io/fedora-commops/issue/98
17:43:10 <Rhea> paging bexelbie as well
17:43:11 <jflory7> bt0: Is this still in progress or awaiting confirmation from bexelbie?
17:43:37 <bt0> ohh, I want a little more of help
17:44:03 <jflory7> bt0: Sure! Maybe this is a timely ticket, we will definitely find time to visit this one today then.
17:44:09 <jflory7> * Maybe since this is a
17:44:23 <jflory7> #info [IN PROGRESS] Will revisit during ticket discussion
17:44:27 <bt0> i get a lot of info, I only validate 20 talks from FAS/talks
17:44:41 <jflory7> #topic Tickets
17:44:45 <jflory7> #link https://pagure.io/fedora-commops/issues?tags=meeting
17:44:57 <jflory7> So before diving in, a note for the minutes:
17:45:46 <jflory7> #info Today's ticket queue was intentionally left empty to give us a chance to look through some older tickets and see if we can either (1) consolidate, (2) close, or (3) reevaluate what is needed to complete them. We may also file some new tickets based on recent discussions elsewhere.
17:46:09 <jflory7> #info ***** EXISTING TICKETS *****
17:46:29 <jflory7> bt0: Let's start with the FOSDEM one
17:46:39 <Rhea> mhm
17:46:44 <jflory7> #info === Ticket #98 ===
17:46:47 <jflory7> #info "Round Up of Fedora Contributor Talks @ FOSDEM"
17:46:48 <Rhea> #link https://pagure.io/fedora-commops/issue/98
17:46:53 <Rhea> :]
17:46:57 <jflory7> Rhea++
17:46:59 <Rhea> :D
17:47:06 * jflory7 takes a quick read of the ticket
17:49:19 <jflory7> Awesome! So, here's what I'm seeing and thinking so far. bt0 has combined a list of attending Fedorans (still needs feedback / help with parts). Amita's idea of having a summary post next week on CommBlog / Magazine is a good way to promote Fedora's presence there. Should we choose that route, all descriptions of talks on the FOSDEM website are licensed under CC-BY-SA 2.0 or 3.0, so we can use those without having to ask them for a description
17:49:19 <jflory7> of their talk.
17:49:30 <jflory7> bt0: What were you still wanting some feedback or help on?
17:50:20 <bt0> well, i use FAS API for compare all the people in the talks with all fedorians
17:50:56 <bt0> but i get a huge list of similar results
17:52:22 <jflory7> Hmmm... I'm not too familiar with the FAS API.
17:52:27 <bt0> I can convert quickly the csv to html, so only need cross reference names and fas accounts from my list
17:53:06 <bt0> me neither :D
17:53:16 <jflory7> bt0: How did you generate the file? Manually or was there a way to do on the FOSDEM site?
17:53:22 <jflory7> (just curious for that one)
17:53:49 <dhanesh95> bt0++
17:53:49 <zodbot> dhanesh95: Karma for bt0dotninja changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:53:49 <bt0> give me one day more to validate all my list
17:53:59 <jflory7> s/was there a way to do/was there an API
17:54:13 <jflory7> bt0: Okay, sure, no problem.
17:54:15 <bt0> get the XML from the FOSDEM site and
17:54:24 <jflory7> So this ticket is probably one that we can close pretty easily and also soon…
17:54:27 <mailga> Are we sure they want to match their FAS nicks with their names? If I remember correctly FAS is private so, maybe, we should ask them if they want. Not a big problem, I know.
17:54:29 <bt0> the fedorians from the FAS
17:54:35 <jflory7> Here's what I suggest:
17:54:53 <bt0> I serach for similar
17:54:58 <bt0> no equal
17:55:13 <bt0> *search
17:55:55 <jflory7> bt0 validates the accuracy of the list by tomorrow. We put out a call on the... development? mailing list asking for any attending and speaking Fedorans to please verify our list and make sure they're on it. Afterwards, write an article introducing FOSDEM + all Fedoran speakers plus the short summary of their talk from the FOSDEM site?
17:56:00 <jflory7> So three steps to completion?
17:56:39 <jflory7> Does this seem doable? I can help with the article, but it would be awesome if someone wanted to help with the call to the development list. I actually wonder if the devel-announce list would be more appropriate, but we can ask in #fedora-admin later.
17:56:48 <Rhea> mhm
17:57:35 <bt0> ok :D, i can do that
17:57:39 * jflory7 nods
17:58:00 <jflory7> #action bt0 Verify the accuracy of the current list of Fedora speakers attending FOSDEM (due: 2017-01-25)
17:58:13 <jflory7> Anyone want to help with the devel list call?
17:58:42 * dhanesh95 can post a message
17:59:06 <jflory7> dhanesh95: Okay, awesome. If bt0 verifies the list tomorrow, do you want to try to get this done on Thursday?
17:59:18 <dhanesh95> jflory7: done
17:59:50 <jflory7> #action dhanesh95 Put a call out on the devel mailing list asking for any Fedorans speaking at FOSDEM to please check if their name is added to our list so that they are covered in a later post on the Fedora Magazine
17:59:54 <jflory7> #undo
17:59:54 <zodbot> Removing item from minutes: ACTION by jflory7 at 17:59:50 : dhanesh95 Put a call out on the devel mailing list asking for any Fedorans speaking at FOSDEM to please check if their name is added to our list so that they are covered in a later post on the Fedora Magazine
18:00:04 <dhanesh95> Oops
18:00:04 <jflory7> #action dhanesh95 Put a call out on the devel mailing list asking for any Fedorans speaking at FOSDEM to please check if their name is added to our list so that they are covered in a later post on the Fedora Magazine (due: 2017-01-26/27)
18:00:47 <jflory7> #action jflory7 Write article introducing Fedora speakers at FOSDEM on Tue., Jan. 31, publish on Wednesday or Thursday before FOSDEM (due: 2017-01-31)
18:00:57 <jflory7> #info These three items, once completed, will close the ticket.
18:00:59 <jflory7> .thank bt0
18:00:59 <zodbot> jflory7 thinks bt0 is awesome and is happy they are helping! (Please don't forget to bt0++ also)
18:01:03 <jflory7> .thank dhanesh95
18:01:03 <zodbot> jflory7 thinks dhanesh95 is awesome and is happy they are helping! (Please don't forget to dhanesh95++ also)
18:01:24 <jflory7> Awesome! Let's hit one of the other old tickets marked as meeting. (We'll keep this on the meeting tag for now to check in next week)
18:01:57 <jflory7> #info === Ticket #93 ===
18:02:03 <jflory7> #info "Elections: Better explain roles of Council and FESCo"
18:02:07 <jflory7> #link https://pagure.io/fedora-commops/issue/93
18:02:33 <jflory7> Okay, need to remember back on this one a little bit...
18:02:53 <Rhea> We were talking about this (and 90 i think) a little bit, we wanted to see if there is anything, any data or numbers to pull out of the candidates that could be published in some charts and stuff
18:03:12 <Rhea> Kinda came to conclusion though, that it may affect peoples opinions too much?
18:03:35 <Rhea> That it might be too biased if we were putting some charts with numbers together...
18:03:44 <jflory7> dhanesh95: I don't know if we ever received too much feedback on the list about the Council other than people should be able to understand what is already there. Perhaps the Council description is sufficient, but for me personally, I definitely don't know about the FESCo one. It's even a little confusing for me to get an idea of what they do sometimes.
18:03:52 <Rhea> like... favoring people who own more packages, or whatever... (example)
18:04:55 <bt0> Right, the people with more "activities" are developers/maintainers with a lot of commits/bugfiexes
18:04:59 <jflory7> Rhea: I think we should avoid generating metrics specific to each candidates running. However, I think we could use the data and metrics from the election to determine the impact of our efforts, see what worked (e.g. dates of social media posts / mailing list announcements), and also do some critical thinkig on things that didn't work.
18:05:00 <dhanesh95> jflory7: Right. The Council was against the idea of updating the wiki and adding more data on an already crowded page.
18:05:09 <Rhea> As for "better explain" part of this topic, I think that it just comes down to updating wiki to have a bit of well versed TLDR and then longer structured information
18:06:12 <jflory7> dhanesh95: I think having some time off to think about it, I may lean towards that too. But perhaps we should just designate this ticket as something for FESCo instead. I really think bullet points and talking about some of their responsibilities on the wiki page would be enough, but not sure what you all think.
18:06:19 <jflory7> Rhea: Agreed.
18:06:49 <Rhea> I personally always look at the first paragraph to see some TLDR "this giant wiki page basically comes down to this and this"
18:06:57 <Rhea> I never find it.
18:06:59 <Rhea> :D
18:07:09 <dhanesh95> jflory7: I think we should close this ticket by suggesting FESCo to make some amends.
18:07:56 <jflory7> dhanesh95: I was thinking the same thing. Filing a downstream ticket on their Trac/Pagure might be best, so then that way it puts it onto their radar. Ultimately, I think they are the ones most equipped to review that.
18:08:12 <dhanesh95> jflory7: Roger that!
18:08:17 <dhanesh95> Agreed?
18:08:23 <jflory7> +1.
18:08:30 <dhanesh95> +1
18:08:32 <mailga> jflory7: you can figure out something about the FESCo range of interest looking at the badges. IMO
18:08:43 <bt0> +1
18:08:43 <jflory7> Is that something that anyone would want to take on?
18:09:06 <dhanesh95> Do we have any new contributors in the house today?
18:09:09 <jflory7> mailga: Hmmm, how do you mean? Having FESCo try to adopt a strategy with badges? Or do you mean something else?
18:09:18 <dhanesh95> This could be a great "Getting Started" task
18:09:44 <jflory7> dhanesh95: +1, this would be a great getting started task, and we can help provide pointers too.
18:10:23 <dhanesh95> If there are no takers, assign it to me jflory7
18:10:33 <mailga> jflory7: no, only a glance about their interest. Of course I think that is also a FESCo strategy to look at their people work.
18:11:01 <jflory7> dhanesh95: Okay, sounds good. I was going take it on but do it next week. If your schedule is allowing, want to try to have that done by the end of the weekend?
18:11:08 <x3mboy> .hello x3mboy
18:11:09 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
18:11:15 * jflory7 waves to x3mboy
18:11:17 <jflory7> #chair x3mboy
18:11:17 <zodbot> Current chairs: Rhea bt0 cprofitt dhanesh95 jflory7 mailga x3mboy
18:11:28 <dhanesh95> Aloha x3mboy
18:11:38 <bt0> o/
18:11:46 <dhanesh95> Weekend sounds doable jflory7
18:11:50 <jflory7> mailga: Hmm, not sure I follow, but I wonder if it's an English thing.
18:11:58 <jflory7> dhanesh95: Okay, excellent - action incoming.
18:12:26 <mailga> jflory how do you understand when a contributor is a great contributor? Giving a glance at his badges, isn't it?
18:12:53 <Rhea> next #90 ?
18:13:00 <Rhea> related
18:13:22 <jflory7> #action dhanesh95 File a new ticket in the FESCo Trac/Pagure requesting more information to the wiki page about their responsibilities and common tasks (bullet points are great, but if they have time, longer descriptions would help too) (due: 2017-01-29)
18:13:41 <jflory7> mailga: *nods* I'm following.
18:13:42 <dhanesh95> .thank jflory7
18:13:42 <zodbot> dhanesh95 thinks jflory7 is awesome and is happy they are helping! (Please don't forget to jflory7++ also)
18:14:43 <jflory7> Rhea: Yeah, #90 will make a good one while the elections are fresh.
18:14:44 <mailga> jflory7: well, that's the way to understand the FESCo area and how they're moving. IMO.
18:15:48 <jflory7> mailga: I think I'm following a little more now. So maybe as a way to track progress over time about how Fedora is growing, which would reflect on the work performed by FESCo? I like that idea, but I definitely think it would be a whole new discussion item. :) If you'd like to file a new ticket for us to understand your full thoughts, I think that would be awesome!
18:16:06 <jflory7> #info === Ticket #90 ===
18:16:08 <jflory7> #info "Improving Fedora Elections Process."
18:16:12 <jflory7> #link https://pagure.io/fedora-commops/issue/90
18:16:25 * jflory7 pauses for some catch-up on the ticket comments
18:16:38 * mailga takes note to open the ticket.
18:18:47 <cprofitt> hmm... where did the number of activites in the .csv file come from?
18:19:14 <jflory7> bt0: Nice work on digging into this. I do agree with bexelbie's comment, but I think there is a middleground where we can try to find ways to make this data accessible.
18:19:30 <bt0> :D
18:19:39 <jflory7> cprofitt: This was all pulled from fedmsg. So all of the activity in the past month will be from various things that hit fedmsg, e.g. commits, blog posts, translated strings, etc.
18:20:07 <cprofitt> I like the data, but I always ask where it comes from.
18:20:24 * cprofitt nods
18:20:48 <jflory7> However, I think the problem with this ticket is that I don't see an easy way to close it. I might test the title of a ticket as a way to think if the ticket needs to be broken up - can you describe a solution in a sentence to the question asked by the title of the ticket?
18:21:11 <jflory7> I would like to see this ticket broken into smaller, more manageable pieces that we can deliver some kind of end result on, so we can then close them.
18:21:44 <cprofitt> yes, this ticket sounds visionish... some dsicrete goals would be good.
18:22:06 <jflory7> There's a lot of feedback in this ticket that I'm still trying to go through to try to pull smaller goals from.
18:23:14 <cprofitt> jflory7: I can try to assist with writing the goals and pulling them out...
18:23:32 <jflory7> That might be a task of itself, actually
18:24:14 <jflory7> Since we still have some more things we wanted to go through, do you want to try to do this, cprofitt? It could be as a new ticket comment there, or you could file new tickets for specific goals that you can discern from that ticket.
18:27:47 * jflory7 wonders if we lost cprofitt or if he's typing
18:28:54 * Rhea checks under the table... shakes head and shrugs
18:29:14 <cprofitt> sorry, user called... had to work...
18:29:21 <jflory7> No problem. :)
18:29:26 <cprofitt> Yes, I can do that..
18:29:32 <jflory7> cprofitt: Think this is something you could try to do by the next meeting?
18:29:42 <cprofitt> Should be able too.
18:29:54 <jflory7> Okay, awesome!
18:29:57 * jflory7 writes action
18:30:33 <jflory7> #action cprofitt Work on pulling feedback and ideas mentioned in Ticket #90 into smaller, more achievable items, either as bullets in a ticket comment on #90 or as new tickets (due: 2017-01-31)
18:30:36 <Rhea> This ticket is "stub for working out ... badge for packagers ..." and it's empty: #53 [Onboarding Series] Package Maintainers - https://pagure.io/fedora-commops/issue/53
18:30:39 <jflory7> cprofitt++ Thanks!
18:30:50 <bt0> cprofitt++
18:30:51 <zodbot> bt0: Karma for cprofitt changed to 2 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:30:51 <cprofitt> no problem.
18:31:37 <Rhea> The same thing: #51 [Onboarding Series] Websites https://pagure.io/fedora-commops/issue/51
18:31:41 <jflory7> Rhea: I was thinking the onboarding series as a whole might need to be revisited, but that might be a topic for a whole meeting
18:31:46 <dhanesh95> cprofitt__
18:31:48 <Rhea> And this one: #54 [Onboarding Series] EPEL https://pagure.io/fedora-commops/issue/54
18:31:53 <dhanesh95> cprofitt++
18:31:53 <zodbot> dhanesh95: Karma for cprofitt changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:32:01 <jflory7> A lot of these were intended to be next steps after we finished whichever ones we were working on.
18:32:11 <Rhea> yup
18:32:20 <x3mboy> dhanesh95, o/
18:32:22 <jflory7> But I think I'll tentatively hold off on the onboarding series because that will be the next 30 minutes of itself.
18:32:33 <Rhea> Hey I already got a few more questions about #95 dotnet
18:32:34 <dhanesh95> x3mboy: o/
18:32:39 <Rhea> :D
18:33:03 <jflory7> So, let's speed through two more existing tickets and then have some time to talk about new ones, maybe in relation to Join SIG activity
18:33:25 <jflory7> #info === Ticket #95 ===
18:33:32 <jflory7> #info "[Onboarding Series] DotNet SIG"
18:33:36 <jflory7> #link https://pagure.io/fedora-commops/issue/95
18:34:17 <jflory7> Rhea: I know you've actually been powering through a lot of this one on your own, which is awesome. :) What was it you had in mind for this ticket?
18:34:39 <Rhea> The current state section is slightly (a lot) outdated, but not much has changed there. We now have packagers fas group, private list, etc... The problem is that half of our members - RH DotNet engineers who package it for RH, are not in the packagers group which is requirement...
18:35:05 <Rhea> My question is right now, how to proceed with this problem - standard is to create package, submit for review, someone will sponsor you
18:35:15 <Rhea> We don't follow that standard, we have one package for 5 people
18:35:24 * dhanesh95 needs to leave now.. Sorry for leaving so early.. Good Night CommOpc
18:35:31 * Rhea waves
18:35:32 <jflory7> dhanesh95: Good night!
18:35:35 <dhanesh95> CommOps*
18:35:48 <bt0> o/
18:36:23 <jflory7> Rhea: Hmmm. This is something I definitely don't have as much experience with. Is the question trying to expedite the review of a package?
18:36:44 <jflory7> I think it could be possible for all packagers to work together and then have an approved packager submit the package, but I'm really weak on this area. :(
18:37:05 <x3mboy> night
18:37:45 <jflory7> Rhea: Perhaps a good idea could be to reach out to the packagers of another language-specific SIG and get their opinion?
18:37:54 <Rhea> Well the fas-pkgdb group "dotnet-sig" will own the package
18:38:10 <jflory7> I know mhroncok is one of the Python SIG leads, so perhaps he could provide insight that would be helpful and specific for you?
18:38:14 <jflory7> Oh, okay.
18:38:15 <Rhea> the group has membership requirement to be a member of "packagers"
18:38:27 * jflory7 nods
18:38:36 <Rhea> I know that at least three people who should be in it are not due to not being packager...
18:39:11 <Rhea> Nemanja who's talking on devconf about it, Tom who is dotnet redhat engineer, and myself
18:39:29 <Rhea> Omair - the other dotnet redhat engineer, is already packager
18:39:33 <Rhea> And that's it..
18:39:57 <Rhea> So the problem is how do we... what do we do to get sponsored into packagers group? o_o
18:40:51 <Rhea> Dotnet package as such is not in the state to be ready for it yet, so we can't really proceed with that...
18:41:09 <jflory7> Rhea: I know there is a process, but I'm not sure of how it might all piece together as a SIG.
18:41:15 <Rhea> Microsoft issues, licenses, build process... it's ironing out slowly
18:41:18 <bt0> O.o
18:41:36 <jflory7> Rhea: If there's a *legal* concern with regards to that, Fedora Legal will definitely want to take a look
18:42:09 <Rhea> jflory7: exactly, all info i found was about individuals - individual unofficially reviewing other packages, individual submitting package, etc... but we cant make three identical packages and submit them individually :D
18:42:44 <Rhea> There is no info for groups, for teams working on a single package/project
18:42:59 <jflory7> Rhea: Here's my suggestion. For the logistics of how it might work out for you all to submit packages as a SIG even though some of you aren't packagers, I would reach out to another language-specific SIG lead for their opinion / advice. If you have questions about the concerns of the legality and logistics of how it should get into Fedora, Tom Callaway is probably the best contact for that.
18:43:12 <Rhea> Even the info about requirements for pkgdb group was hard to find (which i didnt find by googling or wiki searching at all, i had to ask for it..)
18:43:25 <jflory7> I'm not sure if these are things we might be able to answer for you, but hopefully those folks ^^ should be able to help.
18:44:19 <Rhea> might be a topic for improvement though :p
18:44:26 <jflory7> Rhea: Think it's a good idea for an action item for you to reach out to maybe mhroncok for his opinion about the logistics of how to make it work?
18:44:42 <jflory7> Rhea: Documentation about the pkgdb group could definitely be, yeah.
18:45:03 <Rhea> will see, not sure when will i have time to bite it again with devconf...
18:45:35 <jflory7> How about this: set action item for you to follow up with mhroncok on 31 Jan?
18:45:47 <jflory7> Or maybe 2 Feb, to give some extra recovery time?
18:46:47 <Rhea> Yeah with the lack of info - it is somewhere, but in my opinion not in the right place. I as relatively new contributor, although already with a good picture of what's what and where, couldn't find it... I would suggest updating wiki page http://fedoraproject.org/wiki/Join_the_package_collection_maintainers - https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group - with
18:46:49 <Rhea> information how should whole teams proceed, link to pkgdb documentation, etc...
18:47:18 <Rhea> I'm looking for info on wiki, but there aint any... not even that link to pkgdb
18:47:23 <Rhea> ref: http://pkgdb2.readthedocs.io/en/latest/groups.html
18:47:32 <jflory7> Okay, I see - so this might be a new ticket in itself.
18:47:51 <Rhea> yup
18:48:07 <Rhea> that's my feedback anyway from what i experienced in last week or two
18:48:11 <jflory7> Rhea: We could actually make this a new ticket we mention in another minute. Want to revisit pkgdb documentation in another moment? As far as #90 is concerned, does the above proposed action sound good?
18:48:18 * jflory7 notes we're in the final 10 minutes
18:48:22 <Rhea> sure
18:48:26 * jflory7 nods
18:48:33 <Rhea> dont make action
18:48:37 <Rhea> i dont think there is a need
18:48:42 <jflory7> Ah, okay, cool.
18:48:43 <Rhea> i'll proceed in some way somehow somewhere
18:48:47 <Rhea> :D
18:49:21 <jflory7> #info Rhea will follow up with others to see about the logistics of packaging dilemma with FAS groups and pkgdb, will update in ticket as needed
18:49:23 <Rhea> I had another question - the bot that collects pagure commits, issues, etc... fedmsg irc thing, is there some info about it?
18:49:26 <Rhea> What is it called?
18:50:06 <jflory7> #help Info for new packagers was difficult to find for how new teams should proceed, along with documentation for pkgdb. Better documentation about how to get started is something that would help others in the future.
18:50:21 <jflory7> Rhea: fedmsg. :) http://www.fedmsg.com I think?
18:50:28 <Rhea> Also another quick question - we have a dotnet-sig badge graphics, what do we do with it?
18:50:34 <jflory7> Thatsit.
18:51:05 <jflory7> Rhea: If you have a graphic for it already, you can file a new ticket in the Badges Trac! https://fedorahosted.org/fedora-badges
18:51:18 <jflory7> One last, maybe quick, ticket:
18:51:19 <Rhea> mkay thank you
18:51:24 <Rhea> :]
18:51:28 <jflory7> #info === Ticket #28 ===
18:51:32 <jflory7> #info "Creating an online contributor classroom - "Fedora University""
18:51:36 <jflory7> #link https://pagure.io/fedora-commops/issue/28
18:51:40 <jflory7> .thank Rhea
18:51:40 <zodbot> jflory7 thinks Rhea is awesome and is happy they are helping! (Please don't forget to Rhea++ also)
18:51:53 <jflory7> So, this is a very old ticket describing a very, very big thing
18:51:57 <x3mboy> The title is amazing
18:52:03 <x3mboy> Let me check the idea
18:52:42 <jflory7> After taking time to think about it, though, I'm not sure if this is something that we have the means to realistically pull off. With the upcoming discussion about reviving Fedora Classroom, my proposal was to close this ticket and instead collaborate with some of the Join SIG discussion on Fedora Classroom.
18:53:04 <x3mboy> Fall in EU or in USA???
18:53:06 <bt0> 1+
18:53:10 <x3mboy> Sorry, for this
18:53:15 <x3mboy> I really want to work with this
18:53:23 <jflory7> The scope of a project like this, I think, would be along the size of Fedora Hubs, which I'm not sure if that's something we can realistically pursue.
18:53:33 <x3mboy> I'm an online student
18:54:23 <x3mboy> Sorry, i get enthusiastic. So, work with Fedora Classroom SIG
18:54:34 <x3mboy> Some point of entry for that SIG?
18:54:37 <mailga> jflory7: of course, the ticket is related to the fed-join sig activity.
18:54:43 <jflory7> x3mboy: Well, the idea was for it to be digital. But we don't have anything in place where we might be able to make it happen. My understanding of the topic is something the level of Udemy or another online university, but I'm not sure if that's something we want to go into right now. I do know of some upcoming FOSS learning platforms like that style, but I think we'd be best to focus in on Fedora Classroom for now.
18:55:25 <jflory7> x3mboy: If there was a SIG, it might end up falling to Fedora Join or perhaps CommOps now. I'm not sure why the Classrooms stopped, but my understanding is that the group organizing them became inactive or had to give them up for time.
18:55:37 <mailga> jflory7: let me say that fed-join SIG is more "experimental" than other groups, such as commops that should follow manageable way instead.
18:55:54 <jflory7> mailga: That's how I was thinking too to both comments
18:56:50 <jflory7> x3mboy: Do my thoughts make sense about closing this ticket?
18:57:27 <x3mboy> If there is a SIG called Fedora Classroom, yes it makes sense
18:57:39 * jflory7 nods
18:57:54 <jflory7> Okay, cool. So we will close this ticket and refocus the effort on bringing back the Fedora Classroom.
18:57:57 <x3mboy> Ok, sorry I ger lost
18:58:36 <jflory7> #agreed Ticket will be closed - this idea is out of our scope to complete. Instead, we will refocus efforts on the Fedora Classroom with members of the Join SIG, to provide a mentorship / teaching opportunity for those who want to learn more about contributing to Fedora or other misc. topics related to Fedora
18:58:43 <jflory7> x3mboy: no problem, discourse is good. :)
18:58:44 <x3mboy> Yes, your thoughs make sense, it should fall in other team
18:59:00 <jflory7> I know we're *very* close to the end, but I do want to cover new tickets, even if we go 10 mins over
18:59:07 <jflory7> #info ***** NEW TICKETS *****
18:59:14 * jflory7 appreciates everyone's patience
18:59:19 <x3mboy> No problem
18:59:20 <bt0> ok
18:59:20 <x3mboy> Go dor it
18:59:26 <x3mboy> s/dor/for/g
18:59:55 <jflory7> My only idea here was for the Fedora Join SIG discussion that was going on in the list. Some of the idea was the "Help Wanted Wednesdays" which we do have a ticket for courtesy of bexelbie, and then the idea of bringing back the Fedora Classroom.
19:00:13 <jflory7> I think that could be a good thing for CommOps to "own", but we could discuss specifics in another full meeting block.
19:01:23 <Rhea> joint meeting with join o.o
19:01:50 <Rhea> (I always have to say something stupid.)
19:01:58 <Rhea> :D
19:02:14 <jflory7> Rhea: lolol. Something like that will definitely help us get our thoughts out on the table.
19:02:19 <x3mboy> I think, maybe because I'm relatively new in Fedora's ways. but this cuold be against RD interests
19:02:22 <jflory7> I'll put it as an idea and action me to file a ticket
19:02:35 <jflory7> x3mboy: RD interests?
19:02:45 <x3mboy> RH(
19:02:49 <x3mboy> RH**
19:02:58 <jflory7> x3mboy: The classroom idea?
19:03:08 <x3mboy> Yes
19:03:20 <mailga> jflory7: seems fed-join is becoming a commops branch (or even a FOSCo branch?) :-D
19:03:25 <jflory7> #idea Collaboration with Join SIG on reviving Fedora Classroom and finding ways to make them easier to run for volunteers and organizers - new ticket idea for discussion
19:03:27 <x3mboy> Because they offer training courses and certifications
19:04:03 <jflory7> mailga: I have this longstanding theory (that I didn't realize until long after I was in Fedora), but there have been many different attempts at a CommOpsy thing, but with a different name. :P
19:04:52 <jflory7> x3mboy: I don't think this would interfere. These were volunteer-run virtual classrooms in IRC that knowledgeable folks could run to teach other Fedora people about skills needed to contribute to Fedora, like the topic of packaging (or so I understand).
19:05:13 <jflory7> mailga: Actually, FOSCo branch isn't irrelevant...
19:05:17 <jflory7> #idea FOSCo branch???
19:05:30 <Rhea> o_o
19:05:34 <jflory7> #action jflory7 File a new ticket to discuss the idea of reviving Fedora Classroom more in depth
19:05:50 <mailga> x3mboy: Fedora can offer badges, not certifications.
19:05:57 <jflory7> That too.
19:06:21 <x3mboy> mailga, good call. Well I think that Classroom has a very wide meaning
19:06:36 <x3mboy> But I want to help a lot with the idea, I will be checking this frequently
19:06:44 * jflory7 might need to run out soon now
19:06:58 <jflory7> Hopefully this will be enough to cover for now, anything else we can go over on the list or in the next meeting.
19:07:02 <jflory7> #topic Open Floor
19:07:08 <mailga> jflory7: FOSCo will be (if we are able to make it happen) the outreach front office, so a classroom is more a FOSCo thing than commops. IMO.
19:07:11 <jflory7> Anyone have anything that they wanted us to cover tonight?
19:07:35 <jflory7> mailga: I agree completely… "Outreach" is the key word for me. I think of CommOps more as "in-reach"
19:07:47 <mailga> jflory7++
19:07:57 <x3mboy> Just to thanks for no forgot about me, I get lost like for a month, but I'm retaking things, including my hearings in commops meetings
19:07:58 <mailga> no cookies for you?
19:08:07 <x3mboy> jflory7++
19:08:07 <zodbot> x3mboy: Karma for jflory7 changed to 19 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:08:09 <x3mboy> LOL
19:08:18 <jflory7> x3mboy: No worries, you're not the only one who got lost. :P
19:08:23 <bt0> jflory7++
19:08:30 <jflory7> I'm behind on things, but now that I'm settled, it's getting better.
19:08:41 * jflory7 says this right before DevConf and FOSDEM happen... :P
19:08:52 <Rhea> Sorry i went silent, taking notes and sorting out dotnet stuffs
19:09:06 <mailga> jflory7: I cannot attend, I'm really sad for that.
19:09:07 <jflory7> Anyways, x3mboy, always happy to have you join us and provide your input. :) CommOps meetings are much more engaging when more people participate.
19:09:26 * bt0 agree
19:09:28 <shantorn> thanks for the reiteration of how the future is looking for commops
19:09:30 <jflory7> mailga: Hopefully there will be another opportunity for us to see each other soon, maybe before Flock, but at least Flock! ;)
19:09:38 <cprofitt> these meetings are quick... very eary to get lost.
19:09:39 <jflory7> Hi there, shantorn!
19:09:50 <cprofitt> especially when the meeting is when you are working
19:09:51 <shantorn> ive been here just quiet
19:09:54 <mailga> jflory7: I hope so.
19:09:55 <Rhea> jflory7++ bt0++ x3mboy++ mailga++ dhanesh95++ cprofitt++ =)
19:09:55 <zodbot> Rhea: Karma for x3mboy changed to 4 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:09:59 <zodbot> Rhea: Karma for cprofitt changed to 4 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:10:06 <Rhea> shantorn++ welcome :]
19:10:15 <jflory7> cprofitt: Today was a bit more packed than normal, but I try to thin the agenda a bit normally. Shouldn't be as super-speedy next week, or I hope.
19:10:35 <Rhea> See, dotnet meeting started in this channel 10 minutes ago.
19:10:39 <shantorn> thanks mam
19:10:41 <Rhea> Nobody showed up actually.
19:10:41 <x3mboy> cprofitt, in my case it's at contraire, it's better when I'm at the office
19:10:43 <cprofitt> jflory7: speaking of Flock... Toronto is likely going to wait until 2019 to put a bid in
19:10:44 <jflory7> Well, we're over our time limit, so we can head back to #fedora-commops now. shantorn, if you have any questions, you're welcome to ask there!
19:10:48 <jflory7> Rhea: Oh, shoot, let's clear out!
19:10:53 <jflory7> I didn't realize we had someone after us now.
19:10:55 <Rhea> Nobody is here :D
19:10:57 <jflory7> #endmeeting