16:33:53 <bt0> #startmeeting Fedora CommOps Meeting (2017-07-25)
16:33:53 <zodbot> Meeting started Tue Jul 25 16:33:53 2017 UTC.  The chair is bt0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:33:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:33:53 <zodbot> The meeting name has been set to 'fedora_commops_meeting_(2017-07-25)'
16:34:14 <bt0> #meetingname commops
16:34:15 <zodbot> The meeting name has been set to 'commops'
16:34:49 <bt0> #chair bt0 skamath
16:34:49 <zodbot> Current chairs: bt0 skamath
16:35:13 <skamath> Do we have an agenda bt0 ?
16:35:29 <bt0> #topic Agenda
16:35:39 <bt0> Not really
16:35:48 <nb> .hello nb
16:35:50 <zodbot> nb: nb 'Nick Bebout' <nb@nb.zone>
16:35:58 <skamath> Hi there nb
16:36:06 <bt0> #link https://fedoraproject.org/wiki/Meeting:CommOps_2017-25
16:36:24 <bt0> #info (1) Roll call / Q&A
16:36:40 <bt0> #info (2) Open floor
16:36:43 <bt0> :P
16:36:56 <bt0> #topic Roll call / Q&A
16:37:03 <skamath> I'll open a ticket or two today
16:37:10 <skamath> .hellomynameis skamath
16:37:11 <bt0> #info Name; Timezone; Sub-projects/Interest Areas
16:37:11 <zodbot> skamath: skamath 'Sachin S Kamath ' <sskamath96@gmail.com>
16:37:35 <bt0> #action commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
16:37:35 <bt0> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
16:37:48 <bt0> .hello bt0dotninja
16:37:49 <zodbot> bt0: bt0dotninja 'Alberto Rodriguez Sanchez' <hotgalan@gmail.com>
16:38:01 <bt0> #info Alberto Rodriguez S; UTC-5;CommOps (Metrics, Community engagement), DotNet (Testing), Infrastructure(Apprentice)
16:38:08 <bt0> Hello everyone
16:38:29 <skamath> #info Sachin S. Kamath; UTC +5.30; CommOps, Join, Classroom, SoC, *
16:39:09 <bt0> only have open floor in the agenda
16:39:32 * skamath has some stuff for Open Floor
16:39:40 <bt0> ok
16:39:57 <bt0> #topic Open floor
16:40:23 <skamath> !
16:40:44 <bt0> ok skamath, go
16:40:51 <bt0> ahead
16:41:02 <skamath> So, I had a discussion with bexelbie sometime back about integrating Grimoire into the fedora ecosystem. I am starting my work on it
16:41:05 <skamath> #link https://github.com/grimoirelab
16:41:34 <skamath> This is gonna be a *huge* thing for metrics. The long term goal is to integrate this with fedmsg and possibly other services
16:41:43 <skamath> And build an awesome dashboard around it
16:41:54 <bexelbie> .hello bex
16:41:55 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
16:41:59 <bt0> awesome!!!
16:42:04 <bexelbie> skamath, please keep me in the loop on this so I can connect you with the folks I know there
16:42:05 <skamath> They have something called kibiter, a fork of Kibana dashboard
16:42:09 <skamath> #link https://github.com/grimoirelab/kibiter
16:42:28 <skamath> bexelbie, I already talked to Jesus and a few other people. I did mention your name ;)
16:42:50 <skamath> They are ready to help us with the integration if required
16:43:06 * bt0 reading the links
16:43:37 <skamath> 1) The process is a bit tedious. We need to use perceval, a data gathering tool to gather all the data
16:43:47 <skamath> #link https://github.com/grimoirelab/perceval
16:44:02 <bt0> sounds like a lot of work, can i help? :)
16:44:15 <skamath> bt0, of course.
16:44:30 <skamath> I'll be contributing to the project and integrating it with Fedora.
16:44:40 <skamath> It's a win-win for both the communities.
16:44:57 <skamath> They have an small, yet awesome community.
16:45:09 <bt0> cool
16:45:27 <skamath> bexelbie, will do :)
16:46:11 <skamath> eof
16:46:20 <bt0> so we will open tickets about this?? what do you need? infra tickets?
16:46:37 <skamath> bt0, for now I'll develop it locally
16:46:45 <bt0> ok
16:46:54 <skamath> We already have commops.fic.o
16:47:23 <bt0> O.o
16:47:51 <skamath> bt0, samsung folks built this : https://blogs.s-osg.org/metrics/
16:48:01 <skamath> bexelbie pointed me to it ;)
16:48:36 <skamath> We can add a lot more.
16:49:08 <skamath> bexelbie, quick question : what are the initial metrics you need?
16:49:16 <bt0> it is a beautiful dashboard
16:49:49 <skamath> bt0, you'll be surprised to know it can be made a lot more beautiful ;)
16:50:24 <bt0> awesome
16:50:56 <skamath> bt0, checkout https://cauldron.io/
16:52:06 <skamath> Looks like the certificate expired a month ago
16:52:33 <bt0> yeah
16:53:51 <bt0> ok, this is huge
16:53:51 <skamath> eof
16:54:00 <bt0> Ok, a little more friendly talk... anyone?
16:54:16 <skamath> bt0, It's a very ambitious project :)
16:54:24 <skamath> And it's all in Python \o/
16:55:31 <bexelbie> skamath, I am still thinking this through
16:56:26 <bt0> But the benefits would be incredible
16:56:26 <skamath> bexelbie, Okay. I will open a tracker issue on Pagure. You can add your thoughts there :)
16:56:46 <bexelbie> I am more interested in second order effects - but for now we need to figure out how to load data, etc :)
16:57:17 <skamath> bexelbie, nod nod. The best bet is python fedmsg api
16:57:31 <bexelbie> skamath, yep - but I suspect we can pull feeds from other places where it makes sense
16:57:45 <bexelbie> part of it is that once we have first order numbers we can figure it out from there , I think
16:57:57 <bexelbie> also, we can always tell it, as I understand, to reanalyze for a first or second order number
16:58:10 <skamath> bexelbie, yes. For all the fedmsg stuff, I'll have to write a plugin for perceval which will collect all the data
16:58:41 <bexelbie> yep
16:58:45 <skamath> Second step is to use Sorting hat to link user accounts.
16:58:49 <skamath> That will be a challenge
16:59:18 <bt0> sounds like a beautiful problem
16:59:20 <skamath> I'm just going to concentrate on the first step now. We'll figure something out.
16:59:36 <skamath> There's always a solution.
17:00:17 <skamath> bt0, indeed :D
17:02:40 <bt0> ok, some other issue?
17:03:35 <skamath> I've got nothing.
17:04:07 <bt0> ok
17:04:18 <bt0> Going once…
17:04:51 <bt0> Going twice…
17:05:01 <bt0> Going thrice…
17:05:29 <bt0> #endmeeting