15:29:27 <jwf> #startmeeting Fedora CommOps (2017-12-11)
15:29:27 <zodbot> Meeting started Mon Dec 11 15:29:27 2017 UTC.  The chair is jwf. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:29:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:29:27 <zodbot> The meeting name has been set to 'fedora_commops_(2017-12-11)'
15:29:27 <commopswatch> meetbot.meeting.start -- jflory7 started meeting "Fedora CommOps (2017-12-11)" in #fedora-commops
15:29:41 <jwf> #meetingname commops
15:29:41 <zodbot> The meeting name has been set to 'commops'
15:29:41 <jwf> #nick commops
15:29:46 <jwf> #topic Agenda
15:29:52 <jwf> #link https://infinote.fedoraproject.org/cgit/infinote/tree/meeting-templates/fedora-commops-meeting-next
15:29:52 <jwf> #info (1) Roll call / Q&A
15:29:52 <jwf> #info (2) Announcements
15:29:52 <jwf> #info (3) Action items from last meeting
15:29:52 <jwf> #info (4) Tickets
15:29:53 <jwf> #info (5) Open floor
15:30:26 <jwf> #topic Roll call / Q&A
15:30:36 <jwf> #info Name; Timezone; Sub-projects/Interest Areas
15:30:36 <jwf> #action commops New members, make sure you introduce yourself on the CommOps mailing list [ https://fedoraproject.org/wiki/CommOps/Join ]
15:30:44 <jwf> If this is your first time at a CommOps meeting, feel free to introduce yourself to everyone and say hello! If anyone has any questions before we get started with the rest of the agenda, now is also a good time to ask.
15:30:56 <jwf> #info Justin W. Flory; UTC-5; CommOps, Diversity, Ambassadors, sysadmin-badges
15:31:40 <x3mboy> .hello2
15:31:41 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
15:31:50 <Rhea> #info Radka Janek; UTC+1; .NET SIG, CommOps, Diversity, Ambassadors, Bunnehs, Cookiemonsters
15:31:53 <bt0> # Alberto Rodriguez, UTC-6, CommOps, Marketing,DonNet SIG, infra
15:32:01 <bt0> #info Alberto Rodriguez, UTC-6, CommOps, Marketing,DonNet SIG, infra
15:32:18 <x3mboy> #info Eduard Lucena; UTC-3; CommOps, Ambassadors, Marketing, Cheat-Cubes
15:32:25 <commopstg> <bee2502> Yes.. would be good.
15:32:34 <jwf> #chair x3mboy Rhea bt0 bee2502
15:32:34 <zodbot> Current chairs: Rhea bee2502 bt0 jwf x3mboy
15:32:42 <jwf> Rhea: Cookiemonster is new. :D
15:32:50 <Rhea> (\_/)
15:32:52 <Rhea> (^_^)
15:32:54 <Rhea> @(")(")
15:33:17 <jwf> We'll wait until 5 mins after the start time, and then we'll jump in.
15:33:23 <jwf> @skamath: Ping, are you at the keyboard?
15:33:56 <nauticalnexus> aaaaaaaaaaa
15:33:58 <nauticalnexus> Is this where the metting is
15:34:20 <bt0> yes :)
15:34:28 <nauticalnexus> Okay awesome haha
15:34:38 <nauticalnexus> I'm in the right place then
15:35:31 <jwf> nauticalnexus: Yeah, just this week. We normally run it in #fedora-meeting-2 on Mondays, but we made an exception today since we wanted to take advantage of the Telegram group bridge.
15:35:35 <jwf> #chair nauticalnexus
15:35:35 <zodbot> Current chairs: Rhea bee2502 bt0 jwf nauticalnexus x3mboy
15:35:37 <Rhea> This is the place where we feed wild bunny (me) some cookies.
15:35:45 <jwf> Let's jump in!
15:35:52 * Rhea hops...
15:35:56 <jwf> #topic Announcements
15:35:56 <nauticalnexus> Telegram group bridge? :o
15:36:00 <bt0> Rhea++
15:36:02 <jwf> #topic Announcements
15:36:05 <commopstg> <skamath> Yup, booting up PC.
15:36:09 <jwf> #info === CommOps FAD proposal: First draft complete ===
15:36:09 <jwf> #link https://fedoraproject.org/wiki/FAD_CommOps_2018
15:36:16 <jwf> @skamath: See you soon :)
15:36:30 <nauticalnexus> oohthat's what that is
15:36:30 <jwf> #info A first draft of our FAD proposal is complete. The goals for the event are outlined. We'll cover this more in-depth later in the meeting.
15:36:39 <jwf> #chair skamath
15:36:39 <zodbot> Current chairs: Rhea bee2502 bt0 jwf nauticalnexus skamath x3mboy
15:36:45 <jwf> #info === "Heroes of Fedora (HoF) – F27 Final" ===
15:36:48 <jwf> #link https://communityblog.fedoraproject.org/heroes-of-fedora-f27-final/
15:36:55 <jwf> #info Huzzah to the QA heroes of Fedora! This article gives shout-outs to all the people who helped test, break, and improve Fedora before the general public had their hands on it. Thank you to our heroes! coremodule++
15:36:56 <zodbot> jwf: Karma for coremodule changed to 2 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:37:10 <jwf> #info === "Holiday Reminder" from Fedora Infrastructure team ===
15:37:15 <jwf> #link https://lists.fedoraproject.org/archives/list/infrastructure@lists.fedoraproject.org/thread/AKOJYPA2O4GVGHTY6JJJQP3O4GCT33YX/
15:37:19 <jwf> #info Many people won't be around as often in the next few weeks. If you need help from the Infra team, the best bet is to file a ticket this month.
15:37:25 <jwf> <eof>
15:37:34 <jwf> That's all I have. Anyone else have any announcements they want to throw out?
15:37:40 <Rhea> /ot: For reference of the bunny and cookies: http://i.imgur.com/ngQiXIT.gifv
15:37:49 <skamath> Wow, no commopswatch spam>
15:37:59 <jwf> skamath: I quieted the bot :P
15:38:00 <nauticalnexus> Rhea, awh
15:38:06 <jwf> Rhea: :D
15:38:08 <skamath> jwf++
15:38:15 <jwf> I'll unquiet it after the meeting ends
15:38:25 <jwf> Announcements, going once…
15:38:29 <nauticalnexus> also ot, I think I've seen you around before Rhea
15:38:35 <jwf> Going twice…
15:38:41 <jwf> And thrice…
15:38:47 <jwf> #topic Action items from last meeting
15:38:51 <jwf> #link https://meetbot.fedoraproject.org/fedora-meeting-2/2017-12-04/commops.2017-12-04-15.29.html
15:38:58 <jwf> #info How This Works: We look at past #action items from the last meeting for quick follow-up. If a task is completed, we move on to the next one. If it isn't, we get an update and re-action if needed. If no status, we'll try to get a quick update and move forward.
15:39:08 <jwf> #info === [MOSTLY COMPELTE] "jwf With FAD proposal, create a proposal draft and logic model flowchart, create new sub-tasks to divide and conquer FAD planning" ===
15:39:12 <jwf> #link https://fedoraproject.org/wiki/FAD_CommOps_2018
15:39:16 <jwf> #info Draft is done, but logic model flowchart is pending. We'll figure out the rest during the meeting
15:39:27 <jwf> So nice to finally have this one done, after weeks of incomplete :P
15:39:29 <skamath> jwf++ for all the effort!
15:39:35 <nauticalnexus> +1
15:39:38 <jwf> Thanks :)
15:39:49 <jwf> #info === "skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?" ===
15:39:52 <Rhea> nauticalnexus: you could have seen a wild ~rhea~ *bunny* in many places.
15:39:56 <skamath> Today!
15:40:09 <skamath> I'll do that during the hack session :)
15:40:12 <nauticalnexus> Rhea, I'm pretty sure I follow you on Twitter :P
15:40:12 <jwf> skamath: Yeah, I was going to ask if you wanted to spend some time talking about it in the meeting, if we don't bleed over.
15:40:14 <jwf> Oh, yeah!
15:40:17 <jwf> The hack session also works.
15:40:31 <skamath> Oh yeah, actually. Let's hack during the hack session.
15:40:37 <skamath> I am free all day and night.
15:40:44 <skamath> Let's do this after the meeting.
15:40:48 <jwf> nauticalnexus: Oh yeah – it might help if you know what a hack session is too. We meet in a video call / IRC for an "office hours" once a week, where we work on things together. https://fedoraproject.org/wiki/Hack_session
15:40:57 <jwf> skamath++ It shall be done. :)
15:41:02 <Rhea> nauticalnexus: if it hops on a mountainbike then it's the right bunny...
15:41:02 <jwf> #info === [COMPLETE] "Rhea Create the wiki page for the CommOps FAD, using the 2017 Diversity FAD page as a base" ===
15:41:04 <bt0> skamath++
15:41:07 <jwf> #link https://fedoraproject.org/wiki/FAD_CommOps_2018
15:41:11 <jwf> #info === [COMPLETE] "jwf Reach out to CommOps members and confirm participants, add to wiki page" ===
15:41:16 <jwf> #info === [COMPLETE] "Rhea Research hotel costs in Brno for the duration of the FAD (preferably near DevConf venue, but not required)" ===
15:41:18 * skamath waves to bt0
15:41:20 <jwf> #info Rhea put a hold on two rooms in one hotel already ($30/night); will revisit later in meeting
15:41:27 <jwf> #info === "bt0 For 50% of all drafts in CommBlog, reach out to authors and confirm if they want their articles published or discarded (due: 2017-12-11)" ===
15:41:37 <jwf> bt0: I know you commented in the ticket, but I didn't read it yet.
15:41:52 <bt0> the only mail than i don't sent was for matt
15:42:06 <bt0> but you do, so ..  Complete
15:42:07 <commopstg> <dhanesh95> dhanesh95 waves o/
15:42:16 <skamath> @bee2502, ping meeting :)
15:42:20 <jwf> bt0: Did we get all of them?!
15:42:20 <nauticalnexus> Rhea, yup I definitely follow you on twitter haha
15:42:28 <jwf> skamath: She has classes now, so she may peek in time to time
15:42:36 <skamath> Cool.
15:42:45 <jwf> We may revisit the meeting time in 2018, since a few of us will have schedules shifting again.
15:42:45 <commopstg> <bee2502> skamath I am here
15:42:52 <skamath> \o/
15:42:53 <bt0> yeah
15:42:54 <nauticalnexus> jwf, what kind of things is worked on in the hack session?
15:42:57 <jwf> @dhanesh95: Heyo!
15:43:09 <skamath> nauticalnexus, All things CommOps.
15:43:11 <jwf> nauticalnexus: Usually, we work on items from the meeting or other tickets in our Pagure. :)
15:43:24 <bt0> well, new post about interviews or RP no
15:43:33 <commopstg> <dhanesh95> Meeting in commops channel today?
15:43:51 <jwf> #info Complete! bt0 emailed draft authors and I emailed mattdm on one, so all articles were covered.
15:43:53 <jwf> #link https://pagure.io/fedora-commops/issue/121#comment-483942
15:43:58 <jwf> bt0++ Thanks for your work here!
15:44:08 <skamath> @dhanesh95, we have a bridge here so why not ;)
15:44:12 <jwf> And that's all the action items. Now we can get to the heart of the issue.
15:44:31 <jwf> @dhanesh95: We did it today to take advantage of the bridge, since today's meeting is urgent with regards to the FAD planning
15:44:32 <commopstg> <bee2502> dhanesh95 jwf Rhea nauticalnexus bt0 x3mboy o/
15:44:37 <jwf> #topic Tickets
15:44:39 <nauticalnexus> Hello!
15:44:44 <jwf> #link https://pagure.io/fedora-commops/issues?tags=meeting
15:44:46 <x3mboy> @bee2502 o/
15:44:48 <meskarune> the meeting is here?
15:44:50 <skamath> @bee2502 didn't wave to me :(
15:45:14 <commopstg> <dhanesh95> @bee2502 o/
15:45:20 <meskarune> .hello
15:45:20 <zodbot> meskarune: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
15:45:22 <jwf> meskarune: Yes! Decided to run it in here last minute for the Telegram bridge.
15:45:24 <jwf> #chair meskarune
15:45:24 <zodbot> Current chairs: Rhea bee2502 bt0 jwf meskarune nauticalnexus skamath x3mboy
15:45:26 <jwf> #info === Ticket #125: "[TRACKER TICKET] Organize a CommOps FAD" ===
15:45:30 <jwf> #link https://pagure.io/fedora-commops/issue/125
15:45:33 <jwf> #link https://fedoraproject.org/wiki/FAD_CommOps_2018
15:45:35 <jwf> Okay, so…
15:45:44 <commopstg> <bee2502> skamath we already said hello but o/ o/ double wave from me
15:45:49 <jwf> The most important parts that I want to discuss with everyone are the primary and secondary goals.
15:46:04 <jwf> I'm not sure who has had a chance to read through it or not, but I tried to be realistic with the work we proposed to do.
15:46:11 <skamath> bee2502++ :)
15:46:11 <zodbot> skamath: Karma for bee2502 changed to 5 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:46:16 <jwf> Here's the tl;dr:
15:46:24 <jwf> #info The purpose of the CommOps FAD is to…
15:46:33 <jwf> #info 1. Pursue plan of deploying a GrimoireLabs dashboard, visualizing fedmsg data
15:46:42 <jwf> #info 2. Launch Fedora Appreciation Day in 2018
15:46:55 <jwf> #info 3. (secondary) Analyze Fedora Elections and develop year-long plan to improve community engagement in elections
15:47:06 <jwf> #info 4. (secondary) Evaluate critical areas of Fedora that fedmsg integration would be helpful; create development plan for them (e.g. Fedora Magazine / Community Blog)
15:47:13 <skamath> #1 is always the best. heheh.
15:47:20 <commopstg> <JonaToni> Hello 👋
15:47:21 <nauticalnexus> lol
15:47:21 <Rhea> hm
15:47:35 <skamath> jwf, Solid!
15:47:36 <jwf> @jonatoni: Hey! :)
15:47:47 * skamath waves to @jonatoni
15:47:56 <jwf> One thing I want to emphasize is that I don't anticipate much actual coding at the FAD
15:48:01 <Rhea> hm
15:48:05 <jwf> This is a unique opportunity to have the same folks in the same room
15:48:08 <commopstg> <bee2502> I am a bit confused about 1.. maybe it should be divided into further subgoals.. of what we achieve during FAD for dashboard.
15:48:14 <skamath> jwf, I will make you code all night >:(
15:48:20 <nauticalnexus> skamath, lol
15:48:30 <jwf> @bee2502: Did you see this yet? Or do you mean more details? https://fedoraproject.org/wiki/FAD_CommOps_2018#GrimoireLabs_dashboard
15:48:52 <jwf> The summarized version:
15:48:53 <jwf> The FAD allows us the bandwidth to spend time to discover our needs, map out the development plan for the plugin, and design use cases for potential visualizations. Different parts of this task are addressed in parallel instead of in a linear way. While mapping out the technical requirements, we will discuss what visualizations we want to prepare at launch and how to introduce Fedora contributors to this tool with documentation.
15:48:57 <jwf> Our end deliverable is a year-long plan for how to develop, implement, and promote a GrimoireLabs dashboard powered by fedmsg.
15:49:02 <nauticalnexus> jwf, that's awesome.
15:49:09 <commopstg> <dhanesh95> dhanesh95 quickly hops on to IRC. Things are getting serious here.
15:49:19 <skamath> @bee2502, It's all related. If we work on one, we will already be half way through in the other ones.
15:49:39 <jwf> skamath: lolol, you will have to brush me up on my Python!
15:50:01 <skamath> Bring your own snake.
15:50:05 <skamath> :D
15:50:17 <commopstg> <bee2502> jwf just saw that! That addresses some of my concerns.
15:50:20 * nauticalnexus only knows how to do basic HTML and very basic BASIC
15:50:46 <jwf> #info The purpose of the FAD objectives is to take advantage of our time together for collaborative discussion and planning. We should avoid individual-type of work like research and programming, unless really necessary. We want to take advantage of our time together to the fullest!
15:51:00 <jwf> @bee2502: Perfect \o/
15:51:07 <commopstg> <bee2502> But I guess like skamath said we will work on most of it parallely so time constraints shouldn't be an issue.
15:51:22 <jwf> nauticalnexus: And that's fine, and exactly why I don't want to spend too much time emphasizing on code too. :)
15:51:24 <skamath> We can always look into each others' work :)
15:51:37 <jwf> Okay, so here's what I'd like to ask everyone:
15:51:49 <jwf> 1. Review the FAD proposal, share any feedback on improvements / ways to make it better
15:51:56 <nauticalnexus> jwf, unless you need to repeat text on a screen in BASIC, I'm not your girl :P
15:52:24 <jwf> 2. During the hack session, I plan to grab the logic model (https://pagure.io/FedoraLogicModelTemplate) and add in the GrimoireCon plans
15:52:35 <jwf> 3. We will submit this bid to the Council before their Wednesday meeting for approval
15:52:43 <Rhea> jwf, I'm your gurl if you need a programmer for... tripple-a game? o.o
15:52:52 <jwf> :)
15:52:53 <Rhea> Sorry i'll shut up
15:52:56 <nauticalnexus> lol
15:53:05 <jwf> All good.
15:53:18 <jwf> Oh, I know a specific type of feedback I would love:
15:53:19 <nauticalnexus> I'm like the worst at coding so
15:53:32 <jwf> For the Q&A, I tried to anticipate questions that someone might ask us after reading the proposal
15:53:35 <Rhea> For the record I have to point out that I have not slept for 30 hours (okay I did, an hour and half...)
15:53:39 <Rhea> So I'm slightly crazy.
15:53:52 <skamath> jwf, Q&A ?
15:53:59 <jwf> If you have a question or aren't certain on something, then the odds are someone else does too.
15:54:02 <Rhea> Not sleeping has similar effect on human (or bunny) body as being drunk.
15:54:02 <skamath> During the FAD or for the planning?
15:54:17 <jwf> So if we can anticipate questions that we might get when our proposal is reviewed, we can be at our top game.
15:54:25 <skamath> Got it.
15:54:33 <jwf> skamath: For planning. The audience we're pitching to is the Fedora Council, so thinking of questions they might have for us about our FAD.
15:54:35 <bt0> Rhea But less funny
15:54:36 <skamath> I'll help you with that.
15:54:47 <Rhea> bt0: tru ;p
15:54:49 <skamath> jwf, How about an etherpad?
15:54:53 <x3mboy> Rhea, but is not equally fun
15:54:54 <skamath> or gobby
15:55:02 <jwf> Rhea: Whoa!!! O.O Please grab some sleep soon.
15:55:08 <Rhea> NEVAH
15:55:09 <jwf> skamath: Hmm, for what? The questions?
15:55:14 <skamath> jwf, Yea.
15:55:22 <dhanesh95> skamath, jwf: You guys need to slow down a bit. Too much info to process. :P
15:55:31 <nauticalnexus> hahaha
15:55:44 <jwf> skamath: Ah, I guess an Etherpad works too. I was thinking if you had a question, we could just discuss it and add it to the wiki page with an answer.
15:55:59 <meskarune> so one of the issues with etherpads is that sometimes teh data gets lost
15:56:00 <jwf> dhanesh95: Yeah, sorry – thanks for mentioning that. Trying to speed through too much at once, you're right. We have a full hour still.
15:56:13 <Rhea> meskarune: not if YOU host it.
15:56:19 <skamath> jwf, I think an etherpad is better so that everyone can add to the answers. Wiki traffic saved :)
15:56:19 <jwf> If folks want to take time to review the FAD proposal now in depth, I'm okay with that too.
15:56:24 <jwf> Rhea: Do you mean your Etherpad?
15:56:30 <skamath> It's really hard to edit wiki everytime,
15:56:30 <meskarune> :)
15:56:36 <commopstg> <bee2502> I would like to see a section on how community could utilize some metrics from dashboard etc
15:56:46 <Rhea> Yeah, there is on risk of loss if you host it yourself and know where the backups are in any case...
15:56:50 <meskarune> skamath: yeah, but maybe we all need to make backups on pagure or somethingh more permanet
15:56:58 <meskarune> or user wiki pages idk
15:57:03 <commopstg> <bee2502> Especially to show relevance of metrics dashboard and it's current need
15:57:10 <meskarune> there has been multiple times when stuff was lost when a etherpad disappeared
15:57:22 <commopstg> <bee2502> Since it is one of our primary goals.
15:57:24 <nauticalnexus> jwf, it all looks fine to me :P
15:57:33 <skamath> @bee2502, Actually, the $BIG_GOAL is a dashboard which is the one-stop solution for all the metrics needs.
15:57:44 <Rhea> in real time collaboration is great in etherpad or google docs; where it should be backed up after FAD elsewhere, as a result of our work - pagure/wiki...
15:57:52 <skamath> Come to $URL, get all that you want.
15:58:00 <jwf> #idea Emphasize how the community could utilize metrics in a Grimoire dashboard. Why is it relevant? How could the community benefit? We should try to give a concrete example of our vision.
15:58:02 <meskarune> Rhea: agree
15:58:03 <jwf> bee2502++
15:58:19 <nauticalnexus> afk forgot breakfast
15:58:21 <jwf> Let's focus back towards the FAD proposal, all :)
15:58:22 <bt0> awesome idea
15:58:33 <commopstg> <bee2502> skamath yes but some use cases on how say a localization contribjror or ambassador could use it would be nice to have
15:58:50 <jwf> nauticalnexus: Okay, no problem! See you in a bit.
15:59:07 <skamath> @bee2502, We'll discuss that in a bit. Let's not clutter the FAD discussion.
15:59:22 <jwf> Yeah, I agree. I think a concrete example of what we're trying to do is helpful. I think we all have a clear idea of how the community could benefit from the dashboard, but the Council may not have that context.
15:59:49 <meskarune> jwf: what problem is visualizing fedmsg data goign to solve?
16:00:06 <bt0> maybe we can thing some user cases for the dashboard
16:00:09 <jwf> skamath: I do think one example is helpful for the proposal. We don't have to design full use cases, but giving the gist of what this will actually do is important – I get Bee's point.
16:00:21 <commopstg> <bee2502> jwf exactly. skamath I was talking about adding it to FAD proposal.
16:00:28 <meskarune> I mean, it sounds cool but idk what the purpose is :)
16:00:31 <jwf> meskarune: You know, maybe that is the best place to start.
16:00:35 <skamath> Oh, okay. I see it now.
16:00:35 <x3mboy> Will the FAW be a online event only?
16:00:42 <jwf> #info What problem does visualizing fedmsg data solve?
16:00:51 <x3mboy> What kind of events there are similar to this?
16:00:54 <skamath> meskarune, storytelling, metrics, reports etc simplified.
16:01:04 <x3mboy> What Fedora win with an event ike this?
16:01:25 <Rhea> it solves being able to get an idea about contributor activity
16:01:28 <x3mboy> like*
16:01:28 <Rhea> errh
16:01:35 <Rhea> active contributor percentage
16:01:37 <Rhea> whatever
16:01:42 <Rhea> someone translate my thoughts pleae
16:01:55 <jwf> #info Visualizing fedmsg data in a dashboard allows us to create charts, tables, and other visual aids to understand the data in fedmsg. Right now, to use it, you have to write code / scripts to interact with the data. The dashboard lets anyone, regardless of tech knowledge, see easy-to-understand visualizations about the health of their project / sub-project in Fedor.
16:01:59 <jwf> s/Fedor/Fedora
16:02:08 <skamath> +1
16:02:21 * x3mboy is trying to use the force to read Rhea's mind, but bunny minds are too hard to break
16:02:35 <meskarune> maybe you could use the data to figure out what times/days/months people contribute the most
16:02:47 <meskarune> and then use that information to plan activities and projects
16:03:00 <skamath> That's of course during SoC ;)
16:03:01 <jwf> #info For example, a maintainer of a large project (say, Pagure) might see the number of commits over time, the number of new contributors in a month, etc. The localization team may have a geographic chart for languages, so if a new language suddenly starts receiving translations, the community could reach out and support the new translators in their efforts.
16:03:14 <x3mboy> I know for sure that we can use that data to measure how impactful are Ambassadors events
16:03:18 <jwf> meskarune: Does this answer your question?
16:03:34 <meskarune> jwf: it was a question to help frame discussion mostly ;)
16:03:35 <x3mboy> e.g.: How many contributors the project wins after an event
16:03:39 <bt0> x3mboy yeah
16:03:43 <jwf> meskarune: Ah, gotcha – it was good :)
16:03:44 <skamath> meskarune++
16:03:44 <zodbot> skamath: Karma for meskarune changed to 1 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:04:06 <jwf> #idea Figuring out what times/days/months people contribute the most with bar graphs
16:04:42 <meskarune> if fedora does "hackathons" it could be useful to plan them when more people are contributing in general
16:04:43 <jwf> #idea Seeing if new contributors enter the community after an event is organized / executed
16:04:57 <jwf> meskarune: I hadn't even thought of that, but that's a good point
16:05:05 <nauticalnexus> okay what did I miss
16:05:19 <Rhea> Me.
16:05:20 <jwf> #idea Planning internal Fedora team sprints when more people are contributing
16:05:21 <skamath> #idea Understand new contributors better and where they snap off (if they do)
16:05:32 <jwf> nauticalnexus: I think if you read the #info / #idea tags, you can get the gist quickly. :)
16:05:40 <meskarune> skamath: oh thats also good
16:05:43 <meskarune> retention is important
16:05:43 <jwf> skamath++ Nice one.
16:05:47 <x3mboy> Can we geo-distribute metrics grimoirelab?
16:06:00 <meskarune> and retaining contributing is actually something that should be an active thing
16:06:14 <jwf> x3mboy: Hmm, could you re-phrase the question? What do you mean by geo-distribute?
16:06:17 <skamath> x3mboy, You can get the geo data and put it up on Kibana just fine, yes.
16:06:33 <skamath> x3mboy, something like a map you mean?
16:06:43 <jwf> Like the FAS latitude/longitude field? :P
16:06:47 <skamath> If that, then yes.
16:06:51 <bt0> yeah, maps helps a lot
16:07:01 <bt0> mostly country field
16:07:07 <jwf> Oh, yeah… duh
16:07:15 <jwf> Not sure why I didn't think of that one
16:07:18 <jwf> :P
16:07:19 <skamath> #link https://fedoraproject.org/membership-map/ambassadors.html
16:08:12 <jwf> Okay, so… I think the feedback is mostly positive, and now we have a little feedback to go back and improve some sections of the proposal.
16:08:18 <x3mboy> No, not necesarily un a map, but e.g.: how much activity have LATAM during April/March?
16:08:22 <dhanesh95> !
16:08:31 <x3mboy> s/un/in
16:08:36 <Rhea> O_O
16:08:37 <jwf> We can give folks the afternoon to read it in detail after the meeting, but otherwise, I think we're good for the FAD discussion?
16:08:40 <jwf> dhanesh95: Go for it!
16:08:53 <skamath> x3mboy, Hmm - maybe we can pull the users from the membership wiki and group users based on the region.
16:08:59 <dhanesh95> So have we thought of a use case where this data can somehow be used for describing the journey for a new contributor?
16:09:23 <skamath> x3mboy, Don't worry. There's always a solution. We have tons of data :D
16:09:45 <jwf> #idea The Epic Journey of the New Fedora Contributor (i.e. using the visualizations to see pathways / successes / failures of new contributors entering the community for the first time)
16:10:01 <nauticalnexus> jwf, sounds like me :P
16:10:03 <jwf> dhanesh95: I really like that idea too.
16:10:09 <jwf> nauticalnexus: Heh, actually, yeah. :)
16:10:12 <nauticalnexus> me too considering that I'm new
16:10:14 <x3mboy> Ok, cool!
16:10:24 <skamath> jwf, That sounds like Hubs ;)
16:10:30 <jwf> Okay. Anyone have any other feedback on the proposal?
16:10:47 <nauticalnexus> Othern than I think it's great, none from me :P
16:10:52 <dhanesh95> jwf: That is just visualizing. We could actually analyse that data and define a journey for a new contributor so that he/she doesn't snap off
16:11:09 <jwf> skamath: Yeah, good point, there's probably a lot of Hubs research we should cross-reference. Once we have a chance to organize our thoughts a bit better, we should ping miz mo and get her thoughts, so we don't duplicate work.
16:11:42 <jwf> #info NOTE: The Hubs team did a lot of research into the pathways of new contributors with almost a full-year of research. Make sure we don't duplicate work that's already done and lightyears ahead of us already!
16:11:47 <skamath> dhanesh95, we cannot stop people from snapping no matter how hard you try. And I am definitely -1 to defining a path for a new contributor.
16:12:08 <skamath> The $contributor should decide what to do imo
16:12:09 <jwf> skamath: Well, that's true, but we want to understand the "why" behind that
16:12:17 <nb> hi
16:12:24 <jwf> Anyways, I think we can move on now from this ticket.
16:12:31 <skamath> Hi nb o/
16:12:34 <jwf> Unless anyone has specific feedback on the proposal itself.
16:12:37 <jwf> nb: Heyo!
16:12:40 <jwf> #chair nb
16:12:40 <zodbot> Current chairs: Rhea bee2502 bt0 jwf meskarune nauticalnexus nb skamath x3mboy
16:12:40 <nauticalnexus> hi nb!
16:12:40 <dhanesh95> skamath: We'll give that as an option. Make it easier to fit in.
16:12:58 <Rhea> I have specific feedback on the proposal and the wiki
16:13:10 <jwf> Rhea: Floor is yours!
16:13:12 <dhanesh95> jwf: Proposal looks pretty solid. +1
16:13:24 <Rhea> Y'ALL GO CONFIRM YOUR ATTENDANCE AND TRAVEL ESTIMATES OR ELSE......
16:13:29 <skamath> xD
16:13:31 <nauticalnexus> lmao
16:13:43 <Rhea> I'm hungry.
16:13:45 <dhanesh95> XD
16:13:50 <dhanesh95> Rhea++
16:13:52 <jwf> #action commops FAD attendees, please research your travel costs and add them to the wiki as soon as possible!
16:13:57 <nauticalnexus> Rhea, I love your feedback.
16:14:01 <dhanesh95> Ohh. No more cookies. :P
16:14:06 <jwf> Nice one to note there. I'm going to action myself for a couple of things and then we can move on.
16:14:13 <x3mboy> Rhea we need you dancing at the floor!!!!!
16:14:13 <Rhea> dhanesh95: I ATE THEM!!
16:14:18 <jwf> #action jwf Create a logic model based on the current FAD template
16:14:26 <dhanesh95> .moar cookies Rhea
16:14:26 <zodbot> here Rhea, have some more cookies
16:14:30 <Rhea> x3mboy: at the end of January ;)
16:14:32 <jwf> #action jwf Submit FAD proposal to Council by Tuesday evening, US EST
16:14:40 <jwf> Okay, FAD proposal discussion, going once…
16:14:50 <jwf> Going twice…
16:14:55 <jwf> And thrice…
16:14:57 <dhanesh95> Sold!
16:15:01 <jwf> #info === Ticket #114: "Use metrics dashboard to visualize fedmsg data" ===
16:15:04 <jwf> #link https://pagure.io/fedora-commops/issue/114
16:15:10 <nauticalnexus> dhanesh95, what did I win!?
16:15:12 <jwf> Okay, so sort of more the same, but I really want to focus this discussion down
16:15:35 <jwf> It would be helpful to know an estimated timeline for the fedmsg Perceval plugin, which lets us use fedmsg data in Grimoire
16:15:46 <skamath> Yeah, this has been on hold since Flock.
16:15:59 <jwf> This one: [10:39:48] <jwf> #info === "skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?" ===
16:16:12 <jwf> skamath: Do you think we can answer those three questions now?
16:16:19 <dhanesh95> nauticalnexus++
16:16:19 <zodbot> dhanesh95: Karma for nauticalnexus changed to 1 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:16:22 <skamath> Let's see.
16:16:25 <dhanesh95> nauticalnexus: You just won a cookie :P
16:16:30 <skamath> We need a lot of code, of course.
16:16:33 <nauticalnexus> :O
16:16:37 <nauticalnexus> A cookie!!
16:16:42 <jwf> skamath: Yeah, granted on that
16:17:04 <skamath> jwf, Let us both do a one week research on what to build and what not to build.
16:17:21 <bt0> I'm not the best python coder but i can help
16:17:44 <nauticalnexus> I really should start learning Python..
16:17:47 <skamath> jwf, I have a feeling a lot of things overlap with Hubs
16:17:48 <jwf> skamath: Okay. Can I re-action you for this one? On Wednesday morning, I'm going to go MIA for my university final exams, with the exception of any follow-up based on Council feedback to the FAD.
16:18:00 <skamath> jwf, Sure.
16:18:09 <jwf> My time for research is limited until later this month.
16:18:11 <jwf> Awesome.
16:18:15 <skamath> jwf, I can do it.
16:18:17 <Rhea> O_O
16:18:19 <jwf> #action skamath Add comment to ticket #114 (Grimoire ticket) that estimates a timeline for the Perceval fedmsg plugin development. What is required? About how much work is involved? Do you foresee any possible blockers?
16:18:31 <skamath> I'll talk to Hubs folks and comment on the ticket.
16:18:35 <commopstg> <RheaAyase> O_O
16:18:35 <Rhea> O_O
16:18:39 <jwf> skamath: Bonus points for talking to the Hubs folks.
16:19:08 <dhanesh95> skamath++
16:19:08 <zodbot> dhanesh95: Karma for skamath changed to 7 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:19:14 <jwf> Rhea: After the meeting, make sure you get some sleep… sometime soon :P
16:19:20 <nauticalnexus> jwf, +1
16:19:21 <Rhea> NEVAAAAAAAAAAAH
16:19:21 <jwf> I'd be a zombie by now
16:19:22 <nauticalnexus> lol
16:19:43 <jwf> Okay, since this ticket was blocking on those questions, we can revisit it next week
16:20:11 <jwf> #info === Ticket #121: "Follow up with authors of CommBlog drafts" ===
16:20:17 <jwf> #link https://pagure.io/fedora-commops/issue/121
16:20:42 <jwf> Reading your comment now, bt0, the table is helpful
16:21:17 <jwf> bt0: Oh, one caveat for the Ohio Linux Fest article. Is the author Ryan Lerch on that one?
16:21:24 <jwf> I thought it was award3535.
16:21:35 <jwf> Oh, maybe nb knows this one, since I think he was at Ohio Linux Fest?
16:21:45 <nb> I was not at OLF
16:21:49 <jwf> Ah, okay
16:21:51 <nb> i have never been.  I would like to be sometime
16:21:52 <bt0> let me check
16:22:02 <jwf> I think Ryan might have ported it from the Magazine into the CommBlog, if he's the author.
16:22:08 <jwf> nb: Do you know who might have written the report?
16:22:09 <nauticalnexus> I don't live anywhere near Ohio :P
16:23:15 <bt0> i did send the mail to andrew (award3535)
16:23:28 <jwf> Oh, okay, so just a typo.
16:23:32 <jwf> Cool! That works fine for me then
16:24:09 <jwf> bt0: So then, I think we can mark this ticket as blocked, pending feedback from the authors. Once we have answers from all of them, and have either trashed abandoned ones or updated one to go out in the hopper, we can close the ticket.
16:24:12 <jwf> Sound fair?
16:24:24 <bt0> sounds fair for me
16:24:28 <jwf> Awesome!
16:25:25 <jwf> #agreed Will mark ticket as blocked for now, pending feedback from all authors. Once we receive an answer from all authors, we can close the ticket. Articles that are given a +1 will make it onto the publishing schedule.
16:25:46 <jwf> bt0++ Seriously, thanks for your hard work on all of this. This was so helpful for me and something I wanted to do for months
16:25:50 <jwf> .thank bt0
16:25:50 <zodbot> jwf thinks bt0 is awesome and is happy they are helping! (Please don't forget to bt0++ also)
16:25:59 <dhanesh95> bt0++
16:26:04 <nauticalnexus> bt0++
16:26:04 <zodbot> nauticalnexus: Karma for bt0dotninja changed to 10 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:26:20 <jwf> And I think that's all for tickets…
16:26:31 <jwf> #topic Open floor
16:26:40 <nauticalnexus> Open floor you say!?
16:26:46 <jwf> Okay, we fit a lot into this meeting and it went… really fast, maybe faster than any meeting we've had in a while.
16:26:53 <x3mboy> Dance time!
16:26:57 <nauticalnexus> lol
16:27:09 <nauticalnexus> jwf, do.. do they know I'm new? :P
16:27:09 <jwf> I hope it wasn't too intense for folks – and maybe an earlier ending will let people have a chance to really sink in to some of this.
16:27:32 <skamath> \_(~_~)_\
16:27:40 <Rhea> Go confirm the attenDance
16:27:46 <Rhea> ...FAD stuff
16:27:50 <Rhea> And travel stuff.
16:27:53 <Rhea> o.o
16:27:55 <Rhea> o_o
16:27:55 <skamath> jwf, You're the admin of the main Fedora group right?
16:28:03 <jwf> nauticalnexus: Yeah, I was going to say, this meeting emphasized a single, really specific topic that wasn't as newcomer-friendly. I appreciate you jumping in and looking things over regardless, I know it can be a lot to process!
16:28:05 <Rhea> O_O
16:28:14 <jwf> Does anyone have any general questions before we close out?
16:28:30 <jwf> skamath: Hmm. Could you re-phrase? What is the main Fedora group?
16:28:31 * bt0 a quick afk
16:28:33 <skamath> As I mentioned earlier, it will be nice to pull some stats from that group. You might have to add a bot in there.
16:28:38 <skamath> jwf, the Telegram group.
16:28:48 <jwf> Oh! Yes, I am, along with a few others.
16:28:50 <nauticalnexus> jwf, no problems :) I'd love to help out wherever I can. I have a hard time with criticisism and stuff, criticising things, but I think I did good :P
16:28:56 <Rhea> I have a general nudge.
16:29:01 <skamath> Do you think people will have a problem with that?
16:29:09 <Rhea> TRAVEL ESTIMATE -> FAD WIKI
16:29:12 <jwf> skamath: If you have a bot, I can pitch it to the admins in our private group and see the reaction.
16:29:17 <skamath> It will be able to read all the messages in the group.
16:29:32 <jwf> #help FAD attendees, make sure to get your travel estimates into the FAD wiki page as soon as possible!
16:29:32 <commopsbot> meetbot.meeting.item.help -- jflory7 called for help in the "Fedora CommOps (2017-12-11)" meeting in #fedora-commops: "FAD attendees, make sure to get your travel estimates into the FAD wiki page as soon as possible!"
16:29:35 <jwf> Rhea: :)
16:29:42 <skamath> \o/
16:29:45 <jwf> Hah, I forgot commopsbot listens to the #help tag
16:29:53 <Rhea> imma pester you for that til y'all do
16:29:56 <Rhea> rawr
16:29:58 <jwf> nauticalnexus++ Your enthusiasm is awesome!
16:29:58 <zodbot> jwf: Karma for nauticalnexus changed to 2 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:30:05 <dhanesh95> jwf, skamath, bee2502 : Update on #108
16:30:06 <nauticalnexus> :O thanks
16:30:13 <skamath> jwf, That sounds good. I'll prepare a short markdown file with what the bot will have access to
16:30:31 <jwf> skamath: Sounds good. Feel free to get it to me whenever, I see it as a low priority task. So no big hurry on it.
16:30:37 <jwf> dhanesh95: Looking now
16:30:41 <Rhea> skamath: in general stats are okay, as long as it doesn't save any names or message contents
16:30:42 <skamath> nod nod
16:30:55 <jwf> dhanesh95: Ah, what's up?
16:31:02 <skamath> Rhea, Nope. Just to build fancy word clouds ;)
16:31:05 <jwf> Oh, I see now, you asked a question
16:31:34 <dhanesh95> jwf, skamath: I read the REST API documentation for WordPress and we won't be able to get any metrics or post statistics from them.
16:31:48 <Rhea> In other news, we've touched the 400 peeps mark on Discord.
16:31:48 <jwf> dhanesh95: I see it as critical for this ticket to reach out to stickster and ryanlerch for their thoughts on helpful data that we could get into fedmsg.
16:31:53 <jwf> dhanesh95: … :(
16:31:56 <nauticalnexus> There's a Fedora discord?
16:31:57 <dhanesh95> All of the APIs are related to posting, editing and other administration actions
16:31:58 <jwf> Bummer!!
16:31:59 <Rhea> https://www.carbonitex.net/discord/server?s=232740312194351106
16:32:01 <nauticalnexus> omg I didn't know about this
16:32:13 <jwf> nauticalnexus: Rhea set this one up, and it's bridged with IRC too. :) #fedora-discord I think
16:32:36 <jwf> dhanesh95: Hmmmm. We'll definitely have to revisit this one.
16:32:40 <skamath> dhanesh95, https://codex.wordpress.org/WordPress.org_API#Stats
16:32:42 <Rhea> nauticalnexus: discord.gg/fedora
16:32:49 <jwf> dhanesh95: For #108, could I action you to start a discussion on the Magazine list based on the info you have now?
16:32:58 <jwf> Or ping in #fedora-magazine, either or
16:33:05 <dhanesh95> jwf: Roger that
16:33:07 <jwf> (In IRC, you'll probably need to hang around for a bit)
16:33:09 <nauticalnexus> Rhea, aaa that isn't opening in the app :(
16:33:26 <Rhea> nauticalnexus: https://discord.gg/fedora
16:33:30 <Rhea> o.o
16:33:47 <jwf> #action dhanesh95 Reach out to Fedora Magazine team to get feedback on helpful data to incorporate into fedmsg via WordPress's REST API (note limitations of REST API too – what's helpful for what we can extract?)
16:33:58 <jwf> dhanesh95++ Thanks for tackling this one too!
16:33:58 <zodbot> jwf: Karma for dhanesh95 changed to 2 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:34:10 <jwf> We have a lot of things going on in parallel, this is nice :)
16:34:23 <skamath> jwf, That sure will be tricky. Afaik, stats api requires a privileged API token.
16:34:30 <jwf> Okay folks. Anything else before we close out the meeting?
16:34:44 <dhanesh95> skamath: Are you sure that is what we are looking for? I don't think so.
16:34:55 <jwf> skamath: We may be able to look into that, but it might be a question for Patrick too.
16:35:01 <jwf> Let's spend some time doing research and revisit
16:35:16 <jwf> Getting feedback from Paul and Ryan will be critical for this first
16:35:38 <jwf> Okay, last call for general questions / comments?
16:35:45 <jwf> Open floor, going once…
16:35:48 <nauticalnexus> jwf, I love FEdora
16:35:52 <nauticalnexus> is that a general comment
16:35:53 <nauticalnexus> :P
16:35:55 <jwf> Going twice…
16:35:57 <jwf> nauticalnexus: :)
16:36:01 <jwf> Going thrice…
16:36:03 <jwf> And soooold!
16:36:09 <jwf> Thanks everyone for all of the high energy today
16:36:13 <jwf> This was super motivating for me
16:36:19 <jwf> I hope it was the same for all of you too :)
16:36:20 <nauticalnexus> haha no problem. I had a good breakfast so that helped :P
16:36:24 <jwf> #endmeeting