19:00:27 <gregdek> #startmeeting community-working-group
19:00:27 <zodbot> Meeting started Wed Jul 13 19:00:27 2016 UTC.  The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:27 <zodbot> The meeting name has been set to 'community-working-group'
19:00:27 <rbergeron> not in three weeks, but you'll see everyone in 3 weeks?  i guess?
19:00:34 <gregdek> #topic Roll Call
19:00:40 * rbergeron exists
19:01:44 <gregdek> :)
19:01:55 <gregdek> Agenda as always: https://waffle.io/ansible/community
19:02:48 <gregdek> So, to take it from the top:
19:02:52 <rbergeron> aye.
19:03:02 <gregdek> #topic 93: Planning for Contributor Conference SF
19:03:50 <rbergeron> okay, we seem to have a bunch more feedback last i looked earlier today
19:04:09 <rbergeron> and we promised to send out an agenda -- and i suspect we'll be hosed next week, unless we put that together on monday.
19:04:11 <gregdek> Yes, but not a lot of actual votes. Just... more topics. :/
19:04:30 <rbergeron> well -- we could do a little poll o rsomething via google?
19:04:40 <gregdek> So I'd say, one more note to ansible-devel to urge +1s, and then if we don't have that by next Friday, we just pick 'em.
19:04:48 <rbergeron> are you coming, are you coming remotely, put a yes or not next to what you want to do
19:04:49 <gregdek> Yes, we could do some kind of poll, I imagine.
19:04:57 <rbergeron> but that is a pain and etherpad seems just as effective theoretically
19:05:03 <gregdek> Or not, LOL
19:05:21 <gregdek> I think the poll is actually a good idea. Just a quick Google form.
19:05:22 <rbergeron> well - i am happy either way. i just hate being like, "add your plus 1! well, you can't follow directions, so here is a poll"
19:05:35 <gregdek> Ain't it true? :)
19:05:43 <rbergeron> because some people won't see that, or will think their stuff got counted elsewhere, or whatever.
19:05:49 <gregdek> Yeah, good point.
19:06:04 <rbergeron> But I can make a poll. Or we can. Or whatever. Or we can jsut use our best judgement.
19:06:06 <gregdek> Then just reiterate the etherpad, and if we don't have any better data by next Friday, we'll just pick 'em.
19:06:18 <rbergeron> send the no hanging chads mail :)
19:06:32 <gregdek> ugh
19:06:34 <rbergeron> "for your vote to count, you actually have to... :D"
19:06:35 <rbergeron> lol
19:07:12 <rbergeron> so uh
19:07:18 <rbergeron> which of us is doing that urging
19:07:29 <gregdek> You!
19:07:48 <gregdek> Unless your time is right.
19:07:52 <gregdek> Er, tight.
19:08:00 <rbergeron> did you send the last one? I think you did
19:08:05 <gregdek> Did I?
19:08:07 <rbergeron> My rhymes are tight
19:08:10 <rbergeron> i can mail all night
19:08:13 <rbergeron> without a fight
19:08:15 <rbergeron> there is no plight.
19:08:21 <gregdek> Riiiiight.
19:08:22 <rbergeron> Email, i might!
19:08:29 <rbergeron> (i actually will, tho)
19:08:38 <gregdek> That's enough rhyming now. I mean it!
19:08:52 <rbergeron> #action rbergero to send rhyme-free pun-free mail reminder to plz vote with actual numbers on etherpad
19:09:01 <rbergeron> should i just respond to the mail you sent out?
19:09:08 <rbergeron> that seems logical
19:09:30 <rbergeron> i guess the problem is more topics get added
19:09:38 <rbergeron> and everyone assumes they already voted
19:09:39 <gregdek> Well, if that happens, fine.
19:09:50 <rbergeron> so then we're like "geeeeeez, why isn't this getting more votes"
19:09:53 <gregdek> Worst case scenario is we do our best to pick 'em.
19:09:56 <rbergeron> I dunno. I'll write something up
19:10:00 <rbergeron> and we'll plow ahead
19:10:06 <rbergeron> next item!
19:10:35 <gregdek> Well, still on this one... re: the room, we've got, what, 20ish? I think that's pretty good. We should probably wrap that up here in the next day or two.
19:10:56 <gregdek> Don't actually know that there's an action item there per se. I just think we're in good-ish shape.
19:10:56 <rbergeron> aye.
19:11:13 <rbergeron> did we want to blog post or anything for anyone who might be coming to ansiblefest who might be interested in coming / learning / whatever?
19:11:16 <rbergeron> or not so much
19:11:47 <gregdek> Nah. I think it needs to be a working session, and the people who are participating now are the right people. It's not really the kind of thing for a drop-in.
19:11:58 <gregdek> It's almost like the "Ansible Midcycle" when you get right down to it.
19:12:51 <rbergeron> ... maybe :) lol
19:12:54 <rbergeron> but okay.
19:13:13 <gregdek> OK.
19:13:17 <gregdek> Next item!
19:13:33 <gregdek> #topic 81: Module Maintainer Guidelines
19:14:23 <rbergeron> okay, per notes in the issue: i updated the version i have in my repo (rather than just mangle the real thing) -- i think it's okay, just have this outstanding question re: the things that alikins had in a fork of the contributors.md file
19:14:48 <rbergeron> because i think those things really should be in contributors.md and not in maintainers.md
19:14:56 <rbergeron> just pointed to from contributors.md
19:14:59 <rbergeron> err
19:15:01 <rbergeron> from maintainers.md
19:15:08 <gregdek> Hrm.
19:15:17 <rbergeron> or a good chunk of them.
19:15:28 <rbergeron> you're not a maintainer until you write a thing.
19:15:32 <gregdek> Yes.
19:15:44 <rbergeron> and you need to know those guidelines regardless of being maintainer or just contributor to random module maintained elsewhere.
19:15:54 <rbergeron> maintainer == more what my long-term responsibilities are.
19:15:59 <gregdek> Yeah.
19:16:11 <rbergeron> ... yet "hrm" sounds skeptical.
19:16:13 <rbergeron> :)
19:16:51 <gregdek> No, it's just easy to over-analyze. For now, I'm happy with (a) getting alikins to submit a PR with his CONTRIBUTORS.md changes, and (b) getting your changes into MAINTAINERS.md.
19:17:04 <gregdek> Because it will be better than what we have now.
19:17:15 <gregdek> We may later decide it's insufficient in some way, but it's better than what we have now.
19:17:23 <gregdek> That's my sense.
19:17:49 <rbergeron> okay. well, let's poke at adrian to make that PR, and then merging my stuff should be piece of cake.
19:19:13 <gregdek> Sounds good.
19:19:18 <rbergeron> how do you feel about the rest? missing anything?
19:19:29 <rbergeron> overly sappy?
19:19:35 <rbergeron> too mean?
19:19:37 <rbergeron> :)
19:20:30 <gregdek> No, it's good.
19:20:32 <rbergeron> also, does that PR from alikins (or to be PR from alikins) ... count as the work needed for #78?
19:20:59 <rbergeron> or some of it at least?
19:21:04 <gregdek> ...not quite yet, I don't think. Some of it probably.
19:21:09 <rbergeron> okay.
19:22:52 <gregdek> I'll ping alikins.
19:23:01 <gregdek> Shall we move on?
19:23:31 <rbergeron> yesplz
19:25:02 * rbergeron looks at gregdek wondering if she's driving the bus now
19:25:40 <rbergeron> or if there is lag
19:25:47 <gregdek> Sorry
19:26:05 <gregdek> #topic 38: Public Metrics
19:26:21 <gregdek> This one is on newtMcKerr, and he's waiting for some Google stuff to sort out, so we'll defer this one for now.
19:26:24 <gregdek> Any Qs?
19:26:45 <rbergeron> um - one, i guess
19:26:57 <rbergeron> once we have that stuff sorted out -- what's the reporting mechanism, really?
19:27:21 <rbergeron> are we going to mail things out occasionally or do we want to just have a spreadsheet that front ends to .. one of those pretty boards i had previously, or what?
19:27:27 <rbergeron> just thigns to ponder on - don't need to know today.
19:27:42 <rbergeron> but should probably figure out at some point. if they're public, where is that public place :)
19:28:14 <rbergeron> other than that: no questions
19:28:21 <gregdek> I would very much like some kind of dashboard, but it should really be as cheap as we can do it effort-wise :)
19:28:29 <rbergeron> kudos to newtmckerr for awesomeness
19:28:32 <rbergeron> aye. agreed
19:29:04 <rbergeron> well -- i know of options since i've dug into all this before, so ... I think we find something that is good enough, smart enough, and easy enough
19:29:13 <rbergeron> without being 47 billion dollars
19:29:16 <rbergeron> :)
19:29:20 <gregdek> kk
19:29:24 <gregdek> Next:
19:29:37 <gregdek> #topic 47: Testing Working Group
19:29:44 <gregdek> Nice work by gundalow to move this one along...
19:29:54 <gregdek> And by mattclay as well
19:30:01 <gregdek> gundalow: any status update?
19:31:13 <gregdek> I know gundalow said he's be in and out, so I'll give him a min or two, and then we'll move on
19:31:36 * rbergeron nods
19:31:46 <gundalow> Hi
19:31:51 <gundalow> Me reads back
19:32:27 <gundalow> Ah
19:32:40 <gregdek> :)
19:32:44 <gundalow> Testing working group will formally start after AnsibleFest
19:33:11 <gundalow> Weekly meetings (not Wednesday).
19:34:02 <gundalow> Next step is add any questions we have to the Contributors summit Document.
19:34:17 <gundalow> Which is out for review internally at Ansible.
19:34:50 <gundalow> Then have we can have a productive section of the Contributors Summit as we have an aim
19:35:00 <gregdek> Sounds good to me :)
19:35:05 <gundalow> Think that's it
19:35:43 * rbergeron added some comments, may add a few more, as fyi
19:36:50 <gundalow> rbergeron: Sweet, thanks. I'm not going to add it to either pad till next week,  so feel free time  keep adding stuff
19:36:50 <gregdek> OK.
19:37:01 <rbergeron> gundalow: ack, sounds good
19:37:04 <gregdek> Thanks for the update gundalow
19:37:06 <gundalow> :)
19:37:08 <gregdek> Moving on:
19:37:21 <gregdek> #topic 104: Ansible Durham meetup
19:37:39 <gregdek> Looking at the week of 8/8 with House. Probably Thu 8/11.
19:37:54 <gregdek> Will look at availability of venues and so forth and get that up in the coming days.
19:38:38 <gregdek> Any Q there?
19:38:39 * rbergeron nods
19:38:42 <rbergeron> nope.
19:39:54 <gregdek> Next:
19:39:58 <rbergeron> #topic Ansible phx meetup
19:40:02 <rbergeron> oh
19:40:05 <rbergeron> no chair for me
19:40:07 <gregdek> You got it
19:40:10 <gregdek> Grrr.
19:40:15 <rbergeron> i don't got it
19:40:15 <gregdek> #topic 42: Ansible phx meetup
19:40:21 <gregdek> #char rbergeron
19:40:26 <gregdek> #chair rbergeron
19:40:26 <zodbot> Current chairs: gregdek rbergeron
19:40:27 <rbergeron> do not char me.
19:40:30 <rbergeron> please.
19:40:32 <gregdek> FOOOM
19:40:43 <rbergeron> i am hot enough already
19:40:45 <rbergeron> anyway.
19:41:14 <rbergeron> I have pinged the red hat folks and there is juggling looking. i pinged other folks for independent spaces and .. waiting and seeing. I did think of another human that may be more flexible.
19:41:24 <rbergeron> People kind of hate summer meetups here basically
19:41:31 <gregdek> FAIR ENOUGH
19:41:32 <rbergeron> hosting, going, you name it
19:41:52 <rbergeron> but ... poiking for a venue at this rate might get me something in september when it's slightly less awful
19:42:07 <rbergeron> I think the nice citrix folks might hook me up though
19:42:12 <rbergeron> so I will ping chris
19:43:08 <gregdek> ok!
19:43:11 <rbergeron> I updated the issue.
19:43:17 <gregdek> thx :)
19:43:30 <gregdek> That's all the big stuff.
19:43:50 <rbergeron> thank goodness
19:43:51 <gregdek> And then next week is all-hands, and then week after that is fest!
19:43:56 <gundalow> woot
19:43:56 <rbergeron> #topic open floor
19:44:01 <gregdek> So really it's all about Fest at this point.
19:44:03 <rbergeron> i'll just do that,
19:44:05 <rbergeron> lol
19:44:06 <gundalow> Though no hands for me
19:44:17 <rbergeron> :(
19:44:35 <gundalow> Had already booked holiday
19:44:39 <rbergeron> I will be in many abstracts for talks ... land the next day or so
19:44:58 <rbergeron> at least the rest of today (openstack summit) and then i have to actually come up with my thing for automacon and apparently containercon
19:45:51 <rbergeron> And yes, fest is about it. :) wooo
19:46:43 <rbergeron> anyone else have anything to chat about?
19:46:52 <rbergeron> burning questions?
19:46:55 <rbergeron> hot gossip?
19:47:01 <rbergeron> free winning lottery tickets?
19:47:43 * gundalow will be in SF from Sun 24th so poke me for beer based meetings :)
19:47:58 <rbergeron> lol. that will be no problem, i am sure
19:48:14 <gundalow> :)
19:48:40 <rbergeron> gregdek: you have anything else?
19:48:44 <gregdek> I do not.
19:48:49 <gregdek> Oh...
19:48:54 <rbergeron> you do.
19:49:00 <gregdek> ...except I'm gonna try to get the damned issue bot done this week.
19:49:08 <gregdek> Finally.
19:49:11 <gregdek> Wish me luck.
19:49:15 <rbergeron> it's a blessed issue bot, actually
19:49:22 <rbergeron> :)
19:49:23 <gundalow> Nothing else from me
19:49:29 <rbergeron> let me know when i can be your guinea pig
19:49:35 <gregdek> rbergeron: will do.
19:50:01 <rbergeron> or .. alternately, take the corner case not guinea pig things and just start whittling as you can get through and refine things
19:50:04 <rbergeron> :)
19:50:09 <rbergeron> (i will take the corner cases)
19:50:11 <rbergeron> just lmk.
19:50:16 <rbergeron> and: now that's it?
19:50:52 <gregdek> That's it!
19:50:55 <gregdek> #endmeeting