#ansible-meeting: Contributors Follow up meeting

Meeting started by gundalow at 10:16:03 UTC (full logs).

Meeting summary

    1. ACTION: gundalow http://docs.ansible.com/ansible/dev_guide/developing_modules_general.html#testing-your-module should point to testing.html (gundalow, 10:18:01)
    2. ACTION: gundalow http://docs.ansible.com/ansible/dev_guide/ "Testing Your Module" should be removed (gundalow, 10:18:29)
    3. Wednesdays meeting notes: Main session: #actions & #infos: https://meetbot.fedoraproject.org/ansible-meeting/2017-06-21/ansiblefest_london.2017-06-21-08.27.html (gundalow, 10:20:19)
    4. Wednesdays meeting notes: Main session: raw logs: https://meetbot.fedoraproject.org/ansible-meeting/2017-06-21/ansiblefest_london.2017-06-21-08.27.log.html (gundalow, 10:21:34)
    5. Wednesdays meeting notes: Zuul #actions & #info https://meetbot.fedoraproject.org/ansible-meeting/2017-06-21/ansiblefest_developer_conference_-_zuul.2017-06-21-13.53.html (gundalow, 10:22:06)
    6. Wednesdays meeting notes: Zuul #actions raw logs: https://meetbot.fedoraproject.org/ansible-meeting/2017-06-21/ansiblefest_developer_conference_-_zuul.2017-06-21-13.53.log.html (gundalow, 10:22:19)

  1. Open Floor (gundalow, 10:23:27)
    1. https://github.com/ansible/ansible/pull/19554 <- rebased now. Should be ok (shaps, 10:26:59)
    2. https://github.com/openstack-infra/zuul/blob/feature/zuulv3/zuul/ansible/paths.py (mordred, 11:11:35)

  2. Zuul & Ansible (gundalow, 12:28:27)
    1. ACTION: Zuul to add example test for "make authors" returns over 1000 lines which gives a basic test (gundalow, 12:29:36)
    2. ACTION: Zuul to add example test which ensures Ansible libs are available: "./test/runner/ansible-test --help" (gundalow, 12:30:28)
    3. AGREED: zuul will most likely just be a wrapper round ansible-test (gundalow, 12:36:15)
    4. in the future (post v1) we may want to use Zuul like ansible-core-ci to specify remote notes to test against against, which would be good for parallel runs, like Windows (gundalow, 12:38:20)
    5. http://docs.ansible.com/ansible/dev_guide/testing_units.html shows how to use Ansible-test to install dependencies: e.g. ansible-test units --tox --python 2.7 --requirements apache2_module (gundalow, 12:41:42)
    6. https://github.com/bcoca/ansible/commits/update_json (abadger1999, 13:47:30)
    7. ACTION: gundalow to add links to https://codecov.io/gh/ansible/ansible/ from testing docs (gundalow, 14:42:56)
    8. ACTION: gundalow Look at https://skillsmatter.com/event-space#event_spaces (gundalow, 14:50:07)
    9. ACTION: gundalow to get DCI group linked in with TWG (gundalow, 15:01:29)
    10. ACTION: gundalow to bring Matt Clay upto speed with DCI (gundalow, 15:01:40)
    11. ACTION: gundalow https://github.com/ansible/ansible/pull/25915 (gundalow, 15:14:51)


Meeting ended at 16:36:05 UTC (full logs).

Action items

  1. gundalow http://docs.ansible.com/ansible/dev_guide/developing_modules_general.html#testing-your-module should point to testing.html
  2. gundalow http://docs.ansible.com/ansible/dev_guide/ "Testing Your Module" should be removed
  3. Zuul to add example test for "make authors" returns over 1000 lines which gives a basic test
  4. Zuul to add example test which ensures Ansible libs are available: "./test/runner/ansible-test --help"
  5. gundalow to add links to https://codecov.io/gh/ansible/ansible/ from testing docs
  6. gundalow Look at https://skillsmatter.com/event-space#event_spaces
  7. gundalow to get DCI group linked in with TWG
  8. gundalow to bring Matt Clay upto speed with DCI
  9. gundalow https://github.com/ansible/ansible/pull/25915


Action items, by person

  1. gundalow
    1. gundalow http://docs.ansible.com/ansible/dev_guide/developing_modules_general.html#testing-your-module should point to testing.html
    2. gundalow http://docs.ansible.com/ansible/dev_guide/ "Testing Your Module" should be removed
    3. gundalow to add links to https://codecov.io/gh/ansible/ansible/ from testing docs
    4. gundalow Look at https://skillsmatter.com/event-space#event_spaces
    5. gundalow to get DCI group linked in with TWG
    6. gundalow to bring Matt Clay upto speed with DCI
    7. gundalow https://github.com/ansible/ansible/pull/25915
  2. UNASSIGNED
    1. Zuul to add example test for "make authors" returns over 1000 lines which gives a basic test
    2. Zuul to add example test which ensures Ansible libs are available: "./test/runner/ansible-test --help"


People present (lines said)

  1. gundalow (36)
  2. abadger1999 (12)
  3. bcoca (12)
  4. shaps (8)
  5. zodbot (7)
  6. hyperized (5)
  7. misc (2)
  8. mordred (2)
  9. Shrews (2)
  10. jimi|ansible (2)
  11. jhogarth (0)


Generated by MeetBot 0.1.4.