13:00:40 <mattdm> #startmeeting Council (2017-09-20)
13:00:40 <zodbot> Meeting started Wed Sep 20 13:00:40 2017 UTC. The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:40 <zodbot> The meeting name has been set to 'council_(2017-09-20)'
13:00:41 <mattdm> #meetingname council
13:00:41 <zodbot> The meeting name has been set to 'council'
13:00:43 <mattdm> #chair mattdm jkurik jwb langdon robyduck bexelbie jwf
13:00:43 <zodbot> Current chairs: bexelbie jkurik jwb jwf langdon mattdm robyduck
13:00:45 <mattdm> #topic Introductions, Welcomes
13:00:49 <bexelbie> .hello bex
13:00:50 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bex@pobox.com>
13:00:59 <mattdm> good morning or afternoon everyone!
13:01:24 <jwb> i am actually here
13:01:31 <mattdm> nice :)
13:01:48 <mattdm> robyduck noted that he probably can't make it due to family commitments
13:01:49 <langdon> .hello2
13:01:50 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
13:02:06 <mattdm> so that leaves jwf and jkurik ...
13:02:07 <jkurik> .hello2
13:02:08 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
13:02:11 <mattdm> aha!
13:02:51 * mattdm will wait one more minute for jwf and then go to the agenda...
13:03:39 <jkurik> Hi Council people
13:04:05 <mattdm> okay, agenda...
13:04:09 <mattdm> #topic Today's Agenda
13:04:15 <mattdm> #info 1. Approval for Fedora internationalization group FAD in Nov, 2017
13:04:17 <mattdm> #info 2. New wording for diversity advisor
13:04:19 <mattdm> #info 3. Should we require interview questions to be completed before the election starts?
13:04:21 <mattdm> #info 4. Preliminary approval of new Fedora Playground concept (logo tk)
13:04:50 <mattdm> and we'll do open floor if there's time.
13:04:55 <mattdm> #topic Approval for Fedora internationalization group FAD in Nov, 2017
13:04:57 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/136
13:05:16 <mattdm> This has gone through some revision
13:05:44 <mattdm> bex is +1 in ticket with revisions, and jwb was originally
13:05:55 <mattdm> Anyone have further resevations or should we approve this?
13:06:29 <jwb> still +1, though i lost how it went from $5k to $6800
13:06:39 <langdon> did you want to talk about the free-software/govt money thing?
13:06:42 <bexelbie> they added at least one if not two more people
13:06:59 <mattdm> langdon: I'll stick that at the end if we have time
13:07:00 <langdon> oops.. i missed the "more agenda " bit cause of misreading
13:07:04 <langdon> mattdm: ack
13:07:09 <jkurik> I believe the organizers provided sufficient justification, so I am +1
13:07:48 <mattdm> one of our initial criticisms was "hey this seems like a bunch of red hat people having a team meeting", so they made sure to include other fedora contributors as well
13:08:10 <mattdm> I'm +1 too. Anyone -1 in the next minute, or I'm gonna mark as approved.
13:08:28 <mattdm> (because this has been open for a month)
13:09:05 <mattdm> ok sold :)
13:09:34 <mattdm> #topic New wording for diversity advisor
13:09:36 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/137
13:09:53 <mattdm> note this was a private ticket and I just now made it unprivate because I don't think we're doing anything particularly sensitive
13:10:20 <mattdm> We have general consensus on the plan (make this position be appointed by the diversity team)
13:10:48 <mattdm> but there is an open question over whether it should be a minor rewording or basically made parallel with the engineering and mindshare reps
13:11:12 <mattdm> the later of which would elevate the role to full council member rather than advisory
13:11:34 <mattdm> er auxiliary
13:12:04 <jwb> what would be gained by doing that?
13:12:30 <mattdm> bexelbie, that's your suggestion. go. :)
13:12:50 <bexelbie> I believe it shows that we consider diversity to be an important part of our project and puts equal to other reps
13:13:00 <bexelbie> I guess, I don't understand what we lose by doing this
13:13:53 <mattdm> I *do* consider it to be important, for the record
13:14:40 <mattdm> My concern is that the current mindshare / engineering division lends itself naturally to an org chart, with fesco and releng and qa and fpc and etc. under engineering and famsco, design, docs, etc. under mindshare
13:15:00 <mattdm> whereas in that picture diversity would have one tiny team
13:15:23 <mattdm> rather than being responsible for diversity/inclusion efforts across the project
13:16:23 <langdon> mattdm: which "picture"? full council or aux?
13:17:10 <mattdm> langdon: "picture" as "map of the overall project", and putting diversity advisor at the same place on the map
13:17:14 <jwb> bexelbie: logistically, it doesn't make sense
13:17:26 <bexelbie> At the time the position was created it was appointed and logically fit next to the more limited influence theory that guides the program manager
13:17:29 <bexelbie> the position is no longer appointed
13:17:57 <mattdm> bexelbie: well, the plan is for it to be appointed still -- all of these positions are
13:18:03 <mattdm> but by the team rather than by me.
13:18:16 <jwb> bexelbie: and i think making it a liaison position sets it up for failure. as mattdm says, diversity isn't a separate, concrete thing. it is something that needs to be done across groups
13:18:32 <bexelbie> but we don't limit the impact of other appointed positions like mindshare
13:18:37 <bexelbie> and fesco rep
13:18:45 <bexelbie> s/impact/influence/
13:18:48 <jwb> eng rep
13:18:55 <jwb> eng rep goes beyond fesco
13:18:58 <bexelbie> yes, eng rep - sorry
13:19:54 <jwb> i'm not for or against either positioning. i simply think or diversity to work, they need to be empowered to work across all groups. however that plays out best is what i'll support
13:20:11 <bexelbie> jwb, +1 in agreement to that
13:20:20 <mattdm> We can always draw it up out of Auxillary Seats to full council without putting it in parallel with those other positions
13:20:22 <bexelbie> I don't want us to get stuck painting the shed on this one either
13:21:16 <langdon> i suspect it will have more to do with how "we" treat the position and person than any text.. we can always change the text..
13:21:57 <mattdm> I'd get rid of "Auxiliary Seats" entirely as a heading, and list Diversity [Bikeshed term] and FPgM at the higher level, and just move the wording around auxiliary to the FPgM description
13:22:34 * langdon having expansion fail.. FPgM?
13:22:46 <bexelbie> Fedora Program Manager
13:22:52 <langdon> duh.. right
13:23:06 <bexelbie> Also, we may need to note that the FCAIC is hired by Red Hat ...
13:23:11 <mattdm> we should have a zodbot acronym extender
13:23:15 <bexelbie> we could even group FCAIC, FPL and FCAIC on that basis :)
13:23:21 <bexelbie> no mattdm we should not :P
13:24:00 <jkurik> zodbot: what does mean FCAIC ?
13:24:00 <zodbot> jkurik: No such package exists.
13:24:01 <mattdm> bexelbie: yeah, that's a good point. I'll do that while I'm rearranging
13:24:07 <mattdm> lol
13:24:23 * bexelbie exists
13:24:52 <mattdm> does anyone want to keep the diversity advisor at the auxilliary level?
13:25:37 <mattdm> *crickets*
13:25:41 <jkurik> in case there will be any auxiliary position, then it makes sense to me; otherwise no
13:26:00 <mattdm> I'll move it up, and I'll move FPgM to be next to FPL and FCAIC
13:26:17 <mattdm> #action mattdm rewriting for council page
13:26:19 <jwb> i am only qualified to say Diversity is important. do whatever you need to do to reflect that
13:26:42 <mattdm> In the spirit of lazy consensus and action and stuff, I'm going to just do the edits in the wiki live and then if there are things we need to change we can.
13:27:06 <mattdm> ok next.
13:27:08 <mattdm> #topic Should we require interview questions to be completed before the election starts?
13:27:10 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/135
13:27:44 <langdon> what, possibly, could be the argument against this proposal?
13:28:08 <stefw> langdon ++
13:28:10 <mattdm> jkurik's argument was that it's already hard enough to find candidates for some positions
13:28:30 <mattdm> oh hi stefw!
13:28:35 <mattdm> #chair stefw
13:28:35 <zodbot> Current chairs: bexelbie jkurik jwb jwf langdon mattdm robyduck stefw
13:28:37 <jwb> langdon: my argument was it depends on the committee
13:28:49 * mattdm needs to update the meeting template. sorry about that stefw!
13:28:51 <jwb> in general though, it's a good idea
13:28:53 <stefw> hey mattdm ... thanks
13:29:17 * langdon totally did not see all the replies in the ticket.. my bad
13:29:18 <jkurik> almost every elections we have a problem to find nominees, this might put the bar even higher
13:29:41 <mattdm> I am in favor of just making it a general rule rather than making every group be different
13:30:34 <mattdm> Groups that are concerned about it being a barrier could work with the elections wrangler to make the interview questions for that body short and easy
13:31:04 <mattdm> If I'm the only one who thinks this, though, I'll go along with what the rest of you are saying
13:31:17 <langdon> or "generatable" .. like if fesco thinks "package count" or something matters, just gen the answer
13:32:09 <bexelbie> On the one hand I am very in favor of "you shouldn't be elected if you won't spend a few minutes telling us why ..."
13:32:27 <bexelbie> on the other hand, I dno't want to be so parochial that we refuse to let people vote in "black boxes"
13:32:47 <bexelbie> who may not be opaque in particular parts of the project
13:33:07 <bexelbie> maybe the rule is that if there is no specific group requirement beyond FPCA+1 then you have to do the interview
13:33:17 <bexelbie> otehrwise it is up to the group(s) electing the position?
13:33:35 <langdon> i would also point out, for the last few cycles, i think we have had a fair number of candidates for every position.. so the argument about the "barrier to entry" may be less valid these days
13:33:37 <mattdm> that seems a lot more complicated than a simple policy of "do the interview".
13:33:54 <mattdm> and yeah, I agree, we've had a decent number of candidates in the last few years of elections
13:33:56 <bexelbie> mattdm, the policy is more complex, I believe the implementation is not
13:35:12 <jwb> need to switch networks. brb
13:35:18 <mattdm> bexelbie: Can you put that policy in the form of a proposal?
13:37:05 <bexelbie> #proposal - Positions elected by generally by the Fedora community (FPCA+1 voting requirement) are required to complete an election interview article which will be linked in the elections application. Positions elected by a subset of the Fedora community (FPCA+specific group(s)) must complete an interview or whatever other requirements are put forward by their electing groups.
13:37:10 <bexelbie> there is a first draft
13:37:35 <mattdm> sure, fine with me
13:37:40 <mattdm> anyone hate that?
13:38:01 <jwb> +1
13:38:49 <jkurik> should the interview be published before the candidate is considered as "accepted" ?
13:38:55 * langdon reads
13:39:19 <mattdm> jkurik: Interview should be sent in, at least. Not necessarily published since that's out of their control
13:39:21 <bexelbie> I think the interview is a gateway for getting on to the ballot
13:39:21 <langdon> couple comments
13:39:44 <langdon> "Positions elected by the general Fedora community" and
13:40:11 <langdon> "interview questions will be available before nominations are started" or something
13:40:21 <langdon> my problem with it was timing..
13:41:13 <bexelbie> langdon, I think that is a calendar issue - we need to get the questions out sooner
13:41:26 <bexelbie> or is there something that is a blocker to having the interview be required by the time voting starts?
13:41:44 <langdon> bexelbie: yes.. but.. i don't want to "sign up for a position" w/ required interview questions w/o knowing what they are
13:42:09 <langdon> bexelbie: no.. i agree with mattdm above.. i want the *questions* available before nominations start
13:42:19 <bexelbie> jkurik, could we update the elections timeline to require the questions be finalized before the nominations start
13:42:32 <jkurik> bexelbie: yes, we could
13:42:37 <bexelbie> and if we do nominations by wiki (I think we do??) can we add the questions to that page to make it clear (or at least a link)?
13:43:51 <jkurik> I might prepare a new schedule reflecting the need for an early questionaire and we can revisit it the next Council meeting
13:44:41 <bexelbie> +1000 for review of that schedule :) even in a ticket only form
13:44:45 <mattdm> +1 to all of this :)
13:45:20 <langdon> one more comment
13:45:56 <mattdm> okay, so bexelbie can you put the proposal with whatever rewordings make langdon happy in the ticket? and jkurik, new schedule proposal for next week?
13:46:01 <langdon> i think the interview "answers" should *not* be posted until immediately before the election, preferably at the same time (or close to each other).. no matter when the answers come in..
13:46:31 <bexelbie> langdon, +1
13:46:44 <langdon> i just saw this problem in a local election where someone who got on the interview questions early was hurt by the early publication and the later people publishing right before the actual election
13:46:58 <jkurik> #actio jkurik to prepare election schedule reflecting a need for an early questionaire
13:47:03 <jkurik> #action jkurik to prepare election schedule reflecting a need for an early questionaire
13:47:12 <bexelbie> mattdm, you want to do ticket voting on this?
13:47:58 <mattdm> bexelbie: Yeah, let's do that. because, clock.
13:48:34 <mattdm> ready for next topic?
13:48:49 <langdon> as i am always the late typer +1
13:48:51 <langdon> :)
13:49:02 <mattdm> topic Preliminary approval of new Fedora Playground concept
13:49:04 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/129
13:49:10 <bexelbie> langdon, and others see https://pagure.io/Fedora-Council/tickets/issue/135#comment-467116 please
13:49:29 <mattdm> jwb says he still doesn't know what this is for
13:49:36 <jwb> i don't
13:50:18 <bexelbie> do we have other candidates for this than Boltron?
13:50:21 <jwb> i remember talking about it with you at devconf long ago, but i've lost why we need a separate distinguishing identifier and how it would actually work vs. e.g. Spins
13:50:28 <mattdm> When I was doing Fedora Cloud stuff, multiple times I ran into "that stuff you just made, with Fedora bits in Fedora infrastructure, cannot be called REALLY FEDORA, because you didn't go through $hoops"
13:50:55 <mattdm> Spins, for example, require a certain level of hoop-jumping. there's a formal process and they're rather restricted in what they can do
13:51:08 <mattdm> Some of that is for good reason. Like, you can't have a spin with SELinux off
13:51:24 <bexelbie> I don't know if this is still the case, but I remember someone presenting that COPR slowed down the onboarding of new packages as people stopped at COPR ... do we create that risk here?
13:51:42 <jwb> a big part of the hoops are for HOSTING that content
13:51:54 <jwb> is playground going to be hosted on fedora infrastructure/mirrors?
13:52:23 <mattdm> I think playground things could be hosted in the "alt" section of the mirrors.
13:52:27 <jwb> because in the past, those $things that people made were always "look! i did this. host it and promote it!"
13:52:38 <jwb> and ... we're not a hosting service
13:53:11 <jwb> is playground constrained to an artifact type? e.g. containers?
13:53:30 <jwb> because COPR covers RPMs. spins covers isos.
13:53:34 <mattdm> No, it shouldn't be. It should be able to adapt to the next artifact type we haven't even considered yet.
13:53:46 <jwb> still not making sense to me.
13:54:08 <mattdm> hmm.
13:54:15 <mattdm> Does it make sense to *anyone* besides me? :)
13:54:23 <jwb> maybe a concrete example will help?
13:54:42 <jwb> the old incarnation of playground was a repo of selected COPR packages. it went nowhere
13:55:19 <mattdm> I think Atomic in its first incarnation would have been a great example.
13:55:58 <mattdm> To address bexelbie's question: the alternative is generally that people do the thing not in Fedora at all
13:56:14 <bexelbie> I am not seeing this come up enough to warrant creating structure for it -- maybe the problem is that those people are already self-selecting out
13:56:15 <mattdm> and possibly try to get it back in later, which is harder than incubating it inside the project
13:56:20 <jwb> mattdm: what does "in fedora" mean
13:57:04 <bexelbie> I could be +1 to this if it came with a review in a year and the opportunity to remove the infrastructure if not needed/used ... that way we don't have ot have this around forever if it isn't used
13:57:15 <bexelbie> we have a few ghosts around ... let's not let anymore get created
13:57:22 <jwb> bexelbie: i don't even know what the infrastructure is supposed to be
13:57:31 <bexelbie> the logo, process, approvals, etc
13:57:31 <mattdm> jwb: Largely, it means "in association with the Fedora name", and for it to be considered a Fedora thing in mailing list and whatever else discussions
13:57:46 <mattdm> It's not meant to be heavyweight. That's kind of the point.
13:57:56 <smooge> mattdm, you didn't #topic I think
13:58:01 <jwb> mattdm: well, the bar there has been the ability to download it off of fedoraproject.org
13:58:09 <bexelbie> jwb, I understand this to be content that passed licensing, philosophy, and was built by us but didn't necessarily pass QA and isn't ready for reliable use
13:58:11 <mattdm> smooge: ugh
13:58:15 <mattdm> #topic Preliminary approval of new Fedora Playground concept
13:58:31 <mattdm> #info oops forgot to start the topic. scrollback for more.
13:58:45 <jwb> mattdm: and rel-eng refuses to host artifacts that aren't built from fedora infra for obvious reasons
13:58:56 <jwb> bexelbie: "built by us" is where the hoops come in
13:59:12 <mattdm> I'd be curious if langdon, stefw, robyduck, jwf, jkurik (and smooge and anyone else) see where I'm going with this or are as unclear as jwb
13:59:21 <smooge> I have no clue
13:59:25 <bexelbie> jwb, are we not able to build something that doesn't pass tests?
13:59:32 <stefw> jwb, ... so the Fedora requirements for CI/CD explicitly allow stuff to be built elsewhere
13:59:40 <jwb> bexelbie: this has nothing to do with tests
13:59:46 * jkurik is a bit lost in the discussion
13:59:47 <stefw> https://fedoraproject.org/wiki/Fedora_requirements_for_CI_and_CD
13:59:50 <mattdm> yeah FESCo just okayed that.
13:59:50 * bexelbie read $hoops as tests
13:59:53 * langdon got distracted by other meeting... reading scrollback
14:00:04 <bexelbie> what other hoops are there?
14:00:07 <smooge> i look at anything with alt and see a mostly unmirrored mess of data that causes people trouble if they 'rely' on it
14:00:15 <jwb> bexelbie: no, hoops generally means rel-eng commits to building $thing and infra commits to hosting $thing
14:00:21 * bexelbie wonders if we need an official Cooper for all of our hoops (that was funnier in my head)
14:00:30 <mattdm> bexelbie: no hoops can be a lot more than tests. It can be "built in koji" or "built by a releng person not by you" or can be non-releng related things
14:01:07 <jwb> mattdm: if playground is supposed to be an arbitrary service that lets people produce RPMs/isos/containers from fedora content... that's a pretty large undertaking
14:01:07 <stefw> Q1: I wonder where the overlap is with non-Released Fedora content ... such as developer content or the Fedora Atomic Host Developer Stream that FESCO approved here:
14:01:12 <stefw> https://pagure.io/fesco/issue/1774
14:01:31 <mattdm> jwb: No, it's not supposed to be that at all.
14:01:38 <bexelbie> mattdm, so is this a short cut to hosting? (going back to jwb's hosting point ...)
14:01:47 <jwb> mattdm: then i'm back to not knowing what this is at all
14:02:00 <mattdm> I would expect okayed projects to have some hosting available
14:02:12 <mattdm> okay, i clearly have more homework here. I'll come back with more concrete examples.
14:02:20 <mattdm> stefw: That's a good question :)
14:02:55 <langdon> i would think if it was something like boltron it might make sense.. as in, a number of projects want to ship a preview release.. so we have a potentially borked version of the distro.. but anyone can apply to get in.. so you can use it for user feedback but not have to make it "real" yet
14:03:31 <mattdm> langdon: yes!
14:03:41 <mattdm> boltron would definitely be a Fedora Playground Thing.
14:03:53 <langdon> i was kinda saying boltron == fpt
14:03:54 <jwb> i think that's somewhat dumb
14:04:11 <langdon> i also wonder if arb branching and modularity may make this kinda moot.. if you can ship your previews as just a preview stream.. and it "just works"
14:04:14 <mattdm> I have to run off, y'all. jwb quick tell me why I'm dumb and then we'll close the meeting :)
14:04:33 <jwb> generalizing cases like boltron and atomic developer stream to "playground" under the premise that there are less hoops is a lie
14:05:00 <jwb> both of those are specific deliverables that solved their own hoops questions separately
14:05:44 <jwb> and even under a playground moniker, we're still evaluating and approving on a case by case basis
14:05:49 <jwb> so there's 0 need for a new moniker
14:06:09 <jwb> because it doesn't apply to things like you originally described with your cloud images
14:06:50 <mattdm> I think there's a use because having the moniker makes it clear that we're open to that. But possibly we could make that more clear in other ways.
14:07:01 <jwb> propose an Objective.
14:07:05 <mattdm> I do have to go. I'll think more about this. Thanks jwb.
14:07:09 <jwb> we want more of those, right?
14:07:11 <mattdm> and, yes, maybe that's where it goes.
14:07:34 <mattdm> (do you all want me to endmeeting or do you want to go on without me?)
14:08:19 <mattdm> okay then
14:08:21 <mattdm> #endmeeting