16:00:26 <mattdm> #startmeeting Council (2018-06-20)
16:00:26 <zodbot> Meeting started Wed Jun 20 16:00:26 2018 UTC.
16:00:26 <zodbot> This meeting is logged and archived in a public location.
16:00:26 <zodbot> The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:26 <zodbot> The meeting name has been set to 'council_(2018-06-20)'
16:00:29 <mattdm> #meetingname council
16:00:29 <zodbot> The meeting name has been set to 'council'
16:00:31 <mattdm> #chair mattdm jkurik jwb langdon robyduck bexelbie dperpeet Amita dgilmore pbrobinson tyll
16:00:31 <zodbot> Current chairs: Amita bexelbie dgilmore dperpeet jkurik jwb langdon mattdm pbrobinson robyduck tyll
16:00:33 <mattdm> #topic Introductions, Welcomes
16:00:47 <mattdm> Hi everyone! Who is around?
16:00:51 <langdon> .hello2
16:00:52 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
16:01:07 <mattdm> hi langdon
16:01:27 <langdon> hi mattdm! nice article btw
16:01:45 <mattdm> thank you. you are seeing, I think, the eighteenth draft :)
16:02:04 <langdon> mattdm: half-kiddingly, i was wondering if it was ghost written
16:02:10 * pbrobinson o/
16:02:29 <mattdm> nope, all me :)
16:02:33 <jwb> i am triple booked. will try to pay attention
16:02:48 <mattdm> okay, we got four of us.
16:02:57 <mattdm> I know robyduck has been very busy lately
16:03:07 <mattdm> and bexelbie is galavanting around japan
16:04:12 <mattdm> dunno about the others
16:05:09 <mattdm> okay, so... maybe this will be quick
16:05:16 <mattdm> #topic Today's Open Floor Agenda
16:05:28 <mattdm> This is open floor meeting. You know the drill
16:05:34 <mattdm> I have a couple of things:
16:05:39 <mattdm> 1. Fedora CoreOS
16:05:44 <mattdm> 2. Discourse
16:06:12 <mattdm> and I guess since we have langdon and pbrobinson, maybe a few #info lines on the state of Modularity and IoT
16:06:17 <mattdm> anything else?
16:06:21 <langdon> i got nothing really.. need to do an update for the modularity objective
16:06:32 <langdon> ohh.. that was for agenda
16:06:37 <langdon> ill think about a #info
16:06:50 <mattdm> heh, exacrtly.
16:06:53 <mattdm> okay. so
16:06:58 <mattdm> #topic Fedora CoreOS
16:07:03 <mattdm> there was much announcing this moring
16:07:06 <mattdm> morning
16:07:12 <mattdm> #link https://fedoramagazine.org/announcing-fedora-coreos/
16:07:27 <mattdm> that + the faq basically explains it all
16:07:30 <langdon> excited to see the return of fedora core? ;)
16:07:39 <mattdm> That's in the annoucement!
16:07:54 <langdon> thats what made me think of it :)
16:07:59 <mattdm> So far, this has been relatively quiet
16:08:03 <mattdm> kind of to my surprise.
16:08:18 <mattdm> bgilbert from coreos says to just wait until the west coast wakes up
16:08:25 <langdon> ha
16:08:37 <mattdm> this leads to the next thing:
16:08:44 <mattdm> #topic Fedora Discourse server
16:08:54 <mattdm> #link https://discussion.fedoraproject.org/
16:09:04 <mattdm> discourse is a modern, open source web-based discussion system
16:09:09 <mattdm> (with email integration, too)
16:09:21 * langdon wonders if this topic is his fault
16:09:24 <mattdm> The CoreOS team wanted to use this for user communication rather than a mailing list
16:09:43 <langdon> apparently not (only)
16:09:59 <mattdm> So sbonic is, at least for now, paying for hosting from the Atomic/CoreOS osas budget
16:10:13 <mattdm> Yeah not just langdon :)(
16:10:29 <mattdm> I've been interested in this for Fedora for a long time, but, like everything it takes some doing
16:10:32 <langdon> ooo just processed that link
16:10:39 <misc> mattdm: mhh, did we turned the email integration ?
16:10:50 <mattdm> misc: I dunno. also, thanks misc for setting this all up
16:11:02 <mattdm> and puiterwijk for whatever insane wizardry
16:11:10 <mattdm> it uses FAS for accounts :)
16:11:12 <misc> mattdm: I did nothing for discourse, besides telling "go pay for it" :p
16:11:38 <langdon> ha! i can even do that!
16:11:40 <mattdm> So, I'm basically seeing this as an experiment for possible broader use
16:12:10 <mattdm> For one thing, although the hosted situation with Ask is way better than it falling apart in place...
16:12:24 <mattdm> it still isn't _really_ seeing new development and is kind of stuck in 2009 or so
16:12:41 <mattdm> whereas this is an active project
16:12:58 <langdon> which was a good year for wine (IIRC)..
16:13:18 <puiterwijk> langdon: are you now comparing askbot to wine? :)
16:13:21 <pbrobinson> langdon: depends on the grape region ;)
16:13:38 <langdon> RFE: can we make it use your fp.o alias rather than the address that your alias is mapped too?
16:13:39 <pbrobinson> grape/region even
16:14:06 <mattdm> langdon: maybe. that sounds like a misc / puiterwijk question :)
16:14:07 <langdon> i was more saying.. some things get better with age :)
16:14:12 <puiterwijk> langdon: we can, but please open an infra ticket
16:14:22 <langdon> puiterwijk: ok
16:14:24 <puiterwijk> (as I'll forget otherwise)
16:14:29 <misc> so is it CLA+1 ?
16:14:41 <misc> and if we use the alias, that mean people need to have one
16:14:41 <puiterwijk> misc: no, it requires just a FAS user
16:14:55 <mattdm> and @fedoraproject.org only works for CLA+1
16:15:00 <misc> cause I think discourse send email to the email
16:15:16 <misc> but we can discuss in the ticket that langdon is gonna open
16:15:27 <misc> #action langdon open a ticket for his discourse request
16:15:38 <langdon> in progress
16:15:41 <mattdm> yeah let's figure that out separately
16:16:08 <puiterwijk> We could theoretically just disable all outbound email and use FMN for all notifs. But that's also separate
16:16:13 <mattdm> Anyway, it seems that at least among those of us in this meeting there is enthusiasm for this at the council level
16:16:16 <mattdm> so it's not just me :)
16:16:22 <puiterwijk> (since we'll have discourse2fedmsg hopefully today)
16:16:28 <mattdm> puiterwijk++
16:16:34 * mattdm needs more special fpl cookies
16:16:48 <puiterwijk> mattdm: open an RFE on github.com/fedora-infra/supybot-fedora :D
16:16:56 * pbrobinson drools..... cookies....
16:17:00 <langdon> ha
16:17:04 <mattdm> puiterwijk: we don't want to disable mail, though, because it's got _incoming_ reply-via-mail too
16:17:16 <puiterwijk> Okay, fair enough.
16:17:22 <puiterwijk> Was just giving random ideas :)
16:17:29 <mattdm> anyway. any more thoughts or questions on that?
16:18:06 <misc> mattdm: will it be discussed in flock ?
16:18:16 <misc> (the discourse stuff)
16:18:21 <mattdm> misc: that's a good idea. hmmm let me think about that.
16:18:37 <mattdm> we should have some interesting idea of how it's going by then
16:18:48 <misc> yup, timing would be good
16:19:08 <langdon> as you all probably know from fedmsg, done
16:19:15 <mattdm> #action mattdm to propose a working session on discourse at flock
16:19:28 <mattdm> #topic State of Modularity
16:19:42 <mattdm> langdon: did you find some #infos? :)
16:19:43 <langdon> uh oh.. i havent thought of my #info yet
16:20:03 <langdon> pbrobinson: you first?
16:20:08 <mattdm> #undo
16:20:08 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f541b5ff550>
16:20:13 <mattdm> #topic Internet o' Things
16:20:24 <pbrobinson> things are rolling along
16:20:40 <mattdm> like, it's a rolling release now? :)
16:20:55 <pbrobinson> we have nightly build for F28, and will have rawhide later this week
16:21:13 <pbrobinson> mattdm: go and listen to the council interview again... monthly rolling ;-)
16:21:19 <mattdm> heh
16:21:37 <mattdm> oh, and speaking of previous topic
16:21:39 <mattdm> #link https://discussion.fedoraproject.org/c/iot
16:21:40 <pbrobinson> now that there's something for people to actually play with there's people starting to poke and do things and provide feedback
16:22:06 <mattdm> are people showing up? do we need to poke them to do some poking?
16:22:24 <pbrobinson> the Fedora CoreOS announcement was perfect timing too as I've had a lot of "How does CoreOS affect Fedora IoT" questions
16:22:37 <pbrobinson> people are showing up
16:23:03 <pbrobinson> I've been a little in soft launch trying not to drown myself
16:23:16 <pbrobinson> I think we'll start to see that expand out
16:23:51 <pbrobinson> I'll be doing a Q&A tomorrow with the 96boards community https://twitter.com/96Boards/status/1009466129218187264
16:24:10 <mattdm> ooh, that's exciting
16:24:11 <pbrobinson> feel free to info that and spread it wider#
16:24:51 <mattdm> apparetnly also on #96boards and #OpenHours on this very irc network
16:25:05 <mattdm> oh look and it's our old friend bluejeans :)
16:25:07 <pbrobinson> yes, and correct
16:25:21 <langdon> pbrobinson: i think you are a chair
16:25:56 <mattdm> #info Chat with Peter about Fedora IoT at 16:00 UTC tomorrow
16:26:00 <mattdm> #link https://twitter.com/96Boards/status/1009466129218187264
16:26:17 <mattdm> Last question: anything you need help with?
16:26:31 <pbrobinson> #info Fedora IoT Q&A tomorrow with Linaro 96boards OpenHours https://www.96boards.org/openhours/
16:26:46 <pbrobinson> probably the WG stuff
16:27:07 <pbrobinson> it keep slipping because it's not the thing that keeps yelling at me :)
16:27:25 <mattdm> like, formalizing it?
16:27:26 <pbrobinson> slowly fleshing out bits here https://fedoraproject.org/wiki/InternetOfThings
16:27:40 <pbrobinson> well things I need to do formally like docs and processes etc
16:27:52 <pbrobinson> we have a weekly meeting now, minuted etc
16:28:25 <langdon> is minuted a systemd meetbot!??! :)
16:28:26 <mattdm> we basically need a Secretary of IoT
16:28:28 <pbrobinson> the official monthly releases I think makes sense to start once the CoreOS bits have landed
16:29:02 <mattdm> are you thinking of using some of the provisioning bits from CoreOS? Like, Ignition?
16:29:26 <pbrobinson> I thought we had someone able to help with secretary stuff, I think that's been delayed, I've been doing minutes for the moment
16:29:48 <pbrobinson> yes, and the updates platform when it's open sourced
16:30:01 <pbrobinson> I'm not sure all the details of that
16:30:13 <mattdm> cool. I'm not sure either.
16:30:19 <mattdm> I'm not sure if the team is. :)
16:30:34 <pbrobinson> I've got a whole bunch of other stuff (bolting down systemd for services etc), profiles etc that I'm hoping to start landing next week
16:30:42 <mattdm> So, we do have our new Fedora Program Manager starting next week
16:30:43 <pbrobinson> and some Changes stuff I also need to write up
16:31:14 <mattdm> I may ask them to help you with this stuff as a starting task
16:31:57 <mattdm> let's go over to langdon now
16:32:02 <mattdm> #topic Modularity
16:32:06 <langdon> ok.. so
16:32:12 <pbrobinson> that would be awesome, sometimes (with all the other IoT stuff I get landed with internally too) it sometimes ends up being stuck in process switching contexts before my brain crashes and reboots ;-)
16:32:34 <langdon> sounds like an iot device :)
16:32:34 <mattdm> pbrobinson: *nod*
16:33:16 <langdon> want to switch now?
16:33:19 <mattdm> yes. :)
16:33:29 <langdon> libdnf is moving along.. but slowly..
16:33:30 <pbrobinson> langdon: too much compute power for IoT.... and my food bill would say it draws to much energy ;-)
16:33:48 <pbrobinson> LOL, libdnf.... :)
16:33:53 <mattdm> I am concerned that there are no updates in
16:33:56 <mattdm> #link https://bugzilla.redhat.com/show_bug.cgi?id=1575626
16:34:29 <mattdm> like, "triaged" on May 14, and devel whiteboard to "category:modularity" on May 29
16:34:33 <mattdm> other than that, crickets
16:34:44 <mattdm> And not even literal crickets. that'd be _something_
16:34:50 * langdon trying to open link
16:35:05 <mattdm> It's the blocker bug for f29 beta
16:35:25 <langdon> yeah.. sorry.. brain isn't handling multi-tasking well
16:35:45 <langdon> ok.. so i talked to the team today / yesterday.. and there is definite progress.. ill try to get them to post some info
16:36:35 <langdon> so.. not much more to say on that.. but ill poke them
16:36:50 <mattdm> that would be helpful. this remains a key feature for Fedora, and it's disconcerting to have that in the dark
16:37:01 <langdon> yeah
16:37:06 <langdon> sgallagh also wrote a change for f29 for expansion of modularity support
16:37:07 <mattdm> makes it hard to really recommend working on modules in the community outside of a narrow context
16:37:59 <langdon> yeah.. i am not excited about the status either
16:38:20 <mattdm> okay. well. thanks for poking :)
16:38:29 <mattdm> anything else?
16:38:33 <langdon> the change ^^
16:38:40 <langdon> https://fedoraproject.org/wiki/Changes/ModulesForEveryone
16:39:04 <mattdm> langdon++
16:39:04 <zodbot> mattdm: Karma for langdon changed to 1 (for the f28 release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:39:05 <langdon> woah.. meetbot auto-picked up a link?
16:39:10 <langdon> really..
16:39:13 <langdon> sgallagh++
16:39:13 <zodbot> langdon: Karma for sgallagh changed to 11 (for the f28 release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:39:58 <mattdm> okay. we done here, then? :)
16:40:05 <langdon> we are also working on module tools.. fedmod has had some improvements.. but they have been tough between me busy on devconf.us and lots of vacations because summer
16:40:28 <langdon> otherwise.. im good
16:40:44 <mattdm> Is it time for me to try again to switch my `calc` package over to being just modular?
16:40:52 <langdon> sure
16:40:55 <mattdm> (I want to only maintain the stream branches.)
16:41:28 <jwf> mattdm: Count me in for the Discourse discussion @ Flock :-)
16:41:28 <langdon> right.. i think it would work pretty well now.. nothing deps on it does it?
16:41:32 <mattdm> ok, cool. But if it isn't easy, I'm *definitely* complaining to you.
16:41:45 <mattdm> langdon: no. it's a pretty ideal easy case
16:41:56 <mattdm> jwf awesome
16:42:08 <mattdm> #topic Open Floor
16:42:11 <mattdm> anything else?
16:42:11 <langdon> mattdm: like so few things
16:42:37 <mattdm> as I noted, new FPgM starting next week.
16:42:46 <langdon> WOOT
16:42:50 <langdon> jkurik++
16:42:50 <zodbot> langdon: Karma for jkurik changed to 1 (for the f28 release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:43:17 <mattdm> jkurik++ indeed
16:43:17 <zodbot> mattdm: Karma for jkurik changed to 2 (for the f28 release cycle): https://badges.fedoraproject.org/tags/cookie/any
16:43:26 <mattdm> okay, I think that's it, then.
16:43:29 <mattdm> thanks everyone!
16:44:03 <mattdm> (oh: I think probably with that and with s/nb/tyll/, we should revisit the meeting times yet again. this plan is clearly not really working.)
16:44:05 <langdon> hopefully they travel less than bex :)
16:44:32 <langdon> mattdm: that can be the new FPgM first gig!
16:44:49 <langdon> scare them early!
16:44:52 <mattdm> heh. trial by fire
16:45:10 <mattdm> push this scheduling boulder to the top of this calendar hill
16:45:11 <mattdm> mwhhahaha
16:45:20 * langdon runs off to kid science fair.. see y'all
16:45:25 <mattdm> thanks again
16:45:27 <mattdm> #endmeeting