14:00:28 <mattdm> #startmeeting Council (2019-07-03)
14:00:28 <zodbot> Meeting started Wed Jul 3 14:00:28 2019 UTC.
14:00:28 <zodbot> This meeting is logged and archived in a public location.
14:00:28 <zodbot> The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:28 <zodbot> The meeting name has been set to 'council_(2019-07-03)'
14:00:30 <mattdm> #meetingname council
14:00:30 <zodbot> The meeting name has been set to 'council'
14:00:32 <mattdm> #chair jonatoni bex contyk dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:32 <zodbot> Current chairs: asamalik bcotton bex contyk dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
14:00:34 <mattdm> #topic Introductions, Welcomes
14:00:52 <langdon> .heelo2
14:00:56 <langdon> .hello2
14:00:56 <mattdm> hello everyone
14:00:57 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:01:00 <bcotton> .hello2
14:01:01 <mattdm> heeello langdon!
14:01:01 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:04 <dperpeet> .hello2
14:01:05 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
14:01:52 * pbrobinson is here, also in IoT meeting
14:02:09 <asamalik> .hello2
14:02:12 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:02:17 <mattdm> cool. red hat is very quiet this week as so many people are taking holidays.
14:02:22 <mattdm> but i see fedora never stops :)
14:02:44 <pbrobinson> many people from the USA are taking holidays Matthew.....
14:02:58 <asamalik> fedora is forever :)
14:03:07 <mattdm> exactly :)
14:03:07 <langdon> pbrobinson: i know at least one czech taking this week off
14:03:29 <mattdm> so anyway, let's get started here. pbrobinson you want to go last since you're doing your other meeting too?
14:04:06 <mattdm> #topic Agenda
14:04:24 <mattdm> Did everyone see my mail about changing this up which I sent a little while ago?
14:04:38 <langdon> i did
14:04:39 <pbrobinson> langdon: of 1500?
14:04:50 <pbrobinson> mattdm: yes please
14:04:52 <mattdm> I'd like to discuss that a little bit -- but should we do that before or after going through the objectives one last time?
14:05:02 * asamalik thinks this is his first council meeting!
14:05:11 <mattdm> asamalik: is it?
14:05:18 <mattdm> welcome then!
14:05:19 <langdon> pbrobinson: just proviing the counter point ;)
14:05:31 * asamalik takes the next two weeks off :)
14:05:40 <asamalik> mattdm: thank you!
14:05:44 <langdon> asamalik: it can be a tough meeting
14:06:05 <mattdm> but pay attention to my question, y'all. discussion meta-concept before or after specific updates?
14:06:38 <bcotton> after
14:06:50 <langdon> 6 of one for me... but if it is after i can wade through bcotton's reply ;)
14:06:58 <jonatoni> .hello2
14:06:59 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
14:07:23 <asamalik> maybe updates first and then whatever is left we can discuss other things?
14:07:48 <dgilmore> mattdm: I am behind on email
14:07:59 <mattdm> ok let's do updates first
14:08:14 <mattdm> asamalik: you want to go first?
14:08:22 <asamalik> mattdm: sure!
14:08:28 <mattdm> then dperpeet then langdon then pbrobinson.
14:08:45 <dperpeet> yes sir
14:08:50 <mattdm> #topic Objective: making Fedora tiny (the minimization project)
14:09:02 <mattdm> asamalik: is this, like, solved yet? it's been several weeks.
14:09:22 <asamalik> yeah it's nearly done, just the work is missing
14:09:29 <asamalik> but more seriously...
14:09:57 <mattdm> :)
14:10:30 <asamalik> I've been pulled into other things, like a conference last week and now the Modularity libgit2 fire, to there hasn't been much progress from my side as I would like.
14:11:10 <asamalik> However I had conversations with a few people, learning things, etc.
14:11:24 <asamalik> I still need to set up a tracker, a place to write regular reports, etc.
14:11:27 <mattdm> that is an important start
14:11:50 <mattdm> is this a good use for https://teams.fedoraproject.org/ ?
14:12:05 <asamalik> My original plan for the tracker etc was this week, that might still happen, or when I'm back after two weeks.
14:12:52 <asamalik> mattdm: probably... so I really like Taiga, but a few things I'm missing is the ability to tag people not manually added to the board, and a mobile interface that's at least usable...
14:13:03 <asamalik> that's why I haven't just created a board straight away
14:13:23 <mattdm> maybe we should push the taiga team for that "tag anyone in fedora" feature
14:13:43 <asamalik> that would be really cool
14:13:48 <mattdm> because adding people manually to the board is going to be a scaling problem for a lot of people
14:13:57 * mattdm makes a note
14:14:03 <asamalik> mattdm++
14:14:04 <zodbot> asamalik: Karma for mattdm changed to 5 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:14:13 <bcotton> mattdm: and the ability for people to self-add
14:14:20 <asamalik> Anyway, I think that's all from me for today, hopefully something more interesting next time!
14:14:27 <mattdm> sounds good -- thanks!
14:14:30 <asamalik> bcotton: yes!
14:14:51 <mattdm> or add people based on fas group
14:15:12 <mattdm> but this is going into the weeds.
14:15:32 <mattdm> #info Minimization is in bootstrapping mode. More from asamalik at next update
14:15:40 <asamalik> basically managing users like in Pagure, where I can tag anyone, anyone can watch, and I can add people for additional permissions would be great
14:15:47 <mattdm> #topic Fedora CI and Rawhide Gating
14:16:03 <dperpeet> so... we have submitted a few flock talks :)
14:16:25 <mattdm> dperpeet: in related news, we're voting on flock talks and sending out accceptances this week :)
14:16:36 <dperpeet> good to hear :)
14:16:41 <langdon> how do you vote on flock talks? i don't remember
14:16:47 <langdon> and was looking for docs
14:16:52 <mattdm> langdon: there is a committee
14:17:01 <bcotton> dperpeet: want my paypal address?
14:17:06 <langdon> ohhh.. well... nvm then ;)
14:17:09 <mattdm> langdon: :)
14:17:16 <dperpeet> bcotton, can I use that for my netflix subscription? yes, please!
14:17:26 <mattdm> but we do plan to put it all in sched and have people say what they're actually planning to go to
14:17:50 <mattdm> so that will also consititute a round of practical voting (because if no one is going to a talk, we will want to make adjustments)
14:17:59 <langdon> sorry for the sidebar.. i had seemed to recall with the change to poagure submissions some general public voting as well.. but I may be crazy and I know i have a terrible memory.. but we can drop this now
14:18:06 <dperpeet> I'll wait for the side-topic to die down, I should have known "flock" is a trigger :D
14:18:16 <mattdm> dperpeet: hah. yes, continue please
14:18:41 <dperpeet> that said, *flock* still is our target for things to be ready to a certain degree
14:18:53 <dperpeet> the Packit service was officially launched
14:19:00 <mattdm> yes, i was trying to think how to ask that without saying "flock" again
14:19:09 <dperpeet> we can say early August
14:19:40 <mattdm> I guess the basic question is: do we feel like we're hitting that target in a satisfying way?
14:19:48 <dperpeet> (Packit is about automatically building fedora packages based on upstream changes)
14:19:52 <dperpeet> yes
14:20:14 <dperpeet> the package level testing at a distro-wide scale is progressing nicely (dcantrell, tflink)
14:20:19 <langdon> +1 to packit launch.. good marketing.. x-d all my desks
14:20:24 <mattdm> Like, will Rawhide Gating be _done_ in the agile manifesto sense of "actually complete"?
14:20:35 <dperpeet> Rawhide Gating seems on track for single packages (not multi package updates)
14:20:47 <dperpeet> yes, the intent is to actually gate on rpminspect
14:20:52 <dperpeet> by flock
14:20:53 <mattdm> cool!
14:21:15 <mattdm> #info the intent is to actually gate Rawhide on `rpminspect` by Flock
14:21:27 <mattdm> what happens with multi-package updates?
14:21:28 <dperpeet> we're also working with CPE on nailing down what's actually part of gating
14:21:46 <dperpeet> they require more work and most likely will not be "in prod" by then
14:22:12 <dperpeet> pingou is driving the gating part and the involved engineers want to do it properly :)
14:22:26 <mattdm> so if I submit a multi-package update it bypasses the process? or (more concerning) it is impossible?
14:22:44 <dperpeet> there will be options of bypassing and waiving
14:23:17 <dperpeet> among all the stakeholders I believe we have ensured that all valid paths remain possible
14:23:24 <dperpeet> huh, that was too generic
14:23:27 <mattdm> haha
14:23:31 <mattdm> sounds good though :)
14:24:05 <dperpeet> we're also working with CPE on the communication aspect
14:24:22 <dperpeet> i.e. workflow diagrams and explanations for everyone, so they can see how things work
14:24:28 <langdon> i don't think dperpeet is saying "forever" just that single package will land by the-conf-that-is-not-named .. and multi- will be after
14:24:31 <dperpeet> and have changed, and not changed in many cases
14:24:43 <dperpeet> langdon, exactly
14:24:49 <mattdm> Yeah, a good communication plan is crucial
14:25:14 <dgilmore> what are the biggest risks that could hamper gating by flock?
14:25:18 * langdon pouts at the lack of reaction to his conf reference
14:25:45 * bcotton pats langdon on the head
14:25:47 <dperpeet> dgilmore, the biggest risk would be that the test results are flaky / not good enough to use for gating
14:25:54 <langdon> bcotton++
14:25:55 <zodbot> langdon: Karma for bcotton changed to 17 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:25:55 <dperpeet> of rpminspect
14:26:18 <dperpeet> we do have the dist-git tests to fall back on
14:26:25 <dperpeet> they are still running and producing results
14:26:25 <dgilmore> dperpeet: okay, so we have enough hardware, and sufficient people working on code and tests?
14:26:26 <dperpeet> :)
14:26:31 <mattdm> what about time through the system? how much of a lag from submit-build-to-result are we introducing?
14:26:48 <dgilmore> dperpeet: and the integration into relevant systems is well underway?
14:26:59 <dperpeet> dgilmore, yes, I believe so, on both counts
14:27:19 <dperpeet> rawhide gating is primarily being worked on by the infra folks
14:27:24 <dperpeet> so they're at the source :)
14:27:52 <dperpeet> mattdm, in the long run it depends on the package, but in my experience the average to expect is 10-30 minutes
14:27:59 <dperpeet> but this is anecdotal
14:28:05 <dperpeet> we'll have data once things actually run
14:28:09 <mattdm> oh, that's perfect. it used to take that long just waiting on ARM :)
14:28:11 <dperpeet> on a larger scale
14:28:35 <mattdm> dperpeet: anything else we should know? sounds like everything is on track!
14:28:46 <dperpeet> no, I think we're good for now
14:28:51 <dperpeet> oh
14:28:52 <dperpeet> one thing
14:29:06 <dperpeet> someone should nag me next week if I still haven't sent around the new CI Objective by then
14:29:09 <dperpeet> :)
14:29:13 <dperpeet> apparently I need nagging
14:29:15 <dperpeet> :(
14:29:52 <bcotton> #action bcotton to remind dperpeet to send out the new CI Objective next week
14:29:57 <dperpeet> thank you :)
14:29:58 <mattdm> bcotton++
14:30:01 <dperpeet> that's it from me!
14:30:03 <mattdm> thanks dperpeet!
14:30:05 <bcotton> dperpeet: early, middle, or late week?
14:30:11 <dgilmore> thanks dperpeet
14:30:12 <dperpeet> bcotton, early :)
14:30:15 <dperpeet> bcotton++
14:30:15 <zodbot> dperpeet: Karma for bcotton changed to 18 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:30:20 <mattdm> #topic Modularity (and, speaking of new objectives....)
14:30:28 <mattdm> tag langdon :)
14:30:33 <bcotton> dperpeet: ack
14:31:01 <mattdm> I hear there's a tire fire? asamalik said it, not me :)
14:31:17 <bcotton> uh, the commblog image was a *dumpster* fire, tyvm
14:31:44 <mattdm> ooooh sorry
14:31:45 <langdon> so.. just cause you brought it up.. there is a new objective written.. but a) it needs a few "targets" and b) i am not sure where to put it..
14:32:27 <asamalik> yes it was a dumpster fire
14:32:29 <langdon> re: fires.. i think we continue to run into .. "well rpm has every guideline ever written down and policed, modularity should too" ..
14:32:43 <langdon> i assume you are referencing libgit2?
14:33:00 <langdon> and.. rpm has had ~20 years to figure this out ... modularity has not
14:33:20 <mattdm> Well, really, not libgit2 itself but the mismatch in expectations that that situation highlights
14:33:26 <langdon> so we are working through issues with guidance, goals, best practices, etc as people discover them
14:33:36 * asamalik was refering to the image :)
14:34:31 <langdon> i think "mismatch in expectations" is way stronger than the reality which is "the team thought this was understood but it was not clear"
14:35:00 <mattdm> it was not clear leads to people expecting different things
14:35:15 <mattdm> bcotton: where should langdon put the new objective draft?
14:35:20 <langdon> mattdm: so.. yes.. but .. it is very difficult to prove documentation complete
14:35:49 <langdon> we need all this stuff "in the wild" so we can "fix" things .. be they docs or implementation..
14:35:50 <bcotton> mattdm, langdon: the wiki seems like a good place for *draft* content
14:35:54 <mattdm> langdon: agreed. let's focus on the objective and next steps.
14:36:14 <langdon> referring to the whole thing as a dumpster fire makes me clearly see that fedora may not be actually ready to innovate
14:36:15 <mattdm> it's unfortuante that the wiki can't do asciidoc instead of mediawiki markup
14:36:29 <langdon> bcotton: i wasn't sure if that was still the place
14:36:54 <mattdm> well, dumpster fire is tongue in cheek. I don't _actually_ see it that way.
14:37:26 <bcotton> mattdm, langdon: a branch to the council docs might not hurt, either. then it can be merged when/if approved
14:37:35 <asamalik> langdon: I don't actually see the situation as a dumpster fire. The image was supposed to be funny and to demonstrate that we actually care and want to fix it.
14:37:41 <langdon> bcotton: ha.. now you see why it is sitting in a public gdoc :)
14:37:51 <bcotton> depends on how draft-y it is and how many people are going to edit it
14:37:52 <mattdm> asamalik++
14:38:13 <bcotton> langdon: that's actually my favorite way, but i'm trying to be FOSS-friendly on the record :p
14:38:17 <langdon> bcotton: it is "done" until flock (obviously unless we get feedback)
14:38:20 <asamalik> langdon: To your point about Fedora being ready... is Fedora for innovation? or is it a desktop OS that you use? can it be both? and most importantly, is this message a terrible a rabbit hole?
14:38:40 <dgilmore> bcotton: doing the draft in a fork of the council docs seems best for drafts
14:38:49 <dgilmore> people can branch the fork and collaborate
14:38:52 <mattdm> dgilmore++
14:38:52 <zodbot> mattdm: Karma for ausil changed to 3 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:38:58 <bcotton> dgilmore++
14:38:58 <zodbot> bcotton: Karma for ausil changed to 4 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:39:15 <mattdm> asamalik: that's a rabbit hole but one we _should_ explore perhaps in a future meeting
14:39:26 * bcotton notes we should probably have this written down somewhere and then remembers he has that on his taiga board to do someday
14:39:42 <mattdm> For now: langdon, yeah, if the draft is almost ready a branch in the council docs sounds perfect
14:39:52 <mattdm> and let's move on to pbrobinson if he's ready
14:39:56 <langdon> asamalik: i just think we need to be careful that if we refer to everything we try to do that is new during the "stabilization phase" as a trainwreck/dumpster-fire the people who want to take some risks will stop
14:40:04 <pbrobinson> mattdm: almost
14:40:17 <langdon> mattdm: why are we moving on?
14:40:31 <mattdm> langdon: because there's only twenty minutes left in the meeting?
14:40:49 <langdon> ohh .. i see you called it a rabbit hole... let me make a couple comments then we can swtich
14:41:03 <mattdm> langdon: yeah. thanks :)
14:41:27 <mattdm> for the record, I *don't* think modularity is either a trainwreck or a dumpster-fire
14:41:49 <langdon> a) please be careful how much we joke about the difficulty in stabilizing things.. it is very hard, the people doing the work feel VERY guilty and unhappy every time something goes wrong.. the more we joke about it.. the more they feel bad and are less likely to continue..
14:42:21 * pbrobinson is here
14:42:50 <langdon> on the actual update side.. we have been working through "tracking" which we tried with taiga .. but we are still struggling with moving to a kanban approach.. your best bet for keeping track is to come to the weekly meetings
14:42:50 <mattdm> langdon: fair. I know that can be disheartening.
14:42:51 <smooge> it is very hard to tell if someone is trying to alleviate stress/problems or being an asshole and covering it up with 'what you can't take a joke'
14:43:03 <mattdm> smooge++
14:43:04 <zodbot> mattdm: Karma for smooge changed to 17 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:43:09 <langdon> smooge++
14:43:09 <zodbot> langdon: Karma for smooge changed to 18 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:43:10 <mattdm> smooge: excellent point
14:43:37 <asamalik> smooge++
14:43:37 <zodbot> asamalik: Karma for smooge changed to 19 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:44:01 <mattdm> in this case since it came from asamalik I read it as the "dealing with stress, making light" situation and was just going along with it
14:44:07 <langdon> ill be off to fork the objective repo in a bit.. and then you can see how much is missing from the "hard targets" :/
14:44:42 <asamalik> mattdm: yes
14:44:50 <langdon> mattdm i was really NOT singling anyone or thing out.. but this has been an ongoing problem.. and i think it was worth raising
14:44:50 <asamalik> there was only good intentions behind it
14:45:02 <asamalik> but point taken!
14:45:06 <langdon> mattdm: you just got lucky in sparking it :)
14:45:12 <mattdm> ha
14:45:23 <langdon> but it was *literally* in my notes for the obj update
14:45:40 <mattdm> I definitely know how these things catch on as the overriding narrative and then become hard to counter
14:45:58 <mattdm> anything else before we move on?
14:46:20 <langdon> no.. that was it.. sorry
14:46:41 <mattdm> thanks!
14:46:51 <mattdm> #topic Fedora IoT Edition Launch
14:47:25 <pbrobinson> I have a doc, which I need to convert to mark down and push to IoT docs
14:47:32 <mattdm> asciidoc :)
14:47:33 <pbrobinson> that's on the list for this afternoon
14:47:42 <mattdm> pandoc to the rescue
14:47:44 <pbrobinson> mattdm: what ever!! I have no idea
14:47:49 <mattdm> :)
14:48:06 <pbrobinson> does pandoc do google doc to asciidoc?
14:48:12 <mattdm> how's the overall status, and what are we looking at for a timeline?
14:48:19 <mattdm> (it does html to asciidoc)
14:48:41 <pbrobinson> so phase 1 is looking reasonable, I'm cleaning up a bunch of stuff and I think that should be soon
14:48:58 <pbrobinson> doesn't help I found out late Friday I'm in Houston next week for a bunch of meetings
14:49:19 <mattdm> (or rtf)
14:49:46 <pbrobinson> anyway I'll have that doc done today
14:50:02 <mattdm> is that the "work plan for launch" doc we talked about?
14:50:12 <pbrobinson> and a bunch of the bits by COP tomorrow, then I'm AFK over the weekend (for once) and Houston for 7 days
14:50:19 <pbrobinson> mattdm: yes
14:50:41 <mattdm> ok cool. when that's ready I'll take it to the platform engineering team
14:50:56 <mattdm> Anything else urgent or exciting?
14:50:57 <langdon> what is COP? i know COB and EOD.. but what is the "P"?
14:51:25 <mattdm> close of ... play?
14:51:35 <langdon> wouldn't it be BOP? :)
14:51:46 <pbrobinson> close of play
14:51:53 <pbrobinson> so same as COB
14:52:06 <mattdm> assuming work is play :)
14:52:21 <smooge> play never ends
14:52:53 <pbrobinson> not really, put in 3 things for Flock inc one with a customer
14:53:09 <pbrobinson> a bunch of customer and partner meetings
14:53:27 <mattdm> let's get some of these customers to contribute ... contributors :)
14:53:46 <pbrobinson> Linaro has the basics of CI/CD for Fedora IoT in their CI/CD platform, pwhalen is leading that from the Fedora side
14:53:59 <langdon> best expansion i saw of COP -- Company of Paraclete
14:54:05 <mattdm> ooh that's cool
14:54:07 <pbrobinson> mattdm: there will be some @ Flock, I'm working on it/them ;-)
14:54:13 <mattdm> good!
14:54:18 <mattdm> and let's take the last five minutes to discuss the meeting/ status plan change proposal...
14:54:27 <mattdm> #topic Less meetings, more status
14:54:38 <mattdm> Did everyone see my mail from this morning?
14:55:23 <mattdm> The idea is to drop this meeting and the engineering/mindshare/d&i one in favor of updating a "traffic light" red/yellow/green report with a few highlights
14:55:34 <mattdm> which ben will consolidate into a monthly blog post
14:55:43 <dgilmore> would that mean that the council would then meet fortnightly?
14:55:57 <mattdm> we'll still do tickets and open floor meetings and of course we can discuss important objective things there
14:56:10 <mattdm> dgilmore: indeed, good sir, fortnightly 'til be!
14:56:17 <mattdm> * 'twil
14:56:31 <dperpeet> as long as we still have the interactive part / questions here, I'm good with that :)
14:56:41 <dgilmore> I think it makes things lighter and if done right will make whats going on more visible
14:56:43 <langdon> ohh really? i didn't pick that up from the email at all
14:56:45 <dperpeet> to be more precise: the option of questions
14:56:57 <mattdm> dperpeet: right
14:57:23 <mattdm> langdon: that part is still just a proposal. if you want to argue it should still be weekly, the thread is open :)
14:57:25 <langdon> also.. in bcotton's reply.. i was unclear.. will bcotton be writing a post based on the content we provide or will the post just be an aggregation of what we wrote
14:57:40 <langdon> mattdm: is that in the email? i really didn't even see it
14:57:51 <mattdm> langdon: there is a second email on the list actually
14:57:54 <mattdm> about that
14:58:11 <langdon> oh.. not the same thread?
14:58:18 <mattdm> and as for how much bcotton will write vs. aggregate... bcotton, what do you think?
14:58:18 <bcotton> langdon: it will be a human-friendly summary of what has been submitted
14:58:33 <asamalik> I did see the email yes!
14:58:37 <mattdm> different thread
14:58:41 <langdon> bcotton: ok.. that's what i thought from matt's but then your email confused me abit
14:58:45 <langdon> *a bit
14:58:59 <bcotton> i'm thinking a paragraph or two for each area, depending on how much content is there. but i need the updates to feed into the word-o-matic
14:59:04 <mattdm> literally 1 minute left any other comments, questions, concerns?
14:59:23 <asamalik> I think that makes sense!
14:59:37 <mattdm> please take to the list threads (yes two threads sorry langdon) for followup. thanks!
14:59:48 <asamalik> will do
14:59:55 <langdon> mattdm: yeah.. i see it now.. but the other one was really long :)
15:00:05 <mattdm> langdon: see that's why I also made a short one!
15:00:09 * mattdm must run now
15:00:12 <mattdm> thanks everyone!
15:00:14 <mattdm> #endmeeting