14:00:26 <bcotton> #startmeeting Council (2019-10-02)
14:00:26 <zodbot> Meeting started Wed Oct 2 14:00:26 2019 UTC.
14:00:26 <zodbot> This meeting is logged and archived in a public location.
14:00:26 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:26 <zodbot> The meeting name has been set to 'council_(2019-10-02)'
14:00:27 <bcotton> #meetingname council
14:00:27 <zodbot> The meeting name has been set to 'council'
14:00:36 <bcotton> #chair jonatoni bexelbie contyk dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:36 <zodbot> Current chairs: asamalik bcotton bexelbie contyk dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
14:00:37 <bcotton> #topic Introductions, Welcomes
14:00:50 <asamalik> .hello2
14:00:51 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:00:57 <bcotton> i know mattdm and bexelbie are out for training or something, but who *is* here?
14:01:00 <bcotton> hi asamalik
14:01:06 <asamalik> hi bcotton
14:01:20 * pbrobinson o/
14:01:26 <bcotton> ahoj, pbrobinson!
14:01:39 <pbrobinson> hi bcotton
14:02:02 <asamalik> こんにちわ pbrobinson
14:02:40 <pbrobinson> asamalik: no idea what that means
14:02:47 <langdon> .hello2
14:02:48 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:03:21 <asamalik> pbrobinson: I believe it means hello in Japanese, since we're greeting each other in various languages
14:03:44 * asamalik wonders what language langdon is going to choose
14:04:14 <pbrobinson> asamalik: "believe" :-P
14:04:17 <bcotton> hi langdon!
14:04:27 <langdon> yo
14:04:29 <langdon> aloha
14:04:31 <langdon> shalom
14:05:21 <bcotton> contyk dgilmore dperpeet jonatoni sumantro tyll?
14:05:48 <asamalik> contyk is in meetings
14:05:54 <bcotton> not allowed
14:05:57 <bcotton> #topic Today's agenda
14:05:58 <bcotton> 1. #267—Planning Hackfest 2019
14:05:59 <bcotton> 2. #274—Next phase of minimization objective
14:06:03 <bcotton> 3. #254—Close out current modularity objective. Consider and potentially approve next phase.
14:06:04 <bcotton> 4. #272—Websites team needs revitalizing
14:06:06 <bcotton> 5. Open floor
14:06:16 <bcotton> #topic Planning Hackfest 2019
14:06:17 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/267
14:06:19 <bcotton> #info 18-20 Nov in Prague
14:06:21 <bcotton> #action members to reply to bex's email if they haven't already
14:06:38 <bcotton> so bex conveniently did not provide me a way of knowing who had replied when he asked me to help make sure people reply quickly
14:06:46 <bcotton> so everyone reply if you haven't
14:06:54 * asamalik did!
14:06:57 <bcotton> #action mattdm to develop a draft schedule
14:07:00 <bcotton> asamalik++
14:07:04 <langdon> me too
14:07:08 <bcotton> langdon++
14:07:18 <langdon> ooo is zod back?
14:07:24 <langdon> someone broke the mirror?
14:07:28 <bcotton> langdon: zod loves me better than you
14:07:33 <langdon> apparently
14:07:49 <bcotton> #topic Next phase of Minimization Objective
14:07:50 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/274
14:07:57 <bcotton> asamalik: the floor is yours
14:08:18 <asamalik> bcotton: thank you!
14:08:27 <asamalik> #link https://asamalik.fedorapeople.org/fedora-minimization-logic-model.pdf
14:08:47 <asamalik> I have put together a logic model to help me explain the plans
14:09:02 <asamalik> I'm yet to write down the specific proposal
14:09:27 <asamalik> but the primary focus will be on use cases
14:09:45 <asamalik> by use cases I basically mean "groups of packages in specific context"
14:10:17 <langdon> wait.. where on the use cases?
14:10:47 <langdon> s/on/are
14:10:50 <langdon> oops
14:11:38 <asamalik> by focusing on use cases as opposed to individual packages — because that's hard to approach
14:12:04 <asamalik> there are conflicting requirements on individual packages, because they can be often used in many different ways
14:12:23 <langdon> that sounds familiar!
14:12:26 <asamalik> langdon: some of them are here: https://minimization.github.io/reports/view--use-cases-on-bases.html
14:12:52 <langdon> asamalik: but they aren't in the logic model, right? thats why i am confused ... cause I read it as they are in there (somehow)
14:13:21 <asamalik> langdon: that's correct
14:13:52 <asamalik> the goal for the next phase will be more building the capability to define and track use cases rather than minimizing them
14:14:27 <asamalik> and to monitor them for size changes
14:14:57 <langdon> can i propose that you team that up with adamW and think about using use cases as "acceptance criteria for release" as well?
14:15:07 <asamalik> and to potentially be able to potentially get bugs automatically reported to packages that introduce significant size increases to the use cases we care about
14:15:08 <langdon> like if we cna make the format work for both, thta might be handy
14:15:49 <asamalik> so basically focusing on *keeping* things small and being able to express what and how we want to focus on
14:15:50 <dgilmore> hi all
14:16:08 <asamalik> langdon: I talked exactly about this with bcotton a while ago!
14:16:19 <asamalik> having the use cases defined, we can test them as use cases in CI
14:16:23 <langdon> BDD FTW!
14:16:33 <asamalik> ...we can somehow use that for the project to define priorities
14:16:50 <asamalik> but that's a wider topic and I'll have that prepared for the hackfest
14:17:16 <langdon> hackfest?
14:17:24 <asamalik> anyway, a proper proposal is coming and will be ready by I believe next Friday
14:17:53 <asamalik> langdon: the council hackfest... sorry I need to formulate that better probably for it to make sense
14:18:20 <langdon> soryr.. i should have guessed ... but wondered if you were having one for minimization
14:19:57 <asamalik> bcotton: that's all from my side at this moment
14:20:09 <bcotton> #action asamalik to draft a proposal for the next phase by 11 October
14:20:17 <bcotton> awesome. any more questions, langdon?
14:20:46 <langdon> no... im good...
14:21:23 <dgilmore> asamalik: defining small is hard.
14:21:25 <bcotton> good, then it's your turn...
14:21:35 <bcotton> #topic Close out current modularity objective. Consider and potentially approve next phase.
14:21:36 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/254
14:21:37 <bcotton> #link https://pagure.io/Fedora-Council/council-docs/pull-request/61
14:21:39 <bcotton> #info Community comment period ends on Friday
14:21:51 <asamalik> dgilmore: and keeping it useful at the same time, for everyone, is also tricky :)
14:21:55 <langdon> \o/
14:22:06 <bcotton> langdon: have you been editing based on community feedback or will you do that at the end?
14:22:56 <langdon> bcotton: mostly due to conflicts, i have not.. there was meant to be some discussion of the feedback at last week's meetgin but I haven't followed up on it.. .ill probably update it before the end though
14:23:03 <bcotton> okay, cool
14:24:16 <bcotton> anything else on this?
14:24:55 <bcotton> #topic Websites team needs revitalizing
14:24:56 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/275
14:25:07 <bcotton> since mattdm isn't here, i'm not sure there's much to say
14:25:16 <bcotton> but uh, yeah. we need webz
14:26:04 <asamalik> webz++
14:26:22 <bcotton> #topic Next meeting
14:26:23 <bcotton> #info The next Fedora Council meeting is 16 October
14:26:29 <bcotton> #action mattdm to chair the 16 October meeting
14:26:40 <bcotton> #topic Open floor
14:26:55 <bcotton> anything else we want to talk about this week?
14:27:19 <langdon> do we have an eta on the hackfest agenda?
14:28:28 <bcotton> have you met matthew? ;-)
14:28:40 <langdon> bcotton: i have met *you*!! :)
14:28:56 <bcotton> langdon: when would you like to have it?
14:29:17 <langdon> me? morning of the event... but im pretty seat of the pants :)
14:29:38 <langdon> let's say, it woul dbe reasonable to have it before the meeting after next
14:30:02 <bcotton> okay, i'll push to have it by 30 October
14:30:10 <bcotton> we can always throw it away, after all :-D
14:30:19 <langdon> like the best made plans
14:30:30 <langdon> also, do we have any progress on more cake? aka new fcaic?
14:30:56 <bcotton> #agreed We would like a draft agenda for the Council Hackfest by the 30 October meeting
14:31:43 <bcotton> the FCAIC 3.0 process is underway. that's about all i can say at this point. it is not progressing as quickly as some had perhaps hoped
14:32:09 <langdon> hiring is normally sooooo easy!
14:32:48 <bcotton> right?
14:33:49 <bcotton> okay, last call!
14:34:08 * tachoknight raises his hand
14:35:06 <tachoknight> i mentioned it in the flock channel, but was wondering who/when/where Flock locations are discussed; had a proposal for 2020
14:35:49 <bcotton> welcome, tachoknight!
14:36:18 <tachoknight> thank you
14:36:19 <bcotton> last year, the council agreed to let Red Hat's community events team do site selection and management, since that's their area of expertise
14:36:49 <bcotton> so Flock 2020 will be North America somewhere, but the where is not yet set
14:36:56 <tachoknight> ah, okay, then i'll throw the proposal their way (Chicago for 2020 is my suggestion)
14:37:21 <bcotton> I think that was one of the cities on the list. I'm 2.5 hours away, so I'm in favor of it :p
14:37:31 <langdon> im pretty sure as well..
14:37:51 <langdon> tachoknight: would you be willing to be on the ground support? and when you say "chicago" where do you actually mean?
14:38:10 <langdon> cause I don't think the south loop is gonna happen
14:38:15 <tachoknight> yes, i would be happy to provide ground support, and i mean actual downtown Chicago
14:38:25 <bcotton> langdon: does Gary count?
14:38:26 <smooge> in August
14:38:30 <tachoknight> or near O'Hare i suppose
14:38:36 <langdon> tachoknight: that seems like 20x the normal price of flock :)
14:39:12 <langdon> when i heard chicago mentioned i thought i heard "near subrubs" .. aurora for example
14:39:13 <tachoknight> hmm, i figured Flock was always in ritzy places, cost was no problem ;)
14:39:20 <langdon> right?
14:39:39 * bcotton is still holding out for charting a cruise ship
14:39:43 <tachoknight> well, i'd be happy to work with the RH folks
14:39:51 <smooge> well we can do downtown Chicago in August if we get a place without air conditioning
14:40:00 <bcotton> smooge++
14:40:13 <tachoknight> hmm, my apartment is too small for everyone, sadly
14:40:18 * tachoknight doesn't have air conditioning
14:40:36 <asamalik> that won't be cool
14:40:36 <smooge> that will be in our price range though we may need to throw in near a place where they are digging up the old bone yards
14:40:47 <bcotton> #action bcotton to follow up with events team on Flock 2020 site selection
14:41:38 * tachoknight sits down and resumes listening
14:41:49 <bcotton> tachoknight++ for coming and proving suggestions
14:41:49 <zodbot> bcotton: Karma for tachoknight changed to 1 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:41:54 <bcotton> anything else for this week?
14:42:03 <langdon> my brother's place is pretty big.. we could just get like 5 people to donate places and have a talk in each.. use the l to get between talks
14:42:04 * asamalik has nothing more
14:42:43 <asamalik> I was at a conference where one of the "rooms" was actually a boat!
14:43:16 * langdon thinks all the rooms should be boats..
14:43:18 <bcotton> okay, thanks everyone!
14:43:21 <bcotton> #endmeeting