14:00:02 <bcotton> #startmeeting Council (2020-03-18)
14:00:02 <zodbot> Meeting started Wed Mar 18 14:00:02 2020 UTC.
14:00:02 <zodbot> This meeting is logged and archived in a public location.
14:00:02 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:02 <zodbot> The meeting name has been set to 'council_(2020-03-18)'
14:00:03 <bcotton> #meetingname council
14:00:03 <zodbot> The meeting name has been set to 'council'
14:00:05 <bcotton> #chair jonatoni riecatnor contyk dgilmore mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:05 <zodbot> Current chairs: asamalik bcotton contyk dgilmore jonatoni mattdm pbrobinson riecatnor sumantrom tyll
14:00:06 <bcotton> #topic Introductions, Welcomes
14:00:16 <contyk> .hello psabata
14:00:17 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
14:00:30 <sumantro> .hello sumantrom
14:00:31 <zodbot> sumantro: sumantrom 'Sumantro Mukherjee' <sumukher@redhat.com>
14:00:43 * pbrobinson is here
14:01:19 <dgilmore> hola
14:01:19 <mattdm> hello!
14:01:25 <bcotton> welcome contyk, sumantro, pbrobinson, dgilmore, mattdm
14:01:36 <tyll> .hello till
14:01:37 <contyk> Everyone still healthy?
14:01:39 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
14:01:42 * bcotton is going to refill coffee while we wait for folks to file in
14:01:46 <bcotton> welcome, tyll
14:02:01 <mattdm> contyk: physically yes. Mental health wise, doing what I can :)
14:02:17 <contyk> mattdm: Same old then.
14:02:28 <mattdm> contyk: pretty much :)
14:04:19 <bcotton> okay, shall we?
14:04:21 <bcotton> let's!
14:04:36 <riecatnor> hullo!
14:04:38 <mattdm> yes :)
14:04:39 <bcotton> #topic Today's agenda
14:04:41 <bcotton> #info 290 - Adopt a vision statement for Fedora
14:04:42 <bcotton> #info COVID-19
14:04:44 <bcotton> #info November & January meeting follow ups: status reports, reorg, team directory, NPS survey, etc
14:04:45 <bcotton> #info Your topics here!
14:04:57 <bcotton> anyone have anything they want to tack on to the end of this list?
14:05:44 <bcotton> that's a no
14:05:47 <bcotton> #topic Adopt a vision statement for Fedora
14:05:49 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/290
14:05:50 <bcotton> #info Council voting period ends 20 March
14:06:05 <bcotton> not much to discuss here, just a reminder that this is happening and you should vote in the ticket if you haven't already
14:06:18 <tyll> currently it is +6
14:06:20 <bcotton> i'll wait a moment in case anyone wants to chime in
14:06:50 <tyll> dgilmore: your vote is missing
14:06:57 <contyk> Just voted +1.
14:07:04 <bcotton> contyk++
14:07:06 <bcotton> tyll++
14:07:18 * pbrobinson has it open now and will do it after this cluster of meetings
14:07:24 <bcotton> pbrobinson++
14:07:39 <mattdm> #info Apparently, people were tired of discussing this and this is good enough :)
14:07:44 <bcotton> :-)
14:07:47 <tyll> asamalik might be the only one missing then
14:08:01 * dgilmore is in a meeting with my boss and his boss, so not paying enough attention here :(
14:08:03 <bcotton> speaking of things we're all tired of...
14:08:05 <contyk> He's unavailable today.
14:08:05 <mattdm> #info We can always add and enhance when shortcomings become inherent
14:08:20 <bcotton> #undo
14:08:20 <zodbot> Removing item from minutes: INFO by mattdm at 14:08:05 : We can always add and enhance when shortcomings become inherent
14:08:30 <bcotton> #info We can always add and enhance when shortcomings become apparent
14:08:36 <mattdm> THANK YOU
14:08:37 <bcotton> :-)
14:08:40 <mattdm> that was terrible
14:09:10 <bcotton> and now for something with inherent shortcomings...
14:09:13 <bcotton> #topic COVID-19
14:09:13 <mattdm> also, someone on phoronix called it "socialist". Given that Fedora is a social movement, I'll take it :)
14:09:14 <bcotton> #link https://fedoramagazine.org/fedora-community-and-the-covid-19-crisis/
14:09:16 <bcotton> #info bcotton is working on an assessment of the risk to the Fedora 32 final release and the upcoming datacenter move
14:09:21 <bcotton> mattdm: good :-D
14:09:50 <mattdm> #info thank you bcotton for writing that awesome statement for me. (I changed, like, five words.)
14:10:02 * bcotton blushes
14:10:28 <bcotton> the sneak preview of the risk assessment is that we seem to be in good shape for the F32 release considering the state of the world
14:10:52 <bcotton> but i'm still consolidating some details and i'll share a more helpful doc soon
14:11:04 <bcotton> (hopefully by the end of the week, since i'm on PTO next week)
14:11:19 <bcotton> obviously, the bigger concern is the health and well-being of our community
14:12:05 <bcotton> so i'd encourage all of us to show as much empathy as we're capable of and remind folks that while we're going to keep doing our best, what "our best" looks like now may be radically different from what "our best" looked like in the recent past, and that's okay
14:12:10 <mattdm> yeah. if it comes down to someone needing to be at risk to make the datacenter move or anything else hit our timeline, WE CAN WAIT
14:12:21 <bcotton> and now i will stop rambling and let other people talk if they want to
14:12:30 <mattdm> this means we may be running at diminished infrastructure capability for the F33 cycle.
14:13:11 <riecatnor> If we are on COVID related topics, I can give an update on Flock planning
14:13:18 <bcotton> riecatnor: go ahead :-)
14:14:07 <riecatnor> asically, events team says they can't make a call on it until mid April. If they decide we should cancel, the best time to do that is by 4/30, based on our hotel contract. I did ask Veronica to see if what is happening falls under any "natural disaster" type clauses as well
14:15:06 <riecatnor> Should we wait until we get a final decision to do a CFP?
14:15:12 <bcotton> #info Flock 2020 decision can't be made until mid-April and if we need to cancel, we should do that before 30 April
14:16:29 <bcotton> i'd be okay with getting the CfP machinery going. at least getting any sort of theme or particular content areas we want highlighted. even if we end up canceling, the ideas people come up with could be magazine/commblog articles or talks at conferences later in the year
14:17:18 <mattdm> or Fedora Council video meetings :)
14:17:18 <riecatnor> sounds good.
14:17:23 <bcotton> mattdm++
14:17:49 <bcotton> anyone disagree with getting the CfP ball rolling?
14:18:04 <sumantro> bcotton++
14:18:26 <mattdm> I agree, and let's make it explicitly talk about the alternatives we might turn to
14:18:38 <smooge> I have something about datacentre move when you need to speak about it and COVID
14:18:45 <mattdm> smooge: go for it
14:18:58 <bcotton> #agreed We will continue to proceed with Flock CfP planning for the time being
14:19:12 <bcotton> smooge: one sec, please
14:19:26 <smooge> Red Hat IT and the various vendors are working through various capacity plans. We are beginning to be hit with delays due to hardware not arriving into the country but nothing has become a hard stop
14:19:30 <bcotton> riecatnor: are you going to put together a schedule for the CfP process?
14:19:36 <smooge> .. oops will wait
14:19:58 <bcotton> smooge: no problem. mattdm thinks he's FPL or something ;-)
14:20:05 <mattdm> lol
14:20:18 <riecatnor> bcotton, I can do that. I can throw that together for next weeks meeting?
14:20:43 <bcotton> #action riecatnor to prepare schedule for Flock CfP process for 1 April meeting
14:21:18 <bcotton> riecatnor: and feel free to bring me in if you want help or to put it in The Official Scheduling Tool
14:21:27 <bcotton> okay, smooge, the floor is yours
14:21:33 <smooge> Red Hat IT and the various vendors are working through various capacity plans. We are beginning to be hit with delays due to hardware not arriving into the country but nothing has become a hard stop
14:21:55 <bcotton> #info Datacenter move update: Red Hat IT and the various vendors are working through various capacity plans. We are beginning to be hit with delays due to hardware not arriving into the country but nothing has become a hard stop
14:22:00 <smooge> Most of the work is being planned to be done remotely except for some physical work
14:22:35 <smooge> The datacentre's have quarentine rules in to keep any spread to a minimum so it will be more on 'us' dealing with infections
14:22:58 <bcotton> #info The datacenters have quarentine rules in to keep any spread to a minimum so it will be more on 'us' dealing with infections
14:23:12 <smooge> The major concern will be that the power off of the PHX2 area in June is pretty much set in stone.
14:23:30 <smooge> We would be running on diminished capacity while dealing with any hardware move
14:24:30 <smooge> I expect that Council and FESCO will need to come up with rationing rules for number of builds etc
14:24:51 <smooge> or at least approve what releng comes up with to deal with limitations
14:25:48 <smooge> At the moment the hardware move times have not changed: April 11 for Communishift and some other hardware. May 15th for QA hardware. June 1st for everything else
14:26:04 <bcotton> #info As of now, the hardware move schedule remains unchanged
14:26:38 <smooge> If we are asked to drop one, the May 15th is probably the one which may get moved which means QA work would be affected
14:26:57 <smooge> <end eyeore voice>
14:27:03 <bcotton> :-) thanks smooge
14:27:05 <bcotton> smooge++
14:27:37 <sumantro> smooge ++
14:27:42 <bcotton> smooge: for the hardware delay, is that for the reduced-capacity-infrastructure-that-we-are-not-giving-a-name in IAD2?
14:28:31 <bcotton> (the shipment delays from hardware not arriving in the country, i mean)
14:29:03 <smooge> bcotton, it was for rails and some other supplies for the hardware
14:29:28 <smooge> we are looking at alternative shelving and zip ties
14:29:51 <bcotton> zip ties: a sysadmin's best friend :-)
14:30:10 <mattdm> What about humans doing the shelving and zip tying? That's my main concern.
14:30:49 <smooge> that work is done by the datacentre at the moment
14:31:17 <smooge> I was told that they check people coming in and out for temperatures and are deploying other methods to screen people
14:32:06 <smooge> beyond that we just rely on our 1.5 sysadmins not getting too sick
14:33:20 <smooge> anything else?
14:33:29 <mattdm> stay healthy!
14:33:42 <smooge> i try not to derail more than 3 meetings a day
14:33:49 <bcotton> that's all i have. thanks for the update and please let me know whenever the situation changes
14:34:33 <mattdm> smooge: not derailing. thanks for the first-hand info!
14:35:37 <bcotton> anyone have any other COVID-19 questions or comments?
14:36:39 <bcotton> #topic November & January meeting follow ups: status reports, reorg, team directory, NPS survey, etc
14:36:47 <bcotton> #info bcotton has written guidance for status reports and intends to email points of contact this week (for real this time!)
14:37:00 <mattdm> Ben is slowly dragging me through the followups I need to do here :)
14:37:02 <contyk> bcotton++
14:37:14 <bcotton> mattdm: any update on the NPS survey?
14:38:01 <mattdm> no... it kind of got swept under $allthethings
14:38:21 <mattdm> riecatnor and i should schedule a followup call
14:38:34 <mattdm> #action mattdm schedule followup about nps
14:38:40 <bcotton> beat me to it! :-)
14:39:21 <bcotton> #info bcotton is slowly but surely making progress on a full writeup of the contributor recruitment plan for the community
14:40:05 <riecatnor> I finished writing that blog post for the commblog, needs review, links, and pics
14:40:06 <bcotton> so for the team directory... i thought i remember us saying we should make asamalik, our resident antora/asciidoc expert, come up with a skeleton implementation that we can start filling in
14:40:15 <bcotton> does anyone else remember that?
14:40:19 <bcotton> riecatnor: which blog post?
14:40:35 <contyk> Sounds reasonable.
14:40:36 <riecatnor> mmm, the one I promised y'all :)
14:41:00 <riecatnor> sorry, we can come back around the the blog post.
14:41:02 <mattdm> bcotton: I do remember that!
14:41:04 <bcotton> riecatnor: on reorg or something else?
14:41:30 <riecatnor> RISE initiative and other relevant things.
14:41:31 <bcotton> #agreed We remember saying asamalik, our resident antora/asciidoc expert, come up with a skeleton implementation of the team directory
14:41:31 <sumantro> riecatnor, the new org chart?
14:41:51 <bcotton> #action bcotton to open a ticket for asamalik on the team directory
14:42:02 <riecatnor> this one is specific to rise, there is a draft there to be reviewed
14:42:15 <bcotton> #info riecatnor has written a commblog post on the RISE initiative and other related things
14:42:29 <sumantro> riecatnor++
14:42:30 <zodbot> sumantro: Karma for riecatnor changed to 8 (for the current release cycle): https://badges.fedoraproject.org/tags/cookie/any
14:42:31 <bcotton> riecatnor: did you post a review request in discussion.fp.o
14:43:32 <riecatnor> not yet, still needs some links and pics still
14:43:41 <bcotton> okie dokie
14:44:46 <bcotton> anything else on our November/January follow ups (follows up?)?
14:46:09 <bcotton> moving right along, then
14:46:13 <bcotton> #topic Next meeting
14:46:14 <bcotton> #info The next Fedora Council meeting is 1 April.
14:46:26 <contyk> And that's no joke.
14:46:26 <bcotton> no joke!
14:46:29 <bcotton> contyk++
14:46:35 <bcotton> #topic Do we have anything to announce?
14:46:37 <bcotton> #info This is a regular check to make sure we're communicating to the contributor (via CommBlog) and user (via Magazine) communities
14:46:41 <bcotton> #info We released Fedora 32 Beta on the preferred target date!
14:46:43 <bcotton> #link https://fedoramagazine.org/announcing-the-release-of-fedora-32-beta/
14:46:51 <mattdm> everyone++
14:47:15 <mattdm> the datacenter info should go to the commblog
14:47:22 <mattdm> so people are prepared for less build capacity
14:47:43 <bcotton> agreed
14:48:07 <bcotton> #bcotton to work with infra team on commblog posts re: datacenter move and reduced build capacity
14:48:18 <bcotton> speaking of which...
14:48:36 <contyk> That seems broken ^
14:48:42 <bcotton> sigh
14:48:47 <bcotton> #action bcotton to work with infra team on commblog posts re: datacenter move and reduced build capacity
14:49:09 * bcotton is not a zodbot command
14:49:16 <contyk> Yet.
14:49:35 <bcotton> speaking of capacity, though, how do we feel about...
14:50:23 <bcotton> #proposed #agreed The Release Engineering team should develop a plan for how to fairly allocate build resources during the reduced infrastructure capacity and present it to FESCo for approval
14:50:50 <contyk> Any specific concerns?
14:51:03 <bcotton> i don't think this needs to come to the Council, but i would like to see a plan in place before we start hitting conflicts
14:51:24 <mattdm> I don't know if rel-eng is necessarily the right place to make the weighting decision
14:51:35 <bcotton> contyk: i know there have been cases before where some contributors have submitted a large quantity of builds at once
14:51:35 <contyk> The way I see it is we might have fewer builders and builds will take longer.
14:51:38 <mattdm> that's kind of cart before horse.
14:52:11 <contyk> That may always happen.
14:52:30 <bcotton> mattdm: i mean the plan could be "we don't have any restrictions to start, but here's what we'll do if it becomes an issue"
14:52:37 <mattdm> I think builds related to security updates and urgent bugfixes should get priority, followed by packages in the set needed to produce release-blocking artifacts.
14:52:40 <bcotton> contyk: yes, but it's going to be more of an issue while we have reduced capacity
14:53:11 <mattdm> and I think we should start by asking people to self-select
14:53:19 <mattdm> and disable any automated scratch builds and the like
14:53:41 <contyk> I think that'd be the best.
14:53:56 <contyk> In the worst case we might need a separate high priority channel.
14:54:16 <contyk> I'm not sure there are other solutions to the problem currently. We'd need to develop something.
14:54:34 <bcotton> that works for me. i'm mostly interested in having a proactive communication about that, i guess
14:54:38 <contyk> If we want someone to product a simple plan like that, okay.
14:55:36 <bcotton> contyk: as our fesco rep, can i #action you to work with releng to develop a simple plan
14:55:49 <contyk> Sure.
14:55:54 <mattdm> I encourage you to start with ripping off the idea I proposed a few lines up :)
14:56:34 * dgilmore notes that how builds are scheduled are baked into Koji's code
14:56:55 <bcotton> #action contyk to work with release engineering to devleop a simple plan for how builds will be handled during the diminished build capacity window
14:57:07 <dgilmore> all builds unless intentionally given a lower priority (mass rebuilds) have the same priority
14:57:47 <contyk> Yeah.
14:58:06 <contyk> That's why I think a separate channel with reserved builders is the only current option.
14:58:06 <mattdm> I have to go because riecatnor and I have a meeting in 2 minutes.
14:58:08 <dgilmore> we can ask people submitting large builds like a gnome or kde mass rebuild to lower the priority, but there is no way to enforce it
14:58:11 <mattdm> bye and thanks all
14:58:21 <bcotton> okay, last call for open floor
14:58:24 <riecatnor> thanks bcotton!
15:00:33 <bcotton> thanks everyone!
15:00:35 <bcotton> #endmeeting