14:00:22 <bcotton> #startmeeting Council (2020-04-01)
14:00:22 <zodbot> Meeting started Wed Apr  1 14:00:22 2020 UTC.
14:00:22 <zodbot> This meeting is logged and archived in a public location.
14:00:22 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:22 <zodbot> The meeting name has been set to 'council_(2020-04-01)'
14:00:24 <bcotton> #meetingname council
14:00:24 <zodbot> The meeting name has been set to 'council'
14:00:30 <bcotton> #chair jonatoni riecatnor contyk dgilmore mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:30 <zodbot> Current chairs: asamalik bcotton contyk dgilmore jonatoni mattdm pbrobinson riecatnor sumantrom tyll
14:00:31 <asamalik> .hello2
14:00:32 <bcotton> #topic Introductions, Welcomes
14:00:32 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:00:37 * sumantro us here
14:00:40 <riecatnor> good morning, Ben!
14:00:50 <bcotton> hello, asamalik, sumantro, riecatnor!
14:01:00 <mattdm> hey x3mboy -- on the new logo: we have a meeting with RH legal to discuss next steps literally this afternoon :)
14:01:24 <mattdm> hi everyone! Marie and I have a call we have to drop for at 10:30
14:01:31 <mattdm> so let's be fast :)
14:01:43 <bcotton> heh.....well about that
14:01:51 <bcotton> okay, let's start then, people can join as they join
14:02:02 <bcotton> #topic Today's agenda
14:02:03 <bcotton> #info Flock CfP planning
14:02:05 <bcotton> #info git forge follow up
14:02:06 <bcotton> #info Your topics here!
14:02:09 <bcotton> #topic Flock CfP planning
14:02:15 <bcotton> riecatnor, the floor is yours
14:02:25 <riecatnor> I have a png to share, not sure where the best place to do that is
14:02:44 <x3mboy> mattdm, Hi! Thanks for the clarification
14:02:48 <mattdm> upload to your fedorapeople account?
14:02:57 <x3mboy> I mean, my main issue is telegram accounts already using it
14:03:02 <contyk> .hello psabata
14:03:03 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
14:03:33 <mattdm> x3mboy: they should not yet. I know I'm using it on my new avatar, but that's just for fun. Officially, we *need* to keep using the current one.
14:03:45 <mattdm> (We do not want to be seen as abandoning it.)
14:03:55 <x3mboy> Like the main Fedora Linux channel (https://t.me/fedora) and Fedora Albania (https://t.me/FedoraAlbania)
14:04:12 <bcotton> mattdm, x3mboy: can we move this conversation to fedora-council or wait for the next topic, please?
14:04:22 <x3mboy> Oh sorry...
14:04:24 <mattdm> bcotton: can we insert it as next topic quick?
14:04:30 <bcotton> mattdm: sure
14:04:45 <riecatnor> https://pasteboard.co/J1NHgSi.png
14:04:45 * pbrobinson is here
14:04:46 <x3mboy> I though we were still on FPgM office hours
14:04:58 <bcotton> #link https://pasteboard.co/J1NHgSi.png
14:05:20 <asamalik> better than a thousand words!
14:05:52 <riecatnor> For those who have previously worked the CfP process for Flock, I would like you to take a look and see if I have accounted enough time. Specifically for reviewing proposals. Is two weeks enough?
14:06:17 <mattdm> riecatnor: yes, because in practice what we do is wait until the last three days
14:06:39 <mattdm> #info planning on the Flock Call for Papers on April 6
14:06:59 <mattdm> #info with selection at the end of May
14:07:39 <contyk> This Flock might be a virtual event in the end.
14:07:56 <bcotton> i think the timeline is good overall
14:08:11 <riecatnor> Yes, it's true contyk. We will find out in a couple weeks. Meanwhile, CfP is still useful and needs to happen if Flock is happening :)
14:08:18 <bcotton> my concern is getting a good cfp message written this week
14:08:34 <bcotton> e.g. deciding on what we want to really call out as areas for topics, etc
14:08:57 <mattdm> #info Even if Flock turns into a virtual event, we still will need content so CfP will go ahead as normal
14:09:03 <riecatnor> bcotton, ack. I think now would be a good moment for suggestions?
14:09:29 <riecatnor> Maybe not.
14:09:39 <bcotton> .....you know.....stuff? :-)
14:09:50 <riecatnor> stuff n things' flock 2020
14:10:24 <bcotton> we don't necessarily need to have a specific set of focus areas, it's not like we generally theme flock. but if we want to, we should figure that out soon :-)
14:10:50 <riecatnor> k, let me think on it.  I might throw a meeting with you and mattdm for end of the week to review what i come up wiht
14:11:00 <mattdm> sounds good
14:11:16 <bcotton> anything else on the flock cfp?
14:11:21 <riecatnor> nope!
14:12:17 <bcotton> #topic New logo
14:12:33 <bcotton> mattdm, x3mboy, you may un-pause your discussion :-)
14:12:37 <mattdm> #info Please do not use the new logo for anything official yet.
14:12:42 <mattdm> #info This includes social media channels.
14:13:02 <x3mboy> Thanks
14:13:17 <x3mboy> I'm having an interesting discussion on the Telegram admins channel
14:13:25 <mattdm> #info We are in the process of registering the new logo, and we can't be seen as abandoning the old one before that happens.
14:13:25 <x3mboy> But I will try to revert it soon
14:13:43 <mattdm> #info I appreciate the enthusiasm and hopefully we'll have an update soon
14:14:01 <mattdm> I reverted my Twitter avatar to set an example :)
14:14:35 <mattdm> x3mboy++
14:14:38 <zodbot> mattdm: Karma for x3mboy changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:14:39 <mattdm> thanks for bringing this up
14:14:46 <mattdm> let's go on to the main event?
14:14:51 <bcotton> okay!
14:15:04 <bcotton> #topic git forge follow up
14:15:06 <bcotton> I know this is going to generate a lot of passioned discussion, so let's try to be a little more disciplined with the “microphone”. please indicate that you have something to say with . or o/ and when you are done, say “done” or “EOF” or something similar. this way we can avoid talking over each other
14:15:22 <mattdm> o/
14:15:31 <bcotton> mattdm: the floor is yours
14:16:00 <mattdm> Obviously the communication for this did not go so well. Among other things but let's start there. :)
14:16:14 * King_InuYasha waves
14:16:16 <mattdm> I take some responsibility for this, because I actually thought the message from Leigh was pretty good.
14:16:39 <bcotton> King_InuYasha: ack. you'll be next on the list
14:16:56 <mattdm> I see that this was not the general way it was received. I could have done a better job advising CPE leadership to stick to the process outlined in the earlier blog post
14:17:27 <mattdm> So, seriously, sorry, should have done that better. We'll try to do so for the next steps.
14:17:30 <mattdm> .
14:17:40 <bcotton> King_InuYasha: your turn
14:18:19 <King_InuYasha> so, uhh, I don't know what we're talking about?
14:18:21 <mattdm> (King_InuYasha 1. Please introduce yourself for those for whom this handle is not familiar. Also note that Marie and I have to leave in ten minutes for a meeting we couldn't move.)
14:18:28 <King_InuYasha> .hello ngompa
14:18:29 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
14:18:34 <mattdm> (gitforge!)
14:18:36 <King_InuYasha> ah
14:18:48 <mattdm> I was just apologizing for communication lead balloon.
14:19:06 <riecatnor> .
14:19:21 <bcotton> King_InuYasha: oh, sorry, i thought you were waiting to speak on the topic. i know you've had some opinions on the mailing list
14:19:25 <King_InuYasha> yeah
14:19:31 <bcotton> King_InuYasha: while you have the stick, anything you want to add here?
14:19:38 <bcotton> riecatnor: ack, you're next on the list
14:19:48 <mattdm> o/ again :)
14:20:10 <bcotton> mattdm: your call is important to us. you are currently number 2 in the queue
14:20:24 <King_InuYasha> I think I've said the bulk of what I wanted to say about this has been said on the mailing list
14:21:11 <bcotton> King_InuYasha: for the record, i really appreciate your feedback on the list. it's been very constructive and a great example of disagreeing respectfully
14:21:38 <bcotton> okay, i'll pass the baton to riecatnor
14:22:14 <riecatnor> There are three things I would like to address. One is evaluating this situation, taking some time to document what went badly, what maybe went well, how we can roll out decisions like this more effectively in the future. Perhaps even writing something publicly so that the community sees we see it went badly, and that we are listening. Second is for the teams that want to stay on Pagure, is that an option? Third is how do we ease the path of
14:22:14 <riecatnor> acceptance around Gitlab for those teams that have to and/or want to move there. The decision to go with it has been made. We need to help the community see, understand, and accept why the decision was made, and then hopefully become inspired to contribute to it. We are working against a lot for this second piece, though I have a couple ideas. I would really love to get input from everyone else.
14:23:50 <bcotton> i suggest a council-discuss thread for this
14:24:57 <mattdm> yes, sounds good. marie, can you post what you just wrote there? :)
14:25:06 <riecatnor> you got it!
14:25:10 <bcotton> action riecatnor to start a council-discuss thread to collect feedback on improving the decision and communication process, and moving forward
14:25:10 <mattdm> riecatnor++
14:25:11 <zodbot> mattdm: Karma for riecatnor changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:25:32 <bcotton> riecatnor: ready for mattdm's turn?
14:25:41 <riecatnor> yep
14:25:57 <bcotton> mattdm: your turn
14:25:58 <mattdm> Ok, so, five minutes whee
14:26:08 <mattdm> In 2018, we decided this:
14:26:10 <mattdm> #agreed The Fedora Project wants to advance free and open source software and as a pragmatic matter we recognize that some infrastructure needs may be best served by using closed source or non-free tools today. Therefore the Council is willing to accept closed source or non-free tools in Fedora’s infrastructure where free and open source tools are not viable or not available. (+9,0,-0)
14:26:22 <mattdm> #info the above is from 2018 not just now
14:26:45 <mattdm> We were clearly discussing gitlab and github at the time, so it's not like this is a surprise.
14:27:12 * pingou hass been looking where this is documented a few months ago
14:27:16 <mattdm> The community sentiment seems to be very strongly that dist-git is a part of our infrastructure where we need open source
14:28:26 <mattdm> We were unanimous on this before. Is that still the case? And how can we reconcile that difference?
14:28:54 <mattdm> pingou: it is at https://docs.fedoraproject.org/en-US/council/policies/
14:29:00 <mattdm> #link https://docs.fedoraproject.org/en-US/council/policies/
14:29:05 <mattdm> #link https://communityblog.fedoraproject.org/fedora-council-december-2018-hackfest-report/
14:29:12 <mattdm> and the second one has the minutes where we recorded the vote
14:29:28 <mattdm> omg and with that I have to mic drop and run out. but obviously there's more to talk about here.
14:29:42 <bcotton> for the record, the council membership is unchanged from the time of that #agreed, except for replacing the FCAIC, but that doesn't mean people's opinions haven't changed in the interim
14:29:43 * contyk is still +1; I think we knew the "is not viable" part was going to be problematic.
14:30:08 * bcotton agrees with contyk in the entirety
14:30:28 <mattdm> bye all. please solve all problems.
14:30:36 <bcotton> .fire mattdm
14:30:36 <zodbot> adamw fires mattdm
14:31:34 <bcotton> oh, i should correct myself. we've also lost two council members due to completed objectives
14:31:43 <bcotton> does anyone else want to chime in on this?
14:32:34 <dgilmore> mattdm: I am sure many would argue that there is viable open source options for dist-git
14:33:11 <dgilmore> so I do not think that the community viewpoint is in conflict with the statement we made then
14:33:25 <asamalik> I haven't been here in 2018, but I'd be +1 to the above #agreed
14:33:34 <asamalik> I mean, here in the Council
14:33:56 <bcotton> ugh, dang. okay fine, i was totally wrong in my statement earlier
14:34:34 <bcotton> part of the reason we went through the exercise of collecting user stories is so that CPE would have a meaningful way of defining "viable"
14:35:10 <asamalik> I'm using proprietary software that runs in trams and buses all the time, so I can go and buy coffee, which gives me energy to contribute to open source so it can, one day, run on those buses and trams as well :D
14:35:16 <bcotton> it's totally valid to disagree with the assessment, but i think having that list made it a much better process
14:37:12 * bcotton goes to add that to marie's thread
14:38:39 <bcotton> okay, it sounds like this discussion has worked itself out for now
14:39:33 <asamalik> (just to be clear, I'm not endorsing the way that git forge decision has been made, just commenting on the #agreed from 2018)
14:39:44 <bcotton> #topic Next meeting
14:39:46 <bcotton> #info The next Fedora Council meeting is 8 April. It is the monthly video meeting, with special guest pbrobinson talking about Fedora IoT
14:40:07 <pbrobinson> yay
14:40:52 <bcotton> #topic Do we have anything to announce?
14:40:53 <bcotton> #info This is a regular check to make sure we're communicating to the contributor (via CommBlog) and user (via Magazine) communities
14:43:20 <bcotton> sounds like no!
14:43:24 <bcotton> #topic Open floor
14:46:08 <bcotton> last call!
14:48:00 <bcotton> okay, thanks everyone!
14:48:02 <bcotton> #endmeeting