2023-10-11 14:02:43
         <@jflory7:fedora.im>  
        !startmeeting Fedora Council - 2023-10-11
        
2023-10-11 14:03:30 <@meetbot:fedora.im> Meeting started at 2023-10-11 14:02:43 UTC
2023-10-11 14:03:31 <@meetbot:fedora.im> The Meeting name is 'Fedora Council - 2023-10-11'
2023-10-11 14:03:49 <@jflory7:fedora.im> Oh, well, hi Meet Bot
2023-10-11 14:03:59 <@jflory7:fedora.im> !meetingname council
2023-10-11 14:04:12 <@jflory7:fedora.im> !topic Roll call & hello's
2023-10-11 14:04:19 <@jonatoni:fedora.im> hi folks 👋
2023-10-11 14:04:20 <@jflory7:fedora.im> Nice :)
2023-10-11 14:04:47 <@jflory7:fedora.im> Hey Jona Azizaj 👋
2023-10-11 14:04:58 <@jflory7:fedora.im> No problem!
2023-10-11 14:05:29 <@jflory7:fedora.im> bookwar, David Cantrell, Sumantro Mukherjee: Ping, are you all around?
2023-10-11 14:05:29 <@mattdm:fedora.im> I am waiting for Element on my treadmill desk computer to catch up.
2023-10-11 14:05:43 <@bookwar:fedora.im> Hi!
2023-10-11 14:05:54 <@mattdm:fedora.im> hello, element?
2023-10-11 14:06:01 <@jflory7:fedora.im> Hey bookwar 👋
2023-10-11 14:06:07 <@jflory7:fedora.im> mattdm: I am so ready for Matrix 2.0
2023-10-11 14:06:14 <@mattdm:fedora.im> Eh. It is not working right.
2023-10-11 14:06:18 <@jflory7:fedora.im> I don't know someone who is not, actually :P
2023-10-11 14:06:21 <@mattdm:fedora.im> I can't see your posts.
2023-10-11 14:06:24 <@mattdm:fedora.im> yay
2023-10-11 14:06:44 <@jflory7:fedora.im> It seems like a case of Mondays but on a Wednesday!
2023-10-11 14:07:06 <@jflory7:fedora.im> Also, hey bt0dotninja 👋
2023-10-11 14:07:41 <@jflory7:fedora.im> Alright. So, technical issues aside, I think we can push forward.
2023-10-11 14:08:08 <@jflory7:fedora.im> !info Present: @jflory7:fedora.im, mattdm, Jona Azizaj, bookwar, bt0dotninja
2023-10-11 14:08:22 <@jflory7:fedora.im> !topic Announcements, news, & other updates
2023-10-11 14:08:29 <@jflory7:fedora.im> I have one thing to share 🙂
2023-10-11 14:08:54 <@mattdm:fedora.im> I have several, possibly with overlap :)
2023-10-11 14:09:05 <@bookwar:fedora.im> 🥁
2023-10-11 14:09:18 <@jflory7:fedora.im> I want to give an official welcome to Jona Azizaj as our newest member of the Fedora Council. Jona is the new DEI Advisor, as Vipul transitions out of the role. Welcome (back) Jona Azizaj!
2023-10-11 14:09:22 <@jflory7:fedora.im> 🎉
2023-10-11 14:09:27 <@bt0dotninja:fedora.im> 😁
2023-10-11 14:09:43 <@jflory7:fedora.im> !info Jona Azizaj joins the Fedora Council as the new DEI Advisor.
2023-10-11 14:09:56 <@jflory7:fedora.im> mattdm: Floor is yours :)
2023-10-11 14:10:29 <@sumantrom:fedora.im> :D
2023-10-11 14:10:47 <@mattdm:fedora.im> First: Slimbook announcement is out! Please share and promote and stuff.
2023-10-11 14:10:53 <@mattdm:fedora.im> https://fedoramagazine.org/fedora-slimbook-available-now/\
2023-10-11 14:11:01 <@mattdm:fedora.im> https://fedoramagazine.org/fedora-slimbook-available-now/
2023-10-11 14:11:08 <@mattdm:fedora.im> #link https://fedoramagazine.org/fedora-slimbook-available-now/
2023-10-11 14:11:24 <@jflory7:fedora.im> !info Slimbook announcement is out. Please help share and promote it in your channels.
2023-10-11 14:11:30 <@jflory7:fedora.im> !link https://fedoramagazine.org/fedora-slimbook-available-now/
2023-10-11 14:11:32 <@mattdm:fedora.im> Dunno what New Zodbot does with edited messages.
2023-10-11 14:11:47 <@jflory7:fedora.im> Good question.
2023-10-11 14:11:50 <@mattdm:fedora.im> Oh, I see it is ! now. TIL :)
2023-10-11 14:12:05 <@mattdm:fedora.im> Anyway. There's that.
2023-10-11 14:12:48 <@mattdm:fedora.im> Uh, "connectivy to the server has been lost"
2023-10-11 14:13:04 <@mattdm:fedora.im> Um.
2023-10-11 14:13:15 <@mattdm:fedora.im> Curse you, Matrix!!!!
2023-10-11 14:13:26 <@jflory7:fedora.im> (My Internet connection just dropped, so I might be slow to reply here time to time… working off of a mobile hotspot today while home Internet is down 🤦)
2023-10-11 14:14:19 <@jflory7:fedora.im> Oh, I thought it was me :)
2023-10-11 14:14:22 <@bt0dotninja:fedora.im> 😅
2023-10-11 14:14:43 <@mattdm:fedora.im> Not you. Ugfgghhh.
2023-10-11 14:14:49 <@mattdm:fedora.im> ANYWAY.
2023-10-11 14:15:29 <@mattdm:fedora.im> The announcement: Red Hat has hired someone to be the Fedora Operations Architect. We will announce this sometime next week.
2023-10-11 14:16:03 <@bt0dotninja:fedora.im> Cool
2023-10-11 14:16:54 <@jflory7:fedora.im> FYI, Sumantro Mukherjee just wrote me that power dropped at his location and he is offline for now. Evidently, something rippled across the Internet in that blip :P
2023-10-11 14:16:57 <@mattdm:fedora.im> For transparency: all Fedora leadership roles hired by Red Hat require council approval for their actual Council power. This is largely a formality, but I think it's an important check-and-balance thing, in case Red Hat Really Screws Up sometime int he future.
2023-10-11 14:17:28 <@jflory7:fedora.im> !info Red Hat has hired someone to be the Fedora Operations Architect. An announcement will follow sometime next week.
2023-10-11 14:17:39 <@mattdm:fedora.im> I'm confident that this is not one of those times, but still. Once the announcement is made, I will make a ticket for "ratify new council member".
2023-10-11 14:18:33 <@mattdm:fedora.im> In retrospect we probably also should have done this for Justin too, but I think we're well into consent-by-lack-of-objection on that one. :)
2023-10-11 14:18:54 <@mattdm:fedora.im> okay, and the third one:
2023-10-11 14:19:32 <@mattdm:fedora.im> #info Next week, Justin and I will be at All Things Open in Raleigh, North Carolina. And, the new Fedora Operations Architect will be too. Come by and say hello!
2023-10-11 14:20:05 <@mattdm:fedora.im> If you are in RDU area I mean. If you're in Mexico or India it will probably be harder. But, we'll try to come visit you too sometime!
2023-10-11 14:20:38 <@jflory7:fedora.im> !info Next week, Justin and I will be at All Things Open in Raleigh, North Carolina. And, the new Fedora Operations Architect will be too. Come by and say hello!
2023-10-11 14:20:46 <@mattdm:fedora.im> (Seriously, I put in my budget request for travel for next year for me and the FOA and included requests for travel to events there.)
2023-10-11 14:20:52 <@jflory7:fedora.im> !link https://2023.allthingsopen.org/
2023-10-11 14:20:57 <@mattdm:fedora.im> Thank you justin! I forgot the ! in _such a short time_
2023-10-11 14:21:27 <@jflory7:fedora.im> All good, the pound sign is muscle memory :)
2023-10-11 14:22:10 <@jflory7:fedora.im> Next week will be an exciting week.
2023-10-11 14:22:20 <@jflory7:fedora.im> Any other news, announcements, updates?
2023-10-11 14:22:29 <@mattdm:fedora.im> also apparently we have cookies in Matrix now?
2023-10-11 14:22:35 <@jflory7:fedora.im> Yes!
2023-10-11 14:22:46 <@jflory7:fedora.im> Oh, we should give @darknao one for fixing Meet Bot just for us especially :)
2023-10-11 14:22:48 <@jflory7:fedora.im> darknao++
2023-10-11 14:22:50 <@zodbot:fedora.im> You have already given cookies to darknao during the F38 timeframe
2023-10-11 14:23:11 <@mattdm:fedora.im> darknao++
2023-10-11 14:23:13 <@zodbot:fedora.im> darknao has 2 cookie(s)
2023-10-11 14:23:19 <@jonatoni:fedora.im> darknao++
2023-10-11 14:23:21 <@zodbot:fedora.im> darknao has 3 cookie(s)
2023-10-11 14:23:21 <@jflory7:fedora.im> !info FYI: zodbot now has cookie support added back! Try it out by adding "++" to someone's Matrix ID or writing their FAS username directly.
2023-10-11 14:23:49 <@mattdm:fedora.im> The big question: will it give cookies for adding a cookie reaction?
2023-10-11 14:23:51 <@jflory7:fedora.im> Oh, how I have missed cookies 😀
2023-10-11 14:23:53 <@bt0dotninja:fedora.im> darknao++
2023-10-11 14:23:53 <@mattdm:fedora.im> BECAUSE IT SHOULD
2023-10-11 14:23:55 <@zodbot:fedora.im> darknao has 4 cookie(s)
2023-10-11 14:24:41 <@jflory7:fedora.im> Fun things aside, any other news and updates from folks?
2023-10-11 14:24:48 <@jflory7:fedora.im> Going once…
2023-10-11 14:25:01 <@jflory7:fedora.im> Going twice…
2023-10-11 14:25:10 <@jflory7:fedora.im> Going thrice…
2023-10-11 14:25:20 <@jflory7:fedora.im> 🔨
2023-10-11 14:25:27 <@jflory7:fedora.im> !topic Ticket discussion
2023-10-11 14:25:52 <@jflory7:fedora.im> !info This part of the Fedora Council meeting is focused on going through pending tickets in the Fedora Council ticket tracker.
2023-10-11 14:25:59 <@jflory7:fedora.im> !link https://pagure.io/Fedora-Council/tickets/issues
2023-10-11 14:26:00 <@mattdm:fedora.im> We are REALLY backlogged on tickets.
2023-10-11 14:26:19 <@mattdm:fedora.im> I want to pick https://pagure.io/Fedora-Council/tickets/issue/463 as the most pressing
2023-10-11 14:26:31 <@jflory7:fedora.im> Yeah… 😕 Not that the Operations Architect will fix all the challenges, but I think it would help.
2023-10-11 14:26:37 <@jflory7:fedora.im> mattdm: Ack, I have that one and one more
2023-10-11 14:26:43 <@jflory7:fedora.im> !topic #465: formal trademark approval for "Fedora Slimbook"
2023-10-11 14:26:48 <@jflory7:fedora.im> !link https://pagure.io/Fedora-Council/tickets/issue/465
2023-10-11 14:26:55 <@jflory7:fedora.im> mattdm: This one is yours. Is this officially approved?
2023-10-11 14:27:03 <@jflory7:fedora.im> I mean… the announcement shipped today 🙂
2023-10-11 14:27:06 <@jflory7:fedora.im> But should we close it?
2023-10-11 14:28:29 <@mattdm:fedora.im> Yeah ... it's been 5 days and we have more than 3 +1s. Only vote outstanding is David Cantrell.
2023-10-11 14:28:38 <@jflory7:fedora.im> And Sumantro Mukherjee
2023-10-11 14:29:01 <@jflory7:fedora.im> But, I think it is probably OK to close… I mean, I don't know what a -1 would look like at this point anyways :P
2023-10-11 14:29:27 <@jflory7:fedora.im> So, if there is not any more pending action, I will ack this one as approved and we will move on
2023-10-11 14:29:52 <@sumantrom:fedora.im> I am +1 as well
2023-10-11 14:29:58 <@jflory7:fedora.im> Excellent
2023-10-11 14:30:08 <@mattdm:fedora.im> Oh, sorry Sumantro -- I thought yours was there!
2023-10-11 14:30:23 <@jflory7:fedora.im> !agreed Ticket currently sitting at `+5`/`0`/`-0` and a `+1` in the meeting. The press release shipped today.
2023-10-11 14:30:31 <@mattdm:fedora.im> I talked briefly to Amanda Newby, one of Red Hat's lawyers, and she would like them to add some text to their page about our support commitment and so on. I can _imagine_ holding up things for that, but I think we're on friendly enough terms that it won't be a problem. We can always say "nope, not working out" if an issue arises.
2023-10-11 14:30:47 <@mattdm:fedora.im> Which it won't, I'm very confident.
2023-10-11 14:31:05 <@jflory7:fedora.im> Do we keep the ticket open until then, or are we good to close?
2023-10-11 14:32:27 <@jflory7:fedora.im> !action mattdm Close ticket #465 as approved. Continue the conversation about the support commitment for Fedora on the Slimbook sale page.
2023-10-11 14:32:38 <@jflory7:fedora.im> I see the ticket is closed, so actioning and moving on 🙂
2023-10-11 14:32:46 <@jflory7:fedora.im> Next ticket then…
2023-10-11 14:33:10 <@jflory7:fedora.im> !topic #463: Deprecating IRC and moving to Matrix as the single official chat platform for the Fedora community
2023-10-11 14:33:15 <@jflory7:fedora.im> !link https://pagure.io/Fedora-Council/tickets/issue/463
2023-10-11 14:33:21 <@jflory7:fedora.im> !link https://pagure.io/Fedora-Council/council-docs/pull-request/201
2023-10-11 14:34:16 <@jflory7:fedora.im> There are a lot of pending comments on the Pull Request.
2023-10-11 14:34:41 <@jflory7:fedora.im> I think the two remaining discussion points other than small edits were about how "active presence" is defined and what we call these groups.
2023-10-11 14:35:11 <@jflory7:fedora.im> The last edit was `s/Fedora leadership groups/Specific Fedora Committees and Teams` to the group names… which I did not feel was the right change either
2023-10-11 14:35:47 <@jflory7:fedora.im> David Cantrell also asked for a more specific definition of active presence, but I don't know that this is something _we_ necessarily want to define?
2023-10-11 14:36:06 <@jflory7:fedora.im> My thoughts while authoring was to be intentionally broad, so that the individual teams could specify that on their own terms.
2023-10-11 14:36:07 <@mattdm:fedora.im> I'm feeling a little bit like the IRC bridge might never come back.
2023-10-11 14:36:16 <@jflory7:fedora.im> mattdm: Same.
2023-10-11 14:36:42 <@mattdm:fedora.im> Which means I think we need to go bigger than this. People are split. I can't even talk to Peter Robinson anymore.
2023-10-11 14:36:43 <@jflory7:fedora.im> Last I heard, there was only one engineer working on _all_ of the Matrix bridges, inclusive of IRC but also Slack and whatever other bridges there are.
2023-10-11 14:36:54 <@mattdm:fedora.im> Is David Cantrell listening to this thing? :)
2023-10-11 14:37:36 <@jflory7:fedora.im> Ah, I just opened Slack and saw he messaged me there that he has a conflict today
2023-10-11 14:37:37 <@mattdm:fedora.im> Whichhhhhh, I hate to bring this elephant stomping into the room, but: Matrix was chosen as our solution largely because of the IRC bridge.
2023-10-11 14:38:00 <@mattdm:fedora.im> If we don't have that, is Matrix the platform we _should_ commit to?
2023-10-11 14:38:28 <@mattdm:fedora.im> Should we go back to considering e.g. RocketChat?
2023-10-11 14:38:33 <@jflory7:fedora.im> Yes.
2023-10-11 14:38:45 <@mattdm:fedora.im> Connectivity to the server has been lost.
2023-10-11 14:38:52 <@mattdm:fedora.im> Perfect timing!
2023-10-11 14:39:21 <@jflory7:fedora.im> No.
2023-10-11 14:40:19 <@mattdm:fedora.im> Not everyone is convinced that we should move to Matrix from IRC. We've got a similar split to Discourse/Mailing Lists. I think we need to un-split it, and I think IRC can't be the answer.
2023-10-11 14:40:37 <@jflory7:fedora.im> I get the sunk effort fallacy, but there is a significant amount of confusion already about where Fedora collaborates and works. Matrix is not perfect and has its issues, but aligns with our values, there is a growing ecosystem with other communities that are close to us (e.g. GNOME), and if we move to another platform, it is a _huge_ amount of work to migrate everything that we already have over there. It would be years of more chaos.
2023-10-11 14:40:46 <@jflory7:fedora.im> For instance, Meet Bot and Zodbot, that we _just_ got onto Matrix
2023-10-11 14:40:54 <@mattdm:fedora.im> I don't want our best offer to be "Well, we picked Matrix, and it was disappointing, but we're committed now, so let's dig deeper."
2023-10-11 14:40:59 <@jflory7:fedora.im> And we have a really nice collaboration there with the Ansible folks who are helping us jointly maintain the bots.
2023-10-11 14:41:31 <@jflory7:fedora.im> mattdm: I am feeling optimistic with the Matrix 2.0 improvements coming down the pipeline. I see ecosystem growth happening there that I frankly don't with other platforms.
2023-10-11 14:41:38 <@davdunc:fedora.im> we should make sure that other related communities are considered, like the Ansible community in that consideration.
2023-10-11 14:41:48 <@mattdm:fedora.im> davdunc++
2023-10-11 14:41:52 <@zodbot:fedora.im> davdunc has 1 cookie(s)
2023-10-11 14:42:10 <@jflory7:fedora.im> And we have a really nice collaboration there with the Ansible folks who are helping us jointly maintain the Matrix bots.
2023-10-11 14:42:45 <@mattdm:fedora.im> It's also worth noting that DIscourse has a chat feature which we are not using. Unlike Matrix/Element/EMS, the pricing model _does not punish us for having more users_.
2023-10-11 14:42:58 <@jflory7:fedora.im> For the skeptics, what is their alternate proposal to Matrix though?
2023-10-11 14:43:05 <@mattdm:fedora.im> I know that there is some skepticism re my "Discourse all the things!" attitude, but just wanted to mention.
2023-10-11 14:44:14 <@mattdm:fedora.im> Some people are "libera.chat is good and independent". At least one person _not me_ suggested Discourse because it puts more things closer together. I've heard that Rocket Chat now does have a Matrix bridge....
2023-10-11 14:45:15 <@jflory7:fedora.im> But we wanted to get away from more bridges though, right?
2023-10-11 14:45:44 <@mattdm:fedora.im> I'm okay if the answer is "matrix is still our best choice". I just want to make sure we're _sure_. And I'd like to then tell everyone "this is where real-time comms happen"
2023-10-11 14:46:05 <@mattdm:fedora.im> make IRC _unofficial_, like telegram or reddit or discord
2023-10-11 14:46:31 <@jflory7:fedora.im> I think my perspective is clear but I'd love to hear from others. I am swimming in this all the time so I have some tunnel vision on what I think is the right move
2023-10-11 14:46:42 <@jflory7:fedora.im> We also need an Infra perspective here
2023-10-11 14:47:06 <@jflory7:fedora.im> Because it is a lot of work for Infrastructure even if the platform itself is not hosted in our Infra (thinking of the bots and integrations to other things like Discussion)
2023-10-11 14:47:42 <@mattdm:fedora.im> Proposal: let's start a wider community discussion. Community Blog post, devel-announce post. And I'll even commit to having the discussion _both_ on the devel list and on discussion :)
2023-10-11 14:48:10 <@davdunc:fedora.im> Matrix is working for me. I am a longtime IRC fan, but it's just easier. I think that the Discourse question is one that we can resolve because it's not exclusive of the email experience that many want. we are moving (IMO) towards a _more_ inclusive model.
2023-10-11 14:50:53 <@bt0dotninja:fedora.im> I think making IRC unofficial is good; it won't cover all the necessary features of our modern community, but can Matrix or Discourse do it? Maybe we need to try to do some experiments with discourse, and if we find it is not as good go deep with matrix
2023-10-11 14:51:24 <@bt0dotninja:fedora.im> Unsplit is the thing
2023-10-11 14:53:28 <@jflory7:fedora.im> Are we sure that more feedback would help us drive to an outcome? I am concerned that an open call for ideas might lead to options that we could not actually execute. If we went this route, we would need a fixed menu of options.
2023-10-11 14:54:37 <@mattdm:fedora.im> I don't think we should do an open call for ideas. We're not at that point. I think we should say "Matrix/IRC bridge is down for good. That's a problem we need to resolve. We've taken a look at the options, and think that even though the situation has changed, it is still our best option because a, b, and c."
2023-10-11 14:55:59 <@mattdm:fedora.im> It would be nice if someone other than Justin or me were able to take lead on this, too.
2023-10-11 14:56:45 <@mattdm:fedora.im> But, as someone who was complaining to me about this this week said, "Matthew, what's needed is some _leadership_ here." :)
2023-10-11 14:56:53 <@jonatoni:fedora.im> maybe not having an open call for ideas, but checking with different teams (Marketing team, Mindshare, etc) if Matrix is working well for them and why
2023-10-11 14:56:54 <@mattdm:fedora.im> A point deeply taken :)
2023-10-11 14:56:58 <@davdunc:fedora.im> mattdm: if you need an extra TPM for. that effort. . .
2023-10-11 14:57:24 <@jflory7:fedora.im> (Time check that we have 5 minutes left -- the discussion can continue after the hour ends, but I'll have to hop to other meetings.)
2023-10-11 14:57:34 <@jflory7:fedora.im> (Time check that we have 3 minutes left -- the discussion can continue after the hour ends, but I'll have to hop to other meetings.)
2023-10-11 14:57:37 <@mattdm:fedora.im> Trusted Platform Module? The Phantom Menace?"
2023-10-11 14:57:42 <@mattdm:fedora.im> Trusted Platform Module? The Phantom Menace?
2023-10-11 14:57:59 <@davdunc:fedora.im> haha. Technical project manager. :) I read that book by that guy.
2023-10-11 14:58:48 <@mattdm:fedora.im> davdunc: are you volunteering, or volunteering someone else? :)
2023-10-11 14:58:59 <@davdunc:fedora.im> I'm volunteering.
2023-10-11 14:59:05 <@mattdm:fedora.im> awesome!
2023-10-11 14:59:26 <@davdunc:fedora.im> this is a good community project and I'll be happy to drive some visibility here in the open source way.
2023-10-11 14:59:47 <@mattdm:fedora.im> Okay, then, I propose: david and I talk, come back with a proposal for the council and go from there.
2023-10-11 14:59:59 <@jflory7:fedora.im> That works for me 🙂
2023-10-11 15:00:05 <@davdunc:fedora.im> some milestones and progress reviews and some documents for the project.
2023-10-11 15:00:12 <@mattdm:fedora.im> I too have some other meetings, but have a few minutes to talk now if you're available, david.
2023-10-11 15:00:16 <@bt0dotninja:fedora.im> Sounds like a plan +1
2023-10-11 15:00:22 <@davdunc:fedora.im> yea. I'm available now.
2023-10-11 15:00:35 <@jflory7:fedora.im> I'll get this in the minutes, and then wrap the official meeting. Discussion can continue :)
2023-10-11 15:00:54 <@mattdm:fedora.im> yep! I'll talk to david in side-channel. justin can you comment in the council ticket too?
2023-10-11 15:01:12 <@jflory7:fedora.im> !info Ongoing discussion about whether Matrix is the right platform for us or not. mattdm and davdunc will discuss further and come back with a proposal to the
2023-10-11 15:01:15 <@jflory7:fedora.im> !info Ongoing discussion about whether Matrix is the right platform for us or not. mattdm and davdunc will discuss further and come back with a proposal to the Council.
2023-10-11 15:01:36 <@jflory7:fedora.im> !action davdunc mattdm Come up with a communications platform proposal for driving next steps on the Matrix/IRC dilemma
2023-10-11 15:02:22 <@jflory7:fedora.im> Thanks folks, we are past the hour. It was a fully packed meeting! See y'all next time 👋
2023-10-11 15:02:31 <@jflory7:fedora.im> !endmeeting