18:00:01 <bpepple> #startmeeting cwg -- http://fedoraproject.org/wiki/Fedora_Community_Working_Group
18:00:01 <zodbot> Meeting started Tue Mar  8 18:00:01 2011 UTC.  The chair is bpepple. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:02 <bpepple> #meetingname cwg
18:00:02 <zodbot> The meeting name has been set to 'cwg'
18:00:10 <bpepple> #topic roll call
18:00:19 * red_alert 
18:00:27 <bpepple> ping red_alert nirik rbergeron mjg59
18:00:45 * nirik is here.
18:00:54 <mjg59> Here
18:02:06 * bpepple waits a few minutes before starting to see if rbergeron appears.
18:02:42 <rbergeron> yes
18:02:45 <rbergeron> I'm here.
18:02:51 <rbergeron> SORRY, i was pimping out the beefy miracle.
18:02:54 <rbergeron> http://www.facebook.com/pages/Beefy-Miracle/134458843288921
18:02:59 <rbergeron> :)
18:03:24 <bpepple> #info red_alert nirik bpepple red_alert mjg59 rbergeron present
18:03:30 <bpepple> rbergeron: np.
18:03:48 <red_alert> yay, I made it twice! :D
18:03:57 <bpepple> #topic Code of Conduct draft feedback
18:04:16 <nirik> red_alert: you get an extra vote today. ;)
18:04:48 <bpepple> ok, the code of conduct draft was sent to the fab list, and the only real change that was requested was to remove the 'volunteer' reference in it.
18:05:56 <bpepple> there was also few suggestions of other things we could work on also, that we can put on our future todo list possibly too.
18:06:01 <mjg59> Yeah, I'm fine with that
18:06:24 <mjg59> The other issue raised was that existing mailing list owners may not really be in any position to moderate them
18:06:45 <mjg59> Which would suggest either changing the expectations of list owners (which I think may be impractical) or finding other people to carry out that task
18:06:46 <rbergeron> Meaning that they never wanted/accepted that type of responsibility
18:06:52 * nirik is fine with striking volunteer
18:07:04 <bpepple> mjg59: yeah, I suggested maybe we add more moderators to the list to help with that.
18:07:26 <mjg59> We would probably want to find at least a couple of people who could be tasked with that *before* any incidents
18:07:44 <mjg59> Otherwise there's the additional problem of ensuring that whoever's chosen isn't perceived as having any preference to begin with
18:07:53 <nirik> well, there's a lot of lists. ;) In general if someone doesn't want to/doesn't have time to moderate, they should add more moderators, or allow us to.
18:08:14 <bpepple> mjg59: agreed. we need to contact the current list moderators, and see who wants to help/doesn't want to so we know how many folks we need to recruit.
18:08:20 <red_alert> I also think it's the moderators themselves who should speak up if they need more help
18:08:41 <rbergeron> Is there an easier way to parse through list owners other than looking at each page to see who the owners are?
18:08:54 <mjg59> nirik: I'd prefer it not to be up to us, since we're the level of appeal beyond that
18:09:25 <rbergeron> s/owners/moderators
18:09:26 <mjg59> rbergeron: Uh. Good question. I'd expect anyone with access to lists. to be able to generate that
18:09:27 <nirik> rbergeron: there might well be, yes.
18:09:34 <mjg59> So probably someone on the admin team?
18:09:39 <rbergeron> Otherwise, it's divide and conquer.
18:10:04 <rbergeron> Which wouldn't be terribly terrible between us, but if it's able to be pulled out another way, that other way is probably optimal ;)
18:10:20 <nirik> well, if someone has an issue on a list, and the moderator is not awake, won't that just come to us? and we can say "hey, add more moderators there" as part of the answer?
18:10:55 <bpepple> nirik: possibly, though I think it would be better to address it before the fact list mjg59 suggested.
18:11:15 <bpepple> s/list/like/
18:11:43 <nirik> I think you all may be underestimating how many lists there are. ;)
18:12:00 <nirik> I see 204 on lists.fedoraproject.org
18:12:11 <rbergeron> nirik: yeah
18:12:14 <bpepple> nirik: how active are most of those lists? I'd guess most of them not very.
18:12:39 <nirik> yeah, lots are probibly not very. There's someone working right now on flagging the inactive ones.
18:12:46 <bpepple> aren't some of those mostly dead also.
18:12:53 <bpepple> s/./?/
18:13:20 <nirik> there are 195 on fedorahosted.
18:13:36 <nirik> 128 of which are active
18:14:49 <bpepple> do we know how many are private? like the fesco and private board lists? those obviously we wouldn't need to worry about.
18:15:19 <nirik> 182 out of the 204 on lists are public.
18:15:45 <llaumgui> .
18:15:53 <rbergeron> wow.
18:15:57 * nirik thinks just a announce post explaining that moderators should make sure and have time or add moderators would be enough.
18:16:05 <red_alert> +1
18:16:24 <nirik> or we could just try and hit the really popular lists... devel/test/users and make sure they are ok.
18:16:50 * rbergeron is surprised there isn't a mailman function to notify list moderators of things ... like outages or whatever else they'd be notified of
18:16:54 <rbergeron> but anyway
18:16:55 <bpepple> nirik: probably the ambassador & art lists also.
18:16:59 <rbergeron> I agree with what nirik is saying.
18:19:36 <nirik> so do folks think thats enough? or is a full effort required?
18:19:43 <mjg59> Let's try that for now
18:20:04 <rbergeron> I think that works.
18:20:06 <bpepple> alright, so it sounds like we've got two options (or possibly a combination of both). 1) Send an announcement post asking moderators  if they have the time & interest. 2) contact high traffic lists moderators.
18:20:14 <rbergeron> If people complain, well, they'll complain no matter what, so :)
18:20:43 <nirik> yeah, I think both would be good...
18:20:57 <bpepple> nirik: works for me.
18:21:30 <bpepple> Who wants to handle this?
18:22:24 * bpepple listens to the crickets. ;)
18:22:45 <rbergeron> Contact high traffic list moderators directly with same content from #1?
18:22:51 * nirik guesses he could, won't be until later in the week probibly tho.
18:23:23 <bpepple> rbergeron: yeah, that would be sufficient imo.
18:23:54 <red_alert> nirik: thanks! ;)
18:24:16 * rbergeron watches the bus whiz by
18:24:17 <bpepple> nirik: I don't think anyone else is going to volunteer, so if you could handle it that would be great.
18:24:54 * bpepple would volunteer but I'm still digging myself out of the hole for being offline for 2 weeks. :(
18:25:17 <nirik> no worries. I will write up something and ask you guys to review and get it sent.
18:25:29 <red_alert> great :)
18:25:33 <bpepple> nirik: sounds good. thanks!
18:26:30 <bpepple> #action nirik will work on announcement post asking moderators if they have the time & interest to help moderate mailing lists for COC.
18:27:33 <bpepple> ok, the other thing that was mentioned on the mailing list were general questions about the cwg like how long terms are, how members are appointed, etc.
18:27:55 <red_alert> that's explained on out wiki page isn't it?
18:27:59 <mjg59> I think "Do we want people to sign this" may be a bigger issue
18:28:00 <nirik> there was also some stuff on the enforcement... or are we doing that next?
18:28:00 <red_alert> s/out/our/
18:28:09 <rbergeron> Yup, its on the wiki
18:28:18 <rbergeron> I think at some point having the "transition planning" discussion would be worthwhile
18:28:23 <rbergeron> and just canvassing the community for
18:28:32 <rbergeron> (1) do y'all think this should be elected positions
18:28:38 <rbergeron> (2) Or something else
18:28:46 <rbergeron> (3) how long should these spots last, etc
18:29:04 <bpepple> mjg59: yeah, your right we should probably discuss that next, and discuss cwg future transition after that is decided.
18:29:04 <mjg59> Well, we've got a year
18:29:10 <rbergeron> Maybe after whatever we come up with gets published.
18:29:59 <red_alert> before it's left behind: did we actually agree on removing that volunteer sentence from the COC?
18:30:03 <bpepple> rbergeron: agred. maybe we can start working on that on the mailing list, and then finalize the details in a future meeting.
18:30:11 <bpepple> red_alert: yes.
18:30:28 <red_alert> bpepple: #agreed even? :)
18:30:43 <bpepple> #action bpepple will remove the reference to 'volunteers' from the COC draft.
18:30:45 <rbergeron> yes, agreed :)
18:31:29 <bpepple> red_alert: I assumed since no one disagreed with it early in the meeting that we were in agreement. ;)
18:31:30 * nirik nods.
18:31:49 <red_alert> bpepple: sure, I just want to make sure the log will clearly show that too :)
18:32:57 <red_alert> so back to what mjg59 brought up - should the COC be signed or is that not necessary/helpful?
18:33:02 <bpepple> alright, so trying to get back on track a bit maybe we should discuss the "Do we want people to sign this" issue. Anyone object to that?
18:33:12 <nirik> sure, lets discuss. ;)
18:33:12 * rbergeron grins
18:33:14 <rbergeron> yes.
18:33:18 * bpepple sees red_alert beat him to that. ;)
18:33:23 <nirik> personally I am against any signing. ;)
18:33:32 <bpepple> #topic COC  "Do we want people to sign this" issue.
18:33:41 * rbergeron is with nirik on that one.
18:33:44 <red_alert> -1 signing
18:34:07 <mjg59> The main reason I'm against requiring signing is that we expect it of everyone involved, not just those who have signed the CLA
18:34:12 <nirik> it's the guidelines for everyone using project resources... no need to sign it.
18:34:39 <nirik> right... will lead to "this doesn't apply to me because I never signed it"
18:34:43 <mjg59> We don't require people to sign the CLA to post to fedora-devel, but we should require that they adhere to the CoC
18:35:14 <mjg59> On the other hand, mentioning it as part of the new CLA signing does sound like a good idea
18:35:23 * nirik nods. agreed.
18:35:25 <red_alert> yes
18:35:31 <bpepple> I'm fine with them not signing it, but I think it should be linked in with cla  signing.
18:35:38 <rbergeron> as in
18:35:46 <rbergeron> "acknowledge that you know this page exists" ??
18:35:55 <mjg59> Even just link to it from the CLA page
18:35:59 <rbergeron> If they're mixed in, I think that certainly implies to some people that there is some degree of signing going on.
18:36:12 * rbergeron doesn't know.
18:36:35 <nirik> "thanks for signing the CLA. You may next want to read our code of conduct for using project resources at your leasure"
18:36:36 <bpepple> what if it's an acknowledge that they've read it similar to how it's done in the first boot?
18:37:13 <rbergeron> yeah.
18:37:17 <nirik> I think thats too much. It should just show it to them, or point it to them...
18:37:34 <rbergeron> Maybe linking to it when you're signing up on a mailing list/wiki might be helpful.
18:37:35 <red_alert> I'd just add it to the mail that announces the new CLA
18:37:42 <rbergeron> though I suppose to edit the wiki you need the cla.
18:37:46 <rbergeron> or fpca.
18:37:54 <rbergeron> or whatever the new acronym is.
18:38:01 <bpepple> red_alert: that would only catch current cla signers, not future ones.
18:38:16 * nirik wonders if we could hack into mailman and mail it to new subscribers...
18:38:22 <nirik> for any list.
18:38:44 <rbergeron> nirik: like in the confirmation mail?
18:38:50 <nirik> yeah.
18:38:54 <red_alert> bpepple: ah, right
18:39:06 <nirik> Welcome to the foo list... please read the CoC
18:39:40 <red_alert> which would only target list subscribers ;)
18:39:45 <nirik> right.
18:40:02 <nirik> so, at some point you just have to point people who don't know about it to it and ask them to follow it.
18:40:52 <red_alert> add it to the "new cla"-mail and to the join wiki page(s)?
18:41:32 <red_alert> like "to join the project do this and that and make sure to have read the COC"
18:41:47 <rbergeron> yeah, i guess
18:42:03 <bpepple> red_alert: I'm not a particular fan of using the wiki as a main point to disperse info, since folks tend to ignore a lot of the content there.
18:42:35 <mjg59> Having it in the mailman welcome messages and in IRC channel topics seems sensible
18:42:36 <red_alert> people are good to ignore content no matter on what channel they get it :)
18:42:49 <rbergeron> :)
18:42:54 <mjg59> But we can't force people to read it, merely point them at it when their behaviour is inappropriate
18:43:16 <red_alert> mailman welcome messages are the same for 99% of the lists on the internet...lots of people just delete them without even opening them
18:43:37 <mjg59> Right, but there's no harm in adding it
18:43:48 <mjg59> "You didn't tell me!" "Yes we did, you just didn't read it"
18:44:16 <red_alert> we can add it to the lists' signatures ;)
18:45:06 <bpepple> hmm, so where are we here? I've heard a lot of ideas but I'm not sure what exactly we are leaning towards.
18:45:09 <nirik> well, at a point it just gets to be too much noise. ;)
18:45:23 <nirik> I think we all agree we should add a note in the new CLA announcement.
18:45:41 <nirik> or perhaps it should just be it's own announcement post?
18:45:58 * bpepple agrees with adding it to the CLA announcement.
18:46:11 <red_alert> +1
18:46:23 <rbergeron> Sure.
18:47:12 <nirik> past that I think it might depend on implementation details or how far we want to go...
18:47:29 <nirik> I could look and see what it would take to add it to default mailman confirm.
18:48:11 <red_alert> mailman's admin interface allows for text that is prepended to new-subscriber welcome messages
18:48:36 <bpepple> my thoughts are it should be added to the CLA signing (whether as just a link or an acknowledgment,either I'm fine with), and added to mailman somehow.
18:48:37 <red_alert> at least my private mailman 2.1.14 allows for that...
18:48:40 <rbergeron> Though iirc the moderator can change that messaging as needed
18:48:52 <rbergeron> can't they?
18:48:59 <nirik> right, we would want it to be global if possible.
18:49:06 <nirik> I think it uses templates...
18:49:13 <bpepple> rbergeron: I believe so.
18:49:15 <nirik> so we could add it in to the template and it wouldn't be changeable.
18:49:50 <red_alert> nirik: I hope such a change would survive a yum update mailman :)
18:50:09 <nirik> yeah, I think so.
18:50:17 <nirik> will have to go look... I don't know off the top of my head.
18:51:35 <nirik> I can do that out of band.
18:52:35 <red_alert> so do we agree on adding it to the CLA mail and to the mailman welcome messages? I figure some irc mods will also add it to the channel topic by themselves where necessary
18:53:04 <mjg59> Sure
18:53:12 <bpepple> I agree with that, but I think we should also have it be a part of the CLA signing process.
18:53:19 <nirik> seems reasonable (as long as it's technically easy)
18:54:19 <rbergeron> yes.
18:56:13 <red_alert> so bpepple has added a "+1 cla signing process" - I think everyone else has expressed a -1 on that?
18:56:47 <nirik> bpepple: just as a 'FYI, please read this' ? or ?
18:57:20 <bpepple> nirik: I'm fine with an FYI or an click thru acknowledgement.
18:57:44 <nirik> ok, so to get that we should probibly file a but on fas / contact maintainers.
18:57:54 <nirik> might also note it in the ticket about the new CLA
18:57:57 <rbergeron> bpepple: so you're advocating that as "people should sign this as well as the cla" ?
18:58:03 <bpepple> I just think it would be confusing having it be included in the CLA announcement, and then not have it be included in the CLA process.
18:58:41 <bpepple> rbergeron: no, just a click thru acknowledgment must like we do in the first-boot process.
18:59:28 <nirik> I think a click through would give the impression you are agreeing to something tho.
18:59:29 <bpepple> or a fyi link at the end like nirik suggested. I don't really care either way.
19:00:23 <red_alert> fyi link at the end works for me as lonk as there's no checkboxes or hard requirements
19:00:33 * nirik isn't sure what it looks like at the end of that process currently.
19:00:40 * rbergeron nods
19:00:56 <rbergeron> maybe we should find out
19:01:04 <nirik> I signed the cla back when it was a fax in. ;)
19:01:17 <bpepple> nirik: same here. old timers.
19:01:29 <red_alert> you mean you lived to see real fax devices? wow! ;)
19:01:31 <bpepple> probably need to check with spot and see what the end of the cla signing process screen looks like.
19:01:51 <nirik> yeah, or fas dev folks...
19:01:51 <bpepple> red_alert: yup. that's how we handled it in Fedora at the beginning. ;)
19:02:49 <nirik> so, perhaps someone could investigate that and we could revisit next week or on list?
19:02:58 <bpepple> ok, how about we check with the FAS folks and see if it's feasible to add a FYI link at the end of the cla process.
19:02:59 <red_alert> right
19:02:59 <bpepple> nirik: +1. I'll do it since I'm the one pushing this.
19:03:07 <nirik> cool
19:03:51 <bpepple> #action bpepple will check with the FAS folks to see if it's feasible to add a FYI link to the COC at the end of the CLA process.
19:04:19 <bpepple> ok, we are over our allotted time. Is there anything else we need to talk about? Otherwise we should probably end the meeting.
19:04:40 * rbergeron has nothing else
19:04:49 * bpepple doesn't either.
19:05:18 <mjg59> Nope
19:05:18 <nirik> we can try and hit enforcement next week. ;)
19:05:20 <red_alert> what's actually the next steps? let fab list discuss it another week or get it to other groups?
19:05:26 <bpepple> nirik: fun!
19:06:37 <red_alert> another week of fab list it is I guess :)
19:06:55 <bpepple> #endmeeting