17:00:04 <bpepple> #startmeeting cwg -- http://fedoraproject.org/wiki/Fedora_Community_Working_Group
17:00:04 <zodbot> Meeting started Tue Mar 22 17:00:04 2011 UTC. The chair is bpepple. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:07 <bpepple> #meetingname cwg
17:00:07 <zodbot> The meeting name has been set to 'cwg'
17:00:16 <bpepple> ping red_alert rbergeron nirik mjg59
17:00:25 <bpepple> #topic roll call
17:00:45 * nirik is here
17:00:57 * red_alert
17:02:08 <rbergeron> oh hai
17:02:36 <bpepple> #info red_alert nirik bpepple rbergeron present
17:03:08 <red_alert> mjg59 can't be far away either, seeing that he's just been active in #fedora-cwg
17:03:12 <mjg59> Hi
17:03:18 <red_alert> :)
17:03:20 <bpepple> #info mjg59 present
17:03:22 <mjg59> Awesome
17:03:28 <bpepple> hi, everyone.
17:03:45 <bpepple> #topic adding fyi to cla signing
17:04:13 <bpepple> I talked to spot and he said it should be feasible to add the fyi we talked about to the cla signing process.
17:04:20 <nirik> cool.
17:04:50 <bpepple> so, we can coordinate with him on the wording we'd like to use.
17:05:23 <nirik> There's an infrastructure ticket about the change too... we could note/add wording there as well.
17:05:47 <bpepple> that's really all I have on this. so if there's nothing else we can start disussing some of the feedback on the enforcing guidelines.
17:06:28 <nirik> sounds good.
17:06:43 <bpepple> #info talked to spot and he said it should be feasible to add the fyi we talked about to the cla signing process.
17:06:57 <bpepple> #topic Enforcment guidelines feedback
17:07:07 <bpepple> ok, nirik you want to lead this?
17:07:28 <nirik> I could try. ;)
17:07:35 <bpepple> cool.
17:07:41 <nirik> folks had much more feedback on this than the CoC I think.
17:07:52 <bpepple> correct.
17:08:06 <nirik> first: are we good with changing "cwg has the final say" to 'The board or it's designate" ?
17:08:16 <nirik> that leaves them open to delegating to us, or not.
17:08:28 * rbergeron agrees with that
17:08:48 <red_alert> +1
17:09:15 <rbergeron> But it should always be consistent.
17:09:32 <red_alert> s/it's/its/ though, if I'm not mistaken :)
17:09:38 <rbergeron> red_alert: totally :)
17:10:03 <nirik> yeah, whatever reads correctly there is fine with me.
17:10:10 * rbergeron isn't going to nitpick punctuation even though it does make her want to stab herself in the eyeball when it is incorrect ;)
17:10:33 <rbergeron> I don't want it to be a matter of "the board wants to handle this one, but not hte next one, etc."
17:10:49 <nirik> yeah.
17:10:54 <bpepple> nirik: I don't have a serious problem with that, though I'm a littl concerned that the board might sometime in the future might try to handle disputes.
17:10:57 <rbergeron> because then it just looks like they're cherry-picking in certain situations, which I think just leads us to fail.
17:11:04 * nirik nods.
17:11:16 <rbergeron> Perhaps it's something that can be designated at the beginning of each CWG... season, if you will.
17:11:18 <bpepple> rbergeron: agreed.
17:11:43 <nirik> The proposed wording on the list was: "The final decision takes place with the Fedora Board, or a delegate of their choosing"
17:11:46 <red_alert> "its long-term designate", then?
17:12:58 * rbergeron thinks that long-term would be a reasonable wording.
17:13:02 <bpepple> The concern was that since we & the board haven't worked out how the cwg will be run long term, that for now we change that to the Board. I think once the governance of the cwg is decided we'd amend the guidelines.
17:13:16 <nirik> yeah, that also sounds reasonable.
17:13:36 <nirik> I do agree when we talk with the board about this we should ask for a long term decision, not a case by case.
17:13:58 <mjg59> Sounds good to me
17:14:18 <nirik> so, proposal:
17:14:40 <nirik> "The final decision takes place with the Fedora Board, or the long term delegate of their choosing"
17:14:50 <rbergeron> +1
17:15:20 <red_alert> +1
17:15:26 <mjg59> +1
17:15:28 <bpepple> +1
17:15:42 <rbergeron> I think if that ever becomes confusing, or the intent is not clear, we can always point back to this log and say, "THIS WAS OUR INTENT" - in some worst case, "you didn't define it clearly enough" scenario. ;)
17:15:55 <rbergeron> Because I think we all are in agreement here. ;)
17:16:00 <rbergeron> logs for the win!
17:16:02 <nirik> ok, cool. ;)
17:16:20 <nirik> so, next, some folks wanted us to list out possible consequences that could happen as part of enforcement.
17:16:42 <bpepple> #agreed amend enforcement guideline to "The final decision takes place with the Fedora Board, or the long term delegate of their
17:16:45 <bpepple> choosing"
17:17:02 <bpepple> d'oh, stupid paste.
17:17:11 <rbergeron> :)
17:18:03 <nirik> I'm not sure we want to list things, otherwise people will complain when something not on the list is done...
17:18:10 <mjg59> I worry about providing a list because then there'll be some expectation that only those right exactly
17:18:19 <nirik> but I guess I don't feel strongly if we wanted to provide a sample list.
17:18:21 <nirik> yeah.
17:18:41 <bpepple> maybe list some possible enforcement methods (like temporary banning, etc)
17:19:00 <mjg59> I'd say that they might range from suggestions for modifying behaviour in future up to permanent exclusion from the project and resources and everything in-between
17:19:12 <nirik> I posted a list on the thread on the board list, but listing them seems wrong to me in the enforcement guidelines.
17:19:12 <bpepple> mjg59: that works for me. ;)
17:19:30 <nirik> we could add something like that tho. :)
17:19:39 <nirik> mjg59: care to propose some wording?
17:19:47 <bpepple> I think it really deals with the situation, but with that being said we should aim to be consistent in the handling.
17:20:26 <mjg59> Yes, consistency is important
17:21:06 <nirik> agreed.
17:21:21 <bpepple> Maybe when a situation occurs we document somewhere what happened and how it was resolved for future reference.
17:21:28 <mjg59> "Violations of the Code of Conduct may be resolved by suggestions for avoiding the problem in future up to permanent exclusion from the project, and anything in-between"
17:21:55 <bpepple> mjg59: +1
17:22:01 <nirik> seems ok. +1
17:22:58 <red_alert> +1
17:23:18 * rbergeron +1's
17:23:31 <nirik> cool.
17:23:48 <bpepple> nirik: you want to add that to the guideline somewhere?
17:23:56 <nirik> #action will add a note about: Violations of the Code of Conduct may be resolved by suggestions for avoiding the problem in future up to permanent exclusion from the project, and anything in-between
17:23:59 <nirik> yeah, I can.
17:24:04 <bpepple> cool.
17:24:12 <nirik> ok, next item:
17:24:39 <nirik> It was suggested that we discourage/avoid the try and resolve the problem yourself section...
17:25:05 <nirik> the idea being that people who can't get along would just make things worse by trying to work it out without bringing a neutral party in place.
17:25:40 <nirik> Personally, I think there is of course a time to escalate, but trying to resolve things yourself is still a good thing to try for many.
17:26:05 <rbergeron> What about an option to "ask a mediator to mediate" rather than "go ask the board or the CWG to fully intervene/punish" ?
17:26:36 <nirik> well, the moderator/manager for that section could suggest that or act as that.
17:26:47 <nirik> BTW, link to the enforcement stuff: http://fedoraproject.org/wiki/Community_working_group/CoC_Enforcement
17:26:54 <nirik> (in case anyone didn't have it open)
17:27:12 * bpepple opens up the link. ;)
17:27:14 <rbergeron> (like me for example)
17:27:20 <red_alert> same here :D
17:27:43 <nirik> :)
17:28:24 <red_alert> I figure there's indeed situations where even trying to resolve it yourself will make it worse - but I also think that people are clever enough in such a case to jsut skip step #1
17:28:32 <bpepple> I'd lean toward leaving in the resolve yourself point, since this is only a guideline, and obviously if there is bad blood between the parties they can just skip that point.
17:28:40 * rbergeron wishes we had collected some of the commentary on the wiki page discussion tab instead ofthe mailing list, but oh well :)
17:28:53 <nirik> yeah, should have worked to summarize it. ;(
17:29:11 <rbergeron> Yeah. I think if people aren't willing to try and work it out, they've probably already skipped all of these steps and gone straight to the highest authority
17:29:31 <bpepple> rbergeron: agreed.
17:30:04 <nirik> yeah
17:30:22 <nirik> so, personally I would like us to keep this section...
17:30:28 <red_alert> +1
17:30:28 <rbergeron> I do think that maybe having a "here are some ways that sometimes misunderstandings happen" called out more clearly might be helpful. Maybe breaking some of that stuff in the first paragraph out into their own bulletpoints might be useful.
17:30:33 <rbergeron> nirik: me too.
17:30:48 <bpepple> nirik: I think we should keep that section also.
17:31:20 <nirik> ok.
17:31:30 <nirik> rbergeron: care to rework it some?
17:32:00 <nirik> I had 2 other feedback items to run thru...
17:32:01 <rbergeron> nirik: I'd be happy to.
17:32:22 <nirik> How about we do them, then rework over the next week and hopefully have a final next week?
17:32:39 <bpepple> sounds good to me.
17:32:43 <rbergeron> #action rbergeron to rework the "try and resolve the problem yourself" section, breaking out some common types of miscommunication/misunderstandsings
17:33:01 <rbergeron> and others can certainly join in of course ;)
17:33:04 <nirik> next item: It was suggested that we operate completely in public for disputes. Ie, open tickets, all parties and information shown, etc.
17:33:32 <mjg59> No
17:33:44 <bpepple> do you think that might deter some folks from speaking up?
17:33:46 <mjg59> I think it's completely reasonable for someone to want to provide us with information privately
17:33:47 <nirik> I think this is well meant, but could provoke ill will.
17:34:01 * rbergeron agrees with mjg59
17:34:14 * bpepple agrees with mjg59 also.
17:34:14 <mjg59> Especially in cases where the alleged violator is a long-standing community member, for instance
17:34:18 <nirik> I think the fear is that something would happen in private and blindside people involved.
17:34:45 <mjg59> Obviously there's the potential for perception that we're going to engage in some sort of kangaroo court to unfairly penalise innocent people
17:35:09 <nirik> yeah.
17:35:16 <mjg59> But I think asking anyone who feels that they've been subject to unacceptable behaviour to say that in public is counterproductive
17:35:59 <bpepple> I agree.
17:36:51 <nirik> yeah. So, we should strive to operate in public as much as we can, but there may be cases where information or issues are kept private for various reasons.
17:37:02 <bpepple> nirik: +1
17:37:07 <mjg59> Right
17:37:12 <red_alert> nirik: agreed
17:37:56 <rbergeron> +1
17:38:40 <bpepple> #agreed we should strive to operate in public as much as we can, but there may be cases where information or issues are kept private for various reasons.
17:38:50 <nirik> ok. Next item: folks who work on Fedora as part of their job. It was suggested that there would be no special treatment for them, including never contacting with their management when issues arise.
17:39:29 <bpepple> agreed. there should be no special treatment on whether Fedora is your job or not.
17:39:37 <red_alert> didn't we say so all time long?
17:40:06 <nirik> yeah, but the suggestion was that we DO NOT bring their job into it at all... ie, wouldn't contact their employer, etc.
17:40:17 <bpepple> red_alert: I believe there was some concern that we mentioned only volunteers originally in the code of conduct. it has since been changed to not reflect that.
17:40:40 <nirik> Personally, I hope it never matters, but I wouldn't want to rule out any enforcement method if decided it was needed.
17:40:56 <red_alert> since we dropped the volunteers part, this is already "fixed". isn't it?
17:41:24 <nirik> the part about not having special treatment -> yes.
17:41:27 <mjg59> nirik: I'd argue that we *should* treat people who work on Fedora full-time specially, in that they really need to demonstrate a higher level of conduct
17:41:30 <bpepple> I agree. I don't see it really being an issue, but I wouldn't want to rule it out either.
17:41:30 <red_alert> personally I think if my work mate would cause trouble in the community I would bring that to our manager's attention - and we're not within red hat
17:41:56 <red_alert> ...of course the CWG shouldn't take action here, that's mmy non-cwg self that'd do so
17:42:21 <mjg59> But I can also see that being a hard argument to sell, so I've no real objection to us saying that everyone will be treatd equally
17:42:26 <bpepple> mjg59: I agree, but that's something that should probably be managed from within Red Hat (or any other company that has paid employees working on Fedora).
17:42:47 <nirik> There could be cases where someone is misusing their company resources to break the code of conduct, and we might need to contact the persons employer to stop that or at least let them know about it.
17:42:57 <nirik> bpepple: +1
17:43:08 <mjg59> nirik: That's true regardless of whether or not they're working on Fedora, though
17:43:45 <nirik> right.
17:44:08 <nirik> so, I don't know what if any changes we should make for this...
17:44:41 <red_alert> no change - there's no mentioning of handling some people differently from others
17:45:24 <bpepple> I don't think any change is warranted. We plan to treat everyone equally in regards to the COC.
17:45:28 <nirik> we could explicitly say everyone using fedora resources should be held to the same standards for the purposes of the CoC
17:45:52 <nirik> or not.
17:46:16 <nirik> thoughts?
17:46:38 <bpepple> I fine with using your suggestion.
17:47:23 <bpepple> If an employer wants to hold there employees to a higher standard that something they should handle internaly.
17:47:48 <red_alert> if so, I think just adding "In this process everyone is treated equally." to the first paragraph in the enforcement should be enough
17:49:05 * nirik isn't sure that gives the right impression.
17:49:42 <nirik> because someone might say: "just because I was a jerk and disobeying the CoC, you punished me instead of the guy who wasn't that was complaining about me"
17:49:54 <nirik> but I don't know how to word it better.
17:50:47 <nirik> I can try and come up with something.
17:51:10 <nirik> I think thats most of the feedback from the list.
17:51:25 <nirik> So, lets revise and hopefully have final next week?
17:51:33 * rbergeron nods
17:51:33 <bpepple> sounds like a plan.
17:52:07 <nirik> #agreed will work on revisions over next week and hopefully have a final next week
17:52:11 <nirik> ok, anything else?
17:52:23 <bpepple> does this meeting time work for everyone? Or would folks like to change it?
17:52:54 <mjg59> Any time on Tuesday is good for me
17:52:54 <nirik> fine for me
17:53:03 <mjg59> But I may be absent for the next two weeks
17:53:07 <bpepple> this time works for me.
17:53:07 <red_alert> works for me...by next week I'll be on DST, too :)
17:53:52 <bpepple> ok, I don't hear anyone objecting to keeping this time, so let's meet back next week at this time.
17:53:59 * rbergeron nods
17:54:07 <bpepple> if there's nothing else I think we can end this meeting. ;)
17:54:08 * nirik nods too
17:54:25 <bpepple> #endmeeting