18:30:31 <bcotton> #startmeeting docs
18:30:31 <zodbot> Meeting started Wed May 25 18:30:31 2022 UTC.
18:30:31 <zodbot> This meeting is logged and archived in a public location.
18:30:31 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:30:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:30:31 <zodbot> The meeting name has been set to 'docs'
18:30:34 <bcotton> #topic Roll call
18:30:40 <pboy> .hi
18:30:41 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:30:53 <bcotton> welcome pboy
18:30:56 <shaunm[m]> .hello shaunm
18:30:59 <zodbot> shaunm[m]: shaunm 'Shaun McCance' <shaunm@gnome.org>
18:31:08 <bcotton> #chair pboy shaunm
18:31:08 <zodbot> Current chairs: bcotton pboy shaunm
18:31:26 <copperi[m]> .hello copperi
18:31:27 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
18:31:31 <darknao> .hi
18:31:33 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:32:37 <py0xc3[m]> .hello py0xc3
18:32:38 <zodbot> py0xc3[m]: py0xc3 'Christopher Klooz' <py0xc3@my.mail.de>
18:33:19 <bcotton> what a party :-)
18:33:25 <bcotton> let's get started
18:33:38 <bcotton> #topic Agenda
18:33:49 <bcotton> #info Announcements
18:33:50 <bcotton> #info Review action items
18:33:50 <bcotton> #info Content plan office hours
18:33:58 <bcotton> #info GitLab followup
18:34:08 <bcotton> #info Retiring old docs
18:34:13 <bcotton> #info Revitalization status
18:34:17 <bcotton> #info Open floor
18:34:36 <bcotton> #topic Announcements
18:34:45 <bcotton> #help Some release notes still need written: https://discussion.fedoraproject.org/t/how-to-write-fedora-release-notes/38311
18:34:50 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:34:50 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:34:57 <bcotton> #info The Write the Docs Prague CfP is open (conference will be held online this year)
18:34:58 <bcotton> #link https://www.writethedocs.org/conf/prague/2022/cfp/
18:35:15 <bcotton> #info Welcome to our Outreachy intern: Anushka Jain
18:35:35 <bcotton> any other announcements?
18:35:39 <pboy> congratulation  Anushka Jain !
18:35:55 <bcotton> oh, i have another announcement
18:36:08 <bcotton> #info The F36 retrospective survey is open through the end of the week: https://fedoraproject.limequery.com/36
18:36:29 <bcotton> #topic Previous action items
18:36:43 <bcotton> #info pbokoc to finally add a relnotes guide to the contributor docs
18:36:55 <bcotton> i didn't see petr check in, so we'll just put this back on the list
18:37:00 <darknao> \o/ congratulations for the internship AnushkaJain[m]1 !
18:37:09 <bcotton> #action pbokoc to finally add a relnotes guide to the contributor docs
18:37:30 <bcotton> #info [DONE] pboy to draft a content plan office hours blog post
18:37:31 <bcotton> (we'll talk about this momentarily)
18:37:47 <bcotton> #info [waiting] bcotton to share post on cloud, devel, desktop, iot, kde, mindshare, server mailing lists
18:37:48 <bcotton> (ditto)
18:37:48 <bcotton> #info [DONE] bcotton to share the "some repos are moving" content
18:37:57 <bcotton> #info [DONE] pboy to draft a proposal for an updated team page that lists current contributors and ongoing projects
18:38:03 <bcotton> (we'll also come back to this further down)
18:38:11 <bcotton> #info bcotton to propose new text for the Mindshare box on the docs home page
18:38:12 <bcotton> still on my list!
18:38:18 <bcotton> #action bcotton to propose new text for the Mindshare box on the docs home page
18:38:27 <bcotton> we had a lot of action items last time :-)
18:38:34 <bcotton> #topic Content plan office hours
18:38:43 <bcotton> #link https://discussion.fedoraproject.org/t/content-plan-office-hours/39208/
18:38:43 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issue/252
18:38:43 <bcotton> #link https://hackmd.io/rNFQUf25RmKWtNT3f1gHBA
18:39:11 <bcotton> pboy's draft (in the hackmd link above) looked good to me. if no one has major edits, i'll get it queued up to publish tomorrow
18:39:21 <bcotton> at which time i can do my action item of sharing it with the various mailing lists, etc
18:39:44 <pboy> I'm ok with it.
18:39:59 <pboy> just added the location of th docs hours.
18:40:08 <bcotton> pboy++
18:40:08 <zodbot> bcotton: Karma for pboy changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:40:15 <bcotton> anyone else have anything on this topic?
18:42:00 <py0xc3[m]> Nothing from my side
18:42:02 <bcotton> #topic GitLab migration
18:42:03 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issue/253
18:42:12 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/boards/GitLab%20migration
18:42:34 <bcotton> i didn't see any incandescent rage directed our way after sharing the CommBlog post, which is good
18:42:53 <darknao> ah, right :)
18:43:05 <bcotton> and it looks like darknao has made some progress
18:43:06 <bcotton> darknao++
18:43:06 <zodbot> bcotton: Karma for darknao changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:43:27 <darknao> I begin to see the end of it, only a few repositories left
18:44:01 <bcotton> unfortunately, they might be some of the most challenging (at least in terms of the number of issues still open) :-)
18:45:16 <bcotton> of course, since we're declaring bankruptcy, the main issue is re-creating the release notes issues for Changes (and then subsequently updating the wiki pages)
18:45:47 <darknao> I may drop the ones related to localization are they are mostly generated content without any user interaction
18:45:49 <bcotton> the former can be easily scripted. the latter requires me to block out a chunk of my calendar one afternoon :-)
18:46:22 <darknao> and I don't see any advantages to move them to gitlab right now
18:46:38 <bcotton> the main advantage i see to moving the localization repos is that we can keep ACLs up to date. we've already encountered a couple of repos where the active docs contributors don't have admin access
18:47:30 <bcotton> but i suppose the ACLs on those repos change infrequently enough that we can get the infra team to help when a change is necessary
18:47:49 <bcotton> i guess what i'm saying is it would be nice to move them, but i won't lose sleep if we don't :-)
18:47:50 <darknao> the translation-script repo (the one that contains the build pipeline for all the l10n stuff) should move, as it's the one users can actually contributes
18:48:49 <darknao> but for the other two, I don't think it's needed. The only accounts that need access are bots & service accounts
18:50:16 <darknao> and since they are used by a few scripts, moving them requires an extensive amount of work, for no real gains
18:50:27 <bcotton> works for me. anyone disagree?
18:50:48 <pboy> no
18:51:04 <copperi[m]> If it does not break weblate updates, then ok
18:51:35 <bcotton> great. anything else on the GitLab migration?
18:51:39 <darknao> I'll summup all that in one of the l10n tickets, and ask jibec about it
18:51:57 <darknao> yes, I have something else
18:52:08 <bcotton> go ahead
18:53:21 <darknao> someone mentioned we should maybe mirror repositories between pagure and gitlab
18:54:20 <pboy> That was Matthew Miller
18:54:27 <darknao> and I was wondering if that's something we can consider or not
18:54:51 <bcotton> it's worth discussing
18:55:03 <pboy> I think he meant one direction: from gitlab as workspace to pagure as backup space.
18:55:22 <pboy> just in case we get a problem with gitlab
18:55:50 <darknao> https://discussion.fedoraproject.org/t/some-docs-repos-are-moving-to-gitlab/39301/2?u=darknao
18:57:09 <bcotton> my concern is that it would create more confusion if people try to submit PRs or make commits against the repo on Pagure
18:58:01 <pboy> Isn't it a matter of readme?
18:58:15 <pboy> and issues read-only or without?
18:59:24 <py0xc3[m]> If we assume confusion because pagure used to be the working repos, github might be an alternative as mirror?
18:59:57 <pboy> I like that idea. :-) But we want to use gtilab advanced features
19:00:50 <py0xc3[m]> I think the dashboards and such are lost anyway if there is an issue with gitlab (which I consider a very low risk?). This would be the case with both github and pagure
19:01:14 <bcotton> i guess i just don't see a lot of value in mirroring the repos like that
19:01:30 <bcotton> it adds complexity for minimal gain
19:01:43 <py0xc3[m]> I would agree on that. The risk is low
19:01:43 <copperi[m]> I agree
19:02:14 <darknao> I think having multiple instance of the same repo can be confusing. we even have the same repo twice in pagure already (docs-fp-o for instance)
19:02:43 <pboy> If I understood  mattdm correctly, he thought about a worst case scenario.
19:03:03 <pboy> I think, we can postpone that
19:03:12 <pboy> that mirroring issue
19:03:42 <bcotton> i don't recall matthew saying anything about it. and he's a pretty strong proponent of Fedora using GitLab more anyway
19:03:52 <bcotton> but it sounds like we're agreed that we won't worry about mirroring right now?
19:03:55 <darknao> well, we have a few repositories on github for quite some times... Are these mirrored on pagure too?
19:04:49 <py0xc3[m]> We could encourage people who are active on Docs to mirror locally as the Docs don't need much space. But I agree to not worry about mirroring at the moment
19:05:16 <bcotton> #agreed We won't worry about mirroring repos from GitLab to Pagure at this time
19:05:26 <pboy> I think, that not a problem, to have some repos on gitlab. Problem may arise, when we have all repos on gitlab and then Oracle buys out gitlab. :-).
19:05:26 <bcotton> anything else on the GitLab migration?
19:05:47 <bcotton> ah! don't say that :p
19:06:23 <darknao> nothing else from me about the migration
19:06:39 <pboy> not frim me either
19:06:55 <bcotton> #topic Retiring old docs
19:07:02 <bcotton> #link https://discussion.fedoraproject.org/t/time-to-retire-the-old-docs-website/39363/
19:08:11 <pboy> It is new for me, that we already have nicely formatred pdfs
19:08:22 <pboy> We should take this chance
19:08:48 <pboy> store the pdfs in repos for easy access and get rid of the old docs.
19:09:00 <pboy> As discussedd previously
19:09:02 <darknao> here is the list of pdfs we have: https://paste.centos.org/view/b1494d08
19:09:12 <darknao> fyi
19:09:43 <py0xc3[m]> Thanks darknao
19:10:46 <pboy> Looks rather complete ar first view. where did you found that?
19:11:09 <bcotton> i don't necessarily love the idea of adding a bunch of PDFs to a git repo, but that might be the easiest way to do it
19:11:35 <darknao> the old-docs content is already in a repository
19:11:42 <darknao> all of it right here: https://pagure.io/fedora-docs-web
19:11:47 <darknao> pdfs included
19:12:03 <pboy> It's systematically not the best option, but the easiest to retain access and get rid of the web pages.
19:12:06 <bcotton> ah, well how about that :-)
19:12:19 <pboy> Or do we have another location to store and access it?
19:12:20 <darknao> this is actually used to sync our proxies
19:12:30 <py0xc3[m]> I suggest to keep a repo with all files as they are (so not just the pdf's) just to have everything in case one need it in future, and then make a repo for easy access with the pdf's ?
19:12:46 <darknao> so we can basically drop everything but pdfs and call it a day
19:12:57 <darknao> or, create a new branch with just pdf
19:13:32 <bcotton> this brings back memories of the time someone accidentally messed up the published repo on release day and i had to re-push from my terrible residential connection :-)
19:13:45 <bcotton> i'm so glad we build things server-side now
19:14:43 <bcotton> i like the idea of a pdf-only branch that we use for publishing
19:14:44 <py0xc3[m]> Do we know if the PDF's are reliable? Or will it be necessary to verify them?
19:14:51 <pboy> darknao: in the repo there is only css and images, or do I miss something?
19:15:14 <darknao> pboy: everything should be there
19:15:50 <darknao> https://pagure.io/fedora-docs-web/blob/master/f/public_html/en-US/Fedora/26/pdf/Installation_Guide for instance
19:16:15 <darknao> https://pagure.io/fedora-docs-web/blob/master/f/public_html/en-US/Fedora/26/html/Installation_Guide for the html version
19:16:43 <pboy> darknao,
19:16:52 <pboy> darknao: yes, I see
19:17:11 <darknao> I think pdf were generated at build time, so they should be as current as they can be
19:17:23 <pboy> It's a bit difficult to find.
19:17:29 <Astero[m]> Hello!
19:17:46 <py0xc3[m]> darknao: sounds good!
19:18:29 <pboy> If we have everything in repo (and are sure about it), why not discard the old websites now?
19:19:09 <bcotton> that's a good point. we don't need to publish anything, just have links to the files in that pagure repo
19:19:52 <pboy> If I remember correctly the discussion in the issue we agreed about discard them as soon as we have pdf backups and the original xml or html files.
19:20:11 <py0xc3[m]> I would add that we need to ensure that the old content does not again end up in the search engines. Google and such can also index pdf's. So it should be available where we can put a robots.txt in place.
19:20:48 <darknao> https://docs.fedoraproject.org/robots.txt
19:21:02 <darknao> that's already in place
19:21:32 <pboy> I would like to have description where to find the old docs on our team page.
19:22:17 <pboy> I plan to inspect some of the old docs as a base to extend our docs.
19:22:29 <pboy> Some of the content is OK.
19:22:48 <pboy> and just needs a bit of update
19:24:14 <pboy> In the old Fedora tree there are also some old release notes. Do we have a new place for those?
19:24:47 <pboy> We decided to retain the complete release notes and make them available.
19:25:08 <bcotton> I'm a big fan of just leaving them in that repo and pointing people there if they need the historical reference
19:25:42 <pboy> Is that compatible with our release selector on docs home page?
19:26:04 <bcotton> At this point, the newest releases in there were EOL 5ish years ago
19:26:13 <bcotton> it's not, and I'm okay with that
19:27:17 <pboy> I see, the selector goes back to 26, so we will have not "page not found"
19:28:13 <pboy> So we agree to ask Infra to discard the complete old docs tree?
19:28:27 <bcotton> We can take that branch out of the antora config if we need to
19:29:04 <bcotton> I think so. We should probably put it on Discussion and let people weigh in on that
19:29:29 <pboy> Ir I remember correcty Infra would like to discard it because of some technical related issues or workload.
19:30:34 <bcotton> That sounds right
19:30:37 <pboy> Yes, let's put it on discussion to check, if there is some abjection.
19:31:13 <bcotton> Sounds good
19:31:26 <bcotton> And we're at the end of the hour
19:31:32 <bcotton> Thanks everyone!
19:31:37 <darknao> I'm sure nirik will be happy about it :D
19:31:44 <bcotton> #endmeeting