18:31:14 <bcotton> #startmeeting docs
18:31:14 <zodbot> Meeting started Wed Jul 20 18:31:14 2022 UTC.
18:31:14 <zodbot> This meeting is logged and archived in a public location.
18:31:14 <zodbot> The chair is bcotton. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:31:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:31:14 <zodbot> The meeting name has been set to 'docs'
18:31:23 <bcotton> #chair pboy darknao
18:31:23 <zodbot> Current chairs: bcotton darknao pboy
18:31:31 <bcotton> #topic Roll call
18:31:35 <darknao> .hi
18:31:36 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
18:31:42 <py0xc3[m]> .hello py0xc3
18:31:43 <zodbot> py0xc3[m]: py0xc3 'Christopher Klooz' <py0xc3@my.mail.de>
18:31:43 <hankuoffroad[m]> .hello hankuoffroad
18:31:46 <zodbot> hankuoffroad[m]: hankuoffroad 'None' <allegrovelo@gmail.com>
18:31:55 <pboy> .hi
18:31:56 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:35:13 <bcotton> #topic Agenda
18:35:18 <bcotton> #info Announcements
18:35:18 <bcotton> #info Review action items
18:35:18 <bcotton> #info Team charter
18:35:18 <bcotton> #info Open floor
18:35:24 <bcotton> #topic Announcements
18:35:27 <bcotton> #help Some release notes still need written: https://discussion.fedoraproject.org/t/how-to-write-fedora-release-notes/38311
18:35:36 <bcotton> #info We're using the docs-fp-o repo to track meta-work
18:35:36 <bcotton> #link https://pagure.io/fedora-docs/docs-fp-o/issues
18:35:41 <bcotton> #topic Previous action items
18:35:48 <bcotton> #info pbokoc to finally add a relnotes guide to the contributor docs
18:35:53 <bcotton> i think i saw this was done
18:36:12 <pbokoc> Yeah, I opened a PR. Lemme check if I merged it or not :)
18:37:18 <pbokoc> Okay, it's done.
18:37:30 <bcotton> hooray!
18:37:51 <bcotton> #info bcotton to draft Docs Team Charter
18:37:58 <bcotton> this is done, and we'll talk about it momentarily
18:38:12 <bcotton> #info darknao to configure remaining repos in GitLab for CI
18:38:19 <darknao> this is also done
18:39:26 <bcotton> awesome!
18:39:32 <bcotton> so now the fun part
18:39:39 <bcotton> #topic Team charter
18:39:39 <bcotton> #link https://discussion.fedoraproject.org/t/docs-team-charter-proposal/40444
18:41:27 <py0xc3[m]> Is there a consensus about a "coordinater" or such?
18:41:28 <bcotton> so nobody has said "this is absolute crap, i want nothing to do with it"
18:42:07 <bcotton> not that i've seen. there have been arguments for and against, but i don't see that one side has more support than the other
18:42:43 <pboy> I’m happy ith the proposal. My suggestions are some fine printings.
18:43:03 <py0xc3[m]> bcotton: I like it!
18:43:39 <bcotton> and, for what it's worth, we can make as many edits to it after we accept it as we need
18:43:43 <py0xc3[m]> I have not yet had time to deeply review the content of the thread (just skimmed a minute ago), but the only thing I remember that used to be undecided was the "coordinator" thing
18:43:47 <pboy> Maybe we should start with the least possible regulars and see how that works out.
18:44:50 <hankuoffroad[m]> bcotton: Sure
18:47:25 <bcotton> the other big point was the names of the membership levels
18:47:45 <bcotton> which...i don't like the ones i proposed, but i don't like any of the alternatives either :-)
18:48:44 <hankuoffroad[m]> there are access levels, which I presume are different from membership tiers (or levels)?
18:48:59 <py0xc3[m]> Do you mean the GitLab access levels?
18:49:04 <hankuoffroad[m]> yes
18:49:36 <py0xc3[m]> I think it is developers for FAS Docs members, and owner for FAS Docs Admin members (as far as I remember, there was a thread about it, I think from darknao ?)
18:49:59 <pboy> I would prefer the term "board" instead of core. It emphasizes that it's about work, not "honour" or something like that. (to my language understanding)
18:50:08 <py0xc3[m]> Additionally, everyone else, as you do not need one of the two roles for merge requests or so
18:50:40 <bcotton> hankuoffroad: the proposal ties membership tiers to gitlab access levels
18:51:13 <darknao> "core-member" would be in docs-admin group,  "members" in docs group, and contributors are everyone else
18:51:13 <bcotton> pboy: "board member" is iinteresting. it implies a level of leadership that we want that group to take on
18:51:35 <hankuoffroad[m]> darknao: oki
18:51:48 <darknao> I like the board member
18:52:13 <py0xc3[m]> pboy: I am flexible about that topic, but I like it, too
18:52:18 <pboy> bcotton for me it is: there is work to be done.
18:53:52 <pboy> I have some issues with the term "leadership" In my understanding it is coordination, looking for initatives and try so supprt them
18:54:40 <pboy> Maybe, we German have had enough "leadership" decades ago.
18:56:08 <py0xc3[m]> darknao: it was referring to gitlab :) but it ends up the same I think: core/board member = FAS Docs Admin = Owner Gitlab; member = FAS Docs = Developer Gitlab, and everyone else each.
18:56:54 <bcotton> proposed #agreed We'll replace "core member" with "board member" in the team charter proposal
18:56:57 <bcotton> any objections to this?
18:57:04 <py0xc3[m]> +1
18:57:08 <darknao> +1
18:57:29 <pboy> +1
18:57:43 <hankuoffroad[m]> +1
18:57:59 <bcotton> #agreed We'll replace "core member" with "board member" in the team charter proposal
18:59:33 <bcotton> do we want to have some discussion about the idea of a chair (for lack of a better term)?
19:00:44 <pboy> For me, it would be OK to start without and see how it develops.
19:01:11 <py0xc3[m]> pboy: Can live with that, +1
19:01:11 <pboy> But it would also be OK for to choose someone.
19:02:45 <py0xc3[m]> pboy: which would also lead to the question of the term (release cycle, or less) :) We have to find out which fits better, but trying first without maybe reveals if it is necessary at all
19:03:00 <py0xc3[m]> So both ok for me
19:03:03 <bcotton> anything else we want to refine before we accept it?
19:03:14 <py0xc3[m]> We just have to keep an eye on it and discuss if necessary
19:03:43 <pboy> Yes, If we start without, we have the chance that a kind of  division of labor with focal points will be formed.
19:04:05 <py0xc3[m]> +1
19:05:03 <pboy> Maybe the question of quorum
19:05:16 <darknao> to my understanding, the chair was more about chairing this meeting than just a general coordinator
19:06:46 <pboy> darknao Yes, but as a chair you may have to structure the discussion, and coordinating it with a longer perspective then one meeting
19:07:01 <bcotton> quorum is a good question. i tried to write it such that quorum doesn't matter (i.e. we're not making decisions in meeting) and that votes, when necessary, are based on the number of total votes
19:07:14 <pboy> depends on the complexity ot a topic
19:08:00 <pboy> And then there are group dynamic effects to take care of.
19:08:13 <darknao> the meeting structure can be decided in advance on Discussion, so the chair will only have to follow it
19:08:53 <darknao> as for coordinating, I would say that's more the role of  board members
19:09:20 <bcotton> my general philosophy when it comes to voting in community projects is that the longer it takes to explain how it works, the worse the system is
19:09:31 <hankuoffroad[m]> darknao: I concur.
19:09:54 <pboy> bcotton agreed
19:10:04 <py0xc3[m]> darknao: it is also to avoid that Docs falls apart, so enforcing topics that have to be discussed, and pushing towards a consensus.
19:10:20 <py0xc3[m]> darknao: can agree on that
19:10:27 <pboy> but it may make a ridiculous impression to decide with 2 members.
19:10:59 <py0xc3[m]> pboy: the question is who is in the beginning in the board, or what do you mean?
19:11:09 <bcotton> pboy i agree. but i think it's worse to not be able to act because only two people are participating
19:11:16 <pboy> The voters should be some kine of representative
19:11:27 <pboy> bcotton indeed!
19:11:46 <bcotton> making a decision with two people might spur more people to participate. inaction due to a lack of votes will reinforce a lack of participation
19:12:09 <pboy> bcotton agree
19:12:16 <py0xc3[m]> bcotton: I agree
19:12:32 <hankuoffroad[m]> bcotton: Well said
19:12:48 <pboy> py0xc3[m] the question about beginning seems me to be a different one.
19:13:19 <bcotton> we could do something like FESCo does where at least three votes are required , but if there aren't three votes after a week, then a single +1 approves a proposal
19:13:46 <bcotton> https://docs.fedoraproject.org/en-US/fesco/#_ticket_policy
19:14:18 <pboy> think that's a good approach.
19:14:53 <py0xc3[m]> And it has already proven successful with them :O
19:15:32 <py0xc3[m]> So stick with that for the beginning? +1
19:16:49 <bcotton> do we like three as the baseline? do we want it higher? lower?
19:17:26 <pboy> Somehow 3 seems to be the sensible minimum.
19:17:46 <darknao> 3 seems fine, but I guess it depends how many we are initially
19:18:33 <py0xc3[m]> Given the average meeting participation, I think three min. for the beginning makes sense?
19:19:05 <pboy> It we start with those who have regulary participated and did some work, we would start with 6 or so 8a rough guess)
19:19:17 <darknao> alright, +1 then
19:19:32 <bcotton> #action bcotton to add a FESCo-style "minimum of three votes, but after a week a single +1 approves" to the voting policy
19:19:37 <hankuoffroad[m]> How do we carry out voting?
19:19:38 <py0xc3[m]> pboy: But this would mean that we cannot decide regularly as often the number is smaller, isnt it?
19:20:23 <pboy> py0xc3[m] According to my statistices we were mostly 4 at minimum
19:21:12 <py0xc3[m]> hankuoffroad[m]: I can live with 4 as well because we usually don't have time critical decisions anyway, but I would not go above 4.
19:21:45 <py0xc3[m]> I mean last week it was also no problem to skip the meeting.
19:21:55 <pboy> Most teams have 3 as far as i know.
19:22:38 <py0xc3[m]> Sorry my "live with 4" comment was directed to pboy
19:23:05 <hankuoffroad[m]> py0xc3[m]: I mean - voting takes place in meeting like this or in mailing list?
19:23:45 <pboy> Voting is in tickets
19:25:01 <pboy> But if we agree in a meeting after an extensive discussion we may take it as a decision as well (according to the proposa)
19:25:24 <hankuoffroad[m]> pboy: oki
19:27:41 <bcotton> So we're near the end. Do we want to have additionall discussion after I make the edits we agreed on, or should we consider the draft accepted with the pending edits?
19:28:11 <pboy> I think accepted  with the pending edits?
19:28:23 <py0xc3[m]> +1
19:28:29 <hankuoffroad[m]> +1
19:28:41 <darknao> +1
19:29:26 <bcotton> #agreed The team charter draft is accepted with the pending edits
19:29:58 <bcotton> #action bcotton to make the edits and add the charter to the team docs
19:30:10 <py0xc3[m]> Unfortunately I have to leave very punctually today :( Have a nice evening/day!
19:30:23 <bcotton> thanks py0xc3!
19:30:41 <bcotton> we're at the end of the hour. anything burning?
19:30:47 <pboy> no
19:30:57 <hankuoffroad[m]> thanks all
19:31:49 <bcotton> okay, thanks everyone! have a great week
19:31:53 <bcotton> #endmeeting