19:31:10 <darknao> #startmeeting docs
19:31:10 <zodbot> Meeting started Wed Dec 21 19:31:10 2022 UTC.
19:31:10 <zodbot> This meeting is logged and archived in a public location.
19:31:10 <zodbot> The chair is darknao. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:31:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:31:10 <zodbot> The meeting name has been set to 'docs'
19:31:16 <darknao> #topic Roll call
19:31:21 <darknao> #chair pboy darknao pbokoc py0xc3[m]
19:31:21 <zodbot> Current chairs: darknao pbokoc pboy py0xc3[m]
19:31:26 <darknao> hi everyone!
19:31:26 <pboy> .hi
19:31:27 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
19:31:28 <darknao> o/
19:31:59 <hankuoffroad[m]> .hello hankuoffroad
19:31:59 <zodbot> hankuoffroad[m]: hankuoffroad 'None' <allegrovelo@gmail.com>
19:32:22 <copperi[m]> .hello copperi
19:32:23 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
19:34:49 <darknao> ok I think everyone is here
19:34:51 <darknao> #topic Agenda
19:35:00 <darknao> #link https://discussion.fedoraproject.org/t/docs-meeting-agenda-2022-12-21/45072
19:35:03 <darknao> #info Announcements
19:35:05 <darknao> #info Repository structure for Fedora Tools
19:35:07 <darknao> #info Quick docs update
19:35:09 <darknao> #info Open Floor
19:35:11 <darknao> #topic Announcements
19:35:21 <darknao> #info Old Fedora docs (anything older than F26) have been retired.
19:35:24 <darknao> #info Beta version of the category system for Quick Docs has been deployed on stg
19:35:26 <darknao> #link https://docs.stg.fedoraproject.org/en-US/quick-docs/categories/administration/
19:35:28 <darknao> #info Next milestone is F38 (2023-04-18)
19:35:30 <darknao> #info We use GitLab to track work: https://gitlab.com/groups/fedora/docs/-/boards
19:36:03 <darknao> anything else anyone wants to add to that list?
19:37:03 <darknao> I take that as a no, moving on
19:37:06 <darknao> #topic Repository structure for Fedora Tools
19:37:09 <darknao> #link https://discussion.fedoraproject.org/t/question-about-our-repo-structure/44761
19:38:17 <darknao> So I guess the idea is to decide whether we want to put the anaconda (and other guides) in the fedora-tools namespace, or if we want them in a separate structure
19:38:57 <darknao> basically, get the guide url as /fedora-tools/anaconda or just /anaconda
19:39:25 <darknao> did I understand it right pboy ?
19:39:34 <pboy> Yes, you did.
19:39:58 <pboy> And I'm still a bit indecisive.
19:40:22 <pboy> So, I would like to know, how others are thinking about it.
19:40:26 <darknao> both are fine to me
19:41:06 <copperi[m]> I like fedora-tools approach better
19:41:15 <darknao> I have a very small preference for the first one (/fedora-tools/anaconda)
19:41:39 <pboy> Well, if we put everything unter /root/ (i.d. /NAME) , it may be a bit unbalanced and chaotic.
19:42:15 <pboy> so I have a (very) slight preference for /...tools/, too
19:42:49 <darknao> ok, so let's vote? +1 is for /fedora-tools/anaconda, -1 is for /anaconda
19:43:18 <copperi[m]> +1
19:43:22 <darknao> +1
19:43:24 <pboy> +1
19:44:03 <darknao> hankuoffroad[m]: any opinion on that?
19:44:51 <hankuoffroad[m]> I'm not sure.
19:46:06 <hankuoffroad[m]> i'm inclined to +1
19:46:16 <darknao> alright then
19:46:19 <darknao> #agreed to use /fedora-tools/anaconda structure
19:47:18 <darknao> the new fedora-tools repository is here: https://gitlab.com/fedora/docs/fedora-linux-documentation/fedora-linux-admin-tools
19:47:48 <darknao> it's the default template for now, but I'll add the current tools page we already have, and the anaconda guide that I couldn't find
19:49:06 <darknao> I believe the anaconda guide is not uploaded yet, that's right pboy? In that case I'll just create the empty directory structure and leave that to you
19:49:50 <pboy> Yes, that's right. It's still in my "local authoring environment" for some reason.
19:50:04 <darknao> ok good
19:50:14 <pboy> I don't remember, why. Maybe lack of time.
19:50:26 <darknao> Anything else regarding this topic or should we move to the next one?
19:50:43 <pboy> I think, we can move on
19:50:48 <darknao> #topic Quick docs update
19:51:11 <pboy> Again, some things to decide of agree upon.
19:51:21 <darknao> so very quickly: I pushed the category system on stg
19:51:28 <pboy> #530 Review of older documents: Anaconda
19:51:35 <darknao> ie.: https://docs.stg.fedoraproject.org/en-US/quick-docs/categories/administration/
19:52:34 <pboy> That looks perfect for me!
19:53:40 <pboy> So we give a good preview of the goal, we would like to achieve.
19:54:53 <pboy> (By the way,I consider to write a community blog about improving QD)
19:55:08 <darknao> that's a great idea!
19:55:50 <pboy> Maybe I'll write it under the Christmas tree :-)
19:57:16 <darknao> back to quick-docs tickets?
19:57:19 <hankuoffroad[m]> pboy: That'll do for visibility
19:57:32 <pboy> hankuoffroad[m]>
19:58:13 <pboy> hankuoffroad[m] that's the intention. And I think we all, who are working on it, shoud be listed as authors. It is a group endeavor.
19:59:00 <pboy> About ticket
19:59:29 <pboy> #link https://pagure.io/fedora-docs/quick-docs/issue/530
19:59:50 <pboy> What to do with Quick doc anaconda article
20:00:45 <pboy> proposal: move the QD Anaconda pages to the new Fedora Sysadmin Tools
20:01:02 <darknao> I agree with the suggestion to move it to the fedora tools repo, that would make a good base of work for the future guide
20:01:14 <darknao> so +1
20:01:53 <pboy> Indeed. And it would help to sharpen the QD profil as how-to and Tutorial
20:02:20 <pboy> (See the quality critera by Anuschka Jain some months ago)
20:03:36 <pboy> I see no objection?
20:04:16 <hankuoffroad[m]> No problem
20:04:49 <pboy> #agreed  move the QD Anaconda pages to the new Fedora Sysadmin Tools
20:04:57 <pboy> Next one:
20:05:11 <pboy> #530 Review of older documents: Anaconda
20:05:17 <pboy> Sorry!!
20:05:32 <pboy> #link https://pagure.io/fedora-docs/quick-docs/issue/528
20:05:53 <pboy> Article Fedora on Raspberry Pi
20:07:38 <pboy> I think, it qualifies as a tutorial. That's good.
20:07:55 <pboy> An issue again: what about the partials.
20:08:22 <darknao> I see two issues here that are kind of related to each other
20:08:34 <darknao> first one: the page seems too long
20:09:07 <darknao> and two: partials (which are a good way to work with long pages)
20:09:46 <darknao> so we can either decide this is too long, and split it in 2 or more smaller pages
20:09:48 <pboy> +1 regarding too long.
20:10:03 <darknao> in that case, we can get rid of partials
20:10:11 <pboy> Therefore, it is  tutorial, not a how-to.
20:10:37 <pboy> But the idea of Quick Doc is, to have just one page.
20:10:56 <hankuoffroad[m]> pboy: Is there a definition between two?
20:12:26 <darknao> we also have a specific section for ARM computer board and the like: https://docs.fedoraproject.org/en-US/arm-sbc/
20:12:36 <pboy> hankuoffroad[m] yes: how-to: short, just one specific issue / task, not much explanation. tutorial: more explanation, more complex issue, not about software, but about a more complex/abstract task.
20:12:45 <pboy> e.g. jot-to
20:13:01 <darknao> maybe we can just move it here? I assume now the rpi is officially supported, it deserve it's own doc?
20:13:09 <pboy> e.g. how-to: configure the target domain in postfix.
20:13:17 <hankuoffroad[m]> pboy: ok,
20:13:26 <pboy> e.g. tutorial: setup a mail service.
20:14:06 <hankuoffroad[m]> thanks let's move on
20:14:12 <pboy> regarding it's own doc: I asked arm SIG if they think it is a good idea, and if they qould support it. No answer, no reaction at all.
20:15:07 <pboy> An own doc without support by the SIG? A bit critical.
20:15:25 <darknao> in that case, we should leave it in QD
20:15:27 <pboy> Ben also asked them some months ago, no reaction either
20:16:01 <darknao> but we can split it in two, like Fedora on Raspberry PI, and Fedora on Raspberry PI FAQ
20:16:18 <darknao> I think the FAQ part deserve it's own page
20:16:25 <pboy> That'a a good idea, yes.
20:16:58 <pboy> A FAQ is neither a how-to nor a tutorial, but we should handle that pradmatically
20:18:10 <pboy> So, we'll make 2 articles of it and i will remove some redundant information, so is will be at least slightly shorter.
20:18:36 <pboy> darknao: Did you had a look on the markup?
20:19:01 <darknao> it's mostly comments
20:19:34 <darknao> and all of them are about the uses of partials, so if we remove those, we can remove the comments too
20:20:06 <darknao> the only attribute you can keep is :experimental:
20:20:14 <hankuoffroad[m]> I wonder how we can create something different from the server doc. https://docs.fedoraproject.org/en-US/fedora-server/installation/on-sbc/
20:20:41 <pboy> OK. What about these [[CAHP_ddddd]] line above each title? I thought, a link is created without that?
20:21:08 <pboy> hankuoffroad[m] that's an article from me.  :-)
20:21:40 <pboy> Yes, We should avoid redundancy.
20:22:09 <hankuoffroad[m]> I just thought we culd reuse some of content, but agree on redundancy
20:22:16 <pboy> Just curious: what is experimental with it?
20:24:10 <darknao> the [id='something'] above the title is to create an anchor with the specified name. It's only useful when using partials, so it can be removed too
20:24:37 <pboy> OK
20:25:14 <darknao> the :experimental: flag is to enable the keyboard macro (kbd:) https://docs.antora.org/antora/latest/asciidoc/ui-macros/
20:25:48 <pboy> Oh, thanks
20:26:53 <pboy> That's all from me, for now.
20:27:00 <darknao> the meeting come to an end, should we keep the last minutes for open floor?
20:27:06 <pboy> yes
20:27:07 <darknao> #topic Open Floor
20:27:21 <hankuoffroad[m]> pboy, Can you do me a favor once again? About the latest MR on local authoring environment in contributors guide, I think nav.adoc file points to the wrong adoc.file.
20:27:39 <hankuoffroad[m]> Can you have a look at and help fixing it when you can? Sorry to lumber you with this
20:27:51 <pboy> hankuoffroad[m] I'll check it.
20:27:59 <hankuoffroad[m]> thanks
20:28:49 <darknao> is anyone going to be around next week?
20:29:13 <hankuoffroad[m]> Re. GD, #521 Finding and installing Linux applications, I'm working on it,
20:29:23 <pboy> I'm "on duty" anyway.
20:29:50 <darknao> last meeting of the year, i'm wondering if we should keep it or not for the "holiday"
20:29:51 <hankuoffroad[m]> darknao: I'm available
20:30:15 <pboy> hankuoffroad[m] Yes, and you are assigned. So anybody else knows.
20:30:16 <darknao> ok no problem then
20:30:52 <pboy> I we keep it , we may be the only one in Fedora universe. :-)
20:31:15 <hankuoffroad[m]> yes
20:31:54 <darknao> alright, Thanks everyone! Have a great end of week, and see you all next time :)
20:32:02 <darknao> #endmeeting