19:30:43 <darknao> #startmeeting docs
19:30:43 <zodbot> Meeting started Wed Jan 18 19:30:43 2023 UTC.
19:30:43 <zodbot> This meeting is logged and archived in a public location.
19:30:43 <zodbot> The chair is darknao. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
19:30:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:30:43 <zodbot> The meeting name has been set to 'docs'
19:30:50 <darknao> #topic Roll call
19:30:52 <darknao> #chair pboy darknao pbokoc py0xc3[m]
19:30:52 <zodbot> Current chairs: darknao pbokoc pboy py0xc3[m]
19:31:03 <pboy> .hi
19:31:04 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
19:31:14 <darknao> .hi
19:31:15 <zodbot> darknao: darknao 'Francois Andrieu' <darknao@drkn.ninja>
19:31:54 <AnthonyMcGlone[m> hi
19:33:02 <darknao> ok, let's start
19:33:06 <darknao> #topic Agenda
19:33:08 <darknao> #link https://discussion.fedoraproject.org/t/docs-meeting-agenda-2023-01-18/45937
19:33:10 <darknao> #info Announcements
19:33:12 <darknao> #info Tickets review
19:33:14 <darknao> #info Quick docs update
19:33:16 <darknao> #info Open Floor
19:33:18 <darknao> #topic Announcements
19:33:24 <darknao> #info The category system for Quick Docs has been deployed on PROD
19:33:26 <darknao> #link https://docs.stg.fedoraproject.org/en-US/quick-docs/categories/administration/
19:33:28 <darknao> #info Next milestone is F38 (2023-04-18)
19:33:30 <darknao> #info We use GitLab to track work: https://gitlab.com/groups/fedora/docs/-/boards
19:33:32 <darknao> #info Vote for an alternate meeting time for 2023 is still open!
19:33:34 <darknao> #link https://whenisgood.net/k7wa88t
19:33:36 <darknao> anything else?
19:33:53 <pboy> not from me
19:34:05 <AnthonyMcGlone[m> or me
19:34:15 <darknao> ok, moving on then
19:34:17 <darknao> #topic Tickets review
19:34:44 <darknao> I think we have 2 tickets left from last week that need review
19:35:24 <darknao> we will review the QD one in the next topic
19:35:47 <darknao> #link https://gitlab.com/fedora/docs/templates/fedora-docs-template/-/issues/7
19:36:09 <darknao> about the docs builder script for mac
19:36:26 <darknao> so I guess we need someone with a Mac for that one
19:36:36 <pboy> Yeah, the monitoring version doesn't work
19:36:52 <pboy> That's due to  missing software on Mac.
19:37:17 <pboy> So, we probably will not get it run on Mac
19:37:34 <pboy> Maybi, I'm the only one with a Mac here.
19:37:55 <pboy> But I'm currently not really able to work on Quick Docs
19:38:20 <pboy> because I don't have a working local authoring system,i.d. no local prevciew.
19:38:46 <pboy> So, can we produce an alternative?
19:39:30 <darknao> you can still use the build/preview functionnality of the script ?
19:39:41 <darknao> like "-b" and "-p"?
19:39:50 <darknao> or is that not working either?
19:40:46 <pboy> Hm, don't know about -b. If I use ./build.sh && ./preview it starts the new monitoring script.
19:41:41 <darknao> build.sh & preview.sh are the older scripts
19:42:10 <darknao> the new docsbuilder.sh script has a build & preview option (withoug the monitoring)
19:42:15 <darknao> without*
19:42:27 <pboy> Great!
19:42:30 <darknao> see --help for usage
19:42:39 <pboy> How do I get that functioning?
19:42:54 <pboy> OK, sometimes --help helps. :-)
19:43:01 <darknao> just docsbuilder.sh -b & docsbuilder.sh -p
19:43:25 <darknao> and that is pretty much the same result as the older build/preview scripts
19:43:42 <pboy> Great! I'll try it later today.
19:44:09 <pboy> We should document that anywhere.  :-)
19:44:24 <darknao> #action pboy to try the -b & -p options of docsbuilder on mac
19:44:39 <darknao> well, it's documented in the usage of the script :)
19:45:11 <darknao> next ticket is:
19:45:15 <darknao> #link https://gitlab.com/fedora/docs/fedora-linux-documentation/release-docs-home/-/issues/4
19:45:24 <darknao> regarding install guide
19:45:29 <darknao> and broken links
19:45:43 <pboy> 'Well, I'm working on this.
19:45:44 <darknao> so the main one (https://docs.fedoraproject.org/en-US/fedora/latest/install-guide/) is fixed
19:45:57 <darknao> but the remaining ones are still missing
19:46:00 <pboy> The base address works fine already
19:46:28 <pboy> I've to amend some text, e.g. about verifying the download, and some others.
19:46:57 <pboy> It's ongoing, hopefully resolved end of next week according to my planning.
19:46:58 <darknao> note that for the other ones, we can just update the links on the website (since we are already rewriting those)
19:47:17 <darknao> instead of using aliases
19:47:40 <darknao> can I assign you the ticket?
19:47:53 <pboy> Good. I'll add to the tocket these addresses, that are difficult to alias.
19:48:11 <pboy> tocket -> ticket
19:48:25 <pboy> And yes, you can assign me the ticket.
19:48:35 <darknao> perfect, once I have those links, I'll handle the websites update
19:49:11 <darknao> ok, that's all for this topic. Time for quick docs
19:49:23 <darknao> #topic Quick docs update
19:49:35 <darknao> pboy: floor is yours
19:49:42 <pboy> Yeah.
19:50:15 <pboy> First a success: We have processed all open PRs now. Open PRs are zero at the moment.
19:50:27 <darknao> \o/
19:50:42 <darknao> that's a great achievement
19:50:53 <copperi[m]> 👍️
19:50:53 <pboy> And we make a lot of progress to complete the first bunch of reviews.
19:51:33 <pboy> The question in the ticket is: how to process long articles.
19:51:56 <pboy> https://pagure.io/fedora-docs/quick-docs/issue/111
19:52:07 <darknao> #link https://pagure.io/fedora-docs/quick-docs/issue/111
19:52:43 <pboy> @darknao Does Antora know about multipart articles?
19:53:01 <darknao> mmh.. You could use pagination I guess? https://docs.fedoraproject.org/en-US/fedora-docs/contributing-docs/asciidoc-markup/#_pagination
19:53:25 <pboy> wait, I look
19:53:47 <darknao> that will get you a Next/Previous link at the bottom to follow several articles about the same topic
19:54:15 <pboy> Without the need to put them into nav.adoc?
19:54:41 <darknao> no, you need to add them to the nav for that
19:54:53 <darknao> but it can be in a subsection
19:55:12 <pboy> what means subsection?
19:56:10 <darknao> in the nav, you could use a sublist, just like the asciidoc page
19:57:02 <pboy> OK, I'll try it and come back next meeting.
19:57:29 <darknao> something like
19:57:35 <darknao> ** installing software from source
19:57:39 <darknao> *** Intro
19:57:47 <darknao> *** Tutorial (or whatever)
19:57:50 <darknao> *** FAQ
19:58:03 <pboy> Oh yeah, I see.
19:58:05 <pboy> Thanks
19:58:06 <darknao> then you enable pagination on all 4 pages
19:58:57 <pboy> On our CMS Multipages are complete independent from the navigation.
20:00:05 <pboy> The other question is, is the text even in modified form, still something for quick docs or vor soemething else?
20:00:35 <pboy> The same questions will arise again for other articles.
20:00:47 <pboy> for example about systemd
20:01:43 <darknao> well, I don't think there is any other section in our Docs that could be a good fit for that one
20:02:23 <pboy> Well, wie could put it under administration. But it doesn't fit well there.
20:02:30 <darknao> building from source is a wide topic, and not really related to an edition, or belong to an admin or tooling guide
20:03:03 <darknao> I mean, we could put that in the admin guide I guess
20:03:12 <pboy> I agreed. Probably, we postpone this until Alan completes the rewriting.
20:03:27 <pboy> He is working on it.
20:04:37 <darknao> ok to postpone
20:04:38 <pboy> By the way, it is very good that in QD we have the new theme with the categories!
20:04:59 <darknao> right, I pushed that on prod last week
20:05:19 <darknao> I see we already have a few categories/tags that exists
20:06:00 <darknao> maybe we should think about a curated list of categories at some point, so we don't end up with a infinite list of category for the same topic
20:06:07 <pboy> Yes, when we work on an article it gets categories and tags
20:06:30 <pboy> darknao agreed, it's a problem of ressources,
20:06:45 <pboy> I'm working in it, too
20:07:20 <darknao> it's all about available resources here :p
20:07:34 <pboy> Yeah.
20:07:40 <pboy> That all about QD at the moment. from me
20:08:02 <darknao> ok then
20:08:09 <darknao> #topic Open Floor
20:08:22 <pboy> Just a question here
20:09:14 <darknao> go ahead
20:09:15 <pboy> Is there anywhere documentation, how to update our server doc repo on pagure, to get the new UI for the local authoring review?
20:09:56 <darknao> https://gitlab.com/fedora/docs/docs-website/ui-bundle
20:10:36 <darknao> in the readme, the first paragraph will tell you how to update your playbook to get the new UI
20:10:46 <darknao> (antora playbook)
20:11:00 <pboy> OK, that's all?
20:11:05 <darknao> that's all
20:11:07 <pboy> Seems to be easy
20:11:14 <pboy> I'll try it
20:11:43 <pboy> Another question
20:12:28 <pboy> Do we have a formatting for something like an abstract ?
20:13:06 <pboy> I mean a dedicated paragraph at the beginnen, with a typography different from the text body.
20:13:15 <pboy> I saw something like
20:13:21 <pboy> [abstract]
20:13:24 <pboy> ----
20:13:30 <pboy> SOME TEXT
20:13:33 <pboy> ----
20:13:51 <pboy> But typographically, there seems to be no difference.
20:14:31 <darknao> that's right, there is none
20:14:52 <darknao> the [abstract] is not used by antora
20:15:24 <pboy> What a piity
20:15:25 <darknao> but if that's something you want, I can make it happen
20:15:46 <darknao> just create a ticket here https://gitlab.com/fedora/docs/docs-website/ui-bundle/-/issues
20:15:57 <darknao> and I'll see what I can do about it
20:16:35 <pboy> Yes. I think it is good practise to provide a very short central "message" or "mission statement" at hte beginning. 1-2 sentences
20:16:57 <pboy> ++1
20:17:22 <darknao> and if you already have an idea in mind on how it should looks, you can also say so in the ticket, it'll be helpful to me if I don't have to come up with a style that no one likes :)
20:17:24 <pboy> that's it from me. :-)
20:17:42 <pboy> I'll do it in the ticket.
20:17:59 <darknao> great :)
20:18:55 <darknao> anything else from copperi[m] or AnthonyMcGlone[m? or should we end the meeting here?
20:19:27 <AnthonyMcGlone[m> I was just wondering about this ticket https://gitlab.com/fedora/docs/community-tools/documentation-contributors-guide/-/issues/15
20:19:47 <AnthonyMcGlone[m> Should those steps be updated (I don't mind volunteering)
20:19:59 <AnthonyMcGlone[m> * be updated? (I
20:21:22 <darknao> I think we have a topic on Discussion about it
20:21:26 <darknao> https://discussion.fedoraproject.org/t/need-help-trying-to-suggest-edits-to-fedora-docs/44106/12
20:21:55 <AnthonyMcGlone[m> Right, I'll have a read down through that.
20:22:12 <darknao> there are a few idea on how to deal with that change
20:22:40 <darknao> you are more than welcome if you want to update that guide :)
20:25:38 <AnthonyMcGlone[m> I can update it. I don't think it would take that long for me to do it.
20:26:08 <darknao> great
20:26:18 <darknao> do you want me to assign you to the ticket?
20:26:28 <AnthonyMcGlone[m> Yes, sure.
20:26:37 <darknao> done
20:26:40 <darknao> thanks :)
20:26:52 <pboy> Well, before we close
20:27:02 <pboy> I would like just to state, we have  developed into a small, but great and productive team over the last months.
20:27:11 <pboy> A huge progress compared to the fall of last year.
20:27:28 <darknao> +100
20:27:29 <pboy> And even more compared to 2020 / 2021
20:28:21 <pboy> Yeah, thanks to everybody!
20:28:48 <pboy> Summer last year I feld a bit lost.
20:29:32 <pboy> But now .....
20:30:09 <AnthonyMcGlone[m> Yes, there seems to be more folks contributing which is great.
20:30:15 <darknao> we have made good progress, thanks to everyone here
20:31:26 <darknao> ok, thanks everyone, see you all next week!
20:31:29 <darknao> #endmeeting