15:31:15 <acozine> #startmeeting Docs Working Group
15:31:15 <zodbot> Meeting started Tue Jan 22 15:31:15 2019 UTC.
15:31:15 <zodbot> This meeting is logged and archived in a public location.
15:31:15 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:31:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:31:15 <zodbot> The meeting name has been set to 'docs_working_group'
15:31:31 <samccann> welcome back!
15:31:35 <acozine> thanks!
15:31:58 * gundalow waves
15:32:05 <acozine> arrived in Minneapolis last night after ~22 hours in transit, so I'm a little jetlagged
15:32:14 <acozine> #chairs samccann gundalow
15:32:20 <acozine> ???
15:32:24 <acozine> #chairs
15:32:25 * alongchamps waves
15:32:34 <acozine> #chair samccann
15:32:34 <zodbot> Current chairs: acozine samccann
15:32:41 <acozine> #chair gundalow alongchamps
15:32:41 <zodbot> Current chairs: acozine alongchamps gundalow samccann
15:32:58 <acozine> who else is around?
15:33:16 <acozine> hi alongchamps and welcome!
15:33:28 <acozine> clearly I have lost my IRC touch
15:33:37 <alongchamps> thanks!
15:34:39 <gundalow> #info Agenda https://github.com/ansible/community/issues/389
15:34:53 <acozine> I see we have an agenda item about working groups - whether/how to fill in the documentation about them
15:35:07 <gundalow> #topic Working Group docs
15:35:25 <gundalow> #info Currently we have https://docs.ansible.com/ansible/devel/community/communication.html#working-groups
15:35:27 <gundalow> though
15:35:27 <acozine> current documentation is minimalist: https://docs.ansible.com/ansible/devel/community/communication.html#working-groups
15:35:32 <acozine> gundalow: jinx
15:35:47 <gundalow> 1) Not all Working Groups have IRC channels (or for that matter meetings)
15:36:09 <gundalow> 2) The number of Working Groups has grown a lot (not all are listed on that page), and will continue to grow
15:36:26 <gundalow> 3) No details of what a Working Group is, how to get involved, that any help is welcome, etc, etc
15:36:32 <gundalow> So I'm wondering about
15:36:43 <gundalow> A) Creating community/working_groups.html
15:37:18 <acozine> we have some of that content here: https://github.com/ansible/community/blob/master/WORKING-GROUPS.md
15:37:19 <gundalow> B) ^ will contain a list of Working Groups, grouped-by category (Cloud, OS, cross-functional, etc)
15:37:38 <acozine> and we  link to that from the communication page
15:37:53 <acozine> I'm not opposed to creating a new page in the docs
15:38:01 <samccann> the forth bullet poing on the workging-groups.md isn't being followed (aka not all WG have a dedicated wiki page)
15:38:21 <acozine> I'd like to limit duplication (and maintenance) though
15:38:26 <gundalow> C) working-group.html will also contain the motivational & overview bits of working group
15:38:29 <samccann> if they all did, then we could just group WG by a logical set of categories and then the link to the wiki page would cover the details
15:38:58 <acozine> samccann: interesting - do we have a Wiki page?
15:39:03 <acozine> DaWGs, I mean
15:39:06 <gundalow> I personally like the main WG info to be on docs.ansible.com, longer term I'd like to link from more modules to WG's etc
15:39:13 <samccann> for docs, yes, I think thanks to gundalow
15:40:16 <samccann> gundalow: the drawback with that is then we (docs) become responsible for that content per working group. By having it in the wiki page they are all supposed to have, the onus is on the WG to maintain that content
15:40:41 <alongchamps> the working groups would know best, but perhaps we start with some sort of stub / minimum required info
15:40:49 <gundalow> samccann: ah, sure, I should clarify that I'm not expecting WG specific information (apart from names) to be on docs.ansible.com
15:40:51 <alongchamps> it's also scalable as the number of groups grow
15:41:05 <gundalow> all the WG specific info should be on gh/ansible/community/wii
15:41:08 <gundalow> wiki*
15:41:11 <acozine> I think we can host the general information on WGs on docs.ansible.com - what is a WG, how to join, how to start a new one, etc.
15:41:21 <gundalow> +1
15:41:22 <samccann> and we gently nudge those who don't have the wiki to create one?
15:41:31 <acozine> without getting too much into maintenance of individual group info
15:41:37 <samccann> acozine +1
15:41:51 <alongchamps> samccann +1
15:42:11 <acozine> gundalow: can you think of other existing content that should be folded in?
15:42:26 <gundalow> #action gundalow to create the most minimal `community/working-group.rst` page which lists the WGs by category
15:42:39 <acozine> on the community repo or blog posts or anything like that?
15:43:26 <gundalow> background: I'm giving cutdown Community Webinary at AnsibleAutomates London on Monday 28th, so I want to get minimal docs live this week
15:43:37 <gundalow> acozine: how do you mean?
15:44:15 <acozine> are there other pages/resources elsewhere that talk about WGs?
15:44:40 <gundalow> ah, zero blog posts at the moment. Though I see blog posts in my future
15:44:40 <acozine> that we should remove or slim down when we merge the new `working-group.rst` page?
15:44:59 <acozine> Magic Eight-Ball says . . . Very LIkely
15:45:01 <gundalow> ah, I see what you mean
15:45:14 <gundalow> Nothing springs to mind at the moment
15:45:24 <acozine> okay, cool
15:45:46 <gundalow> Cool, I'll create a minimal PR, and once the basic page is live we can update over time
15:46:01 <acozine> when you've got content ready, ping us - should be an easy merge
15:46:08 <gundalow> Thanks :)
15:46:21 <acozine> alongchamps: you have anything on your mind?
15:46:23 <gundalow> That's all I had on that
15:46:25 <acozine> PR to shepherd?
15:46:34 <acozine> question to ask?
15:46:51 <acozine> #topic open floor
15:47:02 <alongchamps> nothing from me, I'm mostly watching and getting used to the meetings
15:47:36 <acozine> sounds great - let us know if you come up with ideas for making the channel or meetings more welcoming
15:48:00 <acozine> #topic PR reviews needed!
15:48:23 <acozine> We're at 96 open PRs marked `docs`
15:48:39 <samccann> this might be a good time to confess my worries wrt merging doc prs
15:48:39 <gundalow> #topic Docs PR review
15:48:46 <gundalow> samccann: Sure
15:49:12 <samccann> I am reluctant (due to some embarrassing bad merges on my part) to merge anything that isn't an .rst page change that I understand
15:49:35 <acozine> samccann: embarrassing bad merges - we've all done them
15:49:42 <samccann> which brings that 96 open prs down to something like 12 (last time I  tried a limited search
15:49:45 <gundalow> samccann: Is that a 1) Git(Hub) issue, or 2) a content issue?
15:49:59 <gundalow> Git by name, git by nature
15:50:04 <samccann> HAHAH
15:50:22 <samccann> ok so I merged a PR with code in it, which I know now to avoid
15:50:39 <acozine> I backported a feature, merged a bunch of bugs (even in the rST), and have generally run amok at various times
15:50:42 <samccann> but if the PR is in a module, even if it's only the docstring in that module - how do I know I can merge it?
15:50:42 <gundalow> acozine: we have another meeting in 10 minutes
15:50:49 <gundalow> samccann: ask
15:50:49 <acozine> the beauty of git is, it's all recoverable
15:50:54 <gundalow> acozine: +1
15:51:08 <gundalow> high level rule is: no feature to be backported
15:51:41 <acozine> it's kind of like falling off when riding - you're not really a rider until you've eaten dirt a few times
15:52:14 <acozine> and you're not really a committer until you've screwed up some merges
15:52:46 <acozine> but to answer your question about PRs that change the docstrings
15:53:03 <dag> o/
15:53:21 <gundalow> #chair dag alongchamps
15:53:21 <zodbot> Current chairs: acozine alongchamps dag gundalow samccann
15:53:32 <acozine> you can build the module and visually check it
15:53:39 <acozine> and you can ask maintainers for reviews
15:53:49 <acozine> ultimately it's about trust, I think
15:53:52 <acozine> hey, dag!
15:54:12 <samccann> yeah it's the technical nature of the change that worries me. So seems I should cc/request review from the maintainer (whatever github suggests)
15:54:37 <gundalow> acozine: samccann One things we may need to think about is having some other people from Core/Community around when we do doc PR triage
15:54:51 <acozine> yeah, requesting reviews via github is good, and/or posting a request on IRC
15:55:05 <dag> We need to ensure that older versions of the documentation include the latest WG information, if we keep the list in the docs
15:55:12 <samccann> gundalow: agreed, but we  (acozine and I) are also in there regularly trying to tame the beast of growing backlog
15:55:22 <dag> (like we need this for other information as well, releases, etc.)
15:55:31 <samccann> (as in got a spare 30 min? try to merge a pr or two)
15:55:57 <acozine> dag: this brings us back to the question of whether we can have some content that isn't versioned amidst the versioned content
15:56:03 <samccann> but in general I got my answer thanks
15:56:42 <acozine> dag: gundalow: for the current update to the WG info, I think we can just backport the page
15:57:02 * dag would like to fix the current Wiki index, it now contains sub-documents for specific technologies, it would be better if we only listed the main topics (now that we have more WG's)
15:57:07 * gundalow personally doesn't want `/community/` versioned, or if we do big red text that says "This isn't latest"
15:57:33 <dag> gundalow: agreed, I would rather have a redirect to the devel version for that part
15:57:39 * gundalow has another meeting in 3 minutes I need to swap to
15:57:52 <dag> (or proxied for that matter)
15:58:11 <gundalow> nod, we have an issue for that
15:58:18 <acozine> dag: I agree, but only if we can keep the context for anyone who was looking at an older version and navigates back to the module docs
15:58:34 <dag> acozine: a redirect should work fine for going back
15:58:38 <gundalow> I wonder if it would be worth adding some details to the DaWG wiki for the 2019 aims?
15:58:42 <acozine> or, as gundalow says, a big red banner
15:58:51 <acozine> gundalow: good idea
15:59:17 <dag> gundalow: Or you ok if I clean up the Wiki index to only include one page per WG ?
15:59:23 <dag> s/one page/one link/
15:59:24 <acozine> I'm working on a 2019 priorities list for docs - I'll publish it there
15:59:39 <dag> gundalow: I will make sure that one page also has links to the sub-pages
15:59:45 <dag> acozine: \o/
16:00:32 <gundalow> dag: I think a single link only on the main page of wiki is OK
16:00:58 <gundalow> Also I'm tempted to clear out the `group-`${WG}` directories that aren't used
16:01:02 * gundalow has to drop
16:01:20 <dag> gundalow: I was also thinking of adding a section-header (Ansible / Cloud / Networking / System / Other)
16:01:42 <dag> gundalow: yeah, I don't see the benefit at this point, it's harder to maintain as well
16:01:49 <samccann> dag: I think that aligns with gundalow's original ideas
16:01:59 * acozine also has to drop off
16:02:01 <samccann> meanwhile I think we've lost him and acozine to an overlap meeting
16:02:08 <acozine> thanks everybody!
16:02:19 <acozine> and look at some PRs if you have spare time today!
16:02:22 <samccann> Do we have other topics we want to continue discussing?
16:02:25 <acozine> all reviews welcome
16:03:40 <samccann> dag: gundalow gave himself an action item earlier on here, so please coordinate so you're not both changing the same thing? I lost track whether you were thinking about a different page than he was thinking about
16:04:22 <dag> samccann: I was already editing while missing this meeting :-/
16:04:32 <samccann> heh
16:04:49 <dag> planning to make a screenshot to show him
16:04:56 <samccann> sounds like a plan
16:05:34 <samccann> #action all - please review the PR backlog for docs
16:05:39 <samccann> #topic Open Floor
16:05:49 <samccann> do we have anything else to chat about here today?
16:07:10 <samccann> ok seems silent... I'll end this meeting
16:07:17 <samccann> in 3...
16:07:28 <samccann> 2...
16:07:44 <samccann> 1...
16:08:13 <samccann> #end
16:08:18 <samccann> heh #endmeeting
16:08:29 <samccann> #endmeeting