14:32:27 <samccann> #startmeeting Docs Working Group aka DaWGs
14:32:27 <zodbot> Meeting started Tue Aug  6 14:32:27 2019 UTC.
14:32:27 <zodbot> This meeting is logged and archived in a public location.
14:32:27 <zodbot> The chair is samccann. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:32:27 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
14:32:35 <felixfontein> I'm partially here
14:32:42 <samccann> ok, who's around here to talk docs?
14:32:47 <tributarian> I'm here.
14:32:50 * cyberpear waves
14:32:54 <samccann> #chair felixfontein tributarian cyberpear
14:32:54 <zodbot> Current chairs: cyberpear felixfontein samccann tributarian
14:33:00 <samccann> hellooooo!!
14:34:04 <samccann> #topic - PR #57318
14:34:17 <samccann> #link https://github.com/ansible/ansible/pull/57318
14:34:31 <cyberpear> I mentioned this PR in this channel on July 11, July 16, July 30, and originally on June 3 in -devel, but no progress and it was closed without substantive comment, and the other (complicated) PR referenced hasn't seen any movement since this trivial PR was opened -- truly we don't need a docs rewrite to properly document an existing option?
14:35:17 <samccann> this is the other PR  referenced above - https://github.com/ansible/ansible/pull/55474
14:35:31 <samccann> bcoca: are you around to discuss this?
14:35:54 <cyberpear> (and I can't comment on my own PR because `ansible` locked the PR)
14:37:13 <samccann> I did take a look a bit before this meeting and the open PR has the same sort of information as cyberpear's PR, but also is doing a whole lot more 'stuff'
14:37:55 <felixfontein> I think it would be good if this new option (which has already been released) would be documented ASAP
14:38:56 <samccann> The only info I have is a short text that suggests if we reopen this PR, it will be stalled the same as that other PR, due to 'some discussions' holding things up.  alas, I have no details yet on what  those discussions are
14:39:27 <samccann> felixfontein: was this option released in 2.8?
14:39:30 <cyberpear> I'm here to have those "some discussions" if necessary... seems pretty straightforward to me
14:40:09 <samccann> I tried to get others here to discuss as well, but I think there are meeting overlaps with this one
14:40:12 <cyberpear> (and I added it to the agenda a full 7 days ago, so it's not last-minute)
14:40:20 <felixfontein> samccann: the new value was added in 2.8.2 I think
14:40:36 <samccann> heh yeap.  The problem is the discussions are not hjappening in docs land but somewhere else. So I don't know what they are myself.
14:40:53 <cyberpear> felixfontein: it existed in 2.8.0, but was bug-fixed in 2.8.2 to squash all warnings, not just half of them
14:41:07 <samccann> I do find it worrisome as you both do, that something in 2.8.x is currently undocumented.
14:41:11 <tributarian> The changes in 57318 seem pretty innocuous.
14:42:08 <tributarian> Is there something that conflicts with 55474 that I am missing?
14:42:49 <samccann> They are, but I think what happened was the other PR was created in a similar timeframe so 55474 was closed in favor of the other one. But now that other one is stalled for some reason that affects this simple change (sorry dunno the reason or debate).
14:42:50 <cyberpear> afaics, they're orthogonal other than touching the same file, and this change being included in addition to the major part of that change
14:44:49 <samccann> The one comment I have from the PR owner is that the discussion affects that overlap (as in that new option added in 2.8.x that you're trying to get documented).
14:45:18 <samccann> unfortunately the folks in the know aren't here so I don't know that we can move forward. I will add  it to next weeks agenda
14:45:24 <cyberpear> (also, the only reason this docs and the related bugfix missed the 2.8.0 release was because my original PR to make the bugfix/doc was close in favor of this same PR)
14:45:47 <tributarian> Would it be reasonable to reopen the PR so that the discussion can be documented there?
14:46:03 <cyberpear> here's my original PR that was closed in favor of this long-stalled PR: https://github.com/ansible/ansible/pull/55402/files
14:46:50 <cyberpear> and unlocked maybe? (separate non-docs topic, but the conversation-locking in general is annoying, btw)
14:46:59 <samccann> #info  - related PR also closed in favor of #55474 - https://github.com/ansible/ansible/pull/55402/files
14:47:42 <felixfontein> #55402 isn't necessary anymore, since its most important part - fixing "ignore" - has already been merged. and its docs part is #57318
14:47:54 <samccann> alas, no control over the locking, but bring it up in the core meeting for sure (3pm ET today). Also a good place to bring up the stalled PR.  Not  to force you to repeat yourself  but there may be people in the know over there
14:48:02 <cyberpear> right... just pointing out that the blocking PR has been stalled for quite a while
14:48:34 <samccann> #info 55402 isn't necessary anymore, since its most important part - fixing "ignore" - has already been merged. and its docs part is #57318
14:49:34 <samccann> cyberpear: are you available at 3PM ET to try this conversation in #ansible-meeting and see if you can find further info on it all?
14:49:44 <felixfontein> isn't the core meeting at 19:00 UTC?
14:49:57 <cyberpear> I'll try to make it; it overlaps w/ another, but I'll at least monitor it
14:50:17 <felixfontein> or did something happen so that today it's at 15:00 UTC?
14:50:17 <samccann> erm... today's core meeting, yes.  On my calendar it shows at 3pm ET, but UTC to ET conversions still baffle me.
14:50:25 <felixfontein> ok :)
14:50:41 <felixfontein> I got confused since the docs meeting was originally 15:00 UTC :)
14:51:23 <samccann> okay. I may not still be online at that point, but if I am, I'll try to bring it up as well. At least that way, there is a thread to look back on for more details
14:51:43 <cyberpear> perhaps we can move on to tributarian
14:51:53 <cyberpear> https://github.com/ansible/ansible/issues/12533
14:52:00 <samccann> #agreed - continue the discussion in core meeting
14:52:36 <samccann> #topic - https://github.com/ansible/ansible/issues/12533
14:53:29 <samccann> wow an oldie for sure!
14:53:33 <tributarian> if bcoca isn't here I may not find out much...
14:53:39 <tributarian> Im sorting by oldest first
14:53:52 <tributarian> Looking for my next contribution.
14:54:22 <felixfontein> I think the problem here is that --list-xxx simply list stuff, while the other arguments (like --skip-tags) are only used for processing tasks/roles
14:54:59 <felixfontein> I guess the documentation on what --list-xxx lists (all tasks/..., and not what exactly will be executed) should be improved
14:55:08 <felixfontein> though I guess first part will be finding out what exactly --list-xxx is listing :D
14:55:37 <tributarian> So a couple of questions.
14:55:37 <tributarian> 1. Where should this documentation live
14:55:37 <tributarian> 2. Which part needs to be documented better e.g. that --list bypasses other options or something else
14:56:45 * samccann looks for logical home
14:56:59 <tributarian> So for 1. this looks like a place: https://docs.ansible.com/ansible/latest/cli/ansible-playbook.html?highlight=list%20tags#cmdoption-ansible-playbook-list-tags
14:57:12 <tributarian> but it's not going to be very verbose there
14:57:57 <tributarian> https://docs.ansible.com/ansible/latest/user_guide/playbooks_tags.html?highlight=list%20tags is another candidate
14:57:59 <samccann> https://docs.ansible.com/ansible/latest/user_guide/playbooks_tags.html
14:58:03 <tributarian> yep
14:58:12 <samccann> hah you're faster than I am!
14:58:39 <samccann> that first page is autogenerated so I wouldn't touch that area unless you see a real error.  Go with the 2nd one
14:59:30 <samccann> so if  a doc page has /cli/ in the url, I think they are all autogenerated from the related code (.py) files
14:59:50 <samccann> we can modify if needed, but just trickier than .rst
15:00:11 <tributarian> so it looks like the clarification of behaviour should live hereish https://docs.ansible.com/ansible/latest/user_guide/playbooks_tags.html?highlight=list%20tags#tags
15:00:37 <samccann> yep
15:00:50 <tributarian> potentially as a "Note"
15:00:57 <samccann> #agreed - best place to clarify this issue is in https://docs.ansible.com/ansible/latest/user_guide/playbooks_tags.html?highlight=list%20tags
15:01:15 <tributarian> Cool I think that is what I needed to know. Ill give it a whirl.
15:01:20 <samccann> Read through, maybe experiment if you have the chance based on what is in the issue, and see what doesn't make sense
15:01:37 <samccann> and thanks!!
15:01:54 <tributarian> samccann: Yeah, I'll set up some test scenarios and see how it feels.
15:02:03 <tributarian> I was just messing with this yesterday on a project.
15:02:27 <tributarian> samccann: yw
15:02:48 <samccann> okay gonna open things up for general discussion
15:02:53 <samccann> #topic Open Floor
15:03:19 <samccann> ??? now I'm questioning my terms... is it called Open Floor?  Open Discussion?
15:03:36 * samccann will be very happy when acozine is back to run the show
15:04:30 <tributarian> * open floor  (acozine, 15:35:57)
15:04:38 <tributarian> samccann: you are good
15:05:00 <samccann> haha thanks!
15:05:21 <samccann> Looks like our open PRs are at 82 today. I'll try trimming that a bit.
15:06:53 <samccann> anything else to discuss before we close?
15:08:14 <samccann> going once...
15:08:54 <samccann> twice...
15:09:23 <samccann> and.. #endmeeting
15:09:31 <samccann> #endmeeting