#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:30:16 UTC (full logs).

Meeting summary

  1. Release Notes and Collection-level documentation (samccann, 14:33:56)
    1. network team proposing to use https://docs.openstack.org/reno/latest/ to gather collection-level release notes. This is an .rst tool that can work with sphinx to publish to a docsite (samccann, 14:35:14)
    2. Galaxy's current plans are for .md only, and not for complicated documentation (just what is in the collection /docs folder as a flat display in the future) (samccann, 14:35:54)
    3. along with release notes, we also have the issue of each collection will need its own 'docsite' equivalent for anything more complicated (such as these release note fragments, porting guide details, complete user or developer guides etc) (samccann, 14:36:55)
    4. each collection can already have its own docsite, but what can we do for the collections the Ansible team creates? One proposal - do what docs.openstack.org does - publishes each project as a subdir under that url. (samccann, 14:38:33)
    5. - unsure how we would decide which collection-level docs get to piggyback on docs.ansible.com, and which have to roll their own docsite (samccann, 14:39:01)
    6. network team also will gate PRs with zuul to ensure a correct base level of docs (samccann, 14:41:15)
    7. https://releases.openstack.org/train/index.html (samccann, 14:48:26)
    8. https://governance.openstack.org/tc/reference/pti/python.html#release-notes (dmellado, 14:51:46)
    9. openstack has some docs recommendations/governance, including release notes - https://governance.openstack.org/tc/reference/pti/python.html#release-notes (samccann, 14:52:48)
    10. full openstack docsite - https://releases.openstack.org/train/index.html (samccann, 14:53:18)
    11. https://docs.openstack.org/doc-contrib-guide/ (dmellado, 14:53:59)
    12. docs contributor guide for openstack - https://docs.openstack.org/doc-contrib-guide/ (samccann, 14:54:47)
    13. AGREED: next steps - review how openstack does all this technically, and broaden the discussion to get approval/buyin etc (samccann, 15:02:06)
    14. ACTION: samccann to add 'followup on openstack docs model' to next week's agenda (samccann, 15:05:11)
    15. ACTION: samccann to create proposal for this openstack-like docs on https://github.com/ansible-collections/overview/issues and add it to https://github.com/orgs/ansible-collections/projects/1 (samccann, 15:10:13)

  2. Open Floor (samccann, 15:12:28)
  3. issues triage (acozine, 15:16:59)
    1. https://github.com/ansible/ansible/issues/19478 (acozine, 15:18:59)
    2. https://github.com/ansible/ansible/issues/19478 (samccann, 15:19:33)
    3. the issue is likely resolved at the mentioned config setting was removed in 2.8. Close the issue (samccann, 15:35:15)


Meeting ended at 15:37:52 UTC (full logs).

Action items

  1. samccann to add 'followup on openstack docs model' to next week's agenda
  2. samccann to create proposal for this openstack-like docs on https://github.com/ansible-collections/overview/issues and add it to https://github.com/orgs/ansible-collections/projects/1


Action items, by person

  1. samccann
    1. samccann to add 'followup on openstack docs model' to next week's agenda
    2. samccann to create proposal for this openstack-like docs on https://github.com/ansible-collections/overview/issues and add it to https://github.com/orgs/ansible-collections/projects/1


People present (lines said)

  1. samccann (81)
  2. acozine (65)
  3. dmellado (47)
  4. bcoca (10)
  5. zodbot (9)
  6. gundalow (5)
  7. cbudz (1)


Generated by MeetBot 0.1.4.