#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 14:32:28 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 14:32:34)
  2. how to install ansible (samccann, 14:35:02)
    1. there are details in the code https://github.com/ansible/ansible/pull/70529/files#diff-2eeaed663bd0d25b7e608891384b7298R80 (samccann, 14:36:42)
    2. https://github.com/bcoca/acd <= you can generate and install this (bcoca, 14:39:28)

  3. docs pipeline refinements (acozine, 14:45:27)
    1. reinstall the docs requirements.txt to pick up antsibull-doc (samccann, 14:47:27)
    2. check umask to be sure it is 022 by default (samccann, 14:48:07)
    3. http://docs.testing.ansible.com/ansible/2.10/collections/index.html (acozine, 14:55:48)
    4. http://docs.testing.ansible.com/ansible/devel/collections/index.html (acozine, 14:56:27)
    5. please test out the docs pipeline on http://docs.testing.ansible.com/ansible/devel/collections/index.html (samccann, 15:05:39)
    6. and build locally with the aforementioned steps (samccann, 15:06:13)
    7. on macOS you may need to set `ulimit -n 1024` before running the collections docs build (acozine, 15:13:19)
    8. on Fedora you may need to set the `umask` to 022 before running the collections docs build (acozine, 15:13:54)

  4. changelogs in collections (acozine, 15:14:28)
    1. https://github.com/ansible/community/issues/521#issuecomment-657219778 (acozine, 15:14:36)
    2. AGREED: only a handful of people can edit a manual section in the ansible porting guide and it is not for missing changelog fragments for a collection (samccann, 15:47:17)
    3. AGREED: we will have two porting guides - ansible-base and ansible. The ansible-base content will also be in the ansible porting guide (samccann, 15:47:41)
    4. ACTION: felixfontein create a PR which shows how it would look like (felixfontein, 15:47:54)
    5. ACTION: baptistemm open a PR to discuss about the left column on the doc website (baptistemm, 15:48:59)

  5. open floor (acozine, 15:53:37)
    1. agenda items are welcome for next week's meeting at https://github.com/ansible/community/issues/521 (acozine, 15:57:51)


Meeting ended at 16:00:09 UTC (full logs).

Action items

  1. felixfontein create a PR which shows how it would look like
  2. baptistemm open a PR to discuss about the left column on the doc website


Action items, by person

  1. baptistemm
    1. baptistemm open a PR to discuss about the left column on the doc website
  2. felixfontein
    1. felixfontein create a PR which shows how it would look like


People present (lines said)

  1. acozine (114)
  2. samccann (88)
  3. felixfontein (71)
  4. baptistemm (22)
  5. bcoca (14)
  6. zodbot (10)
  7. zbr|rover (8)
  8. abadger1999 (2)


Generated by MeetBot 0.1.4.