#ansible-docs: Docs Working Group aka DaWGs

Meeting started by acozine at 16:00:45 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 16:00:51)
  2. Ansible 3 release and docsite split (acozine, 16:06:34)
    1. if push come to shove, we can build Ansible 3 from a private branch w/ the pr backported to stable 2.10 (if we can't get reviews in time to merge into stable-2.10) (samccann, 16:20:28)
    2. ACTION: - samccann to fix CI errors by using cp instead of ln and finish other feeback so pr can be merged to devel today (samccann, 16:22:51)
    3. - may not be able to merge the backport to stable-2.10 as it is frozen due to pending release (samccann, 16:25:28)

  3. future of `devel` documentation (acozine, 16:26:53)
    1. docs.ansible.com/ansible-core/devel/ will be what the current nightly build produces after the docsite split. It will not include scenario or network guides (samccann, 16:30:11)
    2. https://github.com/bcoca/acd/blob/devel/generate_acd.yml <= can be made trivial 'run this playbook' (bcoca, 16:36:55)
    3. https://ansible-community.github.io/nightly-builds/ (felixfontein, 16:38:24)
    4. AGREED: goal for `/ansible/devel/` docs is to include the `devel` branch of ansible-core, plus the most recent versions in Galaxy of all included collections for the next ansible package release (acozine, 16:49:28)
    5. ACTION: - turn nightly build to core docs once PR is merged into devel (samccann, 16:50:06)

  4. docs folder in collections (acozine, 16:51:10)
    1. ACTION: samccann - post last week's meeting minutes on the dawgs agenda (samccann, 16:56:31)
    2. ACTION: samccann acozine - find out where the /docs folder is in AH roadmap etc (samccann, 16:58:45)

  5. PR/issue labels: https://github.com/ansible/ansibullbot/pull/1505 (acozine, 17:02:50)
    1. https://github.com/ansible/ansibullbot/pull/1505 | open, created 2021-02-06T14:45:20Z by sommersoft: [WIP] Classify/Label PRs That Are Docs Only (github-linkbot, 17:02:51)
    2. - example of collection that has docs in docs folder - https://github.com/cyberark/ansible-security-automation-collection/tree/master/docs - this displays today on Automation Hub (samccann, 17:17:44)
    3. AGREED: acozine to add a `docs_only` label (acozine, 17:20:36)

  6. open floor (acozine, 17:22:19)
    1. https://github.com/ansible/ansible/pull/73615 | open, created 2021-02-15T17:09:20Z by dmsimard: Update 2.10 porting guide to include module index [affects_2.11,core_review,docs,needs_triage,small_patch,support:core] (github-linkbot, 17:23:45)


Meeting ended at 17:27:18 UTC (full logs).

Action items

  1. - samccann to fix CI errors by using cp instead of ln and finish other feeback so pr can be merged to devel today
  2. - turn nightly build to core docs once PR is merged into devel
  3. samccann - post last week's meeting minutes on the dawgs agenda
  4. samccann acozine - find out where the /docs folder is in AH roadmap etc


Action items, by person

  1. acozine
    1. samccann acozine - find out where the /docs folder is in AH roadmap etc
  2. samccann
    1. - samccann to fix CI errors by using cp instead of ln and finish other feeback so pr can be merged to devel today
    2. samccann - post last week's meeting minutes on the dawgs agenda
    3. samccann acozine - find out where the /docs folder is in AH roadmap etc


People present (lines said)

  1. acozine (135)
  2. samccann (108)
  3. felixfontein (54)
  4. bcoca (20)
  5. abadger1999 (16)
  6. zodbot (15)
  7. sommersoft (13)
  8. lmodemal (5)
  9. tadeboro (4)
  10. briantist (4)
  11. dmsimard (3)
  12. dericcrago (3)
  13. github-linkbot (2)
  14. alongchamps (1)


Generated by MeetBot 0.1.4.