15:01:20 <acozine> #startmeeting Docs Working Group aka DaWGs
15:01:20 <zodbot> Meeting started Tue Jul 13 15:01:20 2021 UTC.
15:01:20 <zodbot> This meeting is logged and archived in a public location.
15:01:20 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:20 <zodbot> The meeting name has been set to 'docs_working_group_aka_dawgs'
15:01:26 <acozine> #topic opening chatter
15:01:29 <acozine> who's around?
15:01:46 <acozine> I know we have a couple of people who are away from their computers today
15:02:36 <samccann> Only parity here today
15:02:50 <abadger1999> Bom dia
15:03:04 <acozine> abadger1999: andersson007_ dmsimard gundalow aminvakil briantist cyberpear felixfontein Xaroth zbr you folks chatting about docs today?
15:03:09 <acozine> #chair abadger1999
15:03:09 <zodbot> Current chairs: abadger1999 acozine
15:03:12 * dericcrago waves
15:03:16 <acozine> #chair dericcrago
15:03:16 <zodbot> Current chairs: abadger1999 acozine dericcrago
15:03:42 <briantist> o/
15:03:51 * acozine needs to feed the cat quickly and grab a glass of water, back in a minute, please chair folks as they arrive
15:04:09 <felixfontein> hi!
15:05:02 * gundalow waves
15:05:12 <dericcrago> #chair felixfontein gundalow
15:05:12 <zodbot> Current chairs: abadger1999 acozine dericcrago felixfontein gundalow
15:05:39 <dericcrago> #chair briantist
15:05:39 <zodbot> Current chairs: abadger1999 acozine briantist dericcrago felixfontein gundalow
15:06:09 * acozine is back and no longer in danger of her cats eating her arm
15:06:13 <felixfontein> :)
15:06:23 <felixfontein> usually they don't eat arms, they just bite in them ;)
15:06:34 <felixfontein> (or scratch them)
15:06:39 <acozine> heh, one of ours is . . . VERY food motivated
15:06:51 <acozine> and if we delay her meals too much she starts "exploring"
15:07:50 <acozine> but yeah, I doubt she would actually eat my arm . . . if only because that wouldn't feed her for long!
15:08:23 <acozine> but I digress
15:08:29 <acozine> today's agenda: https://github.com/ansible/community/issues/579#issuecomment-874944055
15:09:12 <samccann> Heh
15:09:42 <acozine> #topic breadcrumbs and memory issues with the production docs build
15:09:50 <acozine> good news - we got more memory allocated
15:10:15 <abadger1999> Yay!
15:10:21 <acozine> and samccann tested the build, so we know the current allocation will keep the build going for at least the next release or two
15:10:59 <acozine> thanks to abadger1999 for making it possible to test the build with additional collections/modules
15:11:17 <felixfontein> awesome!
15:11:23 <abadger1999> Thanks samccann for doing that testing!
15:11:40 <samccann> Hmm I was supposed to publish devel daily til we had a toggle for breadcrumbs
15:11:41 <gundalow> Brilliant, I know this has taken a lot of people a lot of time
15:12:05 <abadger1999> The breadcrumb toggle was merged yesterday with the default being breadcrumbs on
15:12:18 <acozine> abadger1999: that's great!
15:12:25 <acozine> can you point me to the PR?
15:12:39 <samccann> Ok cool! I’ll take a loook later. Can someone action that to me so I don’t forget?
15:12:52 <abadger1999> I can publish that to pypi if we want to unlock the version of antsibull while we're thinking about it
15:13:33 <acozine> #action samccann to test the devel build with the breadcrumb toggle
15:13:39 <samccann> Good idea
15:13:41 <acozine> samccann: is ^^^ correct?
15:13:50 <samccann> Yep thanks!
15:13:55 <abadger1999> https://github.com/ansible-community/antsibull/pull/292
15:15:00 <abadger1999> If you want to test, do test the main branch rather than the pr, though (felixfontein fixed a bug in my code in a separate pr)
15:15:23 <aminvakil> acozine: hi you better remove me from your list, i'm not involved in more ;) thanks!
15:15:28 <aminvakil> s/in more/anymore
15:15:45 <acozine> aminvakil: I'm very sorry to hear that
15:15:59 <samccann> Abadger1999 not sure how to do that in Jenkins. Was gonna unpin when you have the new release on pypi
15:16:41 <abadger1999> samccann: okay :-). I'll make a new release after the meeting, then
15:16:54 <samccann> Thanks
15:17:04 <aminvakil> acozine: it's fine, thanks!
15:17:41 <acozine> aminvakil: thank you for your contributions and participation
15:18:14 <felixfontein> I hope you can be back soon!
15:19:54 <acozine> #info we can now toggle breadcrumbs on and off
15:19:56 <abadger1999> samccann: (antsibull 0.36.0 is now available on pypi)
15:20:03 <acozine> #info we also got more memory for the docs build
15:20:04 <samccann> Woot!
15:22:02 <acozine> cool, anything else about breadcrumbs or the build?
15:22:06 <acozine> oh, side note:
15:22:23 <samccann> Not from me
15:22:58 <acozine> samccann and I looked through the free-form text responses from the docs survey yesterday, and a bunch of folks had asked for breadcrumbs specifically or for better ways to navigate among modules in a collection more generally
15:23:27 <acozine> so I'm glad we're maintaining the breadcrumbs
15:23:42 <gundalow> That's great
15:23:46 <abadger1999> <nod> way to anticipate people needs :-)
15:23:52 <acozine> heh
15:24:22 <acozine> we're working on a list of actionable suggestions from the survey now
15:24:49 <acozine> but breadcrumbs and the index pages were among the most commonly requested items
15:25:11 <acozine> top request was "more examples", which could mean many things
15:26:44 <samccann> Yes people will be very happy to have that all module index again!
15:26:45 <acozine> #topic roles documentation PR
15:27:20 <acozine> https://github.com/ansible-community/antsibull/pull/272
15:27:34 <felixfontein> thanks for all the comments, acozine and samccann!
15:30:18 <acozine> I had to laugh about the unused "reinstate the Edit on GitHub button" code, which I had not noticed in the plugin docs template
15:30:57 <acozine> it's funny how just copying some code makes it suddenly "visible", even though it has been there a long time
15:31:19 <felixfontein> yep :)
15:31:49 <abadger1999> Yeah :-)
15:31:55 <acozine> https://github.com/ansible-community/antsibull/pull/272/files#diff-3d3bf4a558c2567fdb54935c5e719bf28a889ddd812ece6d3d777ca42be19e8dR5
15:32:16 <acozine> it sounds like we're not quite ready to merge this functionality
15:32:43 <acozine> hmm, we might also want to see how many roles exist now in the Ansible package
15:32:57 <acozine> and test adding maybe 1K new roles to see if there's a performance hit
15:33:20 <acozine> I don't expect one, but I'd feel better if we tested it beforehand
15:33:51 <felixfontein> I guess there will be relatively few roles
15:34:07 <acozine> at first, certainly
15:35:01 <acozine> but I could see a scenario where the package includes a Useful Roles Collection (or three, or five)
15:35:44 <samccann> Does this work with all roles or only those that use the new role argspec?
15:35:51 <felixfontein> Ansible 4.1.0 has 121 roles
15:36:19 <felixfontein> though only 3 have a meta/argument_specs.yml file
15:36:45 <felixfontein> (none of the meta/main.yml files contain `argument`)
15:37:11 <felixfontein> so right now it's basically limited to the three roles of sensu.sensu_go
15:37:16 <acozine> heh
15:37:28 <acozine> at least we have something to test it on
15:37:54 <felixfontein> though I guess some more will follow once people notice that they can have role docs this way :)
15:38:20 <acozine> well, when we're ready to merge the code, we'll need to add a docs page for "here's how to document your role so the docs will appear on docs.a.c"
15:39:02 <felixfontein> definitely!
15:39:23 <abadger1999> An update on the code side of the review: I'm trying to create a version of felix's pr that processes roles in a separate pathway instead of having conditions for roles all the way through the code.  (Roles are not really plugins at the ansible-core level and their documentation schema is very different than any of the plugin schemas. So it may make for more readable code if it's done in a separate path). The hard part had been
15:39:23 <abadger1999> deciding where the code paths should diverge (my current implementation has the paths diverge after the role and plugin data is acquired from the collections)
15:40:55 <acozine> abadger1999: thanks, that sounds like a nice optimization for this work
15:41:15 <acozine> do you have an expected timeframe? should I put this on next week's agenda again?
15:41:32 <abadger1999> I'm definitely going to have it done this week
15:41:57 <acozine> sounds great, thanks, we'll put it on next week's agenda
15:41:59 <abadger1999> S/going/hoping/
15:42:10 <acozine> yeah, stuff happens
15:42:35 <felixfontein> :)
15:42:39 <acozine> I was just checking that there weren't three weeks' worth of other work lined up ahead of it
15:42:42 <abadger1999> Cool :-)
15:42:54 <acozine> and on that note . . .
15:43:04 <acozine> #topic follow-up on action items
15:44:04 <acozine> I have no progress to report on the problems with the docs schema
15:44:14 <acozine> I have no progress to report on the semantic markup plan either
15:44:16 <acozine> mea culpa
15:44:26 <acozine> I will try again this coming week
15:44:31 <felixfontein> i.e. same as most weeks ;)
15:44:38 <acozine> unfortunately, yes
15:44:39 <felixfontein> (the no progress part)
15:44:58 <samccann> AFK
15:45:06 <acozine> ciao samccann
15:46:32 <acozine> I will be opening more PRs to move community Scenario Guides into collections, and would welcome PRs from collection maintainers
15:47:57 <acozine> okay, cyb-clock-clone says we have 13 minutes left
15:48:14 <acozine> #topic open floor
15:48:26 <acozine> anybody have new stuff they want to discuss?
15:48:37 <acozine> all comments, questions, ideas, suggestions welcome
15:48:39 <acozine> from anyone
15:48:41 <felixfontein> this time, nothing from me :)
15:48:45 <acozine> you don't have to be a chair of the meeting
15:49:54 <acozine> I could use some reviews on https://github.com/ansible/ansible/pull/75157/files
15:51:12 <acozine> it tries to clarify how Ansible loads plugins - automatically from certain directories adjacent to the playbook or role, and from configured directories
15:52:03 <acozine> the old docs listed the default configured directories, but didn't make it clear that they were default settings
15:53:20 <acozine> other open floor topics
15:53:23 <acozine> ?
15:54:25 <acozine> it's a quiet week!
15:54:38 <felixfontein> :)
15:54:39 <acozine> I'll post my usual reminders
15:54:49 <abadger1999> I will look at that (but can only review parts of it accurately)
15:54:49 <acozine> topics for the agenda are welcome at any time
15:55:09 <acozine> just add a comment to https://github.com/ansible/community/issues/579
15:55:19 <acozine> all are welcome to participate
15:55:22 <aminvakil> 75157: line 10: s/can't/can not && line 32: augment/extend?
15:55:36 <acozine> aminvakil: ah, good catch
15:56:03 <acozine> thanks, I'll put those in
15:56:43 <acozine> and chat is welcome here in channel any time
15:57:05 <acozine> thanks abadger1999 aminvakil briantist dericcrago felixfontein gundalow samccann
15:57:20 <acozine> #endmeeting