15:30:38 <acozine> #startmeeting Documentation Working Group
15:30:38 <zodbot> Meeting started Tue Apr 16 15:30:38 2019 UTC.
15:30:38 <zodbot> This meeting is logged and archived in a public location.
15:30:38 <zodbot> The chair is acozine. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:30:38 <zodbot> The meeting name has been set to 'documentation_working_group'
15:30:39 <felixfontein> http://docs.testing.ansible.com/ansible/latest/modules/letsencrypt_module.html is a test case
15:31:18 <acozine> #chair felixfontein samccann
15:31:18 <zodbot> Current chairs: acozine felixfontein samccann
15:31:23 * samccann waves
15:31:23 <acozine> who else is around?
15:31:40 <alongchamps> I'm here for the first time in about a month!
15:31:52 <acozine> awesome!
15:31:55 <acozine> #chair alongchamps
15:31:55 <zodbot> Current chairs: acozine alongchamps felixfontein samccann
15:32:20 * gundalow waves
15:32:28 * acozine goes to check our agenda
15:32:31 <acozine> #chair gundalow
15:32:31 <zodbot> Current chairs: acozine alongchamps felixfontein gundalow samccann
15:32:39 <samccann> welcome back alongchamps !
15:32:53 <acozine> #topic final review of the Deprecated Alias PR
15:32:55 <alongchamps> thanks, March was a busy month so it feel good to get back into the usual stuff
15:33:08 <acozine> PR: https://github.com/ansible/ansible/pull/54448
15:33:31 <acozine> Page demonstrating results: http://docs.testing.ansible.com/ansible/latest/modules/letsencrypt_module.html
15:34:33 <acozine> thoughts, folks?
15:34:56 <acozine> I like the look of the stub - clean, user-friendly
15:35:12 <felixfontein> is the text clear enough?
15:36:02 <acozine> hm, good question
15:36:08 <acozine> maybe we could make it more newbie-friendly
15:36:10 <alongchamps> looks good on mobile
15:36:32 <acozine> ooh, excellent thought, thanks for checking that alongchamps
15:36:35 <alongchamps> I like the suggestion for the new name
15:36:47 <alongchamps> use this, don't use that it's deprecated
15:36:56 <samccann> hmm seems pretty straightforward to me
15:37:05 <acozine> I was thinking something like:
15:37:08 <samccann> shipit
15:37:11 <alongchamps> do we want any info such as mod_name will be removed in version ?
15:37:23 <acozine> This is an alias for acme_certificate. This name has been deprecated. Please update your tasks to use the new name acme_certificate instead.
15:37:48 <gundalow> Minor suggestion, both instances of `acme_certificate` should be links
15:38:07 <samccann> alongchamps - if the removed version is known, yes that helps.  acozine - yes that is clearier
15:38:33 <gundalow> If why.reason exists could displaythat
15:38:46 <acozine> gundalow: that's why I was thinking the wording change - the two things are a bit different - the first is "here are the docs you're looking for" and the second is "and here's how you want to update your playbooks"
15:38:47 <felixfontein> gundalow: I think it's not really possible in ReST to combine code formatting and link. also, this way, the new name can easily be copy'n'pasted :)
15:38:48 <samccann> clearier - is an alias for clearer. Please update your typing skils to use clearer instead.
15:38:58 <acozine> heh
15:39:07 <acozine> wait, we have `why.reason`???
15:39:16 * samccann never run doc build during irc meeting... typing can't keep up w/ delay
15:39:22 <acozine> is this an array I can query for anything?
15:39:33 * gundalow looks for an example
15:39:39 <felixfontein> hmm, isn't why.reason used for "properly" deprecated modules, and not for renamed mooules?
15:39:45 <acozine> like `Snow.In.April:why.reason`
15:39:58 <felixfontein> renamed modules don't have deprecation metadata AFAIK
15:40:16 <gundalow> correct, I don't think renames have DOCUMENTATION.deprecation
15:40:20 <bcoca> depends on how you rename
15:40:28 <bcoca> if its pure alias, no
15:40:29 <felixfontein> bcoca: with the symlink approach :)
15:40:35 <bcoca> ^ pure alias then
15:40:38 <felixfontein> yep
15:40:52 <gundalow> oh, ignore me
15:41:02 <felixfontein> otherwise there's no need for a stub, since the deprecated module gets its own docs page
15:41:05 <felixfontein> (AFAIK)
15:41:10 <gundalow> deprectated modules will already display DOCUMENTATION.deprecation, no need for it to go, what felixfontein said
15:41:40 <acozine> yes, I tried to test this PR by looking at the modules marked (D) in the all-modules list, and the ones i hit all had full pages
15:42:16 <acozine> sounds like everyone likes this functionality
15:42:49 <acozine> felixfontein: you want to add the "update your tasks" phrasing, or shall I?
15:44:21 <felixfontein> acozine: feel free to do that, I have to run for train now ;)
15:44:34 <acozine> will do, safe journey
15:45:02 <acozine> #actionitem acozine to update wording and merge #54448
15:45:24 <acozine> oh, bother the IRC syntax
15:45:54 <gundalow> #action acozine to update wording and merge #54448
15:46:00 <acozine> gundalow: thanks
15:46:01 <gundalow> acozine: close :)
15:46:19 <acozine> #topic better docsite 404
15:46:35 <acozine> so after the last meeting, I updated the issue for our New, Improved 404 page
15:46:44 <acozine> https://github.com/ansible/ansible/issues/51439
15:47:13 <acozine> I hesitate to mark the issue `easyfix`, but for anyone with the right skills, it would be fairly quick
15:47:44 <gundalow> Is this just for docs.ansible.com/ansible?
15:47:48 <acozine> yes
15:48:20 <acozine> I updated the title of the issue to reflect that
15:48:23 <samccann> If i can figure out the sphinx theme, there is 'something' I saw that had custom 404 support. If I can find it again, I'll pop it into the issue
15:49:01 <gundalow> Do we know what should be displayed on our new 404 page
15:49:09 <acozine> last week we found a module for custom 404s, I added a link
15:49:22 <acozine> gundalow: I don't think we've ironed that out
15:50:11 <samccann> ah yeah I think that might have been what I was remembering then... thanks acozine
15:50:15 <acozine> we can talk about that now, or we can let the person who picks up the issue make their own text for the proof-of-concept
15:50:54 <gundalow> If we are looking for someone else to fix it we can leave that I guess
15:51:25 <acozine> heh, well, I am hoping someone else will fix it between now and the 2.8 release
15:51:45 <acozine> if the ticket is still open then, we can re-assess
15:53:08 <acozine> any other ideas/suggestions/warnings/thoughts about the 404-page issue?
15:54:02 <felixfontein> re
15:54:10 <felixfontein> (in train now :) )
15:54:29 <acozine> #topic open floor
15:54:48 <acozine> alongchamps: so what were you up to in March? anything fun? challenging?
15:55:15 <acozine> felixfontein: ah, the rhythm of the rails
15:55:50 <felixfontein> acozine: yep, and tunnels without internet :D
15:56:04 <alongchamps> we had some multi-day agile planning meetings, vendor meeting with Dell, and some VMware vSAN training
15:56:28 <alongchamps> I'm hoping April will be more quiet and I can get some more VMware modules done
15:56:36 <acozine> that would be awesome
15:56:46 <acozine> did you see that we moved the VMware guide?
15:57:48 <alongchamps> I'm trying to bring up the docs site now, we're having a major network issue at my office at the moment so I may need to check it out later
15:57:58 <alongchamps> hence why I checked it on mobile earlier :)
15:58:30 <acozine> ah, and here I thought you were being thorough!
15:58:33 <acozine> https://docs.ansible.com/ansible/devel/scenario_guides/guide_vmware.html
15:59:05 <acozine> it should be redirected from the old URLs - let me know if you run into any trouble with any of it
15:59:30 <acozine> we also added a new index page for virtualization and containerization at https://docs.ansible.com/ansible/devel/scenario_guides/virt_guides.html
16:00:39 <alongchamps> I like it though I do notice something odd for the +/- on the left hand nav - it indents when you expand a section
16:00:49 <alongchamps> that's for the dev guide for VMware, your first link of the two
16:01:01 <acozine> hmmmm
16:01:18 <acozine> that might be one of those changes we made to the wrong sphinx style
16:01:25 <acozine> thanks for noticing and reporting that
16:01:28 <alongchamps> I'm on Chrome 73.0.3683.86 on MacOS 10.14.3
16:01:31 <alongchamps> no problem!
16:01:39 <alongchamps> at least my connection is working just long enough for that to come through
16:01:49 <acozine> I'm seeing it too
16:01:58 <alongchamps> glad it's not just me!
16:02:22 <acozine> heh
16:02:34 * gundalow -> another meeting
16:02:52 <acozine> I'll make a note, and either fix it or turn it into an issue later this week
16:03:31 <acozine> we also got rid of the last "template" pages that had "blah blah blah" in the text ;)
16:03:45 <acozine> that was a weight off my mind
16:03:55 <alongchamps> nice
16:04:01 <acozine> long overdue
16:04:32 <acozine> anything else from anybody?
16:05:09 <acozine> we've made progress today, we can rest on our laurels a little and have a short meeting
16:05:25 * samccann fluffs the laurels and parks it
16:05:33 * alongchamps lunchtime it is
16:05:44 <acozine> excellent, thanks everybody!
16:05:55 <acozine> tune in next week for the next episode of . . . .
16:06:02 <acozine> DaWGs In Space!
16:06:05 <samccann> HAHAHAHA
16:06:16 <alongchamps> lol
16:06:35 <acozine> #endmeeting