16:01:54 <samccann> #startmeeting Documentation Working Group aka DaWGs... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/18f89f3e2b8171212d1adc29780a2124eadc5840)
16:01:54 <zodbot> Meeting started Tue Dec 21 16:01:54 2021 UTC.
16:01:54 <zodbot> This meeting is logged and archived in a public location.
16:01:54 <zodbot> The chair is samccann. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:54 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs..._(full_message_at_https://libera.ems.host/_matrix/media/r0/download/libera.chat/18f89f3e2b8171212d1adc29780a2124eadc5840)'
16:02:11 * samccann ponders if that big ol cut n paste worked
16:02:21 <acozine> hm
16:02:24 <samccann> #chair acozine Gwmngilfen
16:02:24 <zodbot> Current chairs: Gwmngilfen acozine samccann
16:02:38 <acozine> the `@room` mention pinged me, but the name mention in the opening comment did not
16:03:26 <samccann> briantist: tadeboro  you around for docs chat and virtual eggnog?
16:03:39 <samccann> yeah I probably need to add the @ in front of each
16:03:51 <briantist> o/
16:03:57 <acozine> it didn't set the topic either
16:04:00 <acozine> at least, I don't think it did
16:04:18 <acozine> #chair briantist
16:04:18 <zodbot> Current chairs: Gwmngilfen acozine briantist samccann
16:04:28 <samccann> #topic opening chatter
16:04:49 <samccann> ah well, big old block of copy pasta doesn't work as well as I thought it w ould
16:05:18 * gwmngilfen-work wonders when Fedora will do a native Matrix zodbot...
16:05:34 <samccann> #info agenda - https://github.com/ansible/community/issues/579#issuecomment-993844821
16:05:47 <briantist> am dealing with a `setuptools` issue for the time being, seems suddenly it "can't be found" on all of our CI pipelines
16:05:56 <samccann> I don't expect we'll cover much this week with so few folks around, but we can pick and choose from the agenda
16:05:56 <briantist> (not docs/ansible related)
16:06:19 <samccann> well the ansible/ansible CI is misbehaving quite a bit of late as well.
16:06:22 <acozine> briantist: that sounds dire
16:06:47 <samccann> I've got at least 3 PRs ready to merge but no amount of hammering on CI reruns is getting them to pass. Gremlins in the system
16:07:01 <samccann> (or possibly elves using the CI to make toys?
16:07:06 <briantist> it seems like it could be related to `setuptools` version 60, so it may be larger than just my stuff :-/
16:07:10 <acozine> what is it failing on? timing out / running out of memory?
16:07:13 <samccann> * make toys?)
16:08:09 <samccann> who knows. core folks (at least brian) is aware. not sure how many others are around this week.
16:08:31 <acozine> that's odd - I merged briantist's suggested change to my "why use roles" PR and it passed CI this morning
16:08:39 <acozine> https://github.com/ansible/ansible/pull/76560
16:08:56 <samccann> ooo is your PR ready to merge???
16:09:15 <acozine> well, for suitably restricted meanings of "ready" . . . yes
16:09:25 <acozine> I am pondering the questions you put on it samccann
16:10:17 <samccann> do you want it to linger a bit while you ponder, or are you considering a separate PR if anything comes of the ponder? I'm fine either way
16:10:35 <acozine> well, I think you raised some interesting points
16:11:08 <samccann> #topics Documentation updates
16:11:10 <acozine> but at the same time, the basic message stays the same - roles help you organize complex automation
16:11:14 <samccann> dagnammit
16:11:19 <samccann> #topic Documentation updates
16:11:24 <acozine> but everyone decides for themselves what counts as "complex"
16:11:50 <acozine> heh
16:12:41 <samccann> ok so I guess my questions remain - would I use a role for a reason OTHER than sharing it with someone else?
16:13:03 <acozine> I'd say yes - I've used roles for my personal consumption when the playbook just got too unwieldy
16:13:13 <samccann> ok cool
16:13:52 <samccann> ok I'm thinking we merge and close the issue. And see if we get more feedback later.
16:13:55 <acozine> I'd also say the use of default vars is an advantage
16:13:59 <briantist> yes absolutely would use roles other than for sharing
16:14:12 <briantist> it's encapsulation, organization of files, etc.
16:14:22 <acozine> you can provide a value that gets used for general cases, while still allowing for overrides
16:15:01 <remindbot[m]> @smccann:matrix.org cyb-clock chimes Fifteen exciting, thrilling minutes have slipped by whilst we plot to take over the universe, one doc at a time!
16:15:56 <samccann> merged
16:16:43 <acozine> thanks!
16:17:17 <acozine> I still don't understand why it passed CI, though
16:17:21 <acozine> when other PRs are failing
16:17:27 <samccann> it's random
16:17:34 <samccann> sometimes it works, sometimes it doesn't.
16:17:40 <samccann> a problem for the New Year!
16:17:41 <acozine> ah, gremlins for sure, then
16:18:02 <samccann> #info some community topics relating to docs. Please add your comments to each - https://github.com/ansible-community/community-topics/issues/created_by/samccann
16:18:24 <samccann> Those cover the Great Debate on FQCN for built in modules, semantic markup, and community examples repo
16:18:34 <samccann> hmm.. actually that last one is mostly settled.
16:18:59 <acozine> I like the `being_implemented` tag
16:19:11 <samccann> anyone feel like this is worth keeping open though? - https://github.com/ansible-community/community-topics/issues/39
16:19:40 <samccann> or maybe I'll jsut ping felix etc and see if it can be closed now. I don't want to mess up any reporting etc they are doing there. Unless Gwmngilfen happens to know?
16:20:08 <acozine> I'd wait until after the New Year, but I think we can probably close it soonish
16:20:16 <samccann> kool
16:20:18 <acozine> does the new repo have a good README?
16:20:26 * gwmngilfen-work does not
16:20:27 <samccann> #info some easyfix docs issues if anyone is in the mood - https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Aeasyfix+label%3Adocs
16:20:54 <acozine> like, if we advertise this in the Bullhorn, would folks be able to learn about contributing?
16:20:55 <samccann> The new repo is still a WIP for sure but we have a couple of open issues there for example suggestions
16:21:56 <acozine> yeah, I see Andersson007 has a to-do item for "Complete README"
16:22:10 <acozine> we should do that before we close the discussion topic
16:22:35 <samccann> yeah there's a lot we don't know yet. I think once we work through the first few examples we can come up with a helpful readme
16:24:14 <samccann> #info we are down to 4 open issues to cover last year's Docs survey feedback!  Help wanted on any of these - https://github.com/ansible/ansible/issues?q=is%3Aissue+is%3Aopen+survey
16:24:44 <samccann> and one of those is `being_implemented` :-)
16:25:01 <acozine> well, issue 75507 is the examples repo . . .
16:25:05 <acozine> heh, exactly
16:25:35 <acozine> oh, and one of them isn't marked `Docs survey feedback` at all
16:25:42 <samccann> yeah it has a few ideas
16:25:45 <acozine> though maybe that's where it came from
16:25:49 <samccann> really? which one?
16:26:18 <samccann> oh mine ..doh! I'll update the title
16:26:47 <acozine> it came from the contrib summit, not the survey
16:26:53 <samccann> oh yeah.. so I'll leave the title
16:27:29 <samccann> flipping the topic switch
16:27:35 <samccann> #topic docs tooling updates
16:28:05 <samccann> somewhere in the ether I think Felix already has a PR in the works that will add the list of new collections to the start of the Ansible porting guide!
16:28:57 <samccann> #info looking for feedback on semantic markup specification - https://hackmd.io/VjN60QSoRSSeRfvGmOH1lQ
16:29:32 <samccann> The hope is to capture what we want from the community side, and then get RH internal involved for the downstream products this impacts. Slow process but still push push pushing it along
16:30:00 <remindbot[m]> @smccann:matrix.org cyb-clock chimes Fifteen exciting, thrilling minutes have slipped by whilst we plot to take over the universe, one doc at a time!
16:30:02 * samccann hopes there isn't a sysyphus aspect to this effort
16:30:54 <acozine> yeah, that's a long-running effort
16:30:59 <acozine> long-long-long-running
16:31:35 <samccann> Gwmngilfen: I added to the Help Wanted section of the upcoming bullhorn to list easyfix issues.  Is that something I need to add weekly now with newsbot or is there a way to make that a permanent thing? We could add core easyfix as well since there may be a few of those around
16:31:36 <samccann> heh
16:31:57 <samccann> only been a year acozine...
16:32:04 * samccann being sarcastic
16:32:24 <bcoca> i've had projects > 4 yrs and coutning in queue
16:32:57 <samccann> haha yeah I saw some when I was going through old PRs bcoca
16:33:08 <samccann> decided not to send you the annual nagogram comment this year ;-)
16:33:22 <bcoca> specially since CI is borked
16:33:23 <gwmngilfen-work> the news queue is cleared after each release, so you'd have to log a new item
16:33:44 <gwmngilfen-work> s/release/edition
16:33:50 <samccann> when is release day Gwmngilfen so I know when to repeat myself?
16:34:12 <samccann> it was going weekly soon, right?
16:34:27 <gwmngilfen-work> cybette should be able to answer that, but I believe the intention is for weekly in the New Year
16:34:35 <samccann> ok cool
16:34:51 <samccann> I can probably then just start posting it on Tuesdays after this meeting
16:35:07 <cybette> samccann: usually thursdays, but this week it'll be going out later today. maybe you can use remindbot to mention newsbot weekly ;)
16:35:13 <acozine> oh, we should also close out the 2021 agenda ticket and open a 2022 one
16:35:27 <samccann> oooo oooo cybette that would be great!
16:35:44 <samccann> #action samccann find a way to use remindbot with newsbot to add Help Wanted on easyfix items each week
16:36:07 <samccann> #action samccann close out 2021 DaWGs agenda issue and create a new on for the new year
16:36:11 <cybette> and even if we don't go weekly right away, it's trivial to remove a duplicate entry.
16:36:51 <cybette> so automate away with the bots!
16:37:17 <samccann> woot!
16:37:33 <samccann> #topic Open Floor and eggnog time!
16:37:40 * gwmngilfen-work generally oesn;t want bots logging news, but in this case I see the point :P
16:37:48 * gwmngilfen-work * generally doesn't want bots logging news, but in this case I see the point :P
16:38:14 <samccann> Gwmngilfen: i'll run it by you before I do it. I'm thinking maybe just one post for all easyfix items (not separating docs from coding ones)
16:38:50 <acozine> mmm, eggnog
16:38:56 <gwmngilfen-work> 🍹
16:38:57 <cybette> happy holidays everyone! 🥳
16:39:12 <samccann> 🍸️
16:39:24 <acozine> I have a recipe for home-made eggnog that involves whipped cream. It is truly a meal in a glass.
16:39:31 <acozine> and so, so tasty
16:39:33 <samccann> #info no DaWGs meeting next week. Very few folks will be around
16:39:37 * gwmngilfen-work had to give up alchol some years ago
16:39:40 <samccann> yum yum!
16:39:53 <acozine> Gwmngilfen: the recipe is alcohol-optional
16:40:02 <gwmngilfen-work> ooh, you win that one
16:40:02 <samccann> yeah I'm pretty close to that as well Gwmngilfen - I think it triggers migraines for me now
16:40:06 <acozine> we made it without for all the years the nephews were underage
16:40:08 <gwmngilfen-work> i have gout :/
16:40:23 <acozine> and I'll probably do it "spike your own" again this year
16:40:32 <samccann> hah sounds tasty
16:40:50 <acozine> Gwmngilfen: oof, that sounds painful
16:41:01 <samccann> The floor is open btw, if anhyone is lingering, feel free to bring up a topic, say hi, or just sip some virtual eggnog to end out the year with us!
16:41:32 <briantist> too busy to do much else than say "hi" and "happy holidays!"
16:41:49 <cybette> happy holidays briantist !
16:42:05 <acozine> happy holidays briantist!
16:42:05 <gwmngilfen-work> acozine: havent had an attack in over a year, but yeah, it's not fun
16:42:21 <samccann> happy holidays briantist !
16:43:00 <samccann> #chair Carol Chen
16:43:00 <zodbot> Current chairs: Carol Chen Gwmngilfen acozine briantist samccann
16:43:09 <samccann> never to late to be made furniture!
16:43:12 <gwmngilfen-work> giving up alcohol was easier than giving up tasty food
16:43:15 <acozine> heh
16:43:34 * gwmngilfen-work does a lot of cooking over this time of year
16:43:46 <cybette> hehe I was just saying that I'm off to make dinner... chair for 2 minutes! have a great holidays everyone, take care, relax, be merry, see you in 2022!
16:43:59 <acozine> happy holidays Carol Chen !
16:44:01 <samccann> enjoy Carol Chen !!
16:44:09 <acozine> enjoy your time off
16:44:23 <cybette> thanks, you too! cheers!
16:44:40 <cybette> #unchair cybette
16:45:01 <remindbot[m]> @smccann:matrix.org cyb-clock chimes Fifteen exciting, thrilling minutes have slipped by whilst we plot to take over the universe, one doc at a time!
16:45:05 * gwmngilfen-work is trying to finish up some survey work for Fedora
16:45:08 <acozine> #unchair Carol Chen
16:45:08 <zodbot> Current chairs: Gwmngilfen acozine briantist samccann
16:45:15 <acozine> there we go
16:45:38 <acozine> Gwmngilfen: oof, we didn't do an Ansible Docs survey this year, did we?
16:45:42 <acozine> well, maybe next year
16:45:47 <gwmngilfen-work> we did not, correct
16:45:51 <acozine> biennial . . . or is that biannual?
16:45:55 <samccann> no I didn't want to do it until we trim down the existing items a bit
16:46:03 <gwmngilfen-work> seems fair
16:46:13 <acozine> fair enough . . . plus - pandemic!
16:46:19 <samccann> yep
16:46:31 <samccann> maybe springtime?
16:46:57 <acozine> that could work
16:47:05 <samccann> that may be optimistic actually, since we probably need the new stuff on /latest/ and letting the dust settle a bit
16:47:22 <samccann> but we'll see
16:47:44 <gwmngilfen-work> anecdotally, I'm seeing a minor uptick in Matrix traffic now that acozine's doc changes have moved from devel to latest :)
16:47:55 <acozine> that's encouraging
16:48:06 <gwmngilfen-work> well, that depends on your view, but I think so, yes :)
16:48:18 <acozine> I noticed somewhere in the DaWGs stuff we mention IRC but not Matrix
16:48:27 <gwmngilfen-work> sabotage!
16:48:30 <acozine> should probably fix that for next year
16:48:35 <acozine> heh
16:48:47 <acozine> I think it was probably in the issue for the 2021 agendas
16:49:05 <acozine> at the very top, from last January
16:49:06 <samccann> lol
16:49:18 <gwmngilfen-work> well, that's fair then :P
16:50:17 <samccann> heh
16:51:38 <samccann> ok about time to wind this down I guess
16:51:53 * samccann gulps last of her eggnog ...
16:52:22 <samccann> #endmeeting