#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 14:32:00 UTC (full logs).

Meeting summary

  1. release notes and changelogs for ACD (acozine, 14:39:45)
    1. https://github.com/ansible-collections/overview/issues/18#issuecomment-613036927 (samccann, 14:40:06)
    2. survey so far leads to #2 option, with a fallback to manual links added to the ACD changelog for those collections who don't have the changelog in a fixed location we could link to programmatically (samccann, 14:57:19)
    3. Still hoping to gather some more feedback from collection owners (samccann, 14:57:49)
    4. #2 option includes a new combined format, so will be an update to what ansible/ansible provided in 2.9 (and possibly what ansible-base would have for 2.10+) (samccann, 14:58:43)
    5. any links added to ACD should be for the collection version in ACD, not the latest collection version, which could be more recent (samccann, 14:59:36)
    6. and the final fallback - no link at all if the collection owner doesn't follow the recommended approach, doesn't provide a link in a programmatically retrievable fixed location, and doesn't manually add their link to the ACD changelog (perhaps in a separate manual link file). (samccann, 15:01:02)
    7. From a collection owner's perspective: I can provide changelog fragments in the ansible/ansible format, which get automatically amalgamated and published in the ACD changelog. If I don't want to do that, I can provide the output of my changelog process in a defined format, which gets automatically published in the ACD changelog. (samccann, 15:04:57)
    8. If I don't want to do that either, I can provide a link to my changelog, wherever I publish it (including GitHub). And if I don't do any of the above, ACD shows a "no entry available" for my collection in the changelog. (samccann, 15:05:00)

  2. how to extract ansible changelog generator (samccann, 15:06:08)
    1. this is Ansible's changelog generator: https://github.com/ansible/ansible/blob/devel/packaging/release/changelogs/changelog.py (samccann, 15:06:22)
    2. this should most likely be pulled out of ansible-base into its own package (samccann, 15:07:21)
    3. - continue the to package or not to package discussion next week (samccann, 15:13:16)

  3. ACD Changelog usability (samccann, 15:13:28)
    1. options for ACD output - a section per collection and whatever we have available in that section (changelog in usable format or a link or nothing). Alternately, we could leave all the links to an end section. That would work better for allowing manual link additions (samccann, 15:20:22)
    2. we could try out the output options on community.general and/or some of the network collections that may have changelog need before ACD releases. (samccann, 15:22:36)
    3. AGREED: try a manual mockup of what we want the end result ACD to look like and review that (samccann, 15:23:18)
    4. ACTION: felixfontein play around with the changelog tool from ansible/ansible, to see whether I can get it to work with community.general and community.network (samccann, 15:23:49)
    5. experiment with pandoc conversions (samccann, 15:32:43)

  4. Felix's PR (samccann, 15:32:48)
    1. https://github.com/ansible/ansible/pull/68899 (samccann, 15:32:53)
    2. ACTION: acozine to review the PR later today (samccann, 15:37:59)

  5. open floor (acozine, 15:40:14)


Meeting ended at 15:43:17 UTC (full logs).

Action items

  1. felixfontein play around with the changelog tool from ansible/ansible, to see whether I can get it to work with community.general and community.network
  2. acozine to review the PR later today


Action items, by person

  1. acozine
    1. acozine to review the PR later today
  2. felixfontein
    1. felixfontein play around with the changelog tool from ansible/ansible, to see whether I can get it to work with community.general and community.network


People present (lines said)

  1. samccann (95)
  2. acozine (79)
  3. felixfontein (50)
  4. abadger1999 (22)
  5. zodbot (10)
  6. gundalow (9)
  7. relrod (4)
  8. odyssey4me (1)
  9. thedoubl3j (1)


Generated by MeetBot 0.1.4.