#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:00:40 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:00:44)
  2. docsite builds (acozine, 15:09:11)
    1. local testing on a VM put 7G too low, but 8G ram worked even when adding a handful more collections that totaled over 1K more plugins (samccann, 15:11:57)
    2. now asking The Powers That Be for more memory for the Jenkins build that runs it all (samccann, 15:12:21)
    3. ACTION: abadger1999 to allow us to turn of breadcrumbs so we can get the docs builds working as an interim fix until we get more Jenkins memory (samccann, 15:15:28)

  3. action items follow-up (acozine, 15:19:47)
    1. https://github.com/ansible/ansible/blob/devel/test/sanity/code-smell/docs-build.py#L33 (felixfontein, 15:34:57)
    2. ACTION: samccann acozine to get a hackmd or something to come up with a list of goals, we can evaluate potential solutions to the problem by how well they meet those goals (samccann, 15:42:00)

  4. open floor (acozine, 15:51:43)
    1. https://github.com/ansible-community/antsibull/pull/272 (role docs) is not blocked by the above though :) (felixfontein, 15:52:08)
    2. ACTION: samccann acozine to review roles output etc from https://github.com/ansible-community/antsibull/pull/272 (samccann, 15:56:57)
    3. interesting case are probably roles which have multiple entrypoints, like the ones in sensu.sensu_go (example: https://ansible.fontein.de/collections/sensu/sensu_go/agent_role.html#ansible-collections-sensu-sensu-go-agent-role) (samccann, 15:57:08)
    4. ACTION: abadger1999 to also work on the structure of the code for that PR to use parallel pathways (samccann, 15:57:59)


Meeting ended at 16:07:21 UTC (full logs).

Action items

  1. abadger1999 to allow us to turn of breadcrumbs so we can get the docs builds working as an interim fix until we get more Jenkins memory
  2. samccann acozine to get a hackmd or something to come up with a list of goals, we can evaluate potential solutions to the problem by how well they meet those goals
  3. samccann acozine to review roles output etc from https://github.com/ansible-community/antsibull/pull/272
  4. abadger1999 to also work on the structure of the code for that PR to use parallel pathways


Action items, by person

  1. abadger1999
    1. abadger1999 to allow us to turn of breadcrumbs so we can get the docs builds working as an interim fix until we get more Jenkins memory
    2. abadger1999 to also work on the structure of the code for that PR to use parallel pathways
  2. acozine
    1. samccann acozine to get a hackmd or something to come up with a list of goals, we can evaluate potential solutions to the problem by how well they meet those goals
    2. samccann acozine to review roles output etc from https://github.com/ansible-community/antsibull/pull/272
  3. samccann
    1. samccann acozine to get a hackmd or something to come up with a list of goals, we can evaluate potential solutions to the problem by how well they meet those goals
    2. samccann acozine to review roles output etc from https://github.com/ansible-community/antsibull/pull/272


People present (lines said)

  1. acozine (88)
  2. samccann (53)
  3. felixfontein (52)
  4. abadger1999 (45)
  5. zodbot (10)
  6. gundalow (5)
  7. dericcrago (1)


Generated by MeetBot 0.1.4.