#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by acozine at 15:01:29 UTC (full logs).

Meeting summary

  1. opening chatter (acozine, 15:01:34)
  2. action item review (acozine, 15:06:58)
    1. fedora found a workaround for the 2.9 documentation, we will continue to build those docs with Sphinx <4 (acozine, 15:11:00)
    2. merged https://github.com/ansible-community/antsibull/pull/272 for role documentation (acozine, 15:13:49)
    3. merged https://github.com/ansible-community/antsibull/pull/297 for sphinx-init antsibull-docs (acozine, 15:14:06)
    4. ACTION: carryover item: acozine samccann to check with testing team about updating Sphinx in CI (currently using 1.7.9) (acozine, 15:15:13)
    5. ACTION: carryover item: acozine samccann to open issues for community scenario guides to be moved to collections (acozine, 15:16:48)
    6. ACTION: abadger1999 to make a new antsibull release this week with role docs and antsibull-docs init features. (abadger1999, 15:18:42)

  3. goals for ansible-doc output, semantic markup, and other future changes to the documentation ecosystem (acozine, 15:19:48)
    1. internal mailing list setup to get internal stakeholders talkng about changes to docs. (abadger1999, 15:20:17)
    2. collection maintainers have to choose between docs.ansible.com (rst) and AH (md) or author in both if they want a presence in community and product. (samccann, 15:35:24)
    3. afaik AH does not use the roles argspec yet for role docs (samccann, 15:45:11)

  4. open floor (acozine, 15:55:30)


Meeting ended at 15:59:49 UTC (full logs).

Action items

  1. carryover item: acozine samccann to check with testing team about updating Sphinx in CI (currently using 1.7.9)
  2. carryover item: acozine samccann to open issues for community scenario guides to be moved to collections
  3. abadger1999 to make a new antsibull release this week with role docs and antsibull-docs init features.


Action items, by person

  1. abadger1999
    1. abadger1999 to make a new antsibull release this week with role docs and antsibull-docs init features.
  2. acozine
    1. carryover item: acozine samccann to check with testing team about updating Sphinx in CI (currently using 1.7.9)
    2. carryover item: acozine samccann to open issues for community scenario guides to be moved to collections
  3. samccann
    1. carryover item: acozine samccann to check with testing team about updating Sphinx in CI (currently using 1.7.9)
    2. carryover item: acozine samccann to open issues for community scenario guides to be moved to collections


People present (lines said)

  1. acozine (89)
  2. samccann (37)
  3. tadeboro (18)
  4. zodbot (11)
  5. abadger1999 (10)
  6. briantist (8)
  7. felixfontein (1)
  8. dmsimard (1)


Generated by MeetBot 0.1.4.