15:00:34 <DonNaro[m]> #startmeeting Documentation Working Group aka DaWGs
15:00:34 <zodbot> Meeting started Tue Sep  6 15:00:34 2022 UTC.
15:00:34 <zodbot> This meeting is logged and archived in a public location.
15:00:34 <zodbot> The chair is DonNaro[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:34 <zodbot> The meeting name has been set to 'documentation_working_group_aka_dawgs'
15:00:59 <DonNaro[m]> @room hi all samccann is out on PTO but who else is here to talk about the docs?
15:02:04 <DonNaro[m]> I'm double booked (again) but will do my best
15:02:56 <DonNaro[m]> #agenda https://github.com/ansible/community/issues/643#issuecomment-1231967346
15:03:14 <jklech[m]> the meeting happens here -- typing in this chat room?
15:03:49 <DonNaro[m]> jklech: yes, the meeting is here. welcome to the DaWGs
15:04:15 <jklech[m]> DonNaro[m]: thanks, my first meeting, not that i have anything to discuss, but i was curious how it happens
15:04:33 <felixfontein> o/
15:04:40 <felixfontein> I'm only partially around
15:05:18 <DonNaro[m]> unfortunately this might not be the most exciting for your first meeting but it's great to have you here
15:05:19 <jklech[m]> im going thru documents on how to contribute to upstream ansible and will start with something easy, so that i familiarize myself with the process
15:05:19 <DonNaro[m]> I'm filling in for the normal docs lead, who is out on PTO, and doing my best to keep the meetings going
15:06:00 <DonNaro[m]> jklech: there are some easyfix issues you can tackle here: https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs+label%3Aeasyfix
15:06:11 <jklech[m]> thanks
15:06:19 <DonNaro[m]> feel free to dig in and pick up one of those. ask any questions in this channel.
15:06:46 <briantist> o/
15:06:55 <briantist> also double-booked
15:08:32 <DonNaro[m]> #info update to the user guide split with issue https://github.com/ansible/ansible/issues/78082 . the work should now be complete and we're ready to start setting up redirects.
15:09:10 <DonNaro[m]> I'll review the couple of PRs that we merged with samccann when she returns from PTO
15:12:03 <tremble> jklech: First PRs can sometimes be daunting, if you need help on a docs PR: "try", push it and open a PR, then ask for help here.
15:12:57 <DonNaro[m]> good advice tremble !
15:13:04 <DonNaro[m]> oops I forgot to chair folks
15:13:05 <DonNaro[m]> #chair tremble
15:13:05 <zodbot> Current chairs: DonNaro[m] tremble
15:13:05 <DonNaro[m]> #chair jklech
15:13:05 <zodbot> Current chairs: DonNaro[m] jklech tremble
15:14:11 <DonNaro[m]> does anyone else have a topic to discuss?
15:14:26 <jklech[m]> I dont have much experience with pull requests, but i do wtih merge requests. I guess they are essentially the same, depends on what angle you are looking at it from.
15:15:49 <jklech[m]> if PR roughly means "pull my content from my fork into the main branch" then i have an idea
15:16:35 <DonNaro[m]> yes, PRs and MRs are the same thing really
15:16:35 <tremble> Very similar:  Create a fork, create a branch, make changes, push to fork/branch, go to original repo and open a Pull request.
15:17:31 <tremble> Only quirk of Ansible is that the 'main' ( or 'master' ) branch is called 'devel'
15:19:08 <tremble> There's a bot that will likely comment on your PR.  If you don't know what it's telling you, ask here.  Folks are friendly
15:19:37 <jklech[m]> What does the bot say about my PR?
15:22:03 <DonNaro[m]> the bot mostly does CI checks and points you to helpful resources. you'll get an email after you create the PR.
15:22:38 <DonNaro[m]> the email points you to this channel and where to find PR assistance
15:22:47 <DonNaro[m]> o/ hello, hello
15:23:02 <DonNaro[m]> #chair briantist felixfontein
15:23:02 <zodbot> Current chairs: DonNaro[m] briantist felixfontein jklech tremble
15:23:20 <DonNaro[m]> I'm doing my best in the double booked crew
15:23:45 <DonNaro[m]> have either of you got updates or any topics for discussion?
15:25:11 <DonNaro[m]> #info proposing the archive for EOL releases: https://github.com/ansible/ansible/issues/78082
15:25:48 <DonNaro[m]> * #info proposing the archive for EOL releases: https://github.com/ansible-community/community-topics/issues/78
15:25:59 <DonNaro[m]> sheesh, clipboard issues there
15:26:19 <DonNaro[m]> any updates from folks on this topic?
15:28:09 <DonNaro[m]> #info call for action! reminder that we're looking contributions to the community examples repo at https://github.com/ansible-community/community-examples/
15:31:20 <DonNaro[m]> #info Documentation issues and requests for help https://github.com/ansible/ansible/issues?q=is%3Aopen+is%3Aissue+label%3Adocs
15:33:09 <DonNaro[m]> jklech: along with those easyfix issues you can probably find something in that list of doc issues 😎
15:41:04 <briantist> there's an open PR on `community.aws` to have docs build (on push) publish to GH pages
15:41:21 <briantist> this is basically the same thing done on `community.windows` and `ansible.windows`
15:41:31 <DonNaro[m]> #info open floor
15:42:07 <briantist> https://github.com/ansible-collections/community.aws/pull/1436
15:46:29 <DonNaro[m]> briantist: I'm a little distracted right now but that looks awesome. I'll dig in some more but this looks like a great solution to streamline docs builds.
15:49:53 <DonNaro[m]> ok the other call just ended, lol
15:50:10 <DonNaro[m]> I see this is in the collections repo, which I didn't notice straightaway
15:51:28 <DonNaro[m]> briantist: or tremble do either of you happen to know who has permissions to enable GitHub pages on that repo?
15:52:04 <tremble> jillr and gundalow  SFAIK
15:52:51 <tremble> I'm assuming there are some other (paid) Ansible folks with access, but I don't know who
15:52:56 <jillr> tremble: abuzachis was just filling me in on this PR, I don't understand why we're deleting all the rst files. Don't we lose collection docs from docs.ansible.com this way?
15:53:35 <tremble> I've asked jillr to take a look.  But they don't usually start this 'early' in the day.
15:54:13 <DonNaro[m]> #action get reviewer with permissions to GitHub actions to review PR https://github.com/ansible-collections/community.aws/pull/1436
15:54:48 <tremble> The auto-generated RST will be regenerated for docs.ansible.com
15:55:03 <tremble> (That's my understanding anyway)
15:56:44 <tremble> briantist felixfontein : Am I understanding correctly that for docs.ansible.com the module RST files are re-generated and then the HTML generated from the fresh RST?
15:57:13 <briantist> yes that's correct
15:57:40 <briantist> DonNaro[m]: gundalow has already volunteered to enable GH pages, but anyone with enough permission on the repo could do it
15:58:51 <DonNaro[m]> this looks like a huge improvement over the manually generated RST pages
15:58:58 <DonNaro[m]> and I'm going to steal some ideas from the GH workflows in here for sure
15:59:27 <tremble> briantist has been doing some great work around docs + GH workflows
15:59:44 <DonNaro[m]> hats off briantist
16:00:05 <briantist> DonNaro[m]: the workflows are "shared" (reusable) workflows, with corresponding actions too, so you can use the actions to create workflows that do more fine-grained things if you want, but also consider whether changes you'd like to see can be incorporated into the existing ones, which are all maintained here: https://github.com/ansible-community/github-docs-build/
16:00:29 <briantist> and big thanks to felixfontein of course, whose work on `antsibull-docs`, specifically the `sphinx-init` subcommand, made all of that possible
16:01:33 <DonNaro[m]> briantist: cool. yes, I noticed how they are shared and really like that approach. plus enabling the "Edit on GitHub" button. very good stuff.
16:01:51 <DonNaro[m]> hats off to felixfontein too! 🎩
16:02:13 <briantist> heh the edit button thing is all possible due to antsibull and the docs build process, that could have been done without doing the build in the repo at all in fact
16:02:42 <DonNaro[m]> I think that's time on the meeting unless anyone else has something to add real quick?
16:04:11 <DonNaro[m]> briantist: gotcha. I hadn't noticed that before. I've still got loads of learning with all this.
16:04:35 <DonNaro[m]> and I still think it's cool!
16:04:39 <briantist> no worries, thanks for your interest!
16:05:09 <DonNaro[m]> I guess we can wrap it up for this DaWGs session. thanks for coming along everyone. I hope I did a decent job filling in for samccann
16:05:13 <DonNaro[m]> #endmeeting