#ansible-docs: Documentation Working Group aka DaWGs

Meeting started by samccann at 16:01:08 UTC (full logs).

Meeting summary

  1. Action Item updates: (samccann, 16:06:46)
    1. open -Looking for community maintainer(s) for the sphinx ansible theme (samccann, 16:06:54)
    2. https://pypi.org/project/sphinx-ansible-theme/ (samccann, 16:08:05)
    3. https://github.com/ansible-community/sphinx_ansible_theme (oranod, 16:08:25)
    4. open samccann to update docs requirements versions before Feb 20 (samccann, 16:09:17)
    5. https://github.com/ansible/ansible/pull/79930 (samccann, 16:09:26)
    6. ACTION: all - review the requirements updates in https://github.com/ansible/ansible/pull/79930 (samccann, 16:15:57)

  2. Documentation updates (samccann, 16:18:36)
    1. Ansible 8 roadmap ready to merge (samccann, 16:18:44)
    2. ACTION: samccann to create a list of 'docs stuff that needs updating for a new release' to catch things like roadmap updates early on (samccann, 16:24:35)
    3. looking for help on documenting how to run tests with Ansible pre-releases - https://github.com/ansible-community/community-topics/issues/156 (samccann, 16:27:19)
    4. booleans and ansible-lint -need help asking collection owners to implement these. See https://github.com/ansible-community/community-team/issues/60 for list that still needs issues opened on the collection itself. (samccann, 16:27:46)
    5. Archived 2.6 docs and will put redirects in place next week from the old docs to /latest/ - https://docs.ansible.com/archive/ansible/2.6/ (samccann, 16:33:16)
    6. examples repo archived as it never got any traction - https://github.com/ansible-community/community-examples/ (samccann, 16:33:54)

  3. personas and revamping the docsite (samccann, 16:34:47)
    1. goal is to evaluate who the people are in our larger Ansible community, and how best to serve them with targeted docs and journeys through our projects etc (samccann, 16:34:55)
    2. https://hackmd.io/pZb5w5JFRQW3RJ73n23tlw?both#/ (oranod, 16:35:56)
    3. https://github.com/ansible/jinja-docsite (oranod, 16:39:51)
    4. the jinja-docsite repo is a first stab at improving the layout and design of docs.ansible.com based on personas and is open for contributions (oranod, 16:40:46)
    5. overarching goal is to ensure the new docsite belongs to the community and provides community with the tools necessary to design/improve/add to it (samccann, 16:45:46)
    6. ACTION: Clone the jinja-docsite repo and show us how you'd like to improve docs.ansible.com https://github.com/ansible/jinja-docsite (oranod, 16:49:49)
    7. see https://ansible.github.io/jinja-docsite/ to view how the main branch looks for the proposed new docsite (samccann, 16:52:24)

  4. Open Floor (samccann, 16:53:21)


Meeting ended at 16:55:45 UTC (full logs).

Action items

  1. all - review the requirements updates in https://github.com/ansible/ansible/pull/79930
  2. samccann to create a list of 'docs stuff that needs updating for a new release' to catch things like roadmap updates early on
  3. Clone the jinja-docsite repo and show us how you'd like to improve docs.ansible.com https://github.com/ansible/jinja-docsite


Action items, by person

  1. samccann
    1. samccann to create a list of 'docs stuff that needs updating for a new release' to catch things like roadmap updates early on
  2. UNASSIGNED
    1. all - review the requirements updates in https://github.com/ansible/ansible/pull/79930
    2. Clone the jinja-docsite repo and show us how you'd like to improve docs.ansible.com https://github.com/ansible/jinja-docsite


People present (lines said)

  1. samccann (101)
  2. oranod (24)
  3. felixfontein (22)
  4. acozine (20)
  5. zodbot (9)
  6. kristianheljas (5)
  7. briantist (2)
  8. Don (0)
  9. Naro (0)


Generated by MeetBot 0.4.