12:00:05 <mmaslano> #startmeeting Env and Stacks (2014-05-13)
12:00:05 <zodbot> Meeting started Tue May 13 12:00:05 2014 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:00:10 <mmaslano> #meetingname env-and-stacks
12:00:10 <zodbot> The meeting name has been set to 'env-and-stacks'
12:00:16 <mmaslano> #chair abadger1999 pkovar tjanez samkottler bkabrda drieden hhorak juhp mmaslano
12:00:16 <zodbot> Current chairs: abadger1999 bkabrda drieden hhorak juhp mmaslano pkovar samkottler tjanez
12:00:21 <mmaslano> #topic init process
12:00:47 <bkabrda> hi
12:01:07 <tjanez> hello
12:01:08 <mmaslano> čau
12:01:31 <tjanez> mmaslano, čau is the same in Slovene :)
12:01:40 <mmaslano> great :)
12:02:08 <juhp_> hi
12:03:23 <hhorak> Hi
12:03:31 * pingou 
12:03:35 <pingou> lurking around :)
12:03:42 <mmaslano> fine 5 members and pingou
12:03:58 <mmaslano> #topic SCL in Fedora
12:04:16 <mmaslano> did you read the ticket?
12:04:22 * pingou did
12:04:24 <mmaslano> #url https://fedorahosted.org/rel-eng/ticket/5894
12:04:59 <mmaslano> jreznik created ticket for pkgdb https://fedorahosted.org/packagedb/ticket/247
12:05:11 <mmaslano> #info pkgdb ticket related to SCL https://fedorahosted.org/packagedb/ticket/247
12:05:33 * pingou notes that with pkgdb2 on the way, we should probably move it to the pkgdb2 tracker
12:05:42 <mmaslano> pingou: yes, I believe so
12:05:56 <mmaslano> pingou: um could you move it where it should be?
12:06:21 * pingou on it
12:06:32 <mmaslano> I must admit I didn't finish the Ruby collection yet
12:06:40 * tjanez is reading the ticket
12:06:48 <mmaslano> I need to patch scl-utils a little to use /opt/fedora and other stuff
12:07:01 <pingou> https://fedorahosted.org/pkgdb2/ticket/2 for the pkgdb2 RFE
12:07:35 <mmaslano> and I need to discuss those changes with owners of scl-utils,so we can do reasonable easily configured changes
12:07:55 <mmaslano> #info new ticket for pkgdb2 related to SCL https://fedorahosted.org/pkgdb2/ticket/2
12:08:00 <juhp_> aha
12:08:24 <mmaslano> #action mmaslano will discuss changes needed in scl-utils with jzeleny
12:09:19 <mmaslano> there is still question who will do those reviews, because I'm quite sure that no-one from SCL won't be interested in reviewing it again, this time for Fedora :)
12:09:55 <mmaslano> and that's probably summary what's happened about SCL last few weeks
12:10:32 * juhp_ is reading #5894
12:10:55 <pingou> mmaslano: I'm wondering, what is required on the pkgdb side?
12:11:12 <pingou> I mean, how is the SCL branch different from the F20 one?
12:11:23 <mmaslano> um there might be different owner?
12:11:42 <pingou> just like F20 and F21 can
12:12:01 <mmaslano> not exactly clear to me either
12:12:08 * pingou notes: pkgdb2 has no 'owner' anymore, just  point of contact :)
12:12:09 <mmaslano> does pkgdb2 provide some mapping to products?
12:12:16 <pingou> hm product?
12:12:19 <mmaslano> so no
12:12:22 <bkabrda> pingou: I'd say that there's nothing special about scl branch
12:12:29 <pingou> that's also my feeling
12:12:34 <mmaslano> jreznik: why did we need the pkgdb ticket?
12:12:46 <pingou> didn't Dennis suggested it?
12:13:07 <pingou> that's what make me think I might be missing something
12:13:13 <mmaslano> ah yeah, but I don't know what you should do :)
12:13:24 <pingou> cool, we're all on the same page then :)
12:13:51 <mmaslano> I guess branch is set to some buildroot, let's say f21+scl-utils-build
12:14:04 <mmaslano> and that's it, even fedpkg can take it automatically from the setting
12:14:04 <juhp_> a "review day" very funny
12:14:12 <juhp_> how about a year ;)
12:14:29 <mmaslano> it's only 60 packages, but I won't find any volunteers, I'm sure
12:14:42 <juhp_> ah - for ruby?
12:14:46 <mmaslano> pingou: what about your review server? :)
12:14:49 <mmaslano> juhp_: yes
12:15:01 <juhp_> okay - but the general problem is much bigger
12:15:34 <mmaslano> it is
12:15:53 <mmaslano> I would love to see strict review only for Base and other packages semi-automatically
12:15:59 <mmaslano> but that will take a lot of time
12:16:04 <juhp_> +1
12:16:12 <bkabrda> +1
12:16:31 <mmaslano> or run by SIG groups
12:16:37 <juhp_> yep
12:17:57 <pingou> mmaslano: still in the boxes :)
12:18:02 <juhp_> so rubygem's will not be needed for scl?
12:18:25 <tjanez> We had ideas/plans for automatic-review-as-a-service thing when we discussed Playground
12:18:42 <mmaslano> juhp_: yes, rubygems also rubygems-* are part of collections
12:18:51 <tjanez> Maybe it would be even more useful to the main Fedora repositories first
12:18:57 <tjanez> s/to/for
12:18:58 <juhp_> ok
12:19:40 <juhp_> mmaslano, but only 60 pkgs? :)
12:20:17 <juhp_> anyway 60 is already a lot...
12:20:36 <juhp_> yes +1 for automation
12:21:45 <mmaslano> well "only"
12:22:10 <mmaslano> tjanez: yes, we discussed it, but now someone need to write a code :)
12:23:22 <juhp_> mmaslano, okay sure - just checking since seems 500+ ruby* packages in fedora
12:24:13 <juhp_> but maybe core lib type packages is sufficient - doing all is surely too much work
12:24:32 <tjanez> mmaslano, yes, I know :). But maybe we can start with smaller steps and write up a plan on the wiki page so that we can attract people who will write the code?
12:24:41 <juhp_> probably similar story for python
12:25:41 <juhp_> tjanez, yes that would be a good start
12:26:01 <mmaslano> juhp_: I shall rebuild what we have for internal product, if someone wants something else, then (s)he can do it
12:26:13 <juhp_> cool
12:26:20 <bkabrda> juhp_: yeah, we should always limit the SCL only to the actually needed packages, no unnecessary burden
12:26:28 <mmaslano> and that's same with python, we had something in collection
12:26:34 <juhp_> ok
12:26:38 <mmaslano> tjanez: sure, pingou already has something, I guess
12:26:44 <mmaslano> or he will prepare somethign
12:26:51 <mmaslano> it's his project after all
12:26:58 <tjanez> mmaslano, that's great
12:27:00 <mmaslano> he started with it before we talked about it
12:27:08 <pingou> long time ago
12:28:19 <tjanez> Looking at things from a bigger perspective, the addition of SCLs and the needed reviews will clearly demonstrate the limits of current review process
12:28:49 <tjanez> I can't see how we can scale with the current way of doing things
12:29:03 * pingou don't intend to delete manual review, just trying to speed them up
12:29:20 <tjanez> either we flex the rules and lower the quality or we try to speed them up with automation
12:29:29 <tjanez> pingou, +1
12:32:42 <juhp_> pingou, what is the current status? :)
12:33:16 <pingou> juhp_: I have clear ideas of where I want to go in my mind :)
12:33:40 <juhp_> ok
12:34:09 <juhp_> any timeline? :)
12:34:10 <pingou> then I have progit as a basis for interacting with git repos
12:34:24 <pingou> http://209.132.184.222/progit (the mentionned progit)
12:34:53 <pingou> juhp_: I won't start working on it before pkgdb2 is in prod (hoping for this soon)
12:35:02 <pingou> then there is mirrormanager2
12:35:27 <pingou> juhp_: so not before July/early August to start on it
12:35:32 <pingou> then we'll see :)
12:35:57 <juhp_> I see thanks
12:36:21 <juhp_> (progit looks nice)
12:37:02 <tjanez> pingou, thanks for the update, this looks cool :)
12:37:31 <pingou> tjanez: progit is a bit of a playground, no idea how far I will take it :)
12:37:49 <pingou> but it allows me to face some issues I'll likely face in the review-server anyway
12:38:39 <tjanez> pingou, cool :). So, if one would like to start contributing, can he help you with anything yet?
12:39:03 <pingou> tjanez: on the review-server or progit? :D
12:39:32 <tjanez> I was thinking ProGit, what is the next thing to add to it / evolve it?
12:40:04 <pingou> tjanez: one I'll need to figure out one way or another is the inline comments
12:40:43 <pingou> tjanez: I want to finish the logic for the hooks, I know how I just need to do it now :) but the inline comments will likely be a big piece
12:41:16 <tjanez> pingou, aha. I'm starting to "get" it. So ProGit would be something smoother that cgit and closer to GitHub?
12:41:31 <pingou> tjanez: precisely ;-)
12:41:43 <tjanez> pingou, very cool :)
12:41:47 <pingou> tjanez: I was wondering if I could not move some of my projects away from trac with it :]
12:42:12 <pingou> anyway, I didn't want to hijack the meeting with my crazy projects/ideas
12:42:24 * pingou gives the floor back to mmaslano
12:42:50 <tjanez> pingou, yea, replacing Trac will be very desired feature :)
12:43:00 <juhp_> yes
12:43:08 <mmaslano> I have no other agenda "0
12:43:22 <mmaslano> does someone have questions or new topic?
12:43:38 <tjanez> anyway, thanks for sharing your ideas/thoughts, you could gain new contributors.
12:43:56 <pingou> tjanez: yeah, I should blog more ^^
12:44:42 <mmaslano> pingou: no worries, give me plan and I'll find some volunteers :) programming is not like reviews
12:44:55 <tjanez> pingou, yeah, a day doesn't have enough hours :)
12:45:11 <pingou> mmaslano: if I do that, you'll run into tjanez 's problem :)
12:45:11 <juhp_> so we might need some manuel checking of scl packages until review server is ready?  unless someone comes up with some intermediate checking scripts say?
12:45:43 <mmaslano> juhp_: we have rpmlint-scl, but it wasn't included in upstream yet
12:45:44 <juhp_> manual checking, even
12:45:49 <juhp_> aha
12:45:49 <mmaslano> and I'm afraid it won't be included
12:46:02 <juhp_> mmaslano, can't it be?
12:46:07 <mmaslano> I heard upstream didn't respond about the plugin
12:46:14 <mmaslano> so maybe we should put it into scl-utils
12:46:14 <bkabrda> juhp_: it can, the upstream just doesn't respond
12:46:15 <pingou> misc: ^
12:46:39 <juhp_> I see
12:46:55 <bkabrda> well, they do respond, but every other month or so... so no, right now rpmlint-scl is not available in upstream
12:46:59 <juhp_> would rpmlint-scl be sufficient you think?
12:47:08 <misc> uh ?
12:47:12 <hhorak> what about include it in rpmlint only downstream?
12:47:25 <bkabrda> misc: that's what miro told me
12:47:27 * misc forgot what was the issue with rpmlint-scl
12:47:48 <misc> bkabrda: yeah, I may have said something about not being generic, and it would be better to have it as a separate check
12:48:03 <misc> because in the end, it is just where the file live in git
12:48:20 <bkabrda> misc: so is that the blocking thing right now?
12:48:30 <misc> bkabrda: I should look at my mail
12:48:50 <misc> we try to have rpmlint to be useful for all, s at least, everybody follow the same policy
12:49:16 <misc> so a fedora only policy kinda go against that idea, even if we did lots of exception in the past
12:50:05 <bkabrda> this is the bug, right? http://sourceforge.net/p/rpmlint/tickets/30/
12:50:06 * juhp_ should try playing with scl soon...
12:50:22 <misc> but to be really honest, I forgot what I said to miro :/ ( or maybe it was Vile Skitta )
12:50:25 <misc> Vil
12:50:33 <bkabrda> it depends http://sourceforge.net/p/rpmlint/tickets/24/, which seems to be solved
12:50:58 <bkabrda> misc: I'll check back with miro
12:51:13 <bkabrda> (when he has the time)
12:51:39 <mmaslano> rpmlint wouldn't solve all our issues but it can be improvement
12:51:45 <juhp_> okay
12:51:47 <mmaslano> we need to run checks somewhere
12:51:55 <juhp_> yep
12:52:53 <hhorak> I think we should talk to Fedora QA about "running checks automatically"
12:53:26 <mmaslano> that's taskotron probably, which is not ready
12:53:52 <juhp_> when is it expected?
12:54:49 <hhorak> nobody knows probably
12:55:03 <hhorak> #action hhorak will ask Fedora QA about taskotron status
12:55:30 <juhp_> thanks
12:59:36 * mmaslano guess we are out of topics
12:59:50 <hhorak> I need to go anyway, thanks a lot! Bye!
13:00:20 <tjanez> mmaslano, yes, let's wrap up
13:00:47 <mmaslano> #endmeeting