13:00:13 <mmaslano> #startmeeting Env and Stacks (2014-08-26)
13:00:13 <zodbot> Meeting started Tue Aug 26 13:00:13 2014 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:19 <mmaslano> #meetingname env-and-stacks
13:00:19 <zodbot> The meeting name has been set to 'env-and-stacks'
13:00:26 <mmaslano> #chair pkovar tjanez samkottler bkabrda hhorak juhp mmaslano vpavlin sicampbell
13:00:26 <zodbot> Current chairs: bkabrda hhorak juhp mmaslano pkovar samkottler sicampbell tjanez vpavlin
13:00:47 <juhp_> hi
13:00:51 <bkabrda1> hi
13:01:06 <vpavlin> hi
13:01:10 <pkovar> hi
13:01:29 <mmaslano> 5 people great
13:01:55 <mmaslano> #topic follow up from we learnt on Flock
13:02:07 <mmaslano> hhorak: thanks for report from other groups
13:02:45 <hhorak> Hi, yeah, it was quite interesting...
13:03:22 <mmaslano> yeah, just laughing on need to package Vagrant :)
13:04:20 <mmaslano> sicampbell: hi, did you already change wiki for requests?
13:04:34 <hhorak> mmaslano: :)
13:06:12 <mmaslano> let's move to next topic
13:06:47 <mmaslano> hhorak: do you want to propose other WG to sum up bi-weekly what was done?
13:07:17 <mmaslano> hhorak: I was trying to write it down for our group, but nothing was happening last month or more, so I've stopped
13:07:59 <langdon> .win 21
13:08:03 <langdon> oops :)
13:09:19 <hhorak> mmaslano: yeah, probably, since this way it is quite time-consuming.. and sending it directly to ML of other groups could be also helpful, so we do not need to find it on different channels (meeting logs, ML, ...)
13:09:56 <juhp_> aha
13:10:09 <mmaslano> hhorak: yes, for example I was trying to follow server WG, but there is too high traffic on mailing list
13:10:19 <mmaslano> hhorak: do you want action item? :)
13:10:25 <hhorak> #action hhorak will send a proposal for every WG to send a short summary time to time to other WGs directly, so we all stay tuned
13:10:26 <hhorak> done
13:11:15 <mmaslano> great
13:11:38 <mmaslano> #action mmaslano will continue in writiing status of env and stacks WG
13:11:51 <mmaslano> #topic EPEL/epic proposal
13:12:49 <mmaslano> I admit I didn't see the talk yet
13:13:43 <juhp_> I missed a large part of it iirc :|
13:14:35 <juhp_> actually correctly I don't think there was so much discussion about epic in the talk?
13:14:50 <juhp_> well the EPEL.next talk anyway
13:15:50 <juhp_> but it was mentioned sure
13:18:26 <hhorak> yeah, only part was dedicated to epic/epel, but it discussed pretty general question -- users have contradict requests -- they need the newest packages and they need something more stable as well.. and we might say that some of the stable things might not be "supported" (whatever it means in Fedora/EPEL)
13:19:21 <juhp_> the idea is that epic is faster moving than epel, right?
13:20:47 <sicampbell> how will epic relate to fedora server ?
13:20:52 <hhorak> yeah, something like that.
13:20:59 <hhorak> And I think, that since fedora and epel currently use the same infrastructure, we might solve this in the same manner.. since requirements in fedora quite are similar...
13:21:44 <mmaslano> fast like adding new version of the same package?
13:21:46 <hhorak> sicampbell: hard to say, since I'm not sure anybody has some real plan yet
13:23:05 <hhorak> stephen was talking about having a new repository for every RHEL/CentOS minor release, where packages would be updated more often; while users would still be able to use some package from older minor release if they want
13:23:16 <juhp_> sicampbell, my understanding is that epic is only for EL fwiw, bicbw
13:23:19 <juhp_> hhorak, ah yes
13:23:45 <hhorak> so, someone would use gnome 3.18 from CentOS 7.4, but other would use Gnome 3.14 from CentOS 7.2 -- at least this is how I understood it
13:23:46 <juhp_> mmaslano, I think so
13:23:54 <juhp_> right
13:24:15 <juhp_> older epic releases would be frozen or best effort maintained perhaps or not
13:26:26 <juhp_> I guess one could not really mix different epic repos though
13:27:20 <hhorak> another thing is that updating in epel is kind of mystery without fix rules now (or at least no one forces the rules), so this would make updating a bit more legitimate
13:27:32 <juhp_> yes
13:28:02 <juhp_> it is often quite a dilemma: to update or not to update
13:28:14 <juhp_> specially for older epel
13:28:45 <bkabrda> the policy is there, the problem is that most people don't respect it at all http://fedoraproject.org/wiki/EPEL_Updates_Policy
13:28:53 <hhorak> juhp_: exactly, and this depends on maintainer only now, while using this proposal it would give users a choice
13:29:05 <hhorak> bkabrda: exactly
13:29:49 <juhp_> hhorak, right
13:30:29 <juhp_> but I think they said epic will not replace epel but supplement it
13:30:49 <juhp_> epel already has too much moment or too successful :)
13:31:32 <juhp_> the graph of epel usage vs fedora etc left quite an impression
13:31:36 <hhorak> juhp_ ah, that's right, so the example with gnome does not work much :)
13:32:27 <juhp_> hhorak, dunno if epic is allowed to update RHEL packages or not - you may be right there
13:32:47 <vpavlin> ls
13:32:52 <vpavlin> sorry:)
13:33:50 <juhp_> I guess there are older threads about epic - I haven't read them though
13:34:27 <hhorak> juhp_: do you have any links to share?
13:34:53 <mmaslano> I don't follow epel list, so I have no idea
13:35:07 <juhp_> I hope I am not making this up :)
13:35:21 <juhp_> at least that was the impression I got from the session
13:35:34 <juhp_> hhorak, not really, sorry
13:35:42 <mmaslano> definitely newer version would be nice. I know people were asking for python3, but which one? Python3.3 or 3.4 and maintain it for 10 years or change it and update to minor releases...
13:36:27 <juhp_> https://lists.fedoraproject.org/pipermail/epel-devel/2014-March/009320.html
13:37:13 <hhorak> mmaslano: so would this help us with python3? like introducing python3.4 stack for say CentOS 7.2 and then python 3.5 for CentOS 7.4? bkabrda?
13:37:20 <hhorak> juhp_ thanks
13:38:10 <juhp_> hhorak, yeah it at least allows both to coexist without overwriting...
13:38:24 <bkabrda> hhorak: it could probably help us, yes; most importantly if we could just leave the old stacks unmaintained. it's still a lot of work, but it'd be doable, I guess
13:38:30 <juhp_> which is the weakness of epel
13:39:20 <juhp_> I think there was talk of only maintaining the latest epic release really - older would be best effort or unmaintained realistically
13:40:24 <juhp_> bkabrda, so I guess it would work for you if that is the case :)
13:40:25 <bkabrda> juhp_: yeah, but we'd still need to rebuild the whole stack for (possibly every) new minor release and make sure the upgrade path works ok between these
13:40:50 <juhp_> right... I agree it is lot of work
13:41:17 <juhp_> but users might be happy :)
13:41:18 <bkabrda> but I guess this is the best solution I know of right now
13:43:05 * bkabrda really needs to find out more about epic, finally
13:44:35 <mmaslano> bkabrda: you mean env and stacks WG, proud supporter of epic idea?
13:45:06 <bkabrda> mmaslano: possibly :) I'll tell you when I learn more
13:45:49 <hhorak> bkabrda: I don't think you'll learn any details, since afaict this is only idea right now.. but I might be wrong.
13:47:09 <juhp_> so should this WG help to encourage/move epic?  it seems topical
13:47:51 <hhorak> juhp_: I guess we should
13:47:51 <juhp_> but maybe EPEL.next is considered orthogonal to Fedora.next?
13:47:55 <juhp_> :)
13:48:10 <juhp_> it would make sense to me if we did anyway
13:48:44 <hhorak> well, if we find a way to deliver more versions of some package to users -- that's actually something we might want in fedora as well (not considering SCLs right now)
13:49:33 <hhorak> I mean, thinking only roughly about how this could work on users' end -- we might give some more logic to dnf, so people would be able to select a specific version of something in EPEL and dnf would handle the rest.
13:49:49 <hhorak> which is quite usable in Fedora as well..
13:49:50 <juhp_> as such epic seems not that hard to implement - just need more branches and dist tags really
13:50:04 <hhorak> but I might be too deep in details already, so do not take me seriously
13:50:04 <juhp_> and releng to do some magic of course
13:50:52 <juhp_> true maybe Fedora could leverage epic too but that would be kind of a plus I guess
13:51:44 <hhorak> juhp_: indeed, releng won't be happy about that, unless branches and tags are done automatically somehow... which are not now afaik
13:53:10 <juhp_> s/Fedora/Fedora users/
13:53:22 <vpavlin> Then it's best time to start the automation;)
13:53:56 <mmaslano> who will speak to Stephen about his proposal?
13:54:00 <mmaslano> maybe he has some update
13:54:01 <juhp_> hhorak, what do you mean by automatically sorry?
13:55:05 <juhp_> has anyone talked to him face-to-face?
13:55:26 <hhorak> juhp_ I meant creating branches for users' stacks, but if we stay only with centos-7.x branches, then nothing :)
13:55:36 <langdon> juhp_: i can if y'all like
13:56:44 <juhp_> langdon, sure, thanks :)
13:57:15 <juhp_> I haven't talked to him and I am also in different tz
13:57:24 <langdon> juhp_: or you could invite him to the next meeting...
13:57:33 <juhp_> good idea
13:57:51 <juhp_> mmaslano, how do you think?
13:57:57 <hhorak> that would be great..
13:57:59 <langdon> personally, i think y'al should be making the proposal... this is part of the "fedora environment"
13:58:02 <mmaslano> juhp_: he's on west coast, I guess
13:58:06 <juhp_> ah
13:58:20 <langdon> mmaslano: like, on the road? he is normally in westford
13:58:25 <mmaslano> really?
13:58:34 <mmaslano> next meeting it is
13:58:40 <langdon> mmaslano: yeah... sits down the hall from me :)
13:58:48 <mmaslano> #mmaslano will invite Stephen for next meeting about Epic
13:58:57 <juhp_> great
13:59:21 <pingou> langdon: smooge ?
13:59:26 <langdon> mmaslano: he has been spending a lot of time in texas or somehere for some customer though
13:59:41 <langdon> pingou: ohhhh ... ha.. i meant gallagher
13:59:42 <pingou> langdon: I think you're not talking about the same Stephen
13:59:43 <juhp_> too many Steve's
13:59:44 <pingou> yeah :)
13:59:59 <juhp_> actually I got confused too
14:00:08 <mmaslano> I meant smooge :)
14:00:11 <juhp_> right
14:00:15 * langdon considers "confused" normal state
14:00:16 <mmaslano> I figure out time zone and let him know
14:00:38 <juhp_> but west coast is easier for me :)
14:00:46 <pingou> .localtime smooge
14:00:47 <zodbot> pingou: The current local time of "smooge" is: "08:00" (timezone: US/Mountain)
14:01:15 <mmaslano> ha I'm right!
14:01:33 <mmaslano> juhp_: feel free to chat with him :)
14:01:37 <juhp_> okay
14:01:37 <langdon> mmaslano: sorta ;)
14:01:42 <mmaslano> pff
14:02:06 <mmaslano> #action juhp_ will chat with smooge about epel/epic proposal and what should Env and Stack WG do about it
14:02:14 <juhp_> okay
14:03:10 <hhorak> ha, found http://meetbot.fedoraproject.org/epel/2014-08-22/epel_reboot.2014-08-22-16.00.html -- epel folks talked about this idea this Friday
14:03:21 <juhp_> aha
14:03:23 <mmaslano> #url http://meetbot.fedoraproject.org/epel/2014-08-22/epel_reboot.2014-08-22-16.00.html
14:04:39 <juhp_> anyway I'll read the logs and try to sync up with him
14:04:43 <mmaslano> thanks
14:04:48 <mmaslano> anything else?
14:05:07 <juhp_> hhorak, thanks
14:06:37 <hhorak> anytime
14:07:44 <mmaslano> end of meeting in five minutes if you don't have anything else
14:14:41 <hhorak> It does not seem so, so thank you and bye!
14:16:36 <mmaslano> #endmeeting