#fedora-meeting: Env and Stacks (2014-09-23)

Meeting started by hhorak at 13:02:08 UTC (full logs).

Meeting summary

  1. init process (hhorak, 13:02:27)
  2. Taskotron's current status (hhorak, 13:15:49)
    1. Taskotron is close to production, soon replacing autoqa (hhorak, 13:16:41)
    2. ncoghlan interested in Taskotron vs. rpmgrill integration, it seems to be better and more flexible choice than the custom app around rpmgrill (hhorak, 13:18:52)

  3. Recommendation for running Koschei for all Fedora packages (hhorak, 13:20:51)
    1. https://fedorahosted.org/rel-eng/ticket/5941 (mizdebsk, 13:40:04)
    2. Koschei devels would like to have our recommendation for using of Koschei before trying to move it into fedora-infra (hhorak, 13:45:15)
    3. mmaslano, juhp and hhorak are +1 for that, others are expected to vote on ML (hhorak, 13:45:15)
    4. ACTION: All voting members should vote on ML on the proposal: "Env & Stacks will recommend Koschei as a good idea and we would like to see it as official fedora service" (hhorak, 13:45:15)
    5. UI for adding a package to Koschei is not ready yet, could be ready around December/January; until then people can contact mizdebsk or msimacek to have packages added (hhorak, 13:45:15)
    6. Koschei builds should be distinguished by user (should be build by koschei user in the future) (hhorak, 13:45:16)

  4. Follow-up: language specific mirrors for Fedora Playground compliant packages (hhorak, 13:49:05)
    1. even if it is kind of repo, we should rather use term "filtered mirror" to not be confused with RPM repos and since devpi is actually a caching mirror (hhorak, 14:03:39)
    2. we should rather postpone something similar in other languages until we see consequences and results of devpi pilot (hhorak, 14:05:15)
    3. we should investigate performance as part of the pilot, as pypi.python.org is behind the Fastly CDN (ncoghlan, 14:09:55)

  5. Follow-up: SCLs, building above them and their position in Fedora/EPEL (hhorak, 14:16:53)
    1. https://github.com/openshift/ruby-19-centos/blob/master/ruby/.bashrc (mmaslano, 14:18:28)
    2. ACTION: Everyone should look at conda since there are some interesting features solved (beside other challenges brought up) so we won't repeat the same mistakes or will be able to use the usable features (hhorak, 14:31:25)

  6. Picking chairman for the next meeting (hhorak, 14:35:10)
    1. ACTION: mmaslano will chair the next meeting (hhorak, 14:39:54)

  7. Open floor (hhorak, 14:40:04)


Meeting ended at 14:41:56 UTC (full logs).

Action items

  1. All voting members should vote on ML on the proposal: "Env & Stacks will recommend Koschei as a good idea and we would like to see it as official fedora service"
  2. Everyone should look at conda since there are some interesting features solved (beside other challenges brought up) so we won't repeat the same mistakes or will be able to use the usable features
  3. mmaslano will chair the next meeting


Action items, by person

  1. mmaslano
    1. mmaslano will chair the next meeting
  2. UNASSIGNED
    1. All voting members should vote on ML on the proposal: "Env & Stacks will recommend Koschei as a good idea and we would like to see it as official fedora service"
    2. Everyone should look at conda since there are some interesting features solved (beside other challenges brought up) so we won't repeat the same mistakes or will be able to use the usable features


People present (lines said)

  1. hhorak (73)
  2. ncoghlan (44)
  3. juhp_ (20)
  4. mmaslano (18)
  5. mizdebsk (15)
  6. zodbot (4)
  7. tflink (3)
  8. kushal (1)
  9. bkabrda (0)
  10. samkottler (0)
  11. sicampbell (0)
  12. vpavlin (0)
  13. tjanez (0)
  14. juhp (0)
  15. pkovar (0)


Generated by MeetBot 0.1.4.