#fedora-meeting: Env and Stacks (2014-10-21)

Meeting started by hhorak at 13:02:31 UTC (full logs).

Meeting summary

  1. init process (hhorak, 13:02:48)
  2. Follow-up -- Docker docs (hhorak, 13:04:46)
    1. ACTION: hhorak will sum up what we agreed the last time on Docker doc and will write it on the wiki for someone who picks it (hhorak, 13:12:02)

  3. Integration tests for packages alias Per-component integration tests in Fedora (hhorak, 13:13:33)
    1. IDEA: we can divide the complex issue into smaller pieces delivered independently -- first have method/rules to keep tests somewhere and write them somehow and later solve how to run them automatically in proper environment (hhorak, 13:29:48)
    2. IDEA: we might consider not to support only one way to define tests, since different use cases need something different and one size does not fit all (hhorak, 13:38:52)
    3. various Fedora maintainers use different approaches right now for components -- some maintainers keep specs in different branches the same and include '%if %fedora' stuff and some prefer different content in different branches and rather have clean spec files (hhorak, 13:47:09)
    4. IDEA: it might be fine if we are able to stay flexible in that regard as well with tests and just are able to provide some sane recommendation (hhorak, 13:47:09)
    5. IDEA: for software collections -- the tests would just be part of the collection (hhorak, 13:49:20)
    6. ACTION: hhorak will send proposal about integration tests to the devel list (hhorak, 13:51:23)
    7. IDEA: if we are able to provide the integration tests as real upstream projects that other distros could benefit from as well, we can start some nice collaboration and benefit all from that (pretty challenging idea, but might be worth keep in mind) (hhorak, 14:07:29)

  4. Picking chairman for the next meeting (hhorak, 14:15:13)
    1. hhorak is actually not available the next week.. (hhorak, 14:15:34)
    2. let's skip the next week's meeting, since many of use won't be here (hhorak, 14:19:40)
    3. let's leave picking a new time to ML discussion and try a new whenisgood (hhorak, 14:40:18)
    4. ACTION: hhorak will chair the meeting in two weeks.. (hhorak, 14:41:23)


Meeting ended at 14:43:35 UTC (full logs).

Action items

  1. hhorak will sum up what we agreed the last time on Docker doc and will write it on the wiki for someone who picks it
  2. hhorak will send proposal about integration tests to the devel list
  3. hhorak will chair the meeting in two weeks..


Action items, by person

  1. hhorak
    1. hhorak will sum up what we agreed the last time on Docker doc and will write it on the wiki for someone who picks it
    2. hhorak will send proposal about integration tests to the devel list
    3. hhorak will chair the meeting in two weeks..


People present (lines said)

  1. hhorak (62)
  2. juhp (60)
  3. nphilipp (33)
  4. sicampbell (19)
  5. bkabrda (9)
  6. zodbot (4)
  7. ncoghlan (3)
  8. Southern_Gentlem (1)
  9. samkottler (0)
  10. vpavlin (0)
  11. tjanez (0)
  12. pkovar (0)


Generated by MeetBot 0.1.4.