12:02:19 <hhorak> #startmeeting Env and Stacks (2015-01-07)
12:02:19 <zodbot> Meeting started Wed Jan  7 12:02:19 2015 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:02:23 <hhorak> #meetingname env-and-stacks
12:02:23 <zodbot> The meeting name has been set to 'env-and-stacks'
12:02:27 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp ncoghlan vpavlin sicampbell
12:02:27 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan pkovar samkottler sicampbell tjanez vpavlin
12:02:54 <hhorak> Happy New Year everybody :)
12:03:08 <bkabrda> hi!
12:03:15 <juhp_> hi
12:03:26 <juhp_> Happy New Year
12:03:37 <jzeleny> hi guys
12:05:09 * langdon lurks and wishes happy new year!
12:05:37 <vpavlin> Hey:) And Štastný nový rok všem!
12:07:37 * hhorak remembering Nick being not available today, so maybe we won't have much updates.. or bkabrda has something?
12:08:31 <bkabrda> to sum up my progress with the missing devpi functionality: I started working on it, but the code is quite complex, so it'll take some time before I implement it. upstream seems keen on the idea, but it seems they don't have enough time to do it themselves
12:08:57 <bkabrda> so the status is "work in progress"
12:09:46 <hhorak> bkabrda: does it change anything about the plan doing the PoC with devpi and look at pupl later or we're still going this way?
12:10:16 <bkabrda> hhorak: nothing has changed. devpi is for pilot, pulp later on
12:10:46 <hhorak> bkabrda: good
12:11:26 <hhorak> #info devpi work is in progress, the code is quite complex, so it'll take some time before having implemented it. upstream seems keen on the idea, but it seems they don't have enough time to do it themselves
12:12:12 <hhorak> It seems we can jump to scl right ahead..
12:12:26 <hhorak> #topic Follow-up: SCLs
12:13:41 <hhorak> I promised to prepare a project page for SCLs with many questions.. as always I did not do it during holiday as I planned it. so I haven't managed to send the link in advanced because I just prepared the first version :) which is:
12:13:41 <hhorak> #link https://fedoraproject.org/wiki/Env_and_Stacks/Projects/SoftwareCollectionsInFedora
12:13:57 <juhp_> cool
12:15:51 <hhorak> I don't expect you'll read it all now, but maybe we can at least answer some questions from the part "What we're trying to solve it here? (the big picture)" -- well it seems ridiculous to answer those questions now but we need to be in sync..
12:19:39 <juhp_> it looks like a good start :-)
12:21:41 <bkabrda> yeah. I think this is a lot of reading and thinking. I suggest posting the link to ML and let everyone meditate on it and discuss on next meeting
12:23:44 <hhorak> I'm thinking about the best way to discuss, the meeting is not much time to discuss much.. we can maybe even open a topic on the mailing list if somebody has opinion about it, even before the next meeting?
12:24:04 <hhorak> I may encourage to do so when posting the link.
12:24:37 <bkabrda> hhorak: yes, that's a long complex topic, let's do it on ML and then perhaps vote about discussed things on one of next meetings
12:24:55 <hhorak> bkabrda: sounds good to me
12:25:48 <hhorak> #info scls are a long complex topic, let's start discussions about questions on ML and then perhaps vote about discussed things on one of next meetings
12:26:31 <hhorak> #action hhorak will post the link to the ML and will encourage to discuss on ML
12:26:35 <juhp_> +1
12:28:06 <hhorak> scls sound like done for today then
12:29:12 <hhorak> #topic Env and Stacks elections
12:29:30 <hhorak> not announced topic, but this will be quick
12:29:50 <hhorak> jreznik asked me to create a page for nominations, so I did https://fedoraproject.org/wiki/Env_and_Stacks/Nominations
12:30:12 <hhorak> some announcement should hit the community the next week.
12:30:14 <juhp_> aha
12:31:14 <juhp_> hhorak, good work :)
12:31:36 <hhorak> when creating it I also came across "Changing These Rules" note at https://fedoraproject.org/wiki/Env_and_Stacks/Governance_Charter#Changing_These_Rules
12:32:59 <hhorak> so maybe this is a good time to reconsider if the rules we set up in the beginning works or there are some changes required in group organization or whatever.. I guess we may change it if needed after elections..
12:33:52 <bkabrda> personally I don't think we need to change the rules ATM.
12:34:13 * juhp_ assumes "January 2014" meant 2015
12:35:11 <juhp_> bkabrda, I tend to agree - maybe we could revisit later after the new members are elected
12:35:20 <bkabrda> +1
12:36:05 <hhorak> #info According to "Changing These Rules" note in Governance Charter we may revisit rules of the working group after elections, but currently there are no specific things to change
12:36:32 <juhp_> (ah ignore my comment about Jan 2014, doh)
12:37:29 <hhorak> juhp_ good, couldn't found anything :)
12:37:31 <juhp_> (time flies:)
12:39:40 <hhorak> #topic Open Floor
12:40:32 <hhorak> (I skipped the chairman picking since I have some feeling who would be picked up, but if there is anybody wishing to do so... :) )
12:40:55 <bkabrda> not sure if I mentioned this on the last meeting, but I'd appreciate feedback on my proposal for python 3 in epel
12:40:59 <hhorak> Anyway, is there anything else to touch today?
12:41:01 <bkabrda> (I sent a mail to our ML)
12:41:30 <bkabrda> I know that it's not directly related to Fedora, but it may influence us, too
12:42:08 <juhp_> bkabrda, aha
12:42:16 <bkabrda> here's the epel-devel mail: https://lists.fedoraproject.org/pipermail/epel-devel/2014-December/010548.html
12:42:23 <juhp_> hhorak, :)
12:42:39 <langdon> hhorak, not to go back to the earlier topic, but, I am a little confused why the "open questions" you have are scl related? like I don't disagree that some of those questions need to be answered, but, why scls' page?
12:43:02 <langdon> hhorak, aren't they wider questions about envs&stacks?
12:43:15 <juhp_> ah
12:43:59 * juhp_ made some minor trivial tweaks to the page before btw
12:46:07 <hhorak> langdon: that's a good point, I'm not against moving them away and consider them separately.
12:46:09 * langdon also made some content edits :) hopefully non conflicting /cc juhp_
12:46:22 <juhp_> cool
12:46:35 <hhorak> sure, feel free to edit the page, no problem.
12:48:31 * hhorak has feeling that the more he thinks about scl the more chaos is in his head
12:48:39 <juhp_> lol
12:49:55 <juhp_> yes they may be a bit like a Klein bottle!
12:50:01 <hhorak> but not to forget about bkabrda's point before, let me create an action for all of us, just to no forget :)
12:50:01 <hhorak> #action everybody to look at the python 3 in EPEL proposal from bkabrda at https://lists.fedoraproject.org/pipermail/epel-devel/2014-December/010548.html
12:50:22 <juhp_> thanks
12:50:29 * hhorak googling Klein bottle
12:50:44 <juhp_> one of those 4d thingies :)
12:50:56 <juhp_> anyway just being silly...
12:51:49 <hhorak> juhp_: yeah, that feels pretty similar to how I feel :)
12:53:22 <juhp_> :)
12:54:41 <juhp_> maybe one controversial question or not, may be if SCL should only live in copr or be allowed in main Fedora repos...
12:55:05 <juhp_> well I think you already have a similar question
12:55:37 <juhp_> if the answer were copr only, then maybe the Klein bottles kind of vanishes?
12:57:00 <juhp_> or maybe there could be separate koji repos for SCL?
12:57:13 <juhp_> anyway just thinking aloud really
12:58:00 <langdon> juhp_, has envs and stacks officially defined the various levels? i think that informs your answer.. i still feel like the basic question(s) of rings are not complete... hence.. this kind of question comes up
12:59:57 <juhp_> langdon, right yes
13:00:24 <hhorak> it seems to me like the chicken and egg problem.. like the way we'll build our rings depends also on the way we want to use them and the way to use them depends on how we build it..
13:00:35 <hhorak> and starting with "usage" part seems more correct to me..
13:00:48 <juhp_> langdon, definitely agree more on this discussion would be useful - and glad you are pushing for it
13:01:08 <langdon> hhorak, well.. personally, I think the rings can be defined in the abstract.. and scls are one,  possible, implementation..
13:01:10 <juhp_> hhorak, aha
13:02:57 <juhp_> maybe we should make a separate page on Rings or "Stacks structure"?
13:04:53 <juhp_> while everything was basically in a single repo (fedora) everything was pretty simple...
13:06:28 <hhorak> juhp_ yeah, old golden age :)
13:07:23 <hhorak> but I'm +1 on detaching rings/stacks
13:07:35 <juhp_> I guess there are several ways of approaching it - one being more abstract/theoretical approach - another thinking about specific use cases
13:07:54 <juhp_> I think they both could be quite informative
13:08:01 * langdon thinks out loud: life was so much simpler when no one trusted open source :/ /cc juhp_ hhorak
13:08:10 <juhp_> haha
13:08:27 <hhorak> langdon: :)
13:08:28 <langdon> juhp_, victims of success
13:08:34 <juhp_> yeah
13:10:25 <langdon> juhp_, i actually don't think your two ideas are "exclusive" ... i just think avoiding tech impl is important during definition..  and, as we have learned from agile, it is almost always better to identify use cases/scenarios/stories and solve for them rather than trying to solve everything at once...
13:11:07 <langdon> so I would think, what do you want fedora users to be able to do? packagers?
13:11:21 <langdon> that the rings concept supports..
13:11:31 <langdon> then have some specific examples..
13:11:44 <langdon> and decide which of the examples you plan to ignore :)
13:13:16 <juhp_> bkabrda, random question - I guess in general churning out python3-* and python2-* subpackages from a single python source package is not realistic, right?
13:13:20 <juhp_> langdon, okay
13:13:44 <juhp_> bkabrda, not that it helps for epel anyway, hmm
13:14:11 <juhp_> probably a bad question
13:14:32 <bkabrda> juhp_: I'm not sure I understand "churning" correctly...
13:14:40 <bkabrda> is that like "getting rid of"?
13:14:44 <juhp_> no
13:14:59 <juhp_> bkabrda, sorry churning = building here
13:15:13 <bkabrda> ah, ok
13:15:46 <juhp_> langdon, sounds like a reasonable approach I think
13:16:29 <bkabrda> well that depends on upstream. for most upstream tarballs it's perfectly possible, but some upstreams release py2 and py3 tarballs separately... so you'd have to pack both into a single srpm
13:16:42 <juhp_> okay
13:18:27 <juhp_> I keep trying to think about examples where some needs a deps from within separate incompatible stacks - I don't have any such realworld example in mind - maybe I am just trying too hard ;o)
13:19:07 <juhp_> s/some needs a deps/someone needs deps/
13:20:07 <juhp_> probably I should shutup for today :)
13:22:12 <langdon> juhp_, am i missing something? i think that one is easy.. i have an app that uses mysql 5.1 and mysql 5.5... am i missing something?
13:22:30 * langdon notices he had the same thought twice ;)
13:23:00 <juhp_> langdon, aha
13:24:37 <juhp_> bkabrda, though to me python34 is kind of a quasi-SCL anyway :) not that I mind
13:25:58 <bkabrda> juhp_: yeah... epel is in a strange situation in this, but for various reasons it's good to have python3X in base there
13:26:12 <juhp_> anyway perhaps we should finish for today?
13:26:16 <juhp_> bkabrda, I agree
13:27:18 <hhorak> juhp_: I guess we may end, starting 3 minutes timeout before ending..
13:29:13 <langdon> juhp_, hhorak one quick question .. can i request that the "rings" topic get added to the official agenda for next meeting?
13:29:26 <juhp_> +1
13:30:29 <bkabrda> +1
13:30:35 * langdon realizes he should probably have given some content "discuss how to officially define the rings for fedora" or something
13:31:31 <hhorak> langdon: sure, will be added (if I forget I'll owe you a beer)
13:31:42 <langdon> hhorak, lol
13:32:06 <hhorak> #endmeeting