#fedora-meeting-2: Env and Stacks (2015-09-24)
Meeting started by hhorak at 12:03:08 UTC
(full logs).
Meeting summary
- Fedora dockerfiles -- versions, size, more involvement from E&S (hhorak, 12:04:30)
- https://github.com/fedora-cloud/Fedora-Dockerfiles/pull/128
(hhorak,
12:07:28)
- some PRs take too long to be merged in Fedora
dockerfiles, let's help Scott with that work.. (hhorak,
12:08:12)
- ACTION: bkabrda to
get in touch with scott tomorrow to see how he can help him
(hhorak,
12:12:15)
- http://imgur.com/TnpcouY
(vpavlin,
12:49:27)
- http://imgur.com/TnpcouY
(vpavlin,
12:51:49)
- it is possible to configure in docker hub what
tags should be used for automatically re(build) images (based on
github branch and path) (hhorak,
12:56:32)
- every tag will require a new build on docker
hub, but we can still set up something like git-branch+path -> {
docker-tag-a, docker-tag-b } ... i will just create more builds than
we'd expect... (hhorak,
13:15:08)
- Product Definition Center is a dependency for
triggering Docker rebuilds on RPM updates (ncoghlan,
13:17:49)
- https://fedorahosted.org/fedora-infrastructure/ticket/4863
(ncoghlan,
13:17:59)
- ACTION: vpavlin will
setup a demo process and document how we can build the versioned
dockerfiles in from
https://github.com/fedora-cloud/Fedora-Dockerfiles (hhorak,
13:18:28)
- open-floor (hhorak, 13:21:31)
- ACTION: hhorak to
touch other topics (not covered today) on ML (hhorak,
13:22:00)
- https://fedoraproject.org/wiki/Env_and_Stacks/Projects/ImageAssemblyRecommendations
(hhorak,
13:25:56)
- Layered images are special, since they're the
ones that can bring in additional non-RPM bits (gem, maven); 1-to-1
mirrors for those could be implemented by RepoFunnel building on
Pulp, but it's still not sure whether this middle step is
necessary (hhorak,
13:36:25)
- fedora rel-eng plans to build at least the
cockpit layered image for f24 and potentially others (hhorak,
13:42:38)
Meeting ended at 13:43:33 UTC
(full logs).
Action items
- bkabrda to get in touch with scott tomorrow to see how he can help him
- vpavlin will setup a demo process and document how we can build the versioned dockerfiles in from https://github.com/fedora-cloud/Fedora-Dockerfiles
- hhorak to touch other topics (not covered today) on ML
Action items, by person
- bkabrda
- bkabrda to get in touch with scott tomorrow to see how he can help him
- hhorak
- hhorak to touch other topics (not covered today) on ML
- vpavlin
- vpavlin will setup a demo process and document how we can build the versioned dockerfiles in from https://github.com/fedora-cloud/Fedora-Dockerfiles
People present (lines said)
- hhorak (91)
- vpavlin (64)
- ncoghlan (53)
- bkabrda (26)
- praiskup (21)
- jkaluza (16)
- langdon (15)
- ttomecek (11)
- dgilmore (5)
- zodbot (4)
- phracek (1)
- juhp (0)
- walters (0)
Generated by MeetBot 0.1.4.