16:00:22 <nirik> #startmeeting EPEL (2010-04-23)
16:00:22 <zodbot> Meeting started Fri Apr 23 16:00:22 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:23 <nirik> #meetingname epel
16:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:27 <zodbot> The meeting name has been set to 'epel'
16:00:32 <nirik> #chair smooge
16:00:33 <zodbot> Current chairs: nirik smooge
16:00:44 <nirik> Hey, whos around for an epel meeting?
16:01:03 <tremble> Me
16:01:52 <nirik> me too sorta...
16:02:45 <tremble> At least we don't have quorum rules to worry about...
16:02:53 <nirik> yeah, true enough. ;)
16:03:11 <nirik> anyhow, I think we would like to use this meeting to discuss bugs, new packages, and general work on epel stuff.
16:03:23 <nirik> also to help new folks get more involved if they would like to.
16:03:26 <tremble> There was also the whole EL-6 thing
16:03:44 <tremble> "15:37 <@smooge> or we can do a meeting today because well EL-6 came out
16:06:23 <jokajak> i'm here
16:06:44 <nirik> yeah... if dgilmore is around, he could give us an update.
16:07:00 <nirik> I think we are waiting to get access to the el6 repo to import it into koji
16:07:58 <jokajak> is the rest of the infrastructure set up for that?
16:08:03 <jokajak> due to the xz update
16:08:07 <tremble> I thought dgilmore was delaying the branch for other reasons too, but I dunno
16:08:21 <tremble> jokajak That came up elsewhere, yes
16:09:37 * nirik gets a phone call.
16:09:51 <tremble> Ergh! the EL6 beta list archives are non-public.
16:10:14 <tremble> Basically looks like the builders use a more up to date version of RPM.
16:10:22 <nirik> fedora builders already do tho
16:10:39 <stahnma> I'm here, but barely
16:10:47 <stahnma> not so much a good time for me
16:11:32 <nirik> stahnma: are any? ;)
16:11:47 <stahnma> fewer and fewer it seems
16:12:18 <dgilmore> hey all
16:12:37 <tremble> Ah someone who knows what's going on :)
16:13:02 <dgilmore> i almost have all of rhel6 on the infrastructure mirror
16:13:22 * tremble notes that this is actually one of the biggest turnouts for a while...
16:15:15 <dgilmore> it looks like we should build  EPEL-6 for ppc64 x86_64 and i686
16:15:21 <dgilmore> we could do s390x also
16:15:47 * stahnma gets pulled away...will read scrollback later :(
16:16:36 <dgilmore> its probably going to take a couple of weeks before we can open up building EL-6
16:16:53 <dgilmore> we need to give time to peopel to opt in and out of EL-6 branches
16:17:10 <dgilmore> we need to make sure that we dont branch anything thats now in RHEL
16:17:40 <jokajak> dgilmore: would we be able to build against EL-6 with scratch builds before we have EL-6 EPEL branches?
16:17:40 * tremble wonders if allowing scratch builds would be benificial.
16:17:53 <dgilmore> jokajak: we can set that up
16:18:22 <jokajak> i would like to build some packages against el6 and currently have no easy way to do that
16:18:29 <tremble> The trouble is you'd only have access to EL deps.
16:18:31 <dgilmore> once i get things up and running ill do an early branch of epel-release and build it
16:18:42 <dgilmore> we will have a new GPG key for EL-6
16:19:12 <dgilmore> jokajak: you can always setup a mock config
16:19:35 <jokajak> dgilmore: then i'd have to install the mock from fedora-infra
16:20:57 <dgilmore> im thinking that when we open up epel  we should put everything in /pub/epel/beta/6/
16:21:14 <smooge> morning
16:21:17 <dgilmore> when EL-6 goes final we can see if anything needs a rebuild
16:21:25 <smooge> sorry I had a house problem to dela with
16:21:28 <tremble> Evenin' smooge
16:21:40 <jokajak> smooge: Good (UGT) morning
16:22:57 <smooge> hi how are things going
16:23:34 <jokajak> dgilmore: is there already a /pub/epel/beta ?
16:23:46 <jokajak> dgilmore: if not, why /pub/epel/beta/6/ and not /pub/epel/6/beta ?
16:24:53 <smooge> dgilmore, would we build s390x with qemu or some special hardwar
16:26:13 <dgilmore> smooge: we would build s390x with a lpar thats inside of RH
16:26:13 <smooge> jokajak, it matches other trees I think
16:26:19 <jokajak> ok
16:26:33 <dgilmore> we could s/beta/test
16:26:43 <smooge> jokajak, also we could do betas for other trees in the far future that way.
16:26:44 <dgilmore> but i think beta makes sense for epel
16:27:10 <smooge> dgilmore, do we know if AP covers every package? what is in AP-optional? etc
16:27:10 <jokajak> i'd do beta because it matches the title given to the product we are building against
16:28:29 <dgilmore> smooge: ive asked and not yet got answers
16:28:33 <smooge> ok no problem
16:29:30 <smooge> I think for the time being we would just keep to our rule if its in AP we build against it.  Then we can deal with damage later
16:30:33 <smooge> dgilmore, when can we do scratch builds against EL-6? I need a couple of packages.. for the desktop :)
16:31:05 <dgilmore> smooge: the rsync is almost done
16:31:07 <jokajak> that is obviously the topic of choice
16:31:20 <dgilmore> scratch builds should be enabled today
16:32:12 <smooge> ok cool.
16:32:28 <dgilmore> Ill email the list when they are working
16:33:21 <tremble> I know at least some (existing) packages are going to need new packages before they'll build with new versions...
16:33:40 <smooge> tremble, can you elaborate?
16:33:56 <tremble> RT 3.8 gained a whole load of new deps
16:34:39 <tremble> which weren't all in EPEL (although I own a batch of them now)
16:35:28 <smooge> ah the ever growing thing called RT
16:35:52 <smooge> one day its going to be 'make cpan-all; make rt'
16:35:59 <tremble> Tell me about it,
16:36:09 <dgilmore> just got the lowdown on AP-optional
16:36:22 <tremble> AP-optional ?
16:36:24 <smooge> on the other hand its cooler than the evils others are stuck with
16:36:26 <dgilmore> AP-optional are packages that fill BuildRequires as well as subpackages that aren't pulled in through deps.  There will a child channel                in RHN that contains these packages.  So, they will be available, but they won't receive the same level of Red Hat support
16:36:38 <smooge> ahhh.
16:36:54 <tremble> That's a nice way to do it.
16:37:07 <dgilmore> EPEL will build against AP and AP-optional
16:37:08 <smooge> to avoid the problem with 2.1 and 3 that occured with 1 or 2 packages
16:37:22 <smooge> cool then we don't have to branch more stuff
16:37:24 <dgilmore> changes are you will need to enable both those channels to use epel on EL-6
16:38:02 <dgilmore> chances are
16:38:06 <smooge> dgilmore, I was wondering if we should put in blockers for most of the core packages this time so we don't have to worry about new versions showing up. They can be removed later correct?
16:38:47 <tremble> dgilmore: What sort of lower level support is it going to be? (If you don't know I'll just wait for the sales droids to explain)
16:39:14 <dgilmore> tremble: i have no idea about anything to do with support
16:39:22 <tremble> Ok
16:39:49 <dgilmore> smooge: we can block them in epel
16:40:03 <dgilmore> smooge: but we need to unblock them in epel-build
16:40:21 <dgilmore> dist-6E-epel can block packages in EL-6
16:40:38 <dgilmore> but they need to be unblocked in dist-6E-epel-build
16:40:53 <dgilmore> if there blocked there they wont be available to build against
16:40:59 <smooge> dgilmore, aaaaahh
16:41:37 <smooge> dgilmore, thanks for explaining. I was just thinking of the CVS branches but I guess there was a lot more than that to deal with
16:41:45 <tremble> Could you do something like block them in dist-6E-epel-testing-candidate?
16:44:36 <dgilmore> tremble: not really
16:45:00 <tremble> Fair enough
16:45:26 <dgilmore> my thoughts were that while LE-6 is in beta we will have a single repo thats auto created without using bodhi
16:45:44 <dgilmore> at GA we will rebuild anything that needs to be
16:45:47 <tremble> Would make life simpler.
16:45:49 <dgilmore> filter out broken deps
16:45:52 <smooge> sounds good
16:46:01 <dgilmore> and make that be the inistall stable tree
16:46:10 <dgilmore> anything with broken deps would go to testing
16:46:32 <dgilmore> and we would use bodhi going forward from there
16:46:46 * tremble nods at dgilmore
16:49:36 <smooge> more +1 from me.
16:49:47 <smooge> I think that sounds like a reall good plan for this
16:49:54 <smooge> dgilmore, how can we help?
16:51:29 <dgilmore> smooge: right now we need to spread the word
16:51:41 <smooge> ok blogs away
16:51:43 <dgilmore> we need to get people to opt in and opt out of EL-6 branches
16:51:54 <dgilmore> we should have a wiki page for opting in
16:52:13 <dgilmore> and existing EL-5 packages need nobranch files added
16:52:25 <dgilmore> if there not going to be branched for EL-6
16:52:43 <tremble> Do you want a list of packages we're happy to be branched or just contributor yes/nos
16:53:03 <dgilmore> tremble: what i want to do is this
16:53:30 <dgilmore> go though the existing EL-5 branches on the cvs server
16:53:39 <dgilmore> and find ones with nobranch files
16:53:57 <dgilmore> so we get a list of packages to branch
16:54:22 <dgilmore> we then add the new EL-6 packages from the wiki
16:54:34 <dgilmore> making sure that we dont branch anything thats in EL-6
16:54:44 <smooge> #action smooge wiki updates for EL-6
16:55:16 <smooge> #action smooge blog about EL-6 when dgilmore gives the go
16:55:17 <jokajak> dgilmore: so i understand, is it: determine packages to be branched, put on wiki, wait X time, branch packages set to be branched ?
16:55:19 <tremble> I assume the usual Fedora -> EL process applies ?
16:55:48 <dgilmore> we will create branches from F-12
16:55:55 <dgilmore> unless there is no F-12 branch
16:56:02 <dgilmore> then it will be from devel
16:56:28 <smooge> dgilmore, just to make sure the maintainer can update to something newer if they think it is more stable than what was in F-12
16:57:01 <dgilmore> smooge: thats fine
16:57:22 <tremble> I assume the usual "we support this until EL6 dies" will only apply post GA ?
16:57:24 <dgilmore> smooge: we will default to branching from FC-12 since thats what EL-6 was branched from
16:57:37 <dgilmore> tremble: right
16:57:47 <dgilmore> more flexibility while in beta
16:58:56 <smooge> and to be honest... we don't support everything til EL-X dies. If it doesn't have a sponsor anymore.. we can't support it
16:59:09 <smooge> ok another meeting starts in 2
16:59:12 <smooge> or 1
16:59:17 <jokajak> <3
16:59:26 <smooge> so I think I will call this and we can talk in #epel as it goes
16:59:35 <smooge> #endmeeting