16:06:19 <smooge> #startmeeting EPEL 2010-07-12
16:06:19 <zodbot> Meeting started Mon Jul 12 16:06:19 2010 UTC. The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:07:37 <smooge> ping nirik Jeff_S
16:07:45 * nirik looks up.
16:07:48 <smooge> #topic Hello
16:07:51 <smooge> Hi
16:07:51 * Jeff_S looks down
16:07:59 <Jeff_S> smooge: hi, thanks
16:08:03 <smooge> sorry I ended up getting caught in something so I am late
16:08:04 <tremble> 'lo
16:08:08 * tremble laughs
16:08:12 <nirik> I'm here, but there is a insurance inspector that could show up anytime... so might have to wander off to deal with them.
16:08:15 <smooge> I think dgilmore will be sleeping finally
16:08:19 * tremble had an over-running meeting too.
16:08:28 <Jeff_S> nirik: "deal" with them? :) do you need an alibi?
16:08:48 <nirik> ha. :) Honest, I was in an epel meeting... ;)
16:08:50 <smooge> nirik, is it an BOFH related insurance inspector? IE leading them towards the tape vaults
16:09:05 <smooge> ok
16:09:35 <smooge> #topic EL-6 issues
16:09:50 <smooge> tremble sent out a lot of emails and I think we have a ton of packages in place.
16:10:00 <tremble> We now have about half our packages built
16:10:04 <smooge> we also have a lot of people thinking there is supposed to be a mass rebuild that would catch it
16:10:18 <smooge> tremble sorry you should be talking :)
16:10:22 <Jeff_S> I have it on my TODO list but haven't built mine yet :)
16:10:34 * tremble grins
16:10:47 * nirik is down to his last 2
16:11:12 <tremble> A number of people have been held up by other people not having built packages.
16:11:43 <tremble> The availability of some packages on some arches only has caused issues, I think nirik was having fun with Java too?
16:11:49 <dgilmore> smooge: im not sleeping now just a little sick still
16:11:56 <Jeff_S> have we seen people building the el-5 version on el-6, or are most people taking the opportunity to pull in a newer version from fedora? Or nobody has tracked this?
16:12:10 <dgilmore> Jeff_S: we branched from F-12
16:12:10 <smooge> dgilmore, I am sorry I didn't know you were sick. I thought you were doing 48 hours straight on the koji move
16:12:29 <tremble> What I've seen, has been people building at least the F-12 version, frequently the rawhide version.
16:12:30 <smooge> I am needing to get hamster-applet split out for EL-6
16:12:32 <nirik> There was a yum bug that prevented 'BuildRequires: java-devel >= 1:1.6.0 from working.
16:12:33 <dgilmore> Jeff_S: so they would have to go out of there way to build the EL-5 version
16:12:39 <Jeff_S> dgilmore: ok, so people would have to make changes in order to build the el-5 version... good
16:12:45 <Jeff_S> dgilmore: thanks
16:13:12 <dgilmore> nirik: i updated yum on all the el-6 builderhosts that should be fixed
16:13:23 <nirik> dgilmore: yep. :) Thanks.
16:13:51 <nirik> I have another question: Should mock work for el6 builds? I see mock in rawhide has .conf files for it, but they don't work.
16:13:52 <smooge> cool
16:13:58 <dgilmore> there are 8 x86_64 builders running rhel5 and 12 running rhel6
16:14:15 <dgilmore> nirik: id be supprised if it works
16:14:23 <dgilmore> nirik: i had some configs for beta1
16:14:29 <dgilmore> i need to update them for beta2
16:14:46 <tremble> With regards the rebranching of EL-6 "optional" packages we probably need to make sure that people built from the RH SRPMs at some point.
16:14:59 <smooge> dgilmore, is there any problem with mock other than configs?
16:15:03 <nirik> dgilmore: it almost works... it can't get the buildsys-build group
16:15:31 <dgilmore> nirik: looks like they pulled in my configs that point at beta1
16:15:39 <dgilmore> smooge: just configs
16:15:58 <nirik> dgilmore: ok. Could you post up the beta2 versions somewhere? and/or get them merged in mock? :)
16:16:05 <dgilmore> nirik: but it should work buildsys-build is in the epel comps file
16:16:32 <dgilmore> nirik: yeah ill get new configs up and request they get pulled in
16:17:04 <smooge> dgilmore, cool.
16:17:20 <smooge> did people see mdomsch's email on packages?
16:18:10 * siXy would like to delay pushing one of his packages to EL-6 even if it misses the deadline if that's ok - major re-write just around the corner, and don't want to fsck with user experiences. It's not a very widely used package anyway
16:18:17 <Jeff_S> smooge: no, I didn't. To the EPEL list?
16:19:03 <smooge> I thought it was to the list.. but maybe it was somewhere else.
16:19:04 <smooge> One sec
16:22:06 <smooge> EPEL test mass rebuild results from mdomsch
16:22:27 <tremble> The result: of the 9262 packages present, 2762 failed to build, 6495 successfully built.
16:22:28 <smooge> basically he threw I think rawhide against EL-6 and got back how many build
16:22:35 <tremble> smooge F-12
16:22:38 <smooge> ah ok
16:22:40 <smooge> cool
16:23:03 <smooge> some of the build problems look like simple things to fix. I need to see about alpine as its on my list of "needs"
16:23:10 <tremble> http://linux.dell.com/files/fedora/epel6-build/x86_64/
16:23:41 <smooge> oh I didn't see that part
16:23:42 <smooge> cool
16:24:42 <tremble> There's a few FTBFS that're going to be holding up a reasonable batch.
16:25:16 <smooge> FTBFS?
16:25:24 <tremble> Fails To Build From Source
16:25:31 <tremble> where deps then can't build
16:26:22 <Jeff_S> smooge: ooh, yeah I did read that
16:26:51 <smooge> tremble, thanks
16:27:20 <smooge> does anyone else have any EL-6 issues to bring up?
16:28:20 <smooge> #topic libsndfile needs love. Security issue
16:28:33 <smooge> did I lose the net?
16:28:44 <tremble> I thought the love had been applied and was now after a proven packager....
16:28:48 <Jeff_S> smooge: no, we're just snoozing on mon. morning
16:28:52 <tremble> proven tester even
16:28:58 <smooge> even zodbot though
16:29:09 <smooge> wait.. zodbot never started
16:29:09 <Jeff_S> smooge: maybe zodbot is sleeping too?
16:29:19 <smooge> bwahahahah
16:29:23 <nirik> smooge: no, it can't change the topic.
16:29:37 <Jeff_S> heh
16:29:43 <nirik> we need z00dax to give us privs to change that.
16:29:49 <smooge> ah yes that thing
16:30:08 * nirik is going to look at that libsndfile thing... but hasn't had time yet.
16:30:10 <Jeff_S> oh wait, I think nirik and I have flags to change stuff here
16:30:17 <nirik> Jeff_S: nope.
16:30:48 <Jeff_S> ?
16:31:25 <tremble> smooge : https://admin.fedoraproject.org/updates/libsndfile-1.0.17-3.el5
16:31:26 <nirik> Jeff_S: there is a modelock set.
16:31:29 <Jeff_S> nirik: what do we need to change to give zodbot access?
16:31:36 <nirik> Jeff_S: it will not let you /mode #epel -t
16:31:48 <Jeff_S> haha
16:32:07 <smooge> see if you can get ChanServ to change it
16:32:11 * nirik has a pretty good handle on this irc thing... but if you can fix it, feel free. ;)
16:32:30 <nirik> smooge: no, it requires flags no one but kbsingh has
16:32:36 <Jeff_S> looks like nirik and I have f flag so we should be able to screw up all sorts of stuff
16:32:48 <smooge> ah well probably time to see about 'changing' that then
16:32:51 <nirik> Jeff_S: we need +s
16:33:23 <smooge> #action smooge will contact z00dax about getting this channel thing fixed
16:33:40 <Jeff_S> nirik: thanks
16:33:45 <Jeff_S> smooge: I'll ask too if I see him first
16:33:58 <Jeff_S> nirik: I don't remember all those irc flags ;)
16:33:59 <nirik> yeah thanks.
16:34:18 <smooge> Actually Jeff_S that might work better. My contact with CentOS seems to have split up
16:34:36 <Jeff_S> smooge: will do
16:34:42 <tremble> z00dax seems fairly contactable on #centos-devel
16:35:35 <nirik> Jeff_S: if you can get him to add +s to me and smooge and you that would be great.
16:36:37 <smooge> z00dax is pming me at the moment.
16:36:49 <smooge> nirik, what does +s do exactly?
16:37:05 <Jeff_S> I just asked him in #centos-devel and he said he'd change
16:37:17 <smooge> Jeff_S, thanks.
16:37:19 <nirik> enables the use of the 'set' command.
16:37:19 <Jeff_S> smooge: /msg chanserv help flags I think lists them all
16:37:28 <smooge> z00dax is cool.
16:37:38 <nirik> http://toxin.jottit.com/freenode_chanserv_commands#cs03
16:37:52 <smooge> nirik, thanks
16:38:59 <smooge> #topic Open Floor
16:39:09 <smooge> Do people have anything they need to bring yup?
16:39:21 <nirik> I have just a FYI...
16:39:27 <nirik> have been working on Xfce for el5/el6.
16:39:45 <nirik> ran into another issue with el5, but as soon as I can get mock builds working I can build and test el6.
16:40:28 * siXy points to his earlier comment
16:40:46 <smooge> siXy, I have no idea what that comment was sorry
16:40:50 <smooge> could you repeat
16:40:56 <smooge> nirik, thanks for the FYI
16:40:59 <siXy> I would like to delay pushing one of his packages to EL-6 even if it misses the deadline if that's ok - major re-write just around the corner, and don't want to fsck with user experiences. It's not a very widely used package anyway
16:41:11 <siXy> s/his/my/
16:41:19 <tremble> Does anything else BR it?
16:41:24 <siXy> no
16:42:56 <tremble> As long as it's not holding up a big stack I'd say no problems,
16:43:04 <Jeff_S> bwhahaha
16:44:08 <siXy> nothing requires or buildrequires it, userbase is pretty small, so I don't envisage any issues with this. I just don't want to ship a somewhat broken package that's going to change noticeably fairly soon
16:44:54 <smooge> siXy, I have no problem iwth that. what package?
16:45:06 <siXy> netsniff-ng.
16:45:16 <siXy> specialised packet dumper for very busy networks
16:45:29 <smooge> ah cool. Yeah.. if its going to be a rewrite/rebuild then no problem.
16:45:44 <smooge> would rather have a good working base than mediawiki all over again.
16:45:59 <siXy> this was my thought too :) thanks!
16:47:00 <smooge> ok anything else? [I have mis-typed most of my lines today... ]
16:47:18 <smooge> then I will be closing in 30.
16:47:48 <Jeff_S> smooge: great, thanks
16:47:55 <RemiFedora> mays I ask what is the process when a fedora maintainer don't answer for creating a EPEL branch ?
16:48:07 <tremble> Wait a week and request the branch yourself
16:48:10 <RemiFedora> ex: https://bugzilla.redhat.com/show_bug.cgi?id=565263
16:48:14 <Jeff_S> RemiFedora: you can file a bug and .... nm, what tremble said
16:48:30 <Jeff_S> RemiFedora: just cc them on your branch request
16:48:41 <RemiFedora> ok, thanks
16:48:48 <smooge> cool. I need to do that on hamster-applet
16:49:04 <smooge> ok anything else?
16:49:44 <tremble> RemiFedora: Oh and check that they weren't listed as being on vacation
16:49:54 <tremble> But that one's been so long any way.
16:50:05 <RemiFedora> yes 5 month...
16:50:53 <Jeff_S> long vacation
16:50:58 <Jeff_S> where do I sign up for that
16:51:38 <RemiFedora> I want too :)
16:51:55 <smooge> #endmeeting